RTL8821CE WiFi adapter - Screen freezes when connecting to wifi

Hi,

i reinstalled garuda linux (Dual boot with windows 10) last month (26 of June) with the iso garuda-dr460nized-linux-zen-210225 (i have reinstalled the entire OS because i wanted to increase the space's partition of garuda 50GB -> 90GB).

Connected to wired connection (tethering) i have installed rtl8821ce-dkms-git, the wifi's driver for my wifi card, and I connected to my wifi after system reboot.

Then i tried to upgrade the system with no success. The problem were the outdated keys, so after sudo pacman-key --refresh-keysand cp /etc/skel/.config/starship.toml ~/.config/starship.tomlall works fine.

After a while (i was still connected to wifi) the screen froze, so i shutdown the laptop with the power button and boot into garuda again. As soon as i connect to wifi the screen froze.

This does not happen with wired connection.

I tought the problem was in the wifi driver, so i reinstalled it 3/4 times with the same package.
I hadn't removed it before install it again: I just went into the folder and typed makepkg -Si every time after reboot when i saw that the problem was still there.

So after those 3/4 times i decided to sudo pacman -R rtl8821ce-dkms-git and reinstalled the package again. Same problem.

Then i figured out that wifi was working even without this driver, but connection was very slow. With this driver speed was about 80-100 Mb/s, without it 5-10 Mb/s.
But the screen continue to freeze even with different wifi.

inxi -Fxxxa output:

System:    Host: dadezana-garuda Kernel: 5.13.4-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0  
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=02abdc43-e389-464b-81db-821055a40507  
rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.22.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM  
Distro: Garuda Linux base: Arch Linux  
Machine:   Type: Laptop System: HP product: HP Laptop 15-dw0xxx v: Type1ProductConfigId  
serial: <superuser required> Chassis: type: 10 serial: <superuser required>  
Mobo: HP model: 85F0 v: 36.35 serial: <superuser required> UEFI: Insyde v: F.20  
date: 11/25/2019  
Battery:   ID-1: BAT1 charge: 22.2 Wh (80.4%) condition: 27.6/41.9 Wh (65.8%) volts: 13.1 min: 11.6  
model: Hewlett-Packard PABAS0241231 type: Li-ion serial: 41167 status: Charging  
CPU:       Info: Quad Core model: Intel Core i5-8265U bits: 64 type: MT MCP arch: Kaby Lake note: check  
family: 6 model-id: 8E (142) stepping: C (12) microcode: EA cache: L2: 6 MiB  
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 28800  
Speed: 800 MHz min/max: 400/1600 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 799  
6: 800 7: 800 8: 903  
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled  
Type: l1tf status: Not affected  
Type: mds status: Not affected  
Type: meltdown status: Not affected  
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
Type: srbds mitigation: TSX disabled
Type: tsx_async_abort status: Not affected
Graphics:  Device-1: Intel WhiskeyLake-U GT2 [UHD Graphics 620] vendor: Hewlett-Packard driver: i915
v: kernel bus-ID: 00:02.0 chip-ID: 8086:3ea0 class-ID: 0300
Device-2: NVIDIA GM108M [GeForce MX110] vendor: Hewlett-Packard driver: nvidia v: 470.57.02
alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:174e class-ID: 0302
Device-3: Quanta HP TrueVision HD Camera type: USB driver: uvcvideo bus-ID: 1-5:3
chip-ID: 0408:5365 class-ID: 0e02
Display: x11 server: X.Org 1.20.12 compositor: kwin_x11 driver: loaded: modesetting
display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9")
Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 142 size: 344x194mm (13.5x7.6") diag: 395mm (15.5")
OpenGL: renderer: Mesa Intel UHD Graphics 620 (WHL GT2) v: 4.6 Mesa 21.1.6 direct render: Yes
Audio:     Device-1: Intel Cannon Point-LP High Definition Audio vendor: Hewlett-Packard
driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
chip-ID: 8086:9dc8 class-ID: 0403
Sound Server-1: ALSA v: k5.13.4-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: yes
Sound Server-4: PipeWire v: 0.3.32 running: no
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Hewlett-Packard
driver: r8169 v: kernel port: 4000 bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: eno1 state: down mac: 04:0e:3c:57:bb:da
Device-2: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter vendor: Hewlett-Packard
driver: rtw_8821ce v: N/A modules: rtw88_8821ce port: 3000 bus-ID: 03:00.0 chip-ID: 10ec:c821
class-ID: 0280
IF: wlo1 state: down mac: c0:e4:34:1e:3a:e7
IF-ID-1: enp0s20f0u2 state: unknown speed: -1 duplex: half mac: b2:f2:cc:26:75:32
Bluetooth: Device-1: Huawei FIG-LX1 type: USB driver: rndis_host v: kernel bus-ID: 1-2:6
chip-ID: 12d1:108a class-ID: 0a00 serial: HBEDU18202008286
Report: bt-service: enabled,stopped note: tool can't run
RAID:      Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci v: 3.0 port: 6060
bus-ID: 00:17.0 chip-ID: 8086.282a rev: 30 class-ID: 0104
Drives:    Local Storage: total: 476.94 GiB used: 19.53 GiB (4.1%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Intel model: SSDPEKNW512G8H size: 476.94 GiB
block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD
serial: PHNH938201YC512A rev: HPS0 temp: 39.9 C scheme: GPT
Partition: ID-1: / raw-size: 90 GiB size: 90 GiB (100.00%) used: 19.45 GiB (21.6%) fs: btrfs
dev: /dev/nvme0n1p5 maj-min: 259:5
ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%) used: 78.2 MiB (30.6%) fs: vfat
dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 90 GiB size: 90 GiB (100.00%) used: 19.45 GiB (21.6%) fs: btrfs
dev: /dev/nvme0n1p5 maj-min: 259:5
ID-4: /var/log raw-size: 90 GiB size: 90 GiB (100.00%) used: 19.45 GiB (21.6%) fs: btrfs
dev: /dev/nvme0n1p5 maj-min: 259:5
ID-5: /var/tmp raw-size: 90 GiB size: 90 GiB (100.00%) used: 19.45 GiB (21.6%) fs: btrfs
dev: /dev/nvme0n1p5 maj-min: 259:5
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.65 GiB used: 2.2 MiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 54.0 C mobo: 29.8 C
Fan Speeds (RPM): N/A
Info:      Processes: 263 Uptime: 46m wakeups: 7 Memory: 7.65 GiB used: 3.74 GiB (48.9%) Init: systemd
v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1276 lib: 312
Shell: fish v: 3.3.1 running-in: konsole inxi: 3.3.06

lsmod | grep rtw88 output:

rtw88_8821ce           16384  0
rtw88_8821c            94208  1 rtw88_8821ce
rtw88_pci              28672  1 rtw88_8821ce
rtw88_core            237568  2 rtw88_pci,rtw88_8821c
mac80211             1241088  2 rtw88_pci,rtw88_core
cfg80211             1069056  2 rtw88_core,mac80211

Have you tried rolling back your system to before your update?

If not, I highly suggest doing that. Obviously that is not a permanent fix, but it will hopefully fix your system temporarily.

Is your bios up to date?

Have you tested alternate kernels yet?

I would recommend starting with the linux, linux-lts, and linux-mainline kernels.

You will need to post your pacman log if my suggestions do not resolve your issue.

Welcome to Garuda.

3 Likes

Thank you ^^

I prefer to rollback after trying all the possible solution.
I tried all the kernel you suggested.

linux-mainline: screen does not freeze
linux-lts: idk why, but it doesn't even show me wifi button
linux: i couldn't see it in the advanced option for garuda

Now wifi works, but a strange things happen: sometimes speed is around 10-14MBps, and sometimes it fall down to 200-500KBps.

However, thank you for the help! Problem solved! :v: :upside_down_face:

(I also tried to update the system again, and this time the problem with linux-zen seems to be disappeared! :smiley:)

Updates: screen continue to freeze, but i found another solution.

Install this driver:

https://aur.archlinux.org/packages/rtl8821ce-dkms-git/

I went to /etc/modprobe.d/ and create a file blacklist.conf.
Into that file i wrote:
blacklist rtw88_8821ce, blacklisting the default wifi driver that comes by default with the kernel.

Then /etc/default/grub and added pci=noaer at the end of the line GRUB_CMDLINE_LINUX_DEFAULT="quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1 loglevel=3 pci=noaer"

Then do sudo update-grub and reboot.

Screen does not freeze anymore :smiley:

And finally went to:
Advanced network configuration -> selected my wifi -> setting (bottom-left) -> set band to 2.4GHz.

Went from 1MB/s to 13MB/s

Hope this post will help someone else. :v:

4 Likes

It is impossible that creating the file above increased your wifi speed. This was obviously some kind of placebo effect on your part. That driver options file only works for Intel based cards using the iwlwifi driver. It could not possibly increase the speed of a Realtek based adapter, as it is only applicable to Intel iwlwifi based network cards. Please edit out this erroneous information from your marked solution.

The other fixes are all good known methods to rectify issues with wifi.

This solution will likely only work if you installed an out of kernel realtek driver. However, you never listed which version of driver or the source of where you obtained this driver that you installed. Without this information your solution is of little benefit to others. Please update your post if you installed an out of kernel driver.

I hope you don't mind. I am going to add your wifi model number to your thread title so that others may find a solution for their rtl8821ce adapter more easily.

Congrats on working through your issues and finding a solution.

4 Likes

RIght now i cannot edit the post cause i can't see the modify option. I'll check out later if the option appears. if not, can you please edit the post for me? :sweat_smile:

You're right: https://aur.archlinux.org/rtl8821ce-dkms-git.git

I think the wifi speed increased because i have switched frequency (from 5GHz to 2.4GHz); i have never tested wifi's speed after writing the iwlwifi.conf file, i tested it just after i switched the frequency.

Thank you :v: :grin:

1 Like

Alrighty, I edited your solution to include some of the missing info.

Thanks for posting back.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.