RTL8821CE - When idle, wifi drops and works only after reconnecting

This is my device conf:-

Kernel: 5.16.16-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=63bfe055-cc5e-4764-83c0-9d4d25d798e0 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3 pci=noaer pcie_aspm=off ipv6.disable=1
Desktop: KDE Plasma 5.24.3 tk: Qt 5.15.3 info: latte-dock wm: kwin_x11
vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Laptop System: HP product: HP Laptop 15g-dr0xxx
v: Type1ProductConfigId serial: <superuser required> Chassis: type: 10
serial: <superuser required>
Mobo: HP model: 84A7 v: 80.31 serial: <superuser required> UEFI: Insyde
v: F.07 date: 11/21/2018
ID-1: BAT1 charge: 6.9 Wh (30.1%) condition: 22.9/38.8 Wh (59.1%)
volts: 10.6 min: 11.4 model: Hewlett-Packard PABAS0241231 type: Li-ion
serial: <filter> status: Discharging
Info: model: Intel Core i5-8250U bits: 64 type: MT MCP arch: Coffee Lake
family: 6 model-id: 0x8E (142) stepping: 0xA (10) microcode: 0xEC
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
L3: 6 MiB desc: 1x6 MiB
Speed (MHz): avg: 3223 high: 3401 min/max: 400/3400 scaling:
driver: intel_pstate governor: powersave cores: 1: 3401 2: 3400 3: 3400
4: 3400 5: 3362 6: 2020 7: 3400 8: 3401 bogomips: 28800
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf
mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: conditional, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Device-1: Intel UHD Graphics 620 vendor: Hewlett-Packard driver: i915
v: kernel ports: active: eDP-1 empty: DP-1,HDMI-A-1,HDMI-A-2
bus-ID: 00:02.0 chip-ID: 8086:5917 class-ID: 0300
Device-2: NVIDIA GM108M [GeForce MX110] vendor: Hewlett-Packard
driver: nvidia v: 510.54 alternate: nouveau,nvidia_drm pcie: gen: 1
speed: 2.5 GT/s lanes: 4 link-max: gen: 3 speed: 8 GT/s bus-ID: 01:00.0
chip-ID: 10de:174e class-ID: 0302
Device-3: Quanta HP TrueVision HD Camera type: USB driver: uvcvideo
bus-ID: 1-5:2 chip-ID: 0408:5362 class-ID: 0e02
Display: x11 server: X.Org v: compositor: kwin_x11 driver: X:
loaded: modesetting,nvidia gpu: i915 display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
s-diag: 582mm (22.9")
Monitor-1: eDP-1 model: BOE Display built: 2015 res: 1920x1080 hz: 60
dpi: 142 gamma: 1.2 size: 344x193mm (13.5x7.6") diag: 394mm (15.5")
ratio: 16:9 modes: 1920x1080
OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2)
v: 4.6 Mesa 21.3.7 direct render: Yes
Device-1: Intel Sunrise Point-LP HD Audio vendor: Hewlett-Packard
driver: snd_hda_intel v: kernel alternate: snd_soc_skl bus-ID: 00:1f.3
chip-ID: 8086:9d71 class-ID: 0403
Sound Server-1: ALSA v: k5.16.16-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.48 running: yes
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Hewlett-Packard driver: r8169 v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: 4000 bus-ID: 02:00.0 chip-ID: 10ec:8168
class-ID: 0200
IF: eno1 state: down mac: <filter>
Device-2: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter
vendor: Hewlett-Packard driver: rtw_8821ce v: kernel
modules: rtw88_8821ce,8821ce pcie: gen: 1 speed: 2.5 GT/s lanes: 1
port: 3000 bus-ID: 03:00.0 chip-ID: 10ec:c821 class-ID: 0280
IF: wlo1 state: up mac: <filter>
Device-1: Realtek Bluetooth 4.2 Adapter type: USB driver: btusb v: 0.8
bus-ID: 1-6:3 chip-ID: 0bda:b00a class-ID: e001 serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 0 state: down
bt-service: enabled,running rfk-block: hardware: no software: yes
address: <filter>
Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci
v: 3.0 port: 6060 bus-ID: 00:17.0 chip-ID: 8086:282a rev: N/A
class-ID: 0104
Local Storage: total: 1.14 TiB used: 307.22 GiB (26.4%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Kingston model: SA2000M8250G
size: 232.89 GiB block-size: physical: 512 B logical: 512 B
speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: S5Z44106
temp: 34.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: HGST (Hitachi) model: HTS541010B7E610
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B
speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter> rev: 1A03
scheme: GPT
ID-1: / raw-size: 48.83 GiB size: 48.83 GiB (100.00%)
used: 21.85 GiB (44.7%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%)
used: 28.5 MiB (29.7%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 48.83 GiB size: 48.83 GiB (100.00%)
used: 21.85 GiB (44.7%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-4: /var/log raw-size: 48.83 GiB size: 48.83 GiB (100.00%)
used: 21.85 GiB (44.7%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-5: /var/tmp raw-size: 48.83 GiB size: 48.83 GiB (100.00%)
used: 21.85 GiB (44.7%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.68 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
System Temperatures: cpu: 59.0 C pch: 51.5 C mobo: 27.8 C
Fan Speeds (RPM): N/A
Processes: 252 Uptime: 8m wakeups: 1 Memory: 7.68 GiB
used: 3.18 GiB (41.4%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.2.0 Packages: pacman: 1381 lib: 353 Shell: fish v: 3.3.1
default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.13
Garuda (2.5.6-2):
System install date:     2022-03-22
Last full system update: 2022-03-25
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Timeshift (maybe)
Failed units:

After keeping my pc idle(offline work such as seeing documents etc) for more than 10min, my internet drops and doesn't work(while showing connected to wifi) till I manually reconnect it to the wifi.Also it sometimes reconnects to my wifi inbetween my online sessions.
I have dual-booted with windows 11 and experiencing this issue in all distros,but i do want to stick with garuda and later switch to it
Till now I have switched 5 different kernel linux mainline, linux,linux next-git, linux zen,linux-lts and linux zen
Switched off powersaving mode,ipv6 and mac address randomization
I have tried changing driver but I dont know if it worked(i.e. garuda is using the new drivers I have tried to install or it is using the original drivers).
I also saw some post about my card in garuda as well as arch linux forum, but it did not work.
So pls assist me and thank you in advance :slight_smile:

Is your 2018 BIOS the latest offered by the manufacturer?

Yup I checked in HP center(while i was in windows) for bios update and it says it is updated

1 Like

Have you tried some kernel boot parameters?
E.g. pci=noaer and pcie_aspm=off.

yup they are there in the boot parameters, I have added 3 such parameters which i saw, these two in your example and one for diableipv6=1

This is probably the other driver you tried, but maybe you could give a look at the part blacklisting the kernel driver and all to try again.


so after reinstalling the driver i got this for the kernel that i am currently usingi.e. zen

Good news! Module version v5.5.2_34066.20200325_COEX20180712-3232 for 8821ce.ko.zst
exactly matches what is already found in kernel 5.16.16-zen1-1-zen.
DKMS will not replace this module.

This worked thanks for the solution, I had not seen that post, since it said that user's screen was flickering while connecting to wifi.
I had installed this driver, but did not gave correct name to the file which blacklists my original driver '/etc/modprobe.d/blacklist.conf'
Thank you for this quick response
(sorry for making this post, but i had scoured arch and garuda forum for 2 days with no solution to my problem)
Thanks thou :slight_smile:

1 Like

First of all: welcome! :slight_smile: , then, you're welcome.
And what's more, you don't have to be sorry for a post, especially when it is so well done.
I hope you'll like our distro and forum to get an idea, over time, of the average quality of the first topics of new users or some new topics in general :joy:

1 Like

Yup I am surely enjoying this distro more than zorin,mint and manjaro.btw how do i close this post, I have got my solution.
(I am seeing it will close in 2 days)

Yes, it will close automatically 2 days after the last post (mods and T4-level users can do it at any time), giving some time just in case you or anyone else has anything to add.
But it will get closed. This is important to avoid "necrobumping" in the future.


Phew this was not closed.
The problem is back when i Shut down and logged in again.
Do you need any logs?
Now it disconnects and reconnects almost randomly

Disable mac address randomization.

Then reboot your router and laptop.

1 Like

Hi I followed many of your steps in earlier posts that you have posted, btw I have already done that

Disable Wifi power saving:

You can disable Network Manager's power saving features by creating /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf with the following command::

sudo touch /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

Add the following contents to the newly created conf file with your preferred text editor:

wifi.powersave = 0

Alternately, you can run the following command to generate the required conf file automatically:

echo -e "[connection]\nwifi.powersave = 0" | sudo tee /etc/modprobe.d/rtl8821ce.conf

Then restart Network Manager, or reboot.

Install the rtw88-dkms-git driver from the Chaotic AUR.

If you have already installed any other driver version then uninstall that driver before proceeding. Once the driver has been uninstalled, then install the rtw88-dkms-git Chaotic AUR driver with the following command:

sudo  pacman -Syu rtw88-dkms-git

Then reboot.

Create /etc/modprobe.d/rtl8821ce.conf:

sudo touch /etc/modprobe.d/rtl8821ce.conf

Add the following contents to the newly created conf file with your preferred text editor:

options rtw_pci disable_aspm=1
blacklist rtw88_8821ce

Alternately, you can run the following command to generate the required conf file automatically:

echo -e "options rtw_pci disable_aspm=1\nblacklist rtw88_8821ce" | sudo tee /etc/modprobe.d/rtl8821ce.conf

Then reboot.


To add full completeness.


Got this, btw i did make the conf for powersave, installed the driver and got this for the command
cat blacklist.conf:-

File: blacklist.conf
blacklist rtw88_8821ce

I have rebooted, the internet seems stable, will add more if the problem persists or I will mark the above one as the solution. Thank you for speedy response


The problem still persists.I think so there is problem with rtl8821CE and some other realtek cards,but it is much stable now, the wifi doesn't drop anymore when idle.
Sometimes it disconnects and reconnects to the wifi thou. I sus the realtek wifi cards are to blame as other users experience this a lot too in many other distros.
Thanks for the help, I guess this is the closest it can get to solving the issue.
Any other suggestions maybe helpful thou.

I completely reinstalled garuda linux and it completely solved the problem, no more hiccups anymore.
Wrote, to help someone else who comes reading this

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.