RPCS3 build issues

Had to edit as it was a different issue.

Preferably i want to installl RPCS3 through garuda assistant but it returns "target not found". Trying with pamac but it instead just hangs. I did attempt to build but ran into another error.

:: jack2 and pipewire-jack are in conflict (jack). Remove pipewire-jack? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: removing pipewire-jack breaks dependency 'pipewire-jack' required by lib32-pipewire-jack
:: removing pipewire-jack breaks dependency 'pipewire-jack' required by pipewire-support
System:
  Kernel: 5.16.11-zen1-2-zen x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=74168034-3331-4447-b79f-cfe584359abd rw [email protected]
    cryptdevice=UUID=5b832090-a2c7-482f-bd8d-c98baf90653c:luks-5b832090-a2c7-482f-bd8d-c98baf90653c
    root=/dev/mapper/luks-5b832090-a2c7-482f-bd8d-c98baf90653c quiet splash
    rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
  Desktop: Cinnamon 5.2.7 tk: GTK 3.24.31 wm: muffin vt: 7
    dm: LightDM 1.30.0 Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: Dell product: Inspiron 7559 v: 1.2.0
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: Dell model: 0H0CC0 v: A00 serial: <superuser required> UEFI: Dell
    v: 1.2.0 date: 09/22/2016
Battery:
  ID-1: hidpp_battery_0 charge: 100% condition: N/A volts: 4.2 min: N/A
    model: Logitech Gaming Mouse G900 type: N/A serial: <filter> status: Full
CPU:
  Info: model: Intel Core i7-6700HQ bits: 64 type: MT MCP arch: Skylake-S
    family: 6 model-id: 0x5E (94) stepping: 3 microcode: 0xEC
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 6 MiB desc: 1x6 MiB
  Speed (MHz): avg: 800 min/max: 800/3500 scaling: driver: intel_pstate
    governor: powersave cores: 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 800
    8: 800 bogomips: 41599
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
    IBRS_FW, STIBP: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort mitigation: TSX disabled
Graphics:
  Device-1: Intel HD Graphics 530 vendor: Dell driver: i915 v: kernel ports:
    active: HDMI-A-1,eDP-1 empty: none bus-ID: 00:02.0 chip-ID: 8086:191b
    class-ID: 0300
  Device-2: NVIDIA GM107M [GeForce GTX 960M] driver: nvidia v: 510.54
    alternate: nouveau,nvidia_drm pcie: gen: 1 speed: 2.5 GT/s lanes: 8
    link-max: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 02:00.0
    chip-ID: 10de:139b class-ID: 0302
  Device-3: Sunplus Innovation Integrated_Webcam_HD type: USB
    driver: uvcvideo bus-ID: 1-4:6 chip-ID: 1bcf:28b0 class-ID: 0e02
  Display: x11 server: X.Org v: 1.21.1.3 driver: X:
    loaded: modesetting,nvidia gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 2816x864 s-dpi: 85 s-size: 838x257mm (33.0x10.1")
    s-diag: 877mm (34.5")
  Monitor-1: HDMI-1 mapped: HDMI-A-1 pos: primary,right
    model: HDMI1-2714UDH serial: <filter> built: 2016 res: 1536x864 hz: 60
    dpi: 65 gamma: 1.2 size: 596x335mm (23.5x13.2") diag: 685mm (27")
    ratio: 16:9 modes: max: 4096x2160 min: 720x400
  Monitor-2: eDP-1 pos: primary,left model: Chi Mei Innolux built: 2013
    res: 1280x720 hz: 60 dpi: 95 gamma: 1.2 size: 344x193mm (13.5x7.6")
    diag: 394mm (15.5") ratio: 16:9 modes: 1366x768
  OpenGL: renderer: Mesa Intel HD Graphics 530 (SKL GT2) v: 4.6 Mesa 21.3.7
    direct render: Yes
Audio:
  Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: Dell
    driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 chip-ID: 8086:a170
    class-ID: 0403
  Device-2: BEHRINGER GmbH UMC204HD 192k type: USB driver: snd-usb-audio
    bus-ID: 1-1:2 chip-ID: 1397:0508 class-ID: fe01
  Sound Server-1: ALSA v: k5.16.11-zen1-2-zen running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.47 running: yes
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Dell driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    port: d000 bus-ID: 04:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-2: Intel Wireless 3165 driver: iwlwifi v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 bus-ID: 05:00.0 chip-ID: 8086:3165 class-ID: 0280
  IF: wlp5s0 state: down mac: <filter>
  IF-ID-1: wgivpn state: unknown speed: N/A duplex: N/A mac: N/A
Bluetooth:
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8
    bus-ID: 1-5:8 chip-ID: 8087:0a2a class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 0 state: down
    bt-service: enabled,running rfk-block: hardware: no software: yes
    address: <filter>
Drives:
  Local Storage: total: 698.65 GiB used: 12.97 GiB (1.9%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital
    model: WDS250G1B0B-00AS40 size: 232.89 GiB block-size: physical: 512 B
    logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 00WD
    scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST9500420AS
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
    type: HDD rpm: 7200 serial: <filter> rev: SDM1 scheme: MBR
Partition:
  ID-1: / raw-size: 232.59 GiB size: 232.59 GiB (100.00%)
    used: 12.97 GiB (5.6%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-5b832090-a2c7-482f-bd8d-c98baf90653c
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 720 KiB (0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
  ID-3: /home raw-size: 232.59 GiB size: 232.59 GiB (100.00%)
    used: 12.97 GiB (5.6%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-5b832090-a2c7-482f-bd8d-c98baf90653c
  ID-4: /var/log raw-size: 232.59 GiB size: 232.59 GiB (100.00%)
    used: 12.97 GiB (5.6%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-5b832090-a2c7-482f-bd8d-c98baf90653c
  ID-5: /var/tmp raw-size: 232.59 GiB size: 232.59 GiB (100.00%)
    used: 12.97 GiB (5.6%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-5b832090-a2c7-482f-bd8d-c98baf90653c
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 15.5 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 54.0 C pch: 53.5 C mobo: 27.8 C sodimm: SODIMM C
  Fan Speeds (RPM): cpu: 0
Info:
  Processes: 308 Uptime: 21m wakeups: 3 Memory: 15.5 GiB
  used: 3.72 GiB (24.0%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.2.0 clang: 13.0.1 Packages: pacman: 1371 lib: 339 Shell: Bash
  v: 5.1.16 running-in: gnome-terminal inxi: 3.3.13
Garuda (2.5.5-1):
  System install date:     2022-03-03
  Last full system update: 2022-03-03
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       No/Undetected
  Snapshots:               Snapper
  Failed units:  

They don't conflict again, you're explicitly asking pacman to install lib32-jack2 which requires jack2.

This is a different issue.

If RPCS3 requires jack2 then that will need to be installed. This is a key usecase for a using a build chroot, e.g. via makechrootpkg .

1 Like

I see, so if i continue with this command everything should be fine, is that right?

sudo pacman -Syu pipewire-jack lib32-pipewire-jack

You will have a working PipeWire setup, if that's what you mean?

1 Like

Why not just download the .AppImage from their website?

Have you already tried with the update command? It should have a fix for that old jack2 conflict.

1 Like

Still have the unresolvable conflict error

I still get jack2 pipewire-jack conflict when installing WINE through assistant, thats what this post was originally about. u/ Jonathon said its due to "explicitly asking pacman to install lib32-jack2 which requires jack2".
So i continued with a different fix from the original post on the isssue.

sudo pacman -Syu pipewire-jack lib32-pipewire-jack

I thought the RPCS3 issue was due to the conflict, apparently not.

  

1 Like

Installing jack2 gives unresolvable conflict, how do i fix this?

Without knowing the specific command and output, the best option would be to use

I don't think I'll have luck building as i lack knowledge with these tools or a simple guide. I'll be fine using the appimage for now. As for the update assistant error, should i wait for fix through an update?

There is documentation available, as well as many ways of asking questions. All it needs is a little desire to learn.

On the other hand, if you just want to play games then using the AppImage is the quickest solution.

1 Like

I dont think it worth the hassle for me, i'm not sure jack2 is the error as assistant returns "target not found".

If it's not found then it's probably not in a repo, and that's probably because of

2 Likes

That makes sense now, thanks jonathon :grin:

Should i mark this as solved?

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.