Rotate grub screen in Garuda Sway

Hi Everyone,

Iam trying to rotate grub screen, i add this to /etc/default/grub :
GRUB_CMDLINE_LINUX="video=efifb fbcon=rotate:1"

but it doesnt work. Any ide for this ? thanks before

Welcome :slight_smile:
Missing your garuda-inxi.
Did you update grub?

1 Like

Hi SGS,
no i dont update any grub, i just want to rotate it 270 degree, i suspect garuda kernel zen doesnt have fbcon module ?

ah ya sorry here is my garuda-inxi :

System:
  Kernel: 6.1.7-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=02effb4e-096b-46b3-919e-9e3607539ee9 rw [email protected]
    fbcon=rotate:1 quiet quiet splash rd.udev.log_priority=3
    vt.global_cursor_default=0 loglevel=3 ibt=off
  Desktop: sway v: 1.8 info: waybar vt: 1 dm: greetd Distro: Garuda Linux
    base: Arch Linux
Machine:
  Type: Desktop System: ONE-NETBOOK product: ONE XPLAYER v: N/A
    serial: <superuser required>
  Mobo: ONE-NETBOOK model: ONE XPLAYER v: 1002-C
    serial: <superuser required> UEFI: American Megatrends LLC. v: 1AWHY7.23
    date: 12/15/2021
Battery:
  ID-1: BAT0 charge: 35.3 Wh (95.9%) condition: 36.8/40.1 Wh (91.8%)
    volts: 13.1 min: 11.6 model: Intel SR 1 SR Real Battery type: Unknown
    serial: <filter> status: charging
CPU:
  Info: model: 11th Gen Intel Core i7-1195G7 bits: 64 type: MT MCP
    arch: Tiger Lake gen: core 11 level: v4 note: check built: 2020
    process: Intel 10nm family: 6 model-id: 0x8C (140) stepping: 2
    microcode: 0x28
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 320 KiB desc: d-4x48 KiB; i-4x32 KiB L2: 5 MiB desc: 4x1.2 MiB
    L3: 12 MiB desc: 1x12 MiB
  Speed (MHz): avg: 2430 high: 3857 min/max: 400/4800:5000 scaling:
    driver: intel_pstate governor: powersave cores: 1: 2505 2: 3801 3: 2043
    4: 796 5: 3345 6: 3857 7: 750 8: 2347 bogomips: 46694
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities: <filter>
Graphics:
  Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] driver: i915 v: kernel
    arch: Gen-12.1 process: Intel 10nm built: 2020-21 ports: active: eDP-1
    empty: DP-1, DP-2, DP-3, DP-4 bus-ID: 00:02.0 chip-ID: 8086:9a49
    class-ID: 0300
  Device-2: AMD Navi 24 [Radeon RX 6400/6500 XT/6500M]
    vendor: Micro-Star MSI driver: amdgpu v: kernel arch: RDNA-2 code: Navi-2x
    process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 4 speed: 16 GT/s
    lanes: 16 ports: active: HDMI-A-1 empty: DP-5 bus-ID: 06:00.0
    chip-ID: 1002:743f class-ID: 0300
  Display: wayland server: Xwayland v: 22.1.7 compositor: sway v: 1.8
    driver: gpu: amdgpu,i915 d-rect: 4640x1920 display-ID: 1
  Monitor-1: HDMI-A-1 pos: right model: Mi Monitor serial: <filter>
    built: 2019 res: 3440x1440 hz: 50 dpi: 110 gamma: 1.2 scale: 1
    size: 797x334mm (31.38x13.15") diag: 864mm (34") modes: max: 3440x1440
    min: 720x400
  Monitor-2: eDP-1 pos: primary,left model: BW8 serial: <filter> built: 2002
    res: 1200x1920 hz: 60 dpi: 324 gamma: 1.2 scale: 1.70000004768372
    size: 94x151mm (3.7x5.94") diag: 178mm (7") modes: 1200x1920
  API: EGL/GBM Message: No known Wayland EGL/GBM data sources.
Audio:
  Device-1: Intel Tiger Lake-LP Smart Sound Audio driver: snd_hda_intel
    v: kernel alternate: snd_sof_pci_intel_tgl bus-ID: 00:1f.3
    chip-ID: 8086:a0c8 class-ID: 0403
  Device-2: AMD Navi 21/23 HDMI/DP Audio driver: snd_hda_intel v: kernel
    pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 06:00.1 chip-ID: 1002:ab28
    class-ID: 0403
  Sound API: ALSA v: k6.1.7-zen1-1-zen running: yes
  Sound Interface: sndio v: N/A running: no
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.64 running: yes
Network:
  Device-1: Intel Wi-Fi 6 AX201 driver: iwlwifi v: kernel bus-ID: 00:14.3
    chip-ID: 8086:a0f0 class-ID: 0280
  IF: wlo1 state: up mac: <filter>
  Device-2: Realtek RTL8153 Gigabit Ethernet Adapter type: USB driver: r8152
    bus-ID: 2-2.4:4 chip-ID: 0bda:8153 class-ID: 0000 serial: <filter>
  IF: enp0s13f0u2u4 state: down mac: <filter>
Bluetooth:
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 3-10:4 chip-ID: 8087:0026 class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
  Local Storage: total: 476.94 GiB used: 8.91 GiB (1.9%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 model: One-Netbook PCI-E 512G SSD
    size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 type: SSD serial: <filter> rev: EDFM90.0 temp: 50.9 C scheme: GPT
Partition:
  ID-1: / raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
    used: 8.91 GiB (1.9%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 608 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
    used: 8.91 GiB (1.9%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-4: /var/log raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
    used: 8.91 GiB (1.9%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-5: /var/tmp raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
    used: 8.91 GiB (1.9%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 15.37 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 65.0 C mobo: N/A gpu: amdgpu temp: 49.0 C
    mem: 46.0 C
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 0
Info:
  Processes: 279 Uptime: 1h 12m wakeups: 0 Memory: 15.37 GiB
  used: 5.52 GiB (36.0%) Init: systemd v: 252 default: graphical
  tool: systemctl Compilers: gcc: 12.2.1 Packages: pm: pacman pkgs: 1158
  libs: 318 tools: pamac,paru Shell: fish v: 3.6.0 default: Bash v: 5.1.16
  running-in: alacritty inxi: 3.3.24
Garuda (2.6.14-1):
  System install date:     2023-01-25
  Last full system update: 2023-01-25
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager mkinitcpio
  Windows dual boot:       No/Undetected
  Failed units:
sudo update-grub
1 Like

already done that, and restart but still same direction. no effect at all.

We use the "standard" zen kernel.
Have you tried with another one, e.g. linux or linux-lts?
Anyway there is one aspect that perhaps escapes me. How can the grub be rotated right away if that parameter is passed by selecting a line in the grub itself?
Try to see if switching or booting to a tty see the console rotated. Maybe that was the sense of that parameter.
This is exactly what happens to me if I use that parameter: after selecting the grub entry, if I press esc during plymouth or later on if a switch to a tty, I can see the rotated console.
Probably the solution you found was aimed to rotate the console and mentioned GRUB for the solution, not the problem.

2 Likes

Ah ya filo, if i going to tty i can see my tty already rotate well. But what i want to achieve is in grub to rotate. I attach my screen here, btw sorry if i mistaken something here ya

So its is possible to rotate that ?

Possibly useful:

Yeah I try that but doesn't work, only diff with my grub config is I don't have this
GRUB_GFXMODE=1200x1920x32

So I added it and GRUB still doesn't rotate

Read

Use 'auto' or check your resolution with link above, and do not add values from other posts.

I am using videoinfo inside grub cli, so I know my resolution 1200x1920x32 is correct. But yeah grub still not rotate when I put it on grub config

Maybe my logic is wrong, but I repeat that in my opinion we are going down a wrong path.

The GRUB is already launched, and shown as landscape, when you set that parameter, so it cannot be shown as portrait before (i.e. the parameter take effect).
I hope there is another approach to the problem (I don't know it unfortunately).

1 Like

Ok, then right now there is no way to rotate that grub @filo ?

Ok I think that the conclusion. Thank you everyone . I will try to rotate Plymouth and SDDM( if I am not mistaken Garuda Sway is using this as dm ) if possible. Thanks for the help

Are you going to give this a shot?

sudo pacman -S linux linux-headers

That way you would be able to test your theory about this kernel module.

It does look like the solution you are trying has worked for some folks in the past: [SOLVED] Display rotated at boot up / Newbie Corner / Arch Linux Forums

You are mistaken, I am afraid. See for yourself:

Did you run update-grubafterwards?

To be on the safe side,
finally do what you are told :slight_smile:

2 Likes

Like I replied on

Ah ya thank you for pointing this

Yes it's same config and it's doesn't work, if you talking about tty yes it's works, but for grub nope, it doesn't work. Dunno whats the wrong here


@ama-db-1 Please, do not ping with -> @ team members. :slight_smile:

does it work if you do not have the second monitor connected?

1 Like

nope, its just stay there like that lol

But for DM greetd it can be rotate via sway

only left is GRUB, and i think plymouth for splash screen that not yet rotate

Just in case it was missed, the configuration in the linked thread is not the same as what you have here.

GRUB_CMDLINE_LINUX="video=efifb fbcon=rotate_all:1"

They are using "rotate_all", not "rotate". Grub Landscape working! - r/GPDPocket