Grub changes back to 420p dispite it being 1920x1080 in /etc/default/grub config file

I have tried every method in existence to solve it, turned ever stone and every forum for it. But couldnt find anything about it.

Heres the code

GRUB_DEFAULT="0"
GRUB_TIMEOUT="5"
GRUB_DISTRIBUTOR="Garuda"
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1 loglevel=3"
GRUB_CMDLINE_LINUX=""

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices
#GRUB_ENABLE_CRYPTODISK="y"

# Set to 'countdown' or 'hidden' to change timeout behavior,
# press ESC key to display menu.
GRUB_TIMEOUT="5"

# Uncomment to use basic console
GRUB_TERMINAL_INPUT="console"

# Uncomment to disable graphical terminal
#GRUB_TERMINAL_OUTPUT="console"

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE="1920x1080"

# Uncomment to allow the kernel use the same resolution used by grub
GRUB_GFXPAYLOAD_LINUX="keep"

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"
#GRUB_DISABLE_LINUX_UUID="true"

# Uncomment to disable generation of recovery mode menu entries
GRUB_DISABLE_RECOVERY="true"

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.
#GRUB_COLOR_NORMAL="light-blue/black"
#GRUB_COLOR_HIGHLIGHT="light-cyan/blue"

# Uncomment one of them for the gfx desired, a image background or a gfxtheme
#GRUB_BACKGROUND="/path/to/wallpaper"
GRUB_THEME="/usr/share/grub/themes/garuda/theme.txt"

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

# Uncomment to make GRUB remember the last selection. This requires
GRUB_DEFAULT="Windows Boot Manager (on /dev/nvme0n1p1)"
#GRUB_SAVEDEFAULT="true"
GRUB_GFXPAYLOAD="keep"

P.S. Bonus if my windows HP boot logo comes again, it went back to default Windows 10 logo!
Thanks a lot!

I also get this error when i update my grub.

Generating grub configuration file ...
Found theme: /usr/share/grub/themes/garuda/theme.txt
Found linux image: /boot/vmlinuz-linux-tkg-bmq
Found initrd image: /boot/amd-ucode.img /boot/initramfs-linux-tkg-bmq.img
Found fallback initrd image(s) in /boot: initramfs-linux-tkg-bmq-fallback.img
Found Windows Boot Manager on /dev/[email protected]/EFI/Microsoft/Boot/bootmgfw.efi
Detecting snapshots ...
Info: Separate boot partition not detected 
Found snapshot: 2021-02-09 14:24:10 | timeshift-btrfs/snapshots/2021-02-09_14-24-10/@
Found snapshot: 2021-02-09 08:47:46 | timeshift-btrfs/snapshots/2021-02-09_08-47-46/@
Found snapshot: 2021-02-07 12:42:12 | timeshift-btrfs/snapshots/2021-02-07_12-42-12/@
Found snapshot: 2021-02-06 22:16:35 | timeshift-btrfs/snapshots/2021-02-06_22-16-35/@
Found snapshot: 2021-02-06 09:47:23 | timeshift-btrfs/snapshots/2021-02-06_09-47-23/@
Found 5 snapshot(s)
Found memtest86+ image: /boot/memtest86+/memtest.bin
/usr/bin/grub-probe: warning: unknown device type nvme0n1.
error: syntax error.
error: Incorrect command.
error: syntax error.
Syntax error at line 223
Syntax errors are detected in generated GRUB config file.
Ensure that there are no errors in /etc/default/grub
and /etc/grub.d/* files or please file a bug report with
/boot/grub/grub.cfg.new file attached.

Why you do not read?

Syntax is GRUB_GFXMODE=auto,1024x768x32 (sample)

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `videoinfo'
GRUB_GFXMODE=auto

and check what is possible, not what you like with

you can see them in real GRUB with the command `videoinfo'
4 Likes

Exactly.
Alternate method to videoinfo:

sudo pacman -S hwinfo --needed
sudo hwinfo | grep -C3 "Resolution"

https://wiki.archlinux.org/index.php/GRUB/Tips_and_tricks#Setting_the_framebuffer_resolution

5 Likes

Press C to drop to grub shell.

To get supported resolutions type:

set pager=1
videoinfo

To test the resolution:

terminal_output console
set gfxmode=1920x1080 
terminal_output gfxterm

Also, if there is an error and you cannot properly update GRUB then any settings you change will not be implemented. You should edit the actual kernel boot line to see if it works before booting.

On the Boot Garuda line in grub menu press E to edit, change the setting then ctrl-X to boot it.

3 Likes

I use 1920x1080x32 and grub works fantastic. You may need to add this.

Edit: This is the actual line in my grub.

GRUB_GFXMODE=1920x1080x32,auto

Maybe it work for you but if monitor resolution best value is less you mut use this like

sudo hwinfo | grep -C3 "Resolution"
  Model: "Generic Monitor"
  Vendor: "Generic"
  Device: "Monitor"
  Resolution: [email protected]
  Year of Manufacture: 0
  Week of Manufacture: 0
  Driver Info #0:
    Max. Resolution: 1024x768
    Vert. Sync Range: 50-90 Hz
    Hor. Sync Range: 31-61 kHz
  Config Status: cfg=new, avail=yes, need=no, active=unknown

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.