Root in Dolphin

First off - Hi everyone.

I have been distrohopping for last month or so trying to find something that will suit me and will work on my laptop and with my printer and scanner without problems. So far Garduda works great apart from root access in Dolphin.
I'm trying to access boot/efi in Dolphin. When I open efi I end up in empty folder with "cannot access /boot/efi/" message. I also tried using Dolphin right-click menu -> Administrator actions -> Open in file manager, but after typing root password in popup window it just closes with no effect.
Also tried adding new entry in app launcher "Dolphin (root)" with dbus-launch dolphin -qwindowtitle "%c" "%u" command (works in openSUSE and endeavouros). It opens Dolphin, but still no root access and same unable to access message.
Is there any way to give Dolphin root access in Garuda?

1 Like

Does this help - How to use Dolphin as root? Superuser? • KDE Community Forums

Anyways, it is a KDE thing, not related to Garuda.
Welcome to the forum!

2 Likes

Thanks for quick reply.
I know it's KDE, but on other OS 's dbus-launch works and on Garuda not.
Just tried pkexec env DISPLAY=$DISPLAY XAUTHORITY=$XAUTHORITY KDE_SESSION_VERSION=5 KDE_FULL_SESSION=true dolphin

i receive

QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root'
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root'
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root'
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root'
Icon theme "adwaita" not found.
Icon theme "ubuntu-mono" not found.
Icon theme "yaru" not found.
Icon theme "Mint-X" not found.
Icon theme "elementary" not found.
kf.xmlgui: KActionCollection::setComponentName does not work on a KActionCollection containing actions! "dolphin"
"Session bus not found\nTo circumvent this problem try the following command (with Linux and bash)\nexport $(dbus-launch)"

Will try other solution from last reply to the topic you linked.
One question - what "Dolphin right-click menu -> Administrator actions -> Open in file manager" suposed to do? Open as root or it have some other meaning?

Yup, opening as root. This is what you may want. I remember it as “Root Actions”... :thinking: Anyways, you got the solution, I think :slight_smile:

2 Likes

I just tried this - [SOLVED]Dolphin as root - #2 by dalto - General system - EndeavourOS
It works for me.
Your just have to install kde-servicemenus-rootactions from AUR.
When you right-click, there is a sub-menu Root actions.

3 Likes

Unforutantely in my case it does not work. Just asks for su password but after I type it and hit Enter the window close. That's it.

Same for me. Did the second link work?

No. I had kde-servicemenus-rootactions installed already. I use Polish language so I translated "Działania administratora" to "Administartor actions", which was incorrect as it is "Root actions"
Also tried kdesu dbus-launch dolphin
Same - asks for su password and nothing happens.

edit:
If I won't find any solution I will probably try libkdeinit5_dolphin.so trick or use krusader/thunar

Login as root. You are not meant to run Dolphin as a user with root privileges anymore. KDE put a stop to that practice 2-3-4 years back. Security issues. The "kde-servicemenus-rootactions" which is an AUR plugin still shows it as a default action, though it will not work. You can disable that action from showing--it's just a checkbox.

3 Likes

I've got solution
I installed/built rootactions-servicemenu via pamac. It uninstalled kde-servicemenus-rootactions (probably some conflict), but now right-click -> Root actions -> Open in file manager opens Dolphin with root privileges.
Screenshot

1 Like

Yeah, yeah, yeah--another AUR pkg that allows you to do what you shouldn't do. Best to learn to use KDE, not AUR pkgs. What you want to accomplish is fully within the bounds of KDE already :frowning:

2 Likes

I'm Linux noob that's why I try to google (DDG actually) my problems and use forums to find solutions.
I thought AUR is actually a good thing and that is what makes Arch/Garuda special. Could you please be so kind and explain it to me or direct to some knowlege source, how can I exactly

I would really appreciate your help.

To be honest, ~ 3 years ago I also wanted to have it that way, but to destroy your system, Kate is enough (at least under KDE).

But all other Linux DEs tend not to have this.

The question is rather, why do you need root in Dolphin?
With a few simple commands in the terminal, you can certainly achieve the same result.

Then enter your wish with, "Linux Arch change owner", in DDG and

https://wiki.archlinux.org/title/users_and_groups
you have learned something again and can call yourself Anonymous :wink:

It is all in Arch Wiki.

6 Likes

@c00ter is correct.

1 Like

Install Midnight Commander if you want to work in a file manager as root. It is a dual paned file manager in built a terminal UI application.

It has double click support and will allow you to manipulate files as root. It has an awesome built in text editor and many advanced features. Install a red skin so that it is readily apparent you are running as root and you should never create problems for yourself.

Only use root privs when absolutely necessary

7 Likes

@bonesaw I never said he is not. I did my research and I already knew that KDE team made it unaccesible on purpose. I do know what risks are associated with running GUI tools as root. I also knew that it is possible anyway and wanted to know how it is done. I'm willing to learn, that is why I asked here, but his answer besides adding +1 to his post count didn't really helped or solved anything?

@SGS Thank you.
Like I said in my first post I have been distrohopping a lot in last month. I need access to root in Dolphin to access /boot/efi as there are leftovers there from previous distros. Currently 98.3/508MiB (19%). I do know I can do it in terminal, but I preffer GUI view.

I do realize I can damage/destroy system, but I'm not bothered. That's how I will learn. I have fresh install of Win10/Mint20.2/Garuda with no data I'd like to keep, so in worst case scenario I will just reinstall.

That is the answer I was hoping for from @c00ter so thanks again. I didn't even know where and what to look for so I simply DDG "dolphin root", "dolphin as supersuser" etc.
I will read through it and see how it can help me with bypassing root lock for Dolphin without using AUR pkgs.

One last thing. I was doing "Hello world" in 80's on my Atari 65XE, so I'm more Anonymous than Anonymous. I also was able to command the turtle to move in Logo :sunglasses:

10 PRINT "Hello world" ;
20 GOTO 10

edit: @tbg might give it a shot. It brings back memories of MS-DOS and Norton Commander

1 Like

c00ter has been lying down and resting a bit, that's why I wrote.
I haven't counted but the reference to the Garuda and Arch wiki is probably a few hundred times here in the forum as well in the

which no one reads, so there are some biting comments from time to time. :smiley:

2 Likes

BTW, @eldresso , why did you open this topic?
You have solved it yourself.
And, after all this trouble, you could just install nautilus or something :grinning_face_with_smiling_eyes:...

1 Like

@SGS I also tried to search Arch forums and wiki, but when one doesn't know what to look for it's hard to find answer or I just suck at searching :grinning:
On endeavouros dbus-launch dolphin -qwindowtitle "%c" "%u worked. Also found few other answers and commands from Arch/Manjaro/Linux that didn't helped at all, so after everything suggested in this topic failed I decided to go for it and experiment myself.
kde-servicemenus-rootactions not working, but there is package with similar name, so why not try it? Worst can happen I will have to reinstall system.

@arco I was hoping to grab few forum badges like "Total n00b - created topic that has been answered thousands of times" or "Time waster - solves problems created by himself" :wink:

or krusader, or thunar or Nemo.
That was easy way out and I guess I'm kind of person that like to make his life harder than it have to be :grinning:

1 Like

I'll finish it tomorrow :smiley:

One is ready :slight_smile:
MSS

7 Likes