Roblox (thru grapejuice) just lags for no reason at times

garuda-inxi Garuda's PrivateBin

On Windwoes it would never lag at all.

On Garuda it just lags at random for no reason even at minimum graphics.

I've tried changing the renderer, using the "Third party integrations" toggling that mesa ogl override.

On further inspektion, i've seen a performance guide page. Doing what's there solves the random lagging for the most part, but now it's random microstutters. Can I get rid of them?

Roblox Renderer: DX11
DXVK: Disabled
These two are the least efficient combination of settings. Try Vulkan renderer, OpenGL renderer or DX11 with DXVK enabled.
EDIT: Also disabling FPS unlocker may make a difference but I doubt it.

1 Like

Oops! I forgot to give updated settings out.

Also I have that force voxel renderer FFlag on.

Why? Can you disable it and try again?
inxi lists only an old iGPU so using OpenGL may fix stutter. Does vkcube from package vulkan-tools properly display a cube?

1 Like

Apparently the voxel renderer is faster.

Yes the vkcube DOES display a spinning cube, but visible microstutter is seen.
To my eyes it looks like the cube is running at like 15-20 fps.

MESA-INTEL: warning: Performance support disabled, consider sysctl dev.i915.perf_stream_paranoid=0 Selected GPU 0: Intel(R) HD Graphics 405 (BSW), type: IntegratedGpu

is what i got when running it in the terminal.

doas sysctl dev.i915.perf_stream_paranoid=0 (yes i use doas when i can)

makes the warning go away, but apparently it doesn't persist after a reboot.

Under Windows my iGPU only supports OpenGL 4.4, no Vulkan at all, and DX up to 11.

Under Garuda apps say OpenGL 4.6 (probably the fact that Mesa is changing my OGL version) , and that Vulkan is supported, and DX probably got overridden too.

What I get from KDE System Info for Vulkan: (won't let me select, sorry for picture)

For OGL it says my video driver is crocus

It seems like all renderers have some sort of stutter. Like even if you click on
any one of my games which are not demanding at all, I still basically lag or at least stutter for no reason.

Please send garuda-inxi so I clearly know your specs.
While ingame, if you hit Shift+F5 you will see your FPS. When you feel stutter if your FPS stays same, the stutter may be caused by window manager / desktop environment and going fullscreen with F11 may fix it.
Shift+F2 will give more information including renderer.


I alr sent it in the OP but here it is anyway:

garuda-inxi Garuda's PrivateBin

I will try the hotkeys when I get around to it.

btw i've noticed stutter even in fullscreen.

also if you go fullscreen then out window decorations disappear for roblox.

My bad, sorry :man_facepalming:

also if you go fullscreen then out window decorations disappear for roblox.

Minimizing and restoring may help.

No problem.

1 Like

I tested in 2 games, one of which is mine, everything was green except for network receive, that means it's my fiber optic connection's fault.

In untitled tag game [beta] the lag mainly happened in the lobby map (where people pick the maps) and randomly in game where all numbers would be red for like 10 seconds, i'd have 2fps and in latter game i got around 30fps most of the time. in the former game around 60 (this is without the unlocker)

I'm running out of ideas but your laptop may be thermal throttling while playing. Disable all performance related options in Garuda Assistant, apply, reboot and run Roblox with MangoHUD. If MangoHUD doesn't work, use a monitoring app like KDE System Monitor or put widgets on your desktop.
If CPU reaches above 85 degrees celsius, it may be throttling.

1 Like

They seem to already be disabled.

Unchecked those 2 boxes, rebooted, installed mangohud (and mangoapp)

did this command
mangohud python -m grapejuice player

and then it just sends me to the home page. Right now I am not free lol.


mangohud python -m grapejuice app

I don't see anything special happen. No temp monitor or anything.

Also, maybe the garuda devs should make a utility that provides hardware temps? :smiley:

sudo pacman -S --needed gamescope-git
mangohud gamescope -f -w 1366 -h 768 -W 1366 -H 768 -- python -m grapejuice app

Now do you see the overlay? If you see it but it doesn't display temps, you can use GOverlay to configure it.

No CAP_SYS_NICE, falling back to regular-priority compute and threads. Performance will be affected.


I'll edit the post with the info needed.

The warning is not much important.

OK, but when I launched it it put me into 4:3 mode.

Hit F11.
Does overlay work?

yes, i get CPU usage and VULKAN in all caps.

edit: oh, oh! I get something that could cause epileptic seizures! Thankfully i'm not sensitive to them. Sound is choppy, and it seems that mango hud is z fighting lol