Right click, root options do not work

when i press right click on something, go to root actions and chose either open in file manager or open terminal here, nothing happens.

System:
Kernel: 5.17.1-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=38add348-b329-4341-8751-7bbc309d28a1 rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=0 loglevel=3
Desktop: KDE Plasma v: 5.24.4 tk: Qt v: 5.15.3 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: Micro-Star model: B450M PRO-VDH MAX (MS-7A38) v: 8.0
serial: <superuser required> UEFI: American Megatrends v: B.40
date: 11/07/2019
CPU:
Info: model: AMD Ryzen 5 3600X bits: 64 type: MT MCP arch: Zen 2
family: 0x17 (23) model-id: 0x71 (113) stepping: 0 microcode: 0x8701013
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
L3: 32 MiB desc: 2x16 MiB
Speed (MHz): avg: 4117 high: 4197 min/max: 2200/4409 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 4159 2: 4077
3: 4138 4: 4147 5: 4158 6: 4162 7: 4105 8: 4171 9: 4160 10: 4197 11: 4178
12: 3752 bogomips: 91200
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Retpolines, IBPB: conditional, STIBP: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: AMD Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT]
vendor: Tul / PowerColor driver: amdgpu v: kernel pcie: gen: 4
speed: 16 GT/s lanes: 16 ports: active: DP-1,HDMI-A-1 empty: DP-2,DP-3
bus-ID: 2b:00.0 chip-ID: 1002:731f class-ID: 0300
Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.1
compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting,radeon
alternate: fbdev,vesa gpu: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 4480x1440 s-dpi: 96 s-size: 1185x381mm (46.65x15.00")
s-diag: 1245mm (49.01")
Monitor-1: DP-1 mapped: DisplayPort-0 pos: right model: Asus VP228
serial: <filter> built: 2015 res: 1920x1080 hz: 60 dpi: 102 gamma: 1.2
size: 476x268mm (18.74x10.55") diag: 546mm (21.5") ratio: 16:9 modes:
max: 1920x1080 min: 720x400
Monitor-2: HDMI-A-1 mapped: HDMI-A-0 pos: primary,left
model: BenQ GL2706PQ serial: <filter> built: 2016 res: 2560x1440 hz: 60
dpi: 109 gamma: 1.2 size: 597x336mm (23.5x13.23") diag: 685mm (27")
ratio: 16:9 modes: max: 2560x1440 min: 640x480
OpenGL: renderer: AMD Radeon RX 5600 XT (navi10 LLVM 13.0.1 DRM 3.44
5.17.1-zen1-1-zen)
v: 4.6 Mesa 22.0.1 direct render: Yes
Audio:
Device-1: AMD Navi 10 HDMI Audio driver: snd_hda_intel v: kernel pcie:
gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 2b:00.1 chip-ID: 1002:ab38
class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 2d:00.4 chip-ID: 1022:1487 class-ID: 0403
Device-3: C-Media CM108 Audio Controller type: USB
driver: hid-generic,snd-usb-audio,usbhid bus-ID: 3-3:4 chip-ID: 0d8c:013c
class-ID: 0300
Sound Server-1: ALSA v: k5.17.1-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.49 running: yes
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Micro-Star MSI driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: f000 bus-ID: 25:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp37s0 state: down mac: <filter>
Device-2: Realtek RTL8811AU 802.11a/b/g/n/ac WLAN Adapter type: USB
driver: rtl88XXau bus-ID: 1-3:3 chip-ID: 0bda:a811 class-ID: 0000
serial: <filter>
IF: wlp3s0f0u3 state: up mac: <filter>
IF-ID-1: enp3s0f0u1 state: unknown speed: -1 duplex: half mac: <filter>
IF-ID-2: virbr0 state: down mac: <filter>
Bluetooth:
Device-1: HTC (High Tech ) MT65xx Android Phone type: USB
driver: rndis_host v: kernel bus-ID: 1-1:5 chip-ID: 0bb4:0004
class-ID: 0a00 serial: <filter>
Report: bt-service: enabled,stopped note: tool can't run
Drives:
Local Storage: total: 3.18 TiB used: 757.22 GiB (23.2%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Toshiba model: DT01ACA300
size: 2.73 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
type: HDD rpm: 7200 serial: <filter> rev: ABB0 scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: Samsung model: SSD 750 EVO 500GB
size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 1B6Q scheme: GPT
Partition:
ID-1: / raw-size: 448.27 GiB size: 448.27 GiB (100.00%)
used: 169.92 GiB (37.9%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 25.8 MiB (8.6%) fs: vfat dev: /dev/sdb1 maj-min: 8:17
ID-3: /home raw-size: 448.27 GiB size: 448.27 GiB (100.00%)
used: 169.92 GiB (37.9%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
ID-4: /var/log raw-size: 448.27 GiB size: 448.27 GiB (100.00%)
used: 169.92 GiB (37.9%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
ID-5: /var/tmp raw-size: 448.27 GiB size: 448.27 GiB (100.00%)
used: 169.92 GiB (37.9%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 17.2 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/sdb3 maj-min: 8:19
ID-2: swap-2 type: zram size: 15.63 GiB used: 244.2 MiB (1.5%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: N/A mobo: N/A gpu: amdgpu temp: 53.0 C
mem: 56.0 C
Fan Speeds (RPM): N/A gpu: amdgpu fan: 0
Info:
Processes: 415 Uptime: 1h 46m wakeups: 0 Memory: 15.63 GiB
used: 6.99 GiB (44.7%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.2.0 clang: 13.0.1 Packages: apt: 0 pacman: 2372 lib: 532
Shell: fish v: 3.4.1 default: Bash v: 5.1.16 running-in: konsole
inxi: 3.3.15
Garuda (2.6.1-1):
System install date:     2022-01-14
Last full system update: 2022-04-11
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Snapper
Failed units:            bluetooth-autoconnect.service systemd-oomd.socket

Are the other functions working? Like copy, move, delete...?

Yes. As far as i see only the open in terminal and open in filemanager as root do not work

And i dont know if that has something to do with the problem, but when i try to execute dolphin (the file manager) as root via command (sudo dolphin) it says "Executing Dolphin with sudo is not possible due to unfixable security vulnerabilities."

Plasma does not like when you try to run root actions in a GUI. Actually linux in general does not like this behavior thus the warning. You will need to do some research as to how to properly use the terminal with elevated privileges to make these types of file system changes.

2 Likes

? When why did it work the whole time and now it just stopped working?

What advantages does running Dolphin and/or Terminal as root give you?
Maybe you have a specific use case for that.

ease of use. I dont like to use the terminal for everything.

What happened just before it stopped working?
Did you perform an system update, installed a package, got a computer hang, etc.?
For a bit of debugging, you could run Dolphin from terminal and then try to open as root within Dolphin like you did before. Maybe something will post in the terminal.

1 Like

Has it ever worked or since when has it been like this?


As far as I know it has been this way for quite some time. Unless you were running your system as root which is also a terrible idea. It would help if we knew what you were trying to accomplish then we can give you better advice. Here is an example of how to move a file in a terminal with elevated privileges...

You have a file named xyz(for this let us say it is in Documents (this is case sensitive) and you want to move it to /usr/share/themes which a normal user can not do since /usr/ is in root.
You need to open a terminal.
then change directory to Documents.
cd Documents
Once there you can issue ls to check the file name and spelling before you move/copy it.
now while still in Documents type su to elevate your user rights.
Now to move/copy the file to the new location.
cp -r xyz /usr/share/themes
It will not give a confirmation only a warning if you get it wrong.
Now move to the dirctory where you have moved the file.
cd /usr/share/themes
again check to see it is there.
ls
That's it you may have to log out and in again after it is case by case.

3 Likes

Some things you need to as a best practice other wise you will break your system and be right back here asking how to fix it...and having no idea what and why you did was wrong in the first place. Linux takes work and research.

1 Like
╰─λ dolphin
Qt: Session management error: networkIdsList argument is NULL
Qt: Session management error: networkIdsList argument is NULL
kf.kio.widgets: The "NextcloudAction" plugin still installs the desktop file for plugin loading. Please use JSON metadata instead, see  KAbstractFileItemActionPlugin class docs for instructions.
kf.service.services: KApplicationTrader: mimeType "x-scheme-handler/file" not found
qt.qpa.xcb: could not connect to display
qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, wayland-egl, wayland, wayland-xcomposite-egl, wayland-xcomposite-glx, xcb.


You break it, you fix it.

Check if some snapshot work or reinstall.

1 Like

wow, thats some support here. I think if its like this, i will search for another linux distro.. Until now i was happy with the support here, but now it changed like this..

You tried to launch dolphin from terminal as your user (not root) and it failed?

That is unfortunate i just gave you very detailed instructions on how to do this. It is not the distros fault you do not want to learn.

2 Likes

Yeah, that log is from open dolphin without root, and then trying to open the terminal as root via the rightlick.

If launching dolphin from terminal as normal user fails, you have other problems than the Root Actions Menus.
They need to get fixed before you look at the Root Actions Menus again.

I didnt mean you with that, That was a reply to SGS message.