Resume from hibernation stopped working

Hi everyone
Resume from hibernation stopped working. When I resume from hibernation it boots into a fresh new session.
Haven’t changed anything in the configuration.

The only thing I can recall is a message during boot about a tmp bug:

tmp tmp0: [Firmware Bug]: TPM interrupt not working, polling instead

I googled it, but it seems to be not related.

My problem is similar to this post: https://forum.garudalinux.org/t/hibernate-not-working/27770 except the solution offered there didn’t work for me.

System:
  Kernel: 6.1.65-1-lts arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: acpi_pm
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-lts
    root=UUID=cf1a950a-21a0-473c-ac72-bb7719092eb3 rw rootflags=subvol=@
    quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
    resume=UUID=a97f3b45-3de3-4fee-bb58-2bb325bfbcaf ibt=off
  Desktop: KDE Plasma v: 5.27.10 tk: Qt v: 5.15.11 wm: kwin_x11 vt: 2
    dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: HP product: HP ZBook Firefly 14 inch G8 Mobile
    Workstation PC v: N/A serial: <superuser required> Chassis: type: 10
    serial: <superuser required>
  Mobo: HP model: 880D v: KBC Version 30.37.00 serial: <superuser required>
    UEFI: HP v: T76 Ver. 01.08.00 date: 01/11/2022
Battery:
  ID-1: BAT0 charge: 38.8 Wh (99.2%) condition: 39.1/53.2 Wh (73.5%)
    volts: 12.5 min: 11.6 model: Hewlett-Packard Primary type: Li-ion
    serial: <filter> status: not charging cycles: 168
  Device-1: hid-34:88:5d:86:61:2a-battery model: Bluetooth Mouse
    M336/M337/M535 serial: N/A charge: N/A status: discharging
CPU:
  Info: model: 11th Gen Intel Core i7-1165G7 bits: 64 type: MT MCP
    arch: Tiger Lake gen: core 11 level: v4 note: check built: 2020
    process: Intel 10nm family: 6 model-id: 0x8C (140) stepping: 1
    microcode: 0xB4
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 320 KiB desc: d-4x48 KiB; i-4x32 KiB L2: 5 MiB desc: 4x1.2 MiB
    L3: 12 MiB desc: 1x12 MiB
  Speed (MHz): avg: 400 min/max: 400/4700 scaling: driver: intel_pstate
    governor: powersave cores: 1: 400 2: 400 3: 400 4: 400 5: 400 6: 400 7: 400
    8: 400 bogomips: 44864
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities: <filter>
Graphics:
  Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] vendor: Hewlett-Packard
    driver: i915 v: kernel arch: Gen-12.1 process: Intel 10nm built: 2020-21
    ports: active: eDP-1 empty: DP-1, DP-2, DP-3, DP-4, HDMI-A-1
    bus-ID: 00:02.0 chip-ID: 8086:9a49 class-ID: 0300
  Device-2: NVIDIA TU117GLM [Quadro T500 Mobile] vendor: Hewlett-Packard
    driver: nvidia v: 545.29.06 alternate: nouveau,nvidia_drm non-free: 545.xx+
    status: current (as of 2023-10; EOL~2026-12-xx) arch: Turing code: TUxxx
    process: TSMC 12nm FF built: 2018-2022 pcie: gen: 4 speed: 16 GT/s
    lanes: 4 link-max: lanes: 16 bus-ID: 01:00.0 chip-ID: 10de:1fbb
    class-ID: 0302
  Device-3: Chicony HP HD Camera driver: uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-2:2 chip-ID: 04f2:b6bf
    class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.9 with: Xwayland v: 23.2.2
    compositor: kwin_x11 driver: X: loaded: modesetting,nvidia unloaded: nouveau
    alternate: fbdev,intel,nv,vesa dri: iris gpu: i915 display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 model: AU Optronics 0x559c built: 2021 res: 1920x1080
    hz: 60 dpi: 158 gamma: 1.2 size: 309x174mm (12.17x6.85") diag: 355mm (14")
    ratio: 16:9 modes: 1920x1080
  API: EGL v: 1.5 hw: drv: intel iris drv: nvidia platforms: device: 0
    drv: nvidia device: 1 drv: iris device: 3 drv: swrast gbm: drv: iris
    surfaceless: drv: nvidia x11: drv: iris inactive: wayland,device-2
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: intel mesa v: 23.2.1-arch1.2
    glx-v: 1.4 direct-render: yes renderer: Mesa Intel Xe Graphics (TGL GT2)
    device-ID: 8086:9a49 memory: 14.95 GiB unified: yes
  API: Vulkan v: 1.3.269 layers: 4 device: 0 type: integrated-gpu name: Intel
    Xe Graphics (TGL GT2) driver: mesa intel v: 23.2.1-arch1.2
    device-ID: 8086:9a49 surfaces: xcb,xlib device: 1 type: discrete-gpu
    name: NVIDIA T500 driver: nvidia v: 545.29.06 device-ID: 10de:1fbb
    surfaces: xcb,xlib device: 2 type: cpu name: llvmpipe (LLVM 16.0.6 256
    bits) driver: mesa llvmpipe v: 23.2.1-arch1.2 (LLVM 16.0.6)
    device-ID: 10005:0000 surfaces: xcb,xlib
Audio:
  Device-1: Intel Tiger Lake-LP Smart Sound Audio vendor: Hewlett-Packard
    driver: sof-audio-pci-intel-tgl
    alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 00:1f.3
    chip-ID: 8086:a0c8 class-ID: 0401
  API: ALSA v: k6.1.65-1-lts status: kernel-api tools: N/A
  Server-1: PipeWire v: 1.0.0 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
  Device-1: Intel Wi-Fi 6 AX201 driver: iwlwifi v: kernel bus-ID: 00:14.3
    chip-ID: 8086:a0f0 class-ID: 0280
  IF: wlp0s20f3 state: up mac: <filter>
Bluetooth:
  Device-1: Intel AX201 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-10:4 chip-ID: 8087:0026
    class-ID: e001
  Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 5.2
    lmp-v: 11 status: discoverable: no pairing: no class-ID: 7c010c
RAID:
  Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd
    v: 0.6 port: N/A bus-ID: 00:0e.0 chip-ID: 8086:9a0b rev: class-ID: 0104
Drives:
  Local Storage: total: 476.94 GiB used: 294.66 GiB (61.8%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
    model: MZVL2512HCJQ-00BH1 size: 476.94 GiB block-size: physical: 512 B
    logical: 512 B speed: 63.2 Gb/s lanes: 4 tech: SSD serial: <filter>
    fw-rev: HPS2NGXH temp: 42.9 C scheme: MBR
Partition:
  ID-1: / raw-size: 62.7 GiB size: 62.7 GiB (100.00%) used: 23.37 GiB (37.3%)
    fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:3
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 576 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 398.32 GiB size: 391 GiB (98.16%)
    used: 271.29 GiB (69.4%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-4: /var/log raw-size: 62.7 GiB size: 62.7 GiB (100.00%)
    used: 23.37 GiB (37.3%) fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:3
  ID-5: /var/tmp raw-size: 62.7 GiB size: 62.7 GiB (100.00%)
    used: 23.37 GiB (37.3%) fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:3
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: partition size: 15.62 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/nvme0n1p4 maj-min: 259:4
  ID-2: swap-2 type: zram size: 15.31 GiB used: 708.8 MiB (4.5%)
    priority: 100 comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 8
    dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 55.0 C mobo: N/A
  Fan Speeds (rpm): N/A
Info:
  Processes: 303 Uptime: 3m wakeups: 0 Memory: total: 16 GiB note: est.
  available: 15.31 GiB used: 5.37 GiB (35.0%) Init: systemd v: 255
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6
  Packages: pm: pacman pkgs: 1853 libs: 448 tools: octopi,pamac,paru,yay
  Shell: fish v: 3.6.2 running-in: konsole inxi: 3.3.31
Garuda (2.6.19-2):
  System install date:     2023-07-09
  Last full system update: 2023-12-11
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut nvidia-dkms
  Windows dual boot:       No/Undetected
  Failed units:      

Below is my /etc/fstab

# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=006C-30E2                            /boot/efi      vfat    defaults,noatime 0 2
UUID=cf1a950a-21a0-473c-ac72-bb7719092eb3 /              btrfs   subvol=/@,defaults,noatime,compress=zstd 0 0
UUID=cf1a950a-21a0-473c-ac72-bb7719092eb3 /root          btrfs   subvol=/@root,defaults,noatime,compress=zstd 0 0
UUID=cf1a950a-21a0-473c-ac72-bb7719092eb3 /srv           btrfs   subvol=/@srv,defaults,noatime,compress=zstd 0 0
UUID=cf1a950a-21a0-473c-ac72-bb7719092eb3 /var/cache     btrfs   subvol=/@cache,defaults,noatime,compress=zstd 0 0
UUID=cf1a950a-21a0-473c-ac72-bb7719092eb3 /var/log       btrfs   subvol=/@log,defaults,noatime,compress=zstd 0 0
UUID=cf1a950a-21a0-473c-ac72-bb7719092eb3 /var/tmp       btrfs   subvol=/@tmp,defaults,noatime,compress=zstd 0 0
UUID=a4298782-ad2e-435d-834c-0105edffe861 /home          ext4    defaults,noatime 0 2
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0
UUID=a97f3b45-3de3-4fee-bb58-2bb325bfbcaf none swap defaults 0 0

As suggested previously I created a file /etc/dracut.conf.d/resume-from-hibernate.conf and added:

add_dracutmodules+=" resume "

And later ran:

sudo dracut-rebuild

But it still doesn’t work.
Any help will be much appreciated.
Thanks in advance

Try this one, slightly different:

3 Likes

Hi @hemanzur , your Fstab is well configured , so please follow this steps :

edit /etc/default/grub → Look for the GRUB_CMDLINE_LINUX line and ensure that it includes the resume parameter with the UUID of your swap partition .
→ something like this GRUB_CMDLINE_LINUX="resume=UUID=a97f3b45-3de3-4fee-bb58-2bb325bfbcaf"
→ after saving changes , sudo grub-mkconfig -o /boot/grub/grub.cfg
try hibernating your system again

→ and share the output of journalctl | grep -i hibernate

Thanks !!
It worked like a charm !!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.