Restoring kernel after pacman update/transaction interrupt, and trouble booting after restoring kernel (permission issues)

During a system update (pacman -Syu), my kernels were uninstalled without being re-installed. The system didn't boot because there is no kernel on the default location any longer.

Solution, boot to USB and re-install kernel through pacman:
I launched garuda through USB bootable, and entered my garuda install by running garuda-chroot -a in terminal.

Then I ran pacman -S linux-tkg-bmq (as root), and got the following crash during Timeshift backup:

resolving dependencies...
looking for conflicting packages...

Packages (1) linux-tkg-bmq-5.10.15-120

Total Installed Size:  73.40 MiB
Net Upgrade Size:       0.08 MiB

:: Proceed with installation? [Y/n]
(1/1) checking keys in keyring                                       [--------------------------------------] 100%
(1/1) checking package integrity                                     [--------------------------------------] 100%
(1/1) loading package files                                          [--------------------------------------] 100%
(1/1) checking for file conflicts                                    [--------------------------------------] 100%
(1/1) checking available disk space                                  [--------------------------------------] 100%
:: Running pre-transaction hooks...
(1/2) Creating Timeshift snapshot before upgrade...
E: System disk not found!
Unable to run timeshift-autosnap! Please close Timeshift and try again. Script will now exit...
error: command failed to execute correctly
error: failed to commit transaction (failed to run transaction hooks)
Errors occurred, no packages were upgraded.

I don't know how to get past this. Any ideas?

Also, Timeshift doesn't backup my boot partition. I'll create a separate issue for that, but just so you know it is an option that I don't have.

After uninstalling timeshift-autosnap, I got to install the kernel (SUCCESS thanks to those who helped on Telegram).

However, while booting, after initializing/"attempting to initialize" the kernel, I encountered the following error:

[FAILED] Failed to start manage swap spaces on zram, files and partitions

What is going on? I thought installing the kernel would solve the problem. There were no errors while installing it.

1 Like
systemctl status systemd-swap

To see more information on the failure :thinking:

1 Like

I can't boot into terminal (terminal through USB bootable only):

<user>@garuda-dr460nized-gaming /> systemctl status systemd-swap
System has not been booted with systemd as init system (PID 1). Can't operate.
Failed to connect to bus: Host is down

But:

[email protected] / [127]> swapon
NAME        TYPE         SIZE USED  PRIO
/dev/zram0  partition 1000.1M   0B 32767
/dev/zram1  partition 1000.1M   0B 32767
/dev/zram2  partition 1000.1M   0B 32767
/dev/zram3  partition 1000.1M   0B 32767
/dev/zram4  partition 1000.1M   0B 32767
/dev/zram5  partition 1000.1M   0B 32767
/dev/zram6  partition 1000.1M   0B 32767
/dev/zram7  partition 1000.1M   0B 32767
/dev/zram8  partition 1000.1M   0B 32767
/dev/zram9  partition 1000.1M   0B 32767
/dev/zram10 partition 1000.1M   0B 32767
/dev/zram11 partition 1000.1M   0B 32767
/dev/zram12 partition 1000.1M   0B 32767
/dev/zram13 partition 1000.1M   0B 32767
/dev/zram14 partition 1000.1M   0B 32767
/dev/zram15 partition 1000.1M   0B 32767

And all my partiotions are detected:
https://bin.garudalinux.org/?0cfca6b165ef5de4#Ai2xCdNDmZf8epYbeC3PpQ1eYGUyQhuZwX62oJPp4bxP

You can't reach run level 3 from Grub?

How to boot to run level 3:

2 Likes

Thank you didn't know about that.

I got into level 3, ran systemctl status systemd-swap, got the following error:

mode = os.stat(zram_dev).st_mode
TypeError: stat: path should be string, bytes, os.PathLike or integer, not NoneType

Now that you have internet access and a working terminal why not try this:

sudo pacman -Syyuu linux-lts

If this errors out you can post the rrors from the terminal using termbin.

You have to post /var/log/pacman.log last part concerning this update.
It's not acceptable that kernels get uninstalled with normal upgrade.
If it's a bug, you are expected to help find it and fix it.

3 Likes
cat /var/log/pacman.log | nc termbin.com 9999

Luckily for you @petsam is here, I was just going to give him a ping for you as he is the best there is for this kind of problem.

3 Likes

https://termbin.com/upu0

The kernel deletion happened today.

Are you using the --noconfirm option when you run your updates?

2 Likes

no. That looks dangerous.

But look at this (from log), sudden shift in time:

[2021-02-15T12:54:44+0100] [ALPM-SCRIPTLET] e[1mPlease check and mergee[0m
[2021-02-15T12:54:44+0100] [ALPM] running 'rebuild-detector.hook'...
[2021-02-15T18:29:57+0100] [PACMAN] Running 'pacman -Syyuu linux-lts'
[2021-02-15T18:29:57+0100] [PACMAN] synchronizing package lists

Seems like I interrupted the update by reboot. Simplest explanation.

After the update and reboot, I got to the login screen (thank you!).

But, now I get a black screen followed by a return to the login screen whenever I try to login to my own account.

Try to switch to the LTS kernel at the grub boot prompt screen if it installed succesfully.

I am only on my cell currently, so I will leave you in others capable hands. This isn't too helpful at this point, but I have one suggestion for the future.

Timeshift is an awesome program, but as you have now learned the hard way it cannot recover from some truly catastrophic system problems.

I would suggest learning how to image your system. A belt and suspenders approach is always best when it comes to backups.

1 Like

as confirmed from your log

[2021-02-15T11:10:18+0100] [ALPM] upgraded kplotting (5.78.0-1 -> 5.79.0-1)
[2021-02-15T11:10:18+0100] [ALPM] upgraded kross (5.78.0-1 -> 5.79.0-1)
[2021-02-15T11:10:20+0100] [ALPM] upgraded latte-dock-git (r4977.69904611-1 -> r5012.3ba909a9-1)
[2021-02-15T11:10:20+0100] [ALPM] transaction interrupted
[2021-02-15T11:34:29+0100] [PACMAN] Running 'pacman -Syyyu'
[2021-02-15T11:34:29+0100] [PACMAN] synchronizing package lists
[2021-02-15T11:34:31+0100] [PACMAN] starting full system upgrade
[2021-02-15T11:36:41+0100] [PACMAN] Running 'pacman -Syu linux-tkg-bmq'

Rebooting while there is an ongoing upgrade is deadly dangerous for your system...

4 Likes

Thank you so much

I tried to switch to the LTS kernel: Got the same issue, black screen and back to login screen.

Get info.
Go in tty3 and check for errors

journalctl -b -p3
journalctl -b -p3 --user
systemctl status systemd-logind
3 Likes

Thank you for these commands. I figured it out by myself, there were permission issues with home/<user>. It wasn't owned by the respective user.

I used chown recursive to fix the problem: chown -R <user> home/<user>

I can login now, and everything seems to be functional!

Just magic. Kernel delete themself and /home change owner.

Covid19 on PC :slight_smile: