Reinstall timeshift

Hi,

Today I realized, that timeshift was no longer installed. I allready reistalled it with pacman -S timeshift. But is there something I have to configure? Like that all the snapshots can be found in the grub menu?

I also just saw right now, that there are 2 entries in grub. My garuda which i am using right now, but which only has advanced options - no timeshift. And a garuda which seems to be on the same partition, which has time timeshift as subentry. But this one is not longer working.

Hi there, welcome.
Have you installed timeshift-support, which provides important configuration?
After that I'd
sudo update-grub
and reboot.

When installing timeshift-support, then there is a note, that it is in conflict with snapper and snap-pac. Same thing was with timeshift. What is snapper anyway? Can't really recognize, that I've installed it

Snapper is the substitute of timeshift.
So, one of the two should be used.
It was introduced/announced here

1 Like

Which one should I use then?

Also - my grub menu is currently looking like:

  1. garuda
    1.1 garuda advanced
  2. garuda (partition name here)
    2.1 advanced
    2.2 uefi
    2.3 timeshfit stuff

the 2. is not working. But there in I find my snapshots. How do I replace all the stuff from 2. to 1. and remove this wheird garuda (2.)?

I'd go for the newer solution, installing
sudo pacman -S snapper-support
which will bring in the tool, its config, and remove timeshift.
But the choice is up to you. Both work.
Then we'll see how to fix the old grub entry.
GRUB has configuration files for that.

ok. Uninstalled timeshift and installed snapper-support. Still no application I can open.

?
Rebooted?
Read again the announcement, and maybe our Wiki

1 Like

Ok, snapper seems to work. I can find it under Btrfs assistent/snapper

The snapper entry in grub also has new snapshots. But the snapper selection is still under the second, not working, garuda.

So, how do I move it up to the first garuda (working and currently used) entry?
Also - is snapper now finished or should I do smth in the configs that it is working like before?

The Backup path is currently /

Unfortunately I'm without my laptop today and cannot help much for this.
Basically, grub configuration files are stored in/etc/grub.d/. So in the meanwhile you could provide the output of:

ls /etc/grub.d/

And start checking the contents of those files to see how they match with the grub you see.
Normally the kernel goes in 10_linux and the snapshots might be under 41_ or 42_

output of ls /etc/grub.d/:

.rwxr-xr-x  12k root 25 Dez  2021  10_linux
.rwxr-xr-x  13k root 25 Dez  2021  20_linux_xen
.rwxr-xr-x  12k root 25 Dez  2021  30_os-prober
.rwxr-xr-x 1,4k root 25 Dez  2021  30_uefi-firmware
.rwxr-xr-x  700 root 13 Dez  2021  35_fwupd
.rwxr-xr-x  214 root 25 Dez  2021  40_custom
.rwxr-xr-x  215 root 25 Dez  2021  41_custom
.rwxr-xr-x  26k root 14 Dez  2021  41_snapshots-btrfs
.rwxr-xr-x 1,2k root 12 Jun  2021  60_memtest86+
.rwxr-xr-x  487 root 14 Dez  2021  61_custom_leave_options
.rw-r--r--  483 root 25 Dez  2021  README

40_custom:

#!/bin/sh
exec tail -n +3 $0
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.

41_custom

#!/bin/sh
cat <<EOF
if [ -f  \${config_directory}/custom.cfg ]; then
source \${config_directory}/custom.cfg
elif [ -z "\${config_directory}" -a -f  \$prefix/custom.cfg ]; then
source \$prefix/custom.cfg
fi
EOF#!/bin/sh
cat <<EOF
if [ -f  \${config_directory}/custom.cfg ]; then
source \${config_directory}/custom.cfg
elif [ -z "\${config_directory}" -a -f  \$prefix/custom.cfg ]; then
source \$prefix/custom.cfg
fi
EOF

41_snapshots-btrfs (without comments)

set -e

sysconfdir="/etc"
grub_btrfs_config="${sysconfdir}/default/grub-btrfs/config"

[[ -f "$grub_btrfs_config" ]] && . "$grub_btrfs_config"
[[ -f "${sysconfdir}/default/grub" ]] && . "${sysconfdir}/default/grub"

## Exit the script, if:
[[ "${GRUB_BTRFS_DISABLE,,}" == "true" ]] && exit 0 # Disable Grub-btrfs is set to true (default=false)
if ! type btrfs >/dev/null 2>&1; then exit 0; fi # btrfs-progs isn't installed
[[ -f "${GRUB_BTRFS_MKCONFIG_LIB:-/usr/share/grub/grub-mkconfig_lib}" ]] && . "${GRUB_BTRFS_MKCONFIG_LIB:
-/usr/share/grub/grub-mkconfig_lib}" || exit 0 # grub-mkconfig_lib couldn't be found
# Root filesystem isn't btrfs
root_fs=$(${grub_probe} --target="fs" / 2>/dev/null)
[[ "$root_fs" != "btrfs" ]] && exit 0

## Error Handling
print_error()
{
local err_msg="$*"
local bug_report="If you think an error has occurred , please file a bug report at \" https://github.
com/Antynea/grub-btrfs \""
printf "%s\n" "${err_msg}" "${bug_report}" >&2 ;

10_linux is pretty big. So I wont copy it here.

Please also the contents of
/boot/grub/grub.cfg
/boot/grub/grub-btrfs.cfg
which is generated starting from the files above every time you update the grub, and provides the final outcome.

there is no custom.cfg:

drwxr-xr-x    - root 30 Dez  2021  fonts
drwxr-xr-x    - root 30 Dez  2021  locale
drwxr-xr-x    - root 30 Dez  2021  themes
drwxr-xr-x    - root 30 Dez  2021  x86_64-efi
.rw-r--r--  35k root  9 Jan 14:00  grub-btrfs.cfg
.rw-r--r--  11k root  9 Jan 11:57  grub.cfg
.rw-r--r-- 1,0k root  8 Jan 17:37  grubenv

edit:
the output:

Sorry, I edited my post now...

I am 2. I uploaded the output to pastebin - was too big to paste it here

Actually - I took a look again to the grub menu. I described it wrong.
the snapshots arn't under 2. . They have their own entry. It only looked like it, since the snapshot entry is directly under the not-working-garuda

So the only thing to do is actually remove the old garuda, that grub looks clean.
here a picture of grub rn: 20220109-152019 — ImgBB

Also just to remention it - the not-working-garuda is on the same partition as the working one. I never installed it twice

I noticed the same looking into your files.
The only thing I can say is that the wrong Garuda entry is generated by the os-prober, which should have only found Windows.
In my opinion you could try to make a backup copy of

/etc/grub.d/30_os-prober

edit it,

sudo micro /etc/grub.d/30_os-prober

remove the part under Windows (if there's anything like that), should be the part from

menuentry 'Garuda Linux (on /dev/nvme0n1p5)'

to the end, then
sudo update-grub
Reboot.

I don't find smth like garuda linux in it.
Only thing I found was on line 186 (A bit above was some windows stuff) what you maybe mean.
File: #! /bin/shset -e# grub-mkconfig helper script.# Copyright (C) 2006,2007, - Pastebin.com

No, I wouldn't touch that file.
I'd go for the hard way...
Backup /boot/grub/grub.cfg
Edit It removing the lines from 679 to 715 (numbers of your pastbin file, not the actual grub.cfg file!).
In this way, if you reboot you shouldn't see that line anymore.
But then I would anyway try
sudo update-grub and reboot to see if it appears again.
It is the hard way in the sense that if something goes wrong, you should use a live USB to login and restore the previous file.
From a live USB you could also reinstall the grub, which is another good option.

1 Like

the etc grub file in the pastebin only has 350 lines. What do you mean?

edit:

Have to make an edit since I can't make another reply since I registered today.

Thank you for helping me out :slight_smile:
The entry is removed now (and the snapshot stuff was already fixed earlier)

1 Like