Reboot instead of shutdown!

i am using garuda for a while now, everything worked fine until recently something broke and my pc reboot every time i try to shut it down.
it happened when i was trying to install and use Xrdp. (but i don't know if its related)

i did some research and i realized there is something wrong with my network adaptor and Wake-on-lan future!
i use dual boot and windows 11 works just fine and there is no problem shutting down with windows.

i even tried to test shutting down throw a live garuda OS on a flash drive, it also did not worked and the pc rebooted again!
after this happened i disabled the Wake on lan on both windows and garuda, and disabled the fast boot option in windows but it didn't worked again!

the only fix that i found is to disable the Power On by PCIE in bios options witch disables the wake on lan function also, but i can't do it because i desperately need it(Wake-on-Lan)!

things that i've tried and did not worked:
resetting the bios
adding the xhci_hcd.quirks=270336 to Kernel Parameters
trying to shut down from live garuda OS
completely disconnecting the Lan cable and then try to shut down( yes! the network adapter instantly turns the pc on even without a lan cable connected :confused: )
even shutting down from GRUB boot menu did not worked. :persevere:

my Network adaptor is Intel 82579LM Gigabit Network connection and the driver i use is e1000e

other info >
inxi -Faz output:

System:
Kernel: 5.15.10-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=72e94341-668a-424d-8830-c9832204de7a rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 xhci_hcd.quirks=270336 loglevel=3
Desktop: KDE Plasma 5.23.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11
vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop System: CDM product: CDM-001 v: N/A
serial: <superuser required>
Mobo: AAEON model: LIQ77A v: Rev X.0x serial: <superuser required>
UEFI: American Megatrends v: 9901 date: 07/23/2013
CPU:
Info: model: Intel Core i5-2500 bits: 64 type: MCP arch: Sandy Bridge
family: 6 model-id: 0x2A (42) stepping: 7 microcode: 0x2F
Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 256 KiB
desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB L3: 6 MiB
desc: 1x6 MiB
Speed (MHz): avg: 1706 high: 1793 min/max: 1600/3700 scaling:
driver: intel_cpufreq governor: schedutil cores: 1: 1596 2: 1793 3: 1692
4: 1745 bogomips: 26339
Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf
mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled
Type: mds mitigation: Clear CPU buffers; SMT disabled
Type: meltdown mitigation: PTI
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
IBRS_FW, STIBP: disabled, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: AMD Baffin [Radeon RX 460/560D / Pro
450/455/460/555/555X/560/560X]
vendor: Gigabyte driver: amdgpu v: kernel bus-ID: 01:00.0
chip-ID: 1002:67ef class-ID: 0300
Display: x11 server: X.Org 1.21.1.2 compositor: kwin_x11 driver:
loaded: amdgpu,ati unloaded: modesetting alternate: fbdev,vesa
display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
s-diag: 582mm (22.9")
Monitor-1: HDMI-A-0 res: 1920x1080 hz: 60 dpi: 69
size: 708x398mm (27.9x15.7") diag: 812mm (32")
OpenGL: renderer: AMD Radeon RX 460 Graphics (POLARIS11 DRM 3.42.0
5.15.10-zen1-1-zen LLVM 13.0.0)
v: 4.6 Mesa 21.3.1 direct render: Yes
Audio:
Device-1: Intel 7 Series/C216 Family High Definition Audio
vendor: ASUSTeK P8Z77-V LX driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
chip-ID: 8086:1e20 class-ID: 0403
Device-2: AMD Baffin HDMI/DP Audio [Radeon RX 550 640SP / RX 560/560X]
vendor: Gigabyte driver: snd_hda_intel v: kernel bus-ID: 01:00.1
chip-ID: 1002:aae0 class-ID: 0403
Sound Server-1: ALSA v: k5.15.10-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.42 running: yes
Network:
Device-1: Intel 82579LM Gigabit Network vendor: ASUSTeK driver: e1000e
v: kernel modules: ndiswrapper port: f040 bus-ID: 00:19.0
chip-ID: 8086:1502 class-ID: 0200
IF: eno1 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:
Local Storage: total: 1.2 TiB used: 68.81 GiB (5.6%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 870 EVO 500GB
size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 2B6Q scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST3500413AS
size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: HDD rpm: 7200 serial: <filter> rev: JC4B scheme: GPT
ID-3: /dev/sdc maj-min: 8:32 vendor: Western Digital
model: WD3200AVJS-63B6A0 size: 298.09 GiB block-size: physical: 512 B
logical: 512 B speed: 3.0 Gb/s type: N/A serial: <filter> rev: 3A02
scheme: GPT
Partition:
ID-1: / raw-size: 72.53 GiB size: 72.53 GiB (100.00%)
used: 31.97 GiB (44.1%) fs: btrfs dev: /dev/sda4 maj-min: 8:4
ID-2: /boot/efi raw-size: 100 MiB size: 98.4 MiB (98.42%)
used: 27.4 MiB (27.9%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 72.53 GiB size: 72.53 GiB (100.00%)
used: 31.97 GiB (44.1%) fs: btrfs dev: /dev/sda4 maj-min: 8:4
ID-4: /var/log raw-size: 72.53 GiB size: 72.53 GiB (100.00%)
used: 31.97 GiB (44.1%) fs: btrfs dev: /dev/sda4 maj-min: 8:4
ID-5: /var/tmp raw-size: 72.53 GiB size: 72.53 GiB (100.00%)
used: 31.97 GiB (44.1%) fs: btrfs dev: /dev/sda4 maj-min: 8:4
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.7 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: amdgpu temp: 44.0 C
Fan Speeds (RPM): N/A gpu: amdgpu fan: 434
Info:
Processes: 244 Uptime: 30m wakeups: 0 Memory: 7.7 GiB
used: 2.21 GiB (28.8%) Init: systemd v: 249 tool: systemctl Compilers:
gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 2105 lib: 471 Shell: fish
v: 3.3.1 default: Bash v: 5.1.12 running-in: konsole inxi: 3.3.11

I should mention again that i know there is other topics that said disabling WOL from bios fixed their problem. but what if someone needs the WOL function like me?
Lets figure it out once and for all :grin:

Your best bet would be to test quite a few alternate kernels as there is a high probability this is a kernel related issue.

I would test at least these kernels in the following order:

linux-lts
linux-mainline
linux
linux-hardened
linux-next-git

Be sure you have the corresponding headers package installed for each kernel you test out.

There is also a possibility that the driver or firmware is part of your problem.

I would recommend testing the linux-fimware-git package.

I would also recommend testing the alternate e1000e-dkms Ethernet driver package from the AUR:

Good luck, and welcome to the Garuda community.

Edit:

I just noticed something rather bizarre in your inxi output:

Did you install your driver using ndiswrapper? This should not be required as your driver is included in the kernel. If you used ndiswrapper then please uninstall that package and driver now. Try the e1000e-dkms driver package I linked earlier if the e1000e kernel module was not working properly for you. Under no circumstances would I recommend using the ndiswrapper driver these days.

6 Likes

I second TBG here, no one should use NDISWrapper in Linux these days. Anyone attempting to use one will just enter untested waters (given that Garuda by default uses the cutting-edge Zen kernel)

2 Likes

I've also seen this "you said shutdown but instead I'll reboot" a few times on a couple of systems. It was fixed (I think) with a kernel update.

5 Likes

Is this a variant of the "you said reboot but I will restart" error? In that one shutdown works, but any reboot attempt bypasses 'bios' and grub (or other boot manager) to just restart. My Garuda used to do it, my MxLinux still does, but perhaps new kernels helped there too?

4 Likes

i was new to garuda and kinda wanted to test everything, now that i think more, the problem may have appeared when i installed a windows driver with ndiswrapper! (witch did not worked and the adaptor gone completely down)
and then i inserted the e1000e again using the modprob command and removed the windows driver.
now after you said, i completely uninstalled the ndiswrapper but the problem still exists, so im going to give other options a shot.
inxi -Faz now return

Network:
Device-1: Intel 82579LM Gigabit Network vendor: ASUSTeK driver: e1000e
v: kernel port: f040 bus-ID: 00:19.0 chip-ID: 8086:1502 class-ID: 0200
IF: eno1 state: up speed: 100 Mbps duplex: full mac: <filter>

I tested e1000e-dkms driver
i also removed the previous default installed linux-firmware and instead installed linux-firmware-git
and i tested these three kernels

5.16.0-rc6-1-mainline
5.10.84-229-tkg-cacule
5.14.16-xanmod1-cacule-1

but weirdly none did not worked! (wake on lan is still disabled and even with the lan cable not connected the problem still persists)
i am sure that the fault is with my network adapter because when i turn in off from bios the shutdown function works fine and there will be no instant reboot.

and there is high probability that the ndiswrapper was the cause because both kernel and driver was working fine before i messed with ndiswrapper out of curiosity.

what else can i try to test? is there any specific kernel that might fix the problem? would reinstalling garuda fix the problem?
is there a chance that Windows11 (and the drivers installed on it) is the cause?

the inxi -Faz output of three kernels that i tested:

 linux-mainline
 System:
Kernel: 5.16.0-rc6-1-mainline x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-mainline
root=UUID=72e94341-668a-424d-8830-c9832204de7a rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 xhci_hcd.quirks=270336 loglevel=3
Desktop: KDE Plasma 5.23.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11
vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux

Network:
Device-1: Intel 82579LM Gigabit Network vendor: ASUSTeK driver: e1000e
v: kernel port: f040 bus-ID: 00:19.0 chip-ID: 8086:1502 class-ID: 0200
IF: eno1 state: up speed: 100 Mbps duplex: full mac: <filter>

linux-lts-tkg

System:
Kernel: 5.10.84-229-tkg-cacule x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: intel_pstate=passive
BOOT_IMAGE=/@/boot/vmlinuz-linux-lts-tkg-cacule
root=UUID=72e94341-668a-424d-8830-c9832204de7a rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.23.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11
vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux

Network:
Device-1: Intel 82579LM Gigabit Network vendor: ASUSTeK driver: e1000e
v: 3.8.7-NAPI port: f040 bus-ID: 00:19.0 chip-ID: 8086:1502 class-ID: 0200
IF: eno1 state: up speed: 100 Mbps duplex: full mac: <filter>

linux-xanmond
System:
Kernel: 5.14.16-xanmod1-cacule-1 x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-xanmod-cacule
root=UUID=72e94341-668a-424d-8830-c9832204de7a rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.23.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11
vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux

Network:
Device-1: Intel 82579LM Gigabit Network vendor: ASUSTeK driver: e1000e
v: 3.8.7-NAPI port: f040 bus-ID: 00:19.0 chip-ID: 8086:1502 class-ID: 0200
IF: eno1 state: up speed: 100 Mbps duplex: full mac: <filter>

Possibly, test a live ISO for an idea if that's likely.

Very possibly.

Try this:

Go into the Windows Device Manager - Network Adaptors - right click on your wireless adaptor.

Then, go to power management and deselect "allow the computer to turn off this device to save power".

Reboot.

If that doesn't help, try disabling the adapter completely through the Device Manager in Windows.

1 Like

Hi, i just discovered something else! When the Turn on by PCIE from bios is disabled the garuda shutdown works well with no issue, but the shutdown button from Grub boot menu still have the reboot issue!
This can mean that its not just the network card that is faulty!

These types of issues are most likely resolved either with a bios or kernel update.

1 Like

I reinstalled the garuda (from a flahs drive that i installed it in the first place with no issue)
But the problem STILL persist! I want to cry right now :man_facepalming:

Next thing i will try is disconnecting all SATA hard drives, reseting the bios and then booting into a live garuda os. If the problem fixes (wich i think will) i will uninstall that ***** windows 11 forever because it will show that that's the cause.
I'll keep in touch and update the topic in case anyone facing same issue.
i appreciate any suggestion :heart:

I read something about resetting the BIOS and checking parameters, but I haven't seen if you verified if an update is available.

1 Like

You should also test linux , linux-lts , and linux-hardened as well.

4 Likes

I checked, the manufacture is a Chinese old (not so popular) company who did not support the product. Im in Iran and because of economic problems its not that easy to find another motherboard( i know its so old :slight_smile: ) and beside that im so curios why should this happen!

i tried to install linux-lts from octopi but it gives 404 http error code while downloading!
but i will give the rest a shot.

now that im writing this im in live garuda os, i disconnected all SATA storage devices, reseted the bios and booted here, the problem unbelievably still persist! im going crazy!
i disconnected every thing! now there is nothing here but me, live garuda and the zen kernel witch all used to work well even with the wake on lan enabled few weeks ago!

could it really be a kernel issue? if yes why does it worked fine few weeks earlier?
or is it a hardware or bios problem? and again if yes why the windows 11 works well?
my mind is blowing!
looks unfixable!
i still appreciate any suggestions. :heart:

though i guess the windows works well because of the driver it uses, but i dont know, can i simulate windows shutdown function or something like that?

I noticed something! When i shutdown the system, on that screen witch prints the log while shutting down, there is some lines of gray color having the word "can't", they fade soon and i can't read them, i think its good to investigate them also, but where can i find last shutdown log containing those lines?

I'm seeing this again on my X230. I'm pretty sure this is a kernel (or systemd?) regression, and so there's nothing to be done but wait until it's fixed.

5 Likes

What happens when you type in the terminal power off and press enter?

2 Likes

same, power off, then back on.