Realtek RTL8822BE - wifi unable to connect

System:
Kernel: 5.16.5-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=44a8aedb-d4a2-4821-a318-8639db755bfe rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
Desktop: KDE Plasma 5.23.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11
vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: HP product: HP Pavilion Gaming Laptop 15-cx0xxx
v: Type1ProductConfigId serial: <superuser required> Chassis: type: 10
serial: <superuser required>
Mobo: HP model: 8477 v: 69.49 serial: <superuser required> UEFI: Insyde
v: F.18 date: 01/21/2019
Battery:
ID-1: BAT1 charge: 24.0 Wh (57.6%) condition: 41.7/52.8 Wh (78.9%)
volts: 11.0 min: 11.6 model: Hewlett-Packard PABAS0241231 type: Li-ion
serial: <filter> status: Discharging
CPU:
Info: model: Intel Core i5-8250U bits: 64 type: MT MCP arch: Coffee Lake
family: 6 model-id: 0x8E (142) stepping: 0xA (10) microcode: 0xEA
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
L3: 6 MiB desc: 1x6 MiB
Speed (MHz): avg: 3394 high: 3402 min/max: 400/3400 scaling:
driver: intel_pstate governor: performance cores: 1: 3401 2: 3400 3: 3401
4: 3400 5: 3401 6: 3402 7: 3349 8: 3401 bogomips: 28800
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX unsupported
Type: l1tf mitigation: PTE Inversion
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
IBRS_FW, STIBP: conditional, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel UHD Graphics 620 vendor: Hewlett-Packard driver: i915
v: kernel bus-ID: 00:02.0 chip-ID: 8086:5917 class-ID: 0300
Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] vendor: Hewlett-Packard
driver: nvidia v: 510.47.03 alternate: nouveau,nvidia_drm bus-ID: 01:00.0
chip-ID: 10de:1c8d class-ID: 0300
Device-3: Lite-On HP Wide Vision HD Camera type: USB driver: uvcvideo
bus-ID: 1-5:2 chip-ID: 04ca:707f class-ID: 0e02 serial: <filter>
Display: x11 server: X.Org 1.21.1.3 compositor: kwin_x11 driver:
loaded: modesetting,nvidia display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
s-diag: 582mm (22.9")
Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 142
size: 344x193mm (13.5x7.6") diag: 394mm (15.5")
OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2)
v: 4.6 Mesa 21.3.5 direct render: Yes
Audio:
Device-1: Intel Sunrise Point-LP HD Audio vendor: Hewlett-Packard
driver: snd_hda_intel v: kernel alternate: snd_soc_skl bus-ID: 00:1f.3
chip-ID: 8086:9d71 class-ID: 0403
Device-2: NVIDIA GP107GL High Definition Audio driver: snd_hda_intel
v: kernel bus-ID: 01:00.1 chip-ID: 10de:0fb9 class-ID: 0403
Sound Server-1: ALSA v: k5.16.5-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.45 running: yes
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Hewlett-Packard driver: r8169 v: kernel port: 4000 bus-ID: 02:00.0
chip-ID: 10ec:8168 class-ID: 0200
IF: eno1 state: down mac: <filter>
Device-2: Realtek RTL8822BE 802.11a/b/g/n/ac WiFi adapter
vendor: Hewlett-Packard driver: rtw_8822be v: N/A modules: rtw88_8822be
port: 3000 bus-ID: 03:00.0 chip-ID: 10ec:b822 class-ID: 0280
IF: wlan0 state: up mac: <filter>
Bluetooth:
Device-1: Realtek Realtek Bluetooth 4.2 Adapter type: USB driver: btusb
v: 0.8 bus-ID: 1-6:3 chip-ID: 0bda:b00b class-ID: e001 serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
Local Storage: total: 931.51 GiB used: 18.28 GiB (2.0%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: HGST (Hitachi) model: HTS721010A9E630
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B
speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter> rev: A3T0
scheme: GPT
Partition:
ID-1: / raw-size: 487.78 GiB size: 487.78 GiB (100.00%)
used: 18.24 GiB (3.7%) fs: btrfs dev: /dev/sda8 maj-min: 8:8
ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%)
used: 36.9 MiB (38.5%) fs: vfat dev: /dev/sda2 maj-min: 8:2
ID-3: /home raw-size: 487.78 GiB size: 487.78 GiB (100.00%)
used: 18.24 GiB (3.7%) fs: btrfs dev: /dev/sda8 maj-min: 8:8
ID-4: /var/log raw-size: 487.78 GiB size: 487.78 GiB (100.00%)
used: 18.24 GiB (3.7%) fs: btrfs dev: /dev/sda8 maj-min: 8:8
ID-5: /var/tmp raw-size: 487.78 GiB size: 487.78 GiB (100.00%)
used: 18.24 GiB (3.7%) fs: btrfs dev: /dev/sda8 maj-min: 8:8
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.68 GiB used: 256 KiB (0.0%) priority: 100
dev: /dev/zram0
ID-2: swap-2 type: partition size: 3.78 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/sda6 maj-min: 8:6
Sensors:
System Temperatures: cpu: 29.8 C pch: 29.5 C mobo: 27.8 C
Fan Speeds (RPM): N/A
Info:
Processes: 263 Uptime: 1h 15m wakeups: 2 Memory: 7.68 GiB
used: 3.52 GiB (45.9%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1859 lib: 548 Shell: fish
v: 3.3.1 default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.12
Garuda (2.5.4-2):
head: cannot open '/var/log/pacman.log' for reading: No such file or directory
System install date:
Last full system update: 2022-02-03
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Snapper
Failed units:            nmb.service

I've installed Garuda Linux on my machine and upgraded the system. However, after I reboot, I face a wifi connection problem : the network manager cannot detect my wifi router but only detects my phone if I set it as a mobile hotspot. I've been searching a lot for a fix to this issue and I even reinstalled Garuda so many times but after I reboot I come to face that annoying problem again.

I've tried many solutions provided for such a problem in various websites and forums and none of them did work :

restarting the network manager with sudo systemctl restart NetworkManager

disabling wifi powersave

adding 2 lines as following to /etc/NetworkManager/NetworkManager.conf:

[device]

wifi.scan-rand-mac-address=no

adding 2 lines as following to /etc/NetworkManager/conf.d/nm.conf :

[device]

wifi.backend=iwd

and I runned these commands :

sudo pacman -S iwd

sudo systemctl stop wpa_supplicant

sudo systemctl mask wpa_supplicant

sudo systemctl enable --now iwd.service

sudo systemctl daemon-reload

sudo systemctl start iwd.service

I also restarted my wifi router in vain

So what shall I do now ?
NOTE :

Sometimes when trying some of the mentionned fixes, the network manager detects my wifi router but it cannot connect to it and shows : Authorization supplicant failed

Hi there, welcome.

This is not enough information.

Let's start providing your garuda-inxi as per the new topic template. :wink:

3 Likes

@filo Done

Mmm, nasty device I guess. I normally start searching for the device inside the Networking Support category, but haven-t found real solutions.
You may want to start reading these:
https://forum.garudalinux.org/search?q=%23issues-assistance:wifi-ethernet-bt%20RTL8822BE%20order:latest
I hope someone will have other advices...

3 Likes

Install:

Then reboot and post:

grep -r "blacklist\|install\|options"  /etc/modprobe.d/ /etc/modules-load.d/ /usr/lib/modprobe.d/ 
4 Likes

could you guide me how to install it, as I'm an absolute Arch Linux beginner.

Have you tried booting into windows, then reboot (warm boot) into linux.

paru rtw88-dkms-git
2 Likes

I deleted WIndows, I'm managing to get used to Linux

# Maintainer: PRESFIL <echo cHJlc2ZpbEBwcm90b25tYWlsLmNvbQo= | base64 -d>
# Contributor: librewish <[email protected]
# Contributor:  Bjoern Franke <[email protected]>
# Contributor: feanor1397 <[email protected]>

pkgname=rtw88-dkms-git
_pkgname=rtw88
pkgver=r1.029812e
pkgrel=2
pkgdesc='Newest Realtek rtlwifi codes'
arch=('any')
url='https://github.com/lwfinger/rtw88'
depends=('dkms')
makedepends=('git' 'gcc' 'make')
provides=('rtlwifi_new-dkms')
conflicts=('rtlwifi_new-dkms')
provides=('rtlwifi_new-dkms' 'rtlwifi_new-extended-dkms-git' 'rtlwifi_new-rtw88-dkms')
conflicts=('rtlwifi_new-dkms' 'rtlwifi_new-extended-dkms-git' 'rtlwifi_new-rtw88-dkms')
replaces=('rtlwifi_new-extended-dkms-git' 'rtlwifi_new-rtw88-dkms-git')
install=${pkgname}.install
source=("git+https://github.com/lwfinger/rtw88.git")
sha256sums=('SKIP')

pkgver() {
cd "${_pkgname}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
: 

What am I supposed to do now

press Q to quit the PKGBUILD review and then confirm to proceed with installation

2 Likes

/usr/lib/modprobe.d/amdgpu.conf:options amdgpu ppfeaturemask=0xffffffff
/usr/lib/modprobe.d/optimus-manager.conf:blacklist nouveau
/usr/lib/modprobe.d/optimus-manager.conf:blacklist nvidia_drm
/usr/lib/modprobe.d/optimus-manager.conf:blacklist nvidia_uvm
/usr/lib/modprobe.d/optimus-manager.conf:blacklist nvidia_modeset
/usr/lib/modprobe.d/optimus-manager.conf:blacklist nvidia
/usr/lib/modprobe.d/systemd.conf:options bonding max_bonds=0
/usr/lib/modprobe.d/systemd.conf:options dummy numdummies=0
/usr/lib/modprobe.d/nvidia-utils.conf:blacklist nouveau
/usr/lib/modprobe.d/nvdimm-security.conf:install libnvdimm /usr/bin/ndctl load-keys ; /sbin/modprobe --ignore-
install libnvdimm $CMDLINE_OPTS
/usr/lib/modprobe.d/bluetooth-usb.conf:options btusb reset=1
/usr/lib/modprobe.d/nobeep.conf:blacklist pcspkr
/usr/lib/modprobe.d/noime.conf:blacklist mei
/usr/lib/modprobe.d/noime.conf:blacklist mei_me

Was this output above run after installing the driver?

1 Like

yes, I installed that driver, executed that code with grep that resulted in that output

With a text editor create /etc/modprobe.d/rtl8822be.conf with the following contents:

blacklist rtw88
blacklist rtw_pci

Reboot.

If no love, try changing blacklist rtw_pci to blacklist rtwpci

2 Likes

I tried that in vain
Please help @tbg

Please do not beg for help nor ping team members with @.
It sounds rude, nobody is paid here, and last but not least, consider the time zones...

5 Likes

Sorry but I didn't mean to bother anyone

Ya, sorry buddy, but people got to sleep. I'm on the other side of the world from you.

I would suggest installing the linux-lts kernel, and then reinstall the driver on the LTS kernel.

Edit:

Also, you will need to check if a bios update is available from your laptop manufacturer. If their is a newer bios, you would be well advised to install it. Having removed Windows this would likely need to be done from a boot disk supporting Windows.

I would advise testing all of the following kernels. You can install kernels through the Garuda GUI for managing your hardware. Also be sure to install the corresponding headers.

This can be done in the terminal:

sudo pacman -Syu linux linux-headers

or:

sudo pacman -Syu linux-mainline linux-mainline-headers

or:

sudo pacman -Syu linux-lts linux-lts-headers

You switch kernels at the advanced grub menu when you reboot. Multiple kernels can be installed at the same time with Garuda.

Also, please post:

cat /etc/modprobe.d/rtl8822be.conf

You can also try revising the /etc/modprobe.d/rtl8822be.conf file. Remove any blacklist reference to rtw_pci or rtwpci and instead add:

options rtw_pci disable_aspm=Y

After revising the file again post:

cat /etc/modprobe.d/rtl8822be.conf
4 Likes

I hope this is not backpedaling, but have you booted into your BIOS menu to ensure secure boot is disabled? It can interfere with the performance of wifi cards, especially new ones.

@BluishHumility That would more likely be fastboot you're thinking of. If secure boot was enabled Garuda would not boot.

This is unfortunately a wifi adapter with a long history of issues.

1 Like