Really Serious Problem on Garuda Hyprland

I just installed Garuda Linux Hyprland edition. “Everything is so messed up”. I reflashed my usb twice. Even tried different tools. Same result. There is no wallpaper. Keyrings are completely messed up. Hyprland config is messed up too.

Try to change any config file. The system just wreaks havoc on itself.

Waybar stretches all the way to the ends cutting itself off. Thinking its on a wide display. I can’t even remove any widgets I don’t want. Try to and it gets messed up real bad.

App Launcher takes a while to open. I’m on a Samsung T7 500 GB NVME USB connected SSD. Windows is fast. Garuda should be FASTER. Also many app launchers are available for some reason (or) maybe different styles of the same launcher. idk.

There are many terminals. Some like Alacritty with outdated configs.

Resetting all configs from the Garuda Assistant does NOTHING.

Copying files over from Garuda-Hyprland-Settings with latest commits from @Ankur himself 4 days ago. Does nothing either.

I’m just getting so SICK and TIRED of going through your forum all day long. To try and find a solution to this.

Also I think its time to put a new ISO. “BIRD OF PREY” was released in April. From May, June and July. Its been quite a while since an update had come.

I know new releases and ISO’s come every time there’s something big changed or there’s many small changes that make up a new version.


Please put a new release / update addressing these issues. I think its better to release a new ISO every month like Arch. To make sure all new fixes and improvements though critical or not get to users. And something like this doesn’t happen again.

P.S. I have been using Linux for the past few years and think of myself as at the very least a little bit of an advanced user. I’ve used Xmonad, Qtile, Hyprland, KDE, GNOME, Cinnamon, Deepin and much more. I’ve tried and used and tweaked numerous configs. But, I’ve never seen a system get so busted like this.

Would be better if newer installations could connect to the internet and import the latest changes and improvements from Garuda’s git repos.

Eagerly waiting for a reply from the team.

1 Like

Man, I was almost scared :eyes:

I am my ownself using the ISO’s from the download page
And that is the same ISO through I installed garuda on my new laptop without getting into any trouble

which type of changes did you did ??

we can’t do anything about that without knowing what you changed ,
also please provide "garuda inxi "

other than that please remember that it is for only advanced users and Hyprland itself is at so much development as it is still not that stable yet

For me it is faster , but as said it is not stable yet so your experience might be different from mine :eyes:

  Kernel: 6.9.7-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 14.1.1
    clocksource: tsc avail: acpi_pm
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=a1f29fc3-c386-48c2-a72f-82c2d9453e4a rw rootflags=subvol=@
    quiet loglevel=3 ibt=off
  Desktop: Hyprland v: 0.41.2-14-gd7ea1b77 with: waybar tools:
    avail: swayidle,swaylock vt: 1 dm: SDDM Distro: Garuda base: Arch Linux
  Type: Laptop System: ASUSTeK product: X200MA v: 1.0
    serial: <superuser required>
  Mobo: ASUSTeK model: X200MA v: 1.0 serial: <superuser required>
    part-nu: ASUS-NotebookSKU uuid: <superuser required>
    UEFI: American Megatrends v: X200MA.506 date: 04/15/2015
  ID-1: BAT0 charge: 0 Wh (0.0%) condition: 28.5/33.8 Wh (84.3%) volts: 11.2
    min: 11.2 model: ASUSTeK X200-30 type: Li-ion serial: N/A
    status: not charging
  Info: model: Intel Celeron N2840 bits: 64 type: MCP arch: Silvermont
    level: v2 built: 2013-15 process: Intel 22nm family: 6 model-id: 0x37 (55)
    stepping: 8 microcode: 0x838
  Topology: cpus: 1x cores: 2 smt: <unsupported> cache: L1: 112 KiB
    desc: d-2x24 KiB; i-2x32 KiB L2: 1024 KiB desc: 1x1024 KiB
  Speed (MHz): avg: 1999 high: 2168 min/max: 500/2582 scaling:
    driver: intel_cpufreq governor: performance cores: 1: 2168 2: 1830
    bogomips: 8666
  Flags: ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities: <filter>
  Device-1: Intel Atom Processor Z36xxx/Z37xxx Series Graphics & Display
    vendor: ASUSTeK driver: i915 v: kernel arch: Gen-7 process: Intel 22nm
    built: 2012-13 ports: active: eDP-1 empty: DP-1,HDMI-A-1,VGA-1
    bus-ID: 00:02.0 chip-ID: 8086:0f31 class-ID: 0300
  Device-2: Chicony USB2.0 HD UVC WebCam driver: uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-1.3:4 chip-ID: 04f2:b424
    class-ID: 0e02 serial: <filter>
  Display: wayland server: v: with: Xwayland v: 24.1.0
    compositor: Hyprland v: 0.41.2-14-gd7ea1b77 driver: X: loaded: modesetting
    alternate: fbdev,intel,vesa dri: crocus gpu: i915 display-ID: 1
  Monitor-1: eDP-1 model: ChiMei InnoLux 0x1130 built: 2013 res: 1366x768
    hz: 60 dpi: 136 gamma: 1.2 scale: 1 size: 256x144mm (10.08x5.67")
    diag: 294mm (11.6") ratio: 16:9 modes: 1366x768
  API: Vulkan v: 1.3.279 layers: 4 device: 0 type: integrated-gpu
    name: Intel HD Graphics (BYT) driver: mesa intel v: 24.1.2-arch1.1
    device-ID: 8086:0f31 surfaces: xcb,xlib,wayland device: 1 type: cpu
    name: llvmpipe (LLVM 17.0.6 128 bits) driver: mesa llvmpipe
    v: 24.1.2-arch1.1 (LLVM 17.0.6) device-ID: 10005:0000
    surfaces: xcb,xlib,wayland
  API: EGL Message: EGL data requires eglinfo. Check --recommends.
  Device-1: Intel Atom Processor Z36xxx/Z37xxx Series High Definition Audio
    vendor: ASUSTeK driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
    chip-ID: 8086:0f04 class-ID: 0403
  API: ALSA v: k6.9.7-zen1-1-zen status: kernel-api tools: N/A
  Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
  Server-2: PipeWire v: 1.2.0 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter
    vendor: AzureWave driver: ath9k v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 bus-ID: 02:00.0 chip-ID: 168c:0036 class-ID: 0280
  IF: wlp2s0 state: up mac: <filter>
  Device-2: Realtek RTL810xE PCI Express Fast Ethernet vendor: ASUSTeK
    driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: e000
    bus-ID: 03:00.2 chip-ID: 10ec:8136 class-ID: 0200
  IF: enp3s0f2 state: down mac: <filter>
  Info: services: NetworkManager, systemd-timesyncd, wpa_supplicant
  Device-1: IMC Networks driver: btusb v: 0.8 type: USB rev: 1.1
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-1.4.1:8 chip-ID: 13d3:3423
    class-ID: e001
  Report: btmgmt ID: hci0 rfk-id: 1 state: up address: <filter> bt-v: 4.1
    lmp-v: 7 status: discoverable: no pairing: no class-ID: 6c010c
  Local Storage: total: 931.52 GiB used: 10.57 GiB (1.1%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Toshiba model: MQ01ABF050
    size: 465.76 GiB block-size: physical: 4096 B logical: 512 B speed: 3.0 Gb/s
    tech: HDD rpm: 5400 serial: <filter> fw-rev: 1J
  ID-2: /dev/sdb maj-min: 8:16 vendor: Samsung model: PSSD T7
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B type: USB
    rev: 2.1 spd: 480 Mb/s lanes: 1 mode: 2.0 tech: SSD serial: <filter>
    scheme: GPT
  ID-1: / raw-size: 221.24 GiB size: 221.24 GiB (100.00%)
    used: 10.53 GiB (4.8%) fs: btrfs dev: /dev/sdb4 maj-min: 8:20
  ID-2: /boot/efi raw-size: 260 MiB size: 257 MiB (98.85%)
    used: 47.1 MiB (18.3%) fs: vfat dev: /dev/sdb1 maj-min: 8:17
  ID-3: /home raw-size: 221.24 GiB size: 221.24 GiB (100.00%)
    used: 10.53 GiB (4.8%) fs: btrfs dev: /dev/sdb4 maj-min: 8:20
  ID-4: /var/log raw-size: 221.24 GiB size: 221.24 GiB (100.00%)
    used: 10.53 GiB (4.8%) fs: btrfs dev: /dev/sdb4 maj-min: 8:20
  ID-5: /var/tmp raw-size: 221.24 GiB size: 221.24 GiB (100.00%)
    used: 10.53 GiB (4.8%) fs: btrfs dev: /dev/sdb4 maj-min: 8:20
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: zram size: 1.81 GiB used: 690 MiB (37.2%) priority: 100
    comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 2 dev: /dev/zram0
  System Temperatures: cpu: 6280.4 C mobo: N/A
  Fan Speeds (rpm): cpu: 4200
  Memory: total: 2 GiB available: 1.81 GiB used: 1.14 GiB (62.9%)
  Processes: 194 Power: uptime: 2h 32m states: freeze,mem,disk suspend: deep
    avail: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
    suspend, test_resume image: 729.9 MiB services: upowerd Init: systemd
    v: 256 default: graphical tool: systemctl
  Packages: pm: pacman pkgs: 1379 libs: 412 tools: pacseek,pamac,paru
    Compilers: gcc: 14.1.1 Shell: garuda-inxi default: fish v: 3.7.1
    running-in: foot inxi: 3.3.35
Garuda (2.6.26-1):
  System install date:     2024-07-01
  Last full system update: 2024-07-01 ↻
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut
  Windows dual boot:       No/Undetected
  Failed units:  

I only removed certain widgets from waybar. Like temperature idle-inhibitor etc. Only removed texts mentioning widgets like these in modules-center, modules-left etc.

Sorry about being “too serious” and going overboard. So much so that you almost got scared. :smiley:

If you still think there isn’t a problem. I’m on Garuda right now and would be happy to download the iso again. And reflash it on my usb. And check from the live cd if everything’s alright. And I would also like to know how to change configs here specifically. Since, even the slightest of changes seems to break things.

Please do not post here in the forum like in chatrooms or Telegram.
As long as no one has responded to your post, you can edit your post.


What do you mean? I feel like this a place where users can discuss openly about their issues. I admit that other platforms like Telegram may give a better experience, but I don’t understand why I shouldn’t post here.

Nobody is forbidding you from posting here, you should just edit your post if no one has replied yet.

Please follow the forum rules :wink:


ok. But,

I would still like some help regarding the following issues.

1. Easily editable configs

I would like to be able to edit the configs easily. For some reason, whatever changes you make, even if its just removing some stuff that you don’t need. Especially in Waybar. The formatting goes all wrong. Everythng gets so out of place that even Garuda’s own programs cannot fix it.

2. Speed

Hopefully for better experience on NVME ssd’s

3. Fresh new “100 % working configs” available on Garuda’s git repos

Config files sure don’t work for everyone. But, maybe a script that makes sure everything’s alright and reinstalls and reconfigures Garuda to its “expected default state”. Would be helpful.

4. Regular check of iso’s by downloading them from Garuda’s website and trying them on your spare PC / VM

This one is not really important as I’m sure you already do this anyways. As much as you can. To make sure Garuda’s compatable.

You haven’t rebooted since your last update, the ‘swoosh’ indicates, Please do so. A lot of changes/updates aren’t effective unless a reboot isn’t performed.


I’ve rebooted multiple times. Even after resetting Garuda configs through your program. The updates that I’ve done weren’t really related to this issue.

I’ve rebooted just now. And no updates are pending. But the Hyprland experience is just the same.

1 Like
  • ONE issue per topic.



I’m sorry but I believe a topic can be about a number of things. I’ve made the topic’s title a bit vague on purpose. Its not about a particular thing, but about Garuda Hyprland and other spins of Garuda in general.

It’s more about the entire user experience and a user’s look at a particular distribution.

Since, in my case a mishap in configs is causing a problem in the entire usability of the system.

This just shows how important “proper” configs are. Allowing the user to edit them easily. Not that the configs are bad or anything but, they are now causing issues that they haven’t before.

Also I don’t wanna post “9 different topics”. But, I admit it can probably get a little confusing.

Apart from the fact that the forum search works better, it quickly becomes confusing when several people reply to different problems.
Also, it does not allow you to mark the topic as solved if only 9 out of 10 issues have been solved.

Again, one issue per topic.


I agree with you on this. But, I would still like some news on this matter. I’m gonna be here till 11:00 PM. As of tommorow, 6:30 PM would be good as I have some important personal work scheduled.

You should perhaps calm down and start communicating properly, this also applies to your font size. If you keep shouting here, you won’t get any help.

Garuda Hyprland is for advanced users only :warning:
If you don’t have any basic knowledge and panic at every little problem, then you are obviously overwhelmed.

Small tip:



A little bit more than my Odroid :expressionless:

I close it now.


Don’t you just sound llke Mister Important!

How much are you willing to pay for support?

Topic was closed.