Radeon 6700xt performance issues on garuda after switching from 1080

Sys Info

  Kernel: 5.17.9-258-tkg-pds arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    parameters: intel_pstate=passive
    root=UUID=ef15347e-a4da-4628-afc3-2bff20cbb710 rw [email protected]
    rd.udev.log_priority=3 vt.global_cursor_default=0
    systemd.unified_cgroup_hierarchy=1 libahci.ignore_sss=1
    resume=UUID=e7745511-30a0-4b3d-93c1-4bc3daa8b2b8 loglevel=3
    amdgpu.ppfeaturemask=0xffffffff sysrq_always_enabled=1 nowatchdog
  Desktop: KDE Plasma v: 5.24.5 tk: Qt v: 5.15.4 info: latte-dock
    wm: kwin_wayland vt: 2 dm: SDDM Distro: Garuda Linux base: Arch Linux
  Type: Desktop Mobo: ASRock model: X470 Taichi serial: <superuser required>
    UEFI: American Megatrends v: P4.86 date: 01/27/2022
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse MX Master 3
    serial: <filter> charge: 100% (should be ignored) rechargeable: yes
    status: discharging
  Info: model: AMD Ryzen 5 2600X bits: 64 type: MT MCP arch: Zen+
    family: 0x17 (23) model-id: 8 stepping: 2 microcode: 0x800820D
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 576 KiB desc: d-6x32 KiB; i-6x64 KiB L2: 3 MiB desc: 6x512 KiB
    L3: 16 MiB desc: 2x8 MiB
  Speed (MHz): avg: 4144 high: 4171 min/max: 2200/3600 boost: enabled
    scaling: driver: acpi-cpufreq governor: performance cores: 1: 4134 2: 4129
    3: 4159 4: 4120 5: 4164 6: 4122 7: 4152 8: 4111 9: 4171 10: 4146 11: 4165
    12: 4157 bogomips: 86492
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2
    mitigation: Retpolines, IBPB: conditional, STIBP: disabled, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: AMD Navi 22 [Radeon RX 6700/6700 XT/6750 XT / 6800M]
    vendor: Gigabyte driver: amdgpu v: kernel pcie: gen: 4 speed: 16 GT/s
    lanes: 16 ports: active: DP-1,HDMI-A-1 empty: DP-2,HDMI-A-2
    bus-ID: 0f:00.0 chip-ID: 1002:73df class-ID: 0300
  Display: wayland server: X.org v: with: Xwayland v: 22.1.1
    compositor: kwin_wayland driver: X: loaded: amdgpu
    unloaded: modesetting,radeon alternate: fbdev,vesa gpu: amdgpu
    d-rect: 3968x1944 display-ID: 0
  Monitor-1: DP-1 pos: bottom-l res: 2048x864 size: N/A modes: N/A
  Monitor-2: HDMI-A-1 pos: top-right res: 1920x1080 size: N/A modes: N/A
  OpenGL: renderer: AMD Radeon RX 6700 XT (navy_flounder LLVM 13.0.1 DRM
    3.44 5.17.9-258-tkg-pds)
    v: 4.6 Mesa 22.0.4 direct render: Yes
  Device-1: AMD Navi 21/23 HDMI/DP Audio driver: snd_hda_intel v: kernel
    pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 0f:00.1 chip-ID: 1002:ab28
    class-ID: 0403
  Sound Server-1: ALSA v: k5.17.9-258-tkg-pds running: yes
  Sound Server-2: sndio v: N/A running: no
  Sound Server-3: PulseAudio v: 15.0 running: no
  Sound Server-4: PipeWire v: 0.3.51 running: yes
  Device-1: Intel I211 Gigabit Network vendor: ASRock driver: igb v: kernel
    pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 09:00.0
    chip-ID: 8086:1539 class-ID: 0200
  IF: enp9s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IF-ID-1: virbr0 state: down mac: <filter>
  Device-1: Edimax type: USB driver: btusb v: 0.8 bus-ID: 1-8:4
    chip-ID: 7392:c611 class-ID: e001 serial: <filter>
  Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
  Local Storage: total: 2.96 TiB used: 3.17 TiB (107.3%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
    model: SSD 970 EVO 250GB size: 232.89 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 2B2QEXE7 temp: 34.9 C scheme: GPT
  ID-2: /dev/nvme1n1 maj-min: 259:5 vendor: Samsung model: SSD 980 1TB
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B
    speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 1B4QFXO7
    temp: 34.9 C scheme: GPT
  ID-3: /dev/sda maj-min: 8:0 vendor: Seagate model: ST2000DX002-2DV164
    size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 7200 serial: <filter> rev: CC41 scheme: GPT
  ID-1: / raw-size: 914.08 GiB size: 914.08 GiB (100.00%)
    used: 773.06 GiB (84.6%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:7
  ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%)
    used: 29.4 MiB (11.5%) fs: vfat dev: /dev/nvme1n1p1 maj-min: 259:6
  ID-3: /home raw-size: 914.08 GiB size: 914.08 GiB (100.00%)
    used: 773.06 GiB (84.6%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:7
  ID-4: /var/log raw-size: 914.08 GiB size: 914.08 GiB (100.00%)
    used: 773.06 GiB (84.6%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:7
  ID-5: /var/tmp raw-size: 914.08 GiB size: 914.08 GiB (100.00%)
    used: 773.06 GiB (84.6%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:7
  Kernel: swappiness: 133 (default 60) cache-pressure: 50 (default 100)
  ID-1: swap-1 type: partition size: 17.18 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/nvme1n1p3 maj-min: 259:8
  ID-2: swap-2 type: zram size: 31.27 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  System Temperatures: cpu: 44.4 C mobo: 35.0 C gpu: amdgpu temp: 54.0 C
    mem: 56.0 C
  Fan Speeds (RPM): cpu: 1888 fan-1: 0 fan-3: 1309 fan-4: 1514 fan-5: 1236
    gpu: amdgpu fan: 0
  Power: 12v: N/A 5v: N/A 3.3v: 3.26 vbat: 3.28 gpu: amdgpu watts: 30.00
  Processes: 488 Uptime: 13m wakeups: 2 Memory: 31.27 GiB
  used: 15.82 GiB (50.6%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 12.1.0 clang: 13.0.1 Packages: 2326 pacman: 2314 lib: 583 flatpak: 12
  Shell: fish v: 3.4.1 default: Bash v: 5.1.16 running-in: alacritty
  inxi: 3.3.16
Garuda (2.6.3-2):
  System install date:     2021-10-17
  Last full system update: 2022-05-22
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       Probably (Run as root to verify)
  Snapshots:               Snapper
  Failed units:

I recently switched from a gtx 1080(fans broke) to a rx6700xt and have been having worse performance in games since.

Acording to mangohud it is not even fully using my GPU and is power throttling as you can see in these two images


also tried in ubuntu and got better performance but still not as good as windows

What I have tried
I have tried using gamemode to force the 6700xt to max performance mode and still get the same issue. I also tried the ppfeaturemask kernel parameter and no change.

Your CPU is too weak for this graphic card and a system bottleneck

One thing I could imagine being different between Ubuntu and your system here is your kernel, you are running linux-tkg-pds-generic_v3. Maybe worth ruling that factor out?


Then it wouldn't be running fine on windows or Ubuntu actually. @TNE yeah i tried different kernel including lts i decided to do a fresh reinstall of Garuda to see if that helps

Could you do some GPU benchmarks to ensure GPU is really power bottlenecked? There be many reasons why a game is lower performance.

1 Like

Well this isn't good i did a fresh install of Garuda and on reboot it was working so i ran the setup process that you get promoted for that asks what extra packages you want etc so did that and i power down the PC

When i boot back up I am at a tty

here is my journal
and this when I try to manually start sddm

$ sddm-greeter
[15:15:03.377] (II) GREETER: High-DPI autoscaling Enabled
[15:15:03.380] (WW) GREETER: could not connect to display 
[15:15:03.380] (II) GREETER: Could not load the Qt platform plugin "xcb" in "" even though it was found.
[15:15:03.380] (EE) GREETER: This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, wayland-egl, wayland, wayland-xcomposite-egl, wayland-xcomposite-glx, xcb.

Why you post a 356 Kb picture from little text in terminal output?
We do not want pictures.

Images can be read worse, are not searchable and copyable for further search.
Should the helpers have to guess everything or laboriously type it in themselves?

1 Like

to make sure i don't miss anything and I show the exact error since this was in a tty and asfaik there no way for my to upload the text from a tty? could be wrong though and if it is possible please let me know and I will replace the images with that and better yet a full journel instead of just that snippet

PASTEBINIT(1)                                                                                         [FIXME: manual]                                                                                        PASTEBINIT(1)

       pastebinit - command-line pastebin client

       pastebinit [-abfhiljmrtup]

       This manual page documents briefly the pastebinit commands

       pastebinit reads text and sends it to a "pastebin" on the internet, returning the URL to the user.

       It allows the text to be passed through a pipe (|) or from files as arguments.
1 Like

it give an http error 405 : method not allowed (i know there a hastebin equivalent but i don't use those comand-line pastebin since they never work for me) and yes i do i have internet i can ping https://hastebin.skyra.pw and https://pastebin.com just fine

that's why i posted an image as I don't know any other working way to show the error

any time I need to post something from the terminal I just copy and paste it here in forum or if its to long in a hastebin. I tried those pastebin clients before and they never work but since I cant actually start a graphical session I have no way of just copying and pasting in this case. sorry for the trouble

was able to get wgetpaste working so I removed the image and posting a link to the paste using http://0x0.st @SGS

EDIT: it was Plymouth that was messing with sddm. I unistalled it and ran systemctl disable sddm-plymouth.service and systemctl enable sddm.service rebooted and now plasma loaded.

Ok good thing, you got rid of that issue which side tracked you from your original issue. :slight_smile:

Now are you able to benchmark the GPU?

figured out what was the issue. I had set up mangohud to force vsync as this was the only way I was able to fix tearing in this game without getting any stuttering when I was using my GTX 1080. Apparently, the Radeon drivers do not like this and run terribly with this enabled

EDIT: though it should be mentiond that I was using the same setting to force vsync on ubuntu and the game ran better there than in Garuda. Still not as good as windows (Garuda with vsync off performs better than windows for this game) but better than the really bad performance on garuda (with vsync). So there may be some regression in some recent mesa version or something with vsync


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.