Quod Libet fails to start

Hi everyone,

I'm trying to get Quod Libet working. It has worked on my system before, but it broke a few months ago. I get the following output:

$ env G_MESSAGES_DEBUG=all quodlibet --run
(quodlibet:164173): GLib-GIO-DEBUG: 20:45:09.860: _g_io_module_get_default: Found default implementation local(GLocalVfs) for ‘gio-vfs’

(quodlibet:164173): Gtk-WARNING **: 20:45:09.886: Theme parsing error: gtk-dark.css:5823:26: '-shadow' is not a valid color name

(quodlibet:164173): Gtk-WARNING **: 20:45:09.886: Theme parsing error: gtk-dark.css:5826:14: not a number

(quodlibet:164173): Gtk-WARNING **: 20:45:09.886: Theme parsing error: gtk-dark.css:5827:13: not a number

(quodlibet:164173): Gtk-WARNING **: 20:45:09.886: Theme parsing error: gtk-dark.css:5828:11: Expected a length
(quodlibet:164173): GLib-GIO-DEBUG: 20:45:09.929: _g_io_module_get_default: Found default implementation dconf(DConfSettingsBackend) for ‘gsettings-backend’
(quodlibet:164173): dconf-DEBUG: 20:45:09.929: watch_fast: "/org/appmenu/gtk-module/" (establishing: 0, active: 0)
(quodlibet:164173): dconf-DEBUG: 20:45:09.929: unwatch_fast: "/org/appmenu/gtk-module/" (active: 0, establishing: 1)
(quodlibet:164173): dconf-DEBUG: 20:45:09.931: watch_established: "/org/appmenu/gtk-module/" (establishing: 0)
(quodlibet:164173): dconf-DEBUG: 20:45:09.931: watch_fast: "/org/appmenu/gtk-module/" (establishing: 0, active: 0)
(quodlibet:164173): dconf-DEBUG: 20:45:09.931: unwatch_fast: "/org/appmenu/gtk-module/" (active: 0, establishing: 1)
(quodlibet:164173): dconf-DEBUG: 20:45:09.932: watch_established: "/org/appmenu/gtk-module/" (establishing: 0)

** (io.github.quodlibet.QuodLibet:164173): WARNING **: 20:45:11.523: Failed to load shared library 'libdee-1.0.so.4' referenced by the typelib: libicui18n.so.70: cannot open shared object file: No such file or directory
E: 1.892: errorreport.main.errorhook: types.py:247:__init__: TypeError: must be an interface

I searched the web, but I couldn't find anything related to the error. Can somebody help figure this out?

garuda-inxi
System:
Kernel: 5.18.16-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=220d401c-e739-49f7-b37b-c9837e340ce5 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3 pci=noaer ibt=off
Desktop: KDE Plasma v: 5.25.4 tk: Qt v: 5.15.5 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: HP product: HP Pavilion Gaming Notebook
v: Type1ProductConfigId serial: <superuser required> Chassis: type: 10
serial: <superuser required>
Mobo: HP model: 816B v: 91.1E serial: <superuser required> UEFI: Insyde
v: F.91 date: 08/20/2019
Battery:
ID-1: BAT0 charge: 27.5 Wh (100.0%) condition: 27.5/27.5 Wh (100.0%)
volts: 16.4 min: 14.8 model: Hewlett-Packard Primary type: Li-ion
serial: N/A status: full
Device-1: hidpp_battery_0 model: Logitech Wireless Keyboard
serial: <filter> charge: 55% (should be ignored) rechargeable: yes
status: discharging
CPU:
Info: model: Intel Core i7-6700HQ bits: 64 type: MT MCP arch: Skylake-S
gen: core 6 built: 2015 process: Intel 14nm family: 6 model-id: 0x5E (94)
stepping: 3 microcode: 0xF0
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
L3: 6 MiB desc: 1x6 MiB
Speed (MHz): avg: 1703 high: 2168 min/max: 800/3500 scaling:
driver: intel_pstate governor: powersave cores: 1: 1927 2: 2168 3: 1544
4: 1602 5: 1958 6: 1182 7: 1655 8: 1592 bogomips: 41599
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX unsupported
Type: l1tf mitigation: PTE Inversion
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
Type: retbleed mitigation: IBRS
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: IBRS, IBPB: conditional, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort mitigation: TSX disabled
Graphics:
Device-1: Intel HD Graphics 530 vendor: Hewlett-Packard driver: i915
v: kernel arch: Gen-9 process: Intel 14n built: 2015-16 ports:
active: HDMI-A-1,eDP-1 empty: none bus-ID: 00:02.0 chip-ID: 8086:191b
class-ID: 0300
Device-2: NVIDIA GM107M [GeForce GTX 950M] vendor: Hewlett-Packard
driver: nvidia v: 515.65.01 alternate: nouveau,nvidia_drm non-free: 515.xx+
status: current (as of 2022-07) arch: Maxwell code: GMxxx
process: TSMC 28nm built: 2014-19 pcie: gen: 1 speed: 2.5 GT/s lanes: 8
link-max: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 01:00.0
chip-ID: 10de:139a class-ID: 0302
Device-3: Intel RealSense 3D Camera (Front F200) type: USB
driver: uvcvideo bus-ID: 2-3:2 chip-ID: 8086:0a66 class-ID: 0e02
serial: <filter>
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
compositor: kwin_x11 driver: X: loaded: modesetting,nvidia gpu: i915
display-ID: :0 screens: 1
Screen-1: 0 s-res: 4480x1440 s-dpi: 96 s-size: 1185x381mm (46.65x15.00")
s-diag: 1245mm (49.01")
Monitor-1: HDMI-A-1 mapped: HDMI-1 pos: primary,right
model: Dell S2722DGM serial: <filter> built: 2021 res: 2560x1440 hz: 60
dpi: 109 gamma: 1.2 size: 597x336mm (23.5x13.23") diag: 685mm (27")
ratio: 16:9 modes: max: 2560x1440 min: 720x400
Monitor-2: eDP-1 pos: primary,left model: Samsung 0x5844 built: 2015
res: 1920x1080 hz: 60 dpi: 142 gamma: 1.2 size: 344x194mm (13.54x7.64")
diag: 395mm (15.5") ratio: 16:9 modes: 1920x1080
OpenGL: renderer: Mesa Intel HD Graphics 530 (SKL GT2) v: 4.6 Mesa 22.1.4
direct render: Yes
Audio:
Device-1: Intel 100 Series/C230 Series Family HD Audio
vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus-ID: 00:1f.3
chip-ID: 8086:a170 class-ID: 0403
Sound Server-1: ALSA v: k5.18.16-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 16.1 running: no
Sound Server-3: PipeWire v: 0.3.56 running: yes
Network:
Device-1: Realtek RTL8723BE PCIe Wireless Network Adapter
vendor: Hewlett-Packard driver: rtl8723be v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: 4000 bus-ID: 08:00.0 chip-ID: 10ec:b723
class-ID: 0280
IF: wlo1 state: up mac: <filter>
Device-2: Realtek RTL810xE PCI Express Fast Ethernet
vendor: Hewlett-Packard driver: r8169 v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 09:00.0 chip-ID: 10ec:8136
class-ID: 0200
IF: eno1 state: down mac: <filter>
IF-ID-1: anbox0 state: down mac: <filter>
IF-ID-2: br-6d1386589274 state: down mac: <filter>
IF-ID-3: docker0 state: up speed: 10000 Mbps duplex: unknown
mac: <filter>
IF-ID-4: veth8a05746 state: up speed: 10000 Mbps duplex: full
mac: <filter>
Bluetooth:
Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8
bus-ID: 1-7:3 chip-ID: 0bda:b006 class-ID: e001 serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 3 state: down
bt-service: enabled,running rfk-block: hardware: no software: yes
address: <filter>
Drives:
Local Storage: total: 1.03 TiB used: 888.64 GiB (84.6%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: MZNLF128HCHP-000H1
size: 119.24 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 1H1Q scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: Toshiba model: MQ01ABD100
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B
speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter> rev: 2C scheme: GPT
Partition:
ID-1: / raw-size: 55.99 GiB size: 55.99 GiB (100.00%) used: 49.48 GiB
(88.4%) fs: btrfs dev: /dev/sda5 maj-min: 8:5
ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%) used: 81.6 MiB
(31.9%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 55.99 GiB size: 55.99 GiB (100.00%) used: 49.48 GiB
(88.4%) fs: btrfs dev: /dev/sda5 maj-min: 8:5
ID-4: /var/log raw-size: 55.99 GiB size: 55.99 GiB (100.00%) used: 49.48
GiB (88.4%) fs: btrfs dev: /dev/sda5 maj-min: 8:5
ID-5: /var/tmp raw-size: 55.99 GiB size: 55.99 GiB (100.00%) used: 49.48
GiB (88.4%) fs: btrfs dev: /dev/sda5 maj-min: 8:5
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.47 GiB used: 4.06 GiB (26.3%)
priority: 100 dev: /dev/zram0
ID-2: swap-2 type: partition size: 4.88 GiB used: 989.4 MiB (19.8%)
priority: -2 dev: /dev/sdb5 maj-min: 8:21
Sensors:
System Temperatures: cpu: 44.0 C pch: 45.5 C mobo: N/A
Fan Speeds (RPM): N/A
Info:
Processes: 366 Uptime: 9h 7m wakeups: 60 Memory: 15.47 GiB used: 10.98 GiB
(71.0%) Init: systemd v: 251 default: graphical tool: systemctl
Compilers: gcc: 12.1.1 Packages: 1659 nix-default: 45 nix-sys: 0 nix-usr: 0
pacman: 1614 lib: 378 Shell: fish v: 3.5.1 running-in: konsole inxi: 3.3.20
Garuda (2.6.5-1):
System install date:     2022-04-24
Last full system update: 2022-08-06
Is partially upgraded:   Yes
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Snapper
Failed units:            systemd-networkd-wait-online.service

You have become partially upgraded somehow. Do you have a snapshot you can fall back on from before that happened?

2 Likes

Oh that happened because I canceled an application installation in pamac I think. No actual partial upgrading occured. Just updated and the issue still persists.

What was your method for installing this program?

1 Like

sudo pacman -S quodlibet

Work fine here.

 ╭─[email protected] in ~ 
 ╰─λ env G_MESSAGES_DEBUG=all quodlibet --run

 ╭─[email protected] in ~ took 197ms
 ╰─λ 

1 Like

Something I'd like to point out here, after being broken in a recent update...
Guayadeque is up and running again - and it's really an incredible player (though I do like quodlibet) so it's worth having that extra string to your bow :wink:

First off, always make sure you're fully updated with garuda-update. You do NOT ever want to be partially updated for many reasons.

When you see Failed to load shared library you can assume you're missing something. You can search for what provides it:

$ pacman -F libdee-1.0.so.4
chaotic-aur/dee 1.2.7-13
usr/lib/libdee-1.0.so.4

In this case you could get it with pacman -Syu chaotic-aur/dee
I'm not sure why it's not listed in depends here though... Arch Linux - quodlibet 4.5.0-1 (any)

2 Likes

Ah, good to know. Maybe I should ask the author for debugging ideas then.

I already have this installed (as dependency for libunity).

I just tried to install it, but I get an error:

Log
==> Starting build()...
CMake Deprecation Warning at CMakeLists.txt:8 (cmake_policy):
  The OLD behavior for policy CMP0037 will be removed from a future version
  of CMake.

  The cmake-policies(7) manual explains that the OLD behaviors of all
  policies are deprecated and that a policy should be set to OLD only under
  specific short-term circumstances.  Projects should be ported to the NEW
  behavior and not rely on setting a policy to OLD.


-- The C compiler identification is GNU 12.1.1
-- The CXX compiler identification is GNU 12.1.1
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working C compiler: /usr/lib/shim/cc - skipped
-- Detecting C compile features
-- Detecting C compile features - done
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Check for working CXX compiler: /usr/lib/shim/c++ - skipped
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- Using install prefix /usr ...
-- Found PkgConfig: /usr/bin/pkg-config (found version "1.8.0") 
-- Could NOT find wxWidgets (missing: wxWidgets_LIBRARIES wxWidgets_INCLUDE_DIRS) 
CMake Error at CMakeLists.txt:38 (MESSAGE):
  wxWidgets not found!


-- Configuring incomplete, errors occurred!

I got a notification that my system is partially upgraded again. It seems it does this after installing anything with Pamac (even if that installation fails apparently), while there are also updates available. That's a different problem though.

Thank you all for your suggestions :slight_smile:

For some time now we have been sending octopi for searching and browsing. We advise against the use of pamac and octopi, except for searching.
The tool for installing should only be pacman. :slight_smile:

3 Likes

sorry - you need to do guayadeque-git because guayadeque got left behind with the recent wxwidget upgrade.

1 Like

Since guayadeque-git seems to be actively used by a few people, I added it to Chaotic-AUR:

4 Likes

With the help of a quodlibet contributor I discovered that I was missing the right version of icu. Version 71 was installed on my system, but dee seems to require icu 70. I just installed icu70 from AUR and now I get a different error message:

ERROR:../pygobject/gi/gimodule.c:1831:_wrap_pyg_hook_up_vfunc_implementation: assertion failed: (G_TYPE_IS_CLASSED (implementor_gtype))
Bail out! ERROR:../pygobject/gi/gimodule.c:1831:_wrap_pyg_hook_up_vfunc_implementation: assertion failed: (G_TYPE_IS_CLASSED (implementor_gtype))

Maybe some packages need to be rebuilt like in this issue that declension from quodlibet mentioned?

quayadeque-git worked and it looks pretty nice! Might switch to it if issues with quodlibet persist.

1 Like

Any help with the new error message or rebuilding packages like in the issue I linked?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.