Question regarding updates

Well this isn’t actually a issue , rather a question.

I had a issue in wine after updating where symlinks for documents folders and others got disabled automatically.

One more issue where after update my input for microphone changed to analog input loopback.

According to @filo , these are a result of upstream changes in the packages that get updated , rather than a issue from garuda’s side.

My question is , could updating change other configurations I’ve made , or these issues may once in a blue moon occur in applications ?

Issues occuring in applications isn’t much big of a deal.

I am mostly bothered if my config of the distro could get changed.


Kernel: 6.6.1-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc available: acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=1a3d0a6e-7ed0-49ad-9764-325911ffd2cd rw rootflags=subvol=@
quiet quiet rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
Desktop: KDE Plasma v: 5.27.9 tk: Qt v: 5.15.11 wm: kwin_x11 vt: 2
dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Desktop System: HP product: HP All-in-One 22-df0xxx v: N/A
serial: <superuser required> Chassis: type: 13 serial: <superuser required>
Mobo: HP model: 87A4 v: 10100 serial: <superuser required> UEFI: AMI
v: F.36 date: 08/07/2023
Info: model: Intel Core i3-1005G1 bits: 64 type: MT MCP arch: Ice Lake
gen: core 10 level: v4 note: check built: 2019-21 process: Intel 10nm
family: 6 model-id: 0x7E (126) stepping: 5 microcode: 0xBC
Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
L1: 160 KiB desc: d-2x48 KiB; i-2x32 KiB L2: 1024 KiB desc: 2x512 KiB
L3: 4 MiB desc: 1x4 MiB
Speed (MHz): avg: 2832 high: 3400 min/max: 400/3400 scaling:
driver: intel_pstate governor: powersave cores: 1: 1960 2: 3199 3: 2769
4: 3400 bogomips: 9523
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel Iris Plus Graphics G1 vendor: Hewlett-Packard driver: i915
v: kernel arch: Gen-11 process: Intel 10nm built: 2019-21 ports:
active: eDP-1 empty: DP-1, DP-2, DP-3, DP-4, HDMI-A-1 bus-ID: 00:02.0
chip-ID: 8086:8a56 class-ID: 0300
Device-2: Luxvisions Innotech HP TrueVision HD Camera driver: uvcvideo
type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-10:6
chip-ID: 30c9:0013 class-ID: 0e02 serial: <filter>
Display: x11 server: X.Org v: 21.1.9 with: Xwayland v: 23.2.2
compositor: kwin_x11 driver: X: loaded: intel unloaded: modesetting
alternate: fbdev,vesa dri: i965 gpu: i915 display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 mapped: eDP1 model: HP ALL-in-One serial: <filter>
built: 2019 res: 1920x1080 hz: 60 dpi: 102 gamma: 1.2
size: 480x270mm (18.9x10.63") diag: 546mm (21.5") ratio: 16:9
modes: 1920x1080
API: EGL v: 1.5 hw: drv: intel iris platforms: device: 0 drv: iris
device: 1 drv: swrast surfaceless: drv: iris x11: drv: iris
inactive: gbm,wayland
API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 23.2.1-arch1.2
glx-v: 1.4 direct-render: yes renderer: Mesa Intel UHD Graphics (ICL GT1)
device-ID: 8086:8a56 memory: 7.35 GiB unified: yes
API: Vulkan v: 1.3.269 layers: 9 device: 0 type: integrated-gpu name: Intel
UHD Graphics (ICL GT1) driver: mesa intel v: 23.2.1-arch1.2
device-ID: 8086:8a56 surfaces: xcb,xlib device: 1 type: cpu name: llvmpipe
(LLVM 16.0.6 256 bits) driver: mesa llvmpipe v: 23.2.1-arch1.2 (LLVM
16.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
Device-1: Intel Ice Lake-LP Smart Sound Audio vendor: Hewlett-Packard
driver: snd_hda_intel v: kernel alternate: snd_sof_pci_intel_icl
bus-ID: 00:1f.3 chip-ID: 8086:34c8 class-ID: 0403
API: ALSA v: k6.6.1-zen1-1-zen status: kernel-api tools: N/A
Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
Server-2: PipeWire v: 0.3.84 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Hewlett-Packard driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: 4000 bus-ID: 01:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp1s0 state: down mac: <filter>
Device-2: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter
vendor: Hewlett-Packard driver: rtw_8821ce v: N/A modules: rtw88_8821ce
pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 02:00.0
chip-ID: 10ec:c821 class-ID: 0280
IF: wlp2s0 state: up mac: <filter>
Device-1: Realtek Bluetooth 4.2 Adapter driver: btusb v: 0.8 type: USB
rev: 1.1 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-5:5 chip-ID: 0bda:b00a
class-ID: e001 serial: <filter>
Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 4.2
lmp-v: 8 status: discoverable: no pairing: no class-ID: 7c0104
Local Storage: total: 946.04 GiB used: 303.08 GiB (32.0%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital
model: WD10EZEX-60WN4A1 size: 931.51 GiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s tech: HDD rpm: 7200 serial: <filter>
fw-rev: 1A03 scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: SanDisk model: Cruzer Blade
size: 14.53 GiB block-size: physical: 512 B logical: 512 B type: USB
rev: 2.1 spd: 480 Mb/s lanes: 1 mode: 2.0 tech: N/A serial: <filter>
fw-rev: 1.00 scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
ID-1: / raw-size: 243.1 GiB size: 243.1 GiB (100.00%) used: 19.61 GiB (8.1%)
fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 513 MiB size: 512 MiB (99.80%)
used: 576 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 243.1 GiB size: 243.1 GiB (100.00%)
used: 19.61 GiB (8.1%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 243.1 GiB size: 243.1 GiB (100.00%)
used: 19.61 GiB (8.1%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 243.1 GiB size: 243.1 GiB (100.00%)
used: 19.61 GiB (8.1%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 7.53 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 4 dev: /dev/zram0
System Temperatures: cpu: 61.0 C mobo: N/A
Fan Speeds (rpm): N/A
Processes: 206 Uptime: 1h 22m wakeups: 0 Memory: total: 8 GiB note: est.
available: 7.53 GiB used: 2.74 GiB (36.4%) Init: systemd v: 254
default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages:
pm: pacman pkgs: 1433 libs: 415 tools: pamac,paru Shell: fish v: 3.6.1
default: Bash v: 5.2.15 running-in: konsole inxi: 3.3.31
Garuda (2.6.18-1):
System install date:     2023-11-07
Last full system update: 2023-11-10 ↻
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       No/Undetected
Failed units:

In my experience settings usually don’t get messed with unless its a bug, or it is because of a massive overhaul of a certain package.

In what way? If you are talking about Desktop Environments (DEs), they could potentially change.
For instance, when KDE 6 releases it requires all its widgets to be made to work for the new version. Some older widgets could not get updated by the time that new version comes out next year.

I’ll move it to Garuda Community so people don’t get confused.


I was talking in terms as , say , vol config , or display settings , customisations , etc .

But now I am assured as I have got the answers.

Again , thanks , as this has solved a Paranoia of mine.


1 Like

Extremely rarely will I have a volume setting reset, and that’s only with bluetooth.
I’ve been having a much better time with Linux than I had with Windows over configurations :laughing:


So in theory you could have a setting reset where your input for microphone changes to something else , RARELY but it can happen , right ?

I am asking this as by default I will have one input for speaker and one for microphone. After installing certain packages only , these analog input and output occur in my audio settings.

If software is packaged correctly, updates should never touch your home directory, which is where most of the settings are stored. Any changes to the settings in /etc will result in a creation of a .pacnew file.

So if anything changes in your home directory after an update, it’s fairly safe to say you have a package from either a malicious or an incompetent packager.

  1. How do you install packages?
  2. Do you install individual applications without updating everything else?
  3. How are you updating?
  4. Are you in a partial update situation?

Please give us the output of garuda-inxi as the original template required.

1 Like

Inxi given in the post now.

Say if I want GIMP , I install it from pamac . Don’t update everything after or before installing it.

I update using system upgrade from Garuda Assistant .

No , I am not in a partial update situation.

I will now describe my issue in fine details.

One day I installed wine and winetricks . The symlinks for all user folders in winecfg were enabled . This proves to be real convenient for me.

I ran system upgrade from Garuda Assistant , just see if there were any updates. After which I saw a update of 700 mb , updating video drivers and countless other packages . I updated and rebooted .
After reboot , none of my games were recognising the savefiles.

I opened winecfg and found that all sysmlinks , except downloads and templates folder were disabled.

Yesterday my default microphone input was selected as built in microphone by default , after a brief update of 50-60 mb , the input for microphone changed to analog input (loopback analog stereo)

Now some extra details I wish to share:

Since October, according to aur website, no updates have been pushed to wine-staging or winetricks.

I am not sure if updating lutris caused this sudden change in wine configuration.

These analog input and output are not listed in my audio devices by default. They only appear after I install a set of specific applications.

I am not sure what caused these issues.

If you are replying to my post, please outline–number–or even bulletpoint your reply. I don’t deal well troubleshooting unless things are taken in a specific, remarkable order. 1, 2, 3 or A, B, C, etc.

Thanks :smiley:

I just noticed that you need to reboot since your last update(s) as the ‘swoosh’ indicates. Don’t count on any changes working well until you do.

1 Like

Well madam/sir I was not talking about changes . This inxi is from a older post as I dont have the inxi after the audio issue because I installed Ubuntu after it .

1.My issue was and is , after a system upgrade and reboot , could there be any changes or updates that can alter your config ?

2.Such as in my case WINE and that analog input (loopback stuff) , my WINE config changed along with my microphone input , which I noticed after a reboot .

3.I am skeptical as I am unsure if this happening is normal or not .


Well I never checked the etc folder and I updated from Garuda Assistant, so it could be a upstream issue or a overhaul as per @filo and @kayo . So this is nothing to worry about, right ?

Can’t you tell a studly penguin when you see one? Nevermind. Joking. :smiley:

  1. Yes. You are running a rolling release distribution with daily updates. But no package manager can accommodate all user configurations & changes. It’s why we can compare before & after changes, even revert them before they’re a problem. Pacnew/pacsave are what we examine.: pacman/Pacnew and Pacsave - ArchWiki There are various tools to do so.
  2. What’s your question?
  3. No, it’s not entirely normal. That’s why one-problem-per-forum-topic is how we normally eliminate problems, unless it’s systemic.

But that’s all moot. It takes work to learn how a new system–especially one so different from Ubuntu–operates. It takes putting in the work. Going back to Ubuntu does not teach you how Garuda works. Using Garuda teaches you how Garuda works. But it takes diligence.


Thanks Madam/Sir ! No the issue wasn’t with how ubuntu or Garuda works . I understand the difference between Garuda And Ubuntu , one which is a rolling release based on Arch while the other is release based on Debian.

I went back to Ubuntu as I doubted the stability of MY installation of Garuda because had to do some office work .

As @filo said this to be a upstream issue from the developers and you agreeing that updates sometimes may change config , is there a solution that can be undertook ?

Well I did forget to mention that I install garuda from a garuda raptor iso , which is quite old , could this be a possible factor.

Would you rather eat stale food or fresh? Of course it did. :smiley:

We’re not Whole Foods, but we do re-stock the shelves. Try something from the fresh food aisle. Less chance of food poisoning. :smiley:

Nice jokes senor ! Just downloaded the new iso and will tell you how it tastes !

1 Like

Gracias. :slight_smile:

So a new discovery !

Today right now after setting up a fresh install , I installed Gparted , in pamac while the status was running post transaction hooks when it highlighted my audio input , analog stereo .
And my input along with output changed to analog input and analog output whereas my speakers vol changed.

After a restart , the config changed back to normal.

Turns out that these analog input output get added to my audio devices only when I’ve installed droidcam , which installs droidcam loopback dkms module.

As for wine , it seems an upstream change was pushed to some package related to it which altered my config.

So this seems to be a issue related to this package .

Any thoughts ?

My thought would be from this would be reboot after any update and see if there is still a problem :smiley:


No no no no ! The culprit isnt vivaldi ffmpeg codecs , just wait for a bit , I sm checking what causes this.

Found it ! The culprit is droidcam , which install some loopback dkms modules !

So any fix ?