Quad Boot Problems

I have multiboot setup with Garuda KDE plasma ultimate,Manjaro,Ubuntu and windows 10. They are installed in 4 SSDs. After I installed Garuda recently, Garuda correctly mounts the windows 10 disk. But the boot entry for windows 10 is missing in the garuda boot menu. How do I add win 10 boot entry.

Try this and restart.

sudo pacman -S os-prober
sudo os-prober
sudo grub-mkconfig -o /boot/grub/grub.cfg

1 Like

Thank you. I tried your idea. It did not work.

Possibly Windows is installed in different mode (UEFI vs. MSDOS/Legacy) than Garuda.


Yes. Windows is installed in MBR/legacy mode. But manjaro in the same pc includes win10 in the boot manjaro boot menu. It boots fine. Also Garuda loads the disk containing win 10. I can access the windows files in Garuda.The problem is withe garuda boot menu.

Can you boot into Windows from the BIOS menu (like select the Windows bootloader and boot into it)?

make sure the windows 10 bootloader partition is mounted at /mnt before updating grub. you can check the partitions with

lsblk (or) sudo fdisk -l

Unless Manjaro uses Black Magic, it is also installed in Legacy.
Keep Manjaro, why adding Garuda?
Or way better, delete everything and install Garuda only. :+1:


I updated manjaro boot menu.Now it lost the win 10 entry but included garuda entry. I think the conflict is between ntfs(win 10) and garuda(btrfs) file systems. Manjaro was installed with legacy bios mobo. I replaced the mobo with eufi, legacy mode support is enabled. Secure boot and fast boot are disabled. Garuda was installed in the eufi mobo. If there is file sys conflict, why is garuda mounting win 10 disk and I still can access win 10 files

The partition layouts--mixing MBR & EFI--could that be the problem?

1 Like

It's not.

As has already been pointed out, you have operating systems which were installed under a mix of BIOS and UEFI boot modes.

You should use one or the other, not both.

You changed the hardware and this broke your setup. That's not unusual. Thankfully you can fix it by reinstalling Garuda when booting in BIOS mode, and then all three OS will match.


Tried that. Windows did not boot

win 10 disk is identified

In the eufi mobo the legacy mode support is enabled. That should prevent any conflict between legacy and eufi modes. May be I should reinstall win10 in the new eufi mobo. Is this a good idea?


I am not very knowledgeable with uefi. I think I should just forget about win10. Three linux versions I have in this pc are working fine.

Why do you 3have 3 linux versions.

Not out of necessity but to explore different features and to determine their stability and usefulness

No. It is a way to help you create mess, if you really want.
The normal usage for this is to have it only in ONE mode, so Linux boot loaders can see all other OSes.
Changing from this, means you know what you are doing. Unless you don't.

If you want to clear the mess (which comes from your decisions, not to blame) you have to find out what boot mode each OS is installed on and then make your choices.

Windows bootloader can only boot to Windows.
Linux/Unix bootloaders can boot to OSes with the same boot mode. Period (unless you are an expert).-

1 Like

A possible solution to the roundy-round is to try rEFInd. It is perfectly capable of picking a legacy Windows, along with UEFI installs. I suggest you boot Garuda by choosing the grub entry on rEFInd to keep the snapshot system fully functional. Optional is disabling the os-prober to speed up (and simplify) the grub entry for Garuda...

1 Like