Qtile and sway problem

So I was thinking to try tiling wm. So I thought to try sway but, I was getting this error: I can't install Wayfire, could not get it resolved by the solutions (same error in virtualbox as well as on real hardware)
Then I tried qtile but get this error in virtualbox:


It's not much to write the error its just in the config file.(And got same error when tried on real hardware.)

Iso's name are:
garuda-qtile-linux-zen-210917.iso
garuda-sway-linux-zen-210914.iso

System:    Kernel: 5.14.5-zen2-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0 
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=f843752b-be3a-4b0e-8dfb-b51dbeb30c59 
           rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 
           systemd.unified_cgroup_hierarchy=1 loglevel=3 mitigations=off 
           Desktop: GNOME 40.4 tk: GTK 3.24.30 wm: gnome-shell dm: GDM 40.1 Distro: Garuda Linux 
           base: Arch Linux 
Machine:   Type: Desktop System: LENOVO product: Lenovo H430 v: Lenovo Product serial: <filter> 
           Mobo: LENOVO model: MAHOBAY serial: <filter> BIOS: LENOVO v: ECKT21A date: 07/11/2012 
CPU:       Info: Dual Core model: Intel Pentium G640 bits: 64 type: MCP arch: Sandy Bridge family: 6 
           model-id: 2A (42) stepping: 7 microcode: 2F cache: L2: 3 MiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 11175 
           Speed: 2306 MHz min/max: 1600/2800 MHz Core speeds (MHz): 1: 2306 2: 2413 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
           Type: l1tf mitigation: PTE Inversion; VMX: vulnerable, SMT disabled 
           Type: mds status: Vulnerable; SMT disabled 
           Type: meltdown status: Vulnerable 
           Type: spec_store_bypass status: Vulnerable 
           Type: spectre_v1 
           status: Vulnerable: __user pointer sanitization and usercopy barriers only; no swapgs barriers 
           Type: spectre_v2 status: Vulnerable, IBPB: disabled, STIBP: disabled 
           Type: srbds status: Not affected 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics vendor: Lenovo 
           driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:0102 class-ID: 0300 
           Display: x11 server: X.Org 1.20.13 compositor: gnome-shell driver: loaded: intel 
           unloaded: modesetting alternate: fbdev,vesa display-ID: :1 screens: 1 
           Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0") s-diag: 414mm (16.3") 
           Monitor-1: VGA1 res: 1366x768 hz: 60 dpi: 85 size: 410x230mm (16.1x9.1") diag: 470mm (18.5") 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 2000 (SNB GT1) v: 3.3 Mesa 21.2.1 compat-v: 3.0 
           direct render: Yes 
Audio:     Device-1: Intel 6 Series/C200 Series Family High Definition Audio vendor: Lenovo 
           driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1c20 class-ID: 0403 
           Sound Server-1: ALSA v: k5.14.5-zen2-1-zen running: yes 
           Sound Server-2: JACK v: 1.9.19 running: no 
           Sound Server-3: PulseAudio v: 15.0 running: no 
           Sound Server-4: PipeWire v: 0.3.35 running: yes 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Lenovo driver: r8169 
           v: kernel port: e000 bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200 
           IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 232.89 GiB used: 61.46 GiB (26.4%) 
           SMART Message: Required tool smartctl not installed. Check --recommends 
           ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD2500AAKX-19U6AA0 size: 232.89 GiB 
           block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s type: HDD rpm: 7200 serial: <filter> 
           rev: 1H15 scheme: MBR 
Partition: ID-1: / raw-size: 224.68 GiB size: 224.68 GiB (100.00%) used: 61.46 GiB (27.4%) fs: btrfs 
           dev: /dev/sda1 maj-min: 8:1 
           ID-2: /home raw-size: 224.68 GiB size: 224.68 GiB (100.00%) used: 61.46 GiB (27.4%) fs: btrfs 
           dev: /dev/sda1 maj-min: 8:1 
           ID-3: /var/log raw-size: 224.68 GiB size: 224.68 GiB (100.00%) used: 61.46 GiB (27.4%) 
           fs: btrfs dev: /dev/sda1 maj-min: 8:1 
           ID-4: /var/tmp raw-size: 224.68 GiB size: 224.68 GiB (100.00%) used: 61.46 GiB (27.4%) 
           fs: btrfs dev: /dev/sda1 maj-min: 8:1 
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) 
           ID-1: swap-1 type: zram size: 3.73 GiB used: 344 MiB (9.0%) priority: 100 dev: /dev/zram0 
           ID-2: swap-2 type: partition size: 8.21 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sda2 
           maj-min: 8:2 
Sensors:   System Temperatures: cpu: 29.8 C mobo: 27.8 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 216 Uptime: 26m wakeups: 0 Memory: 3.73 GiB used: 1.55 GiB (41.7%) Init: systemd 
           v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1224 lib: 311 
           Shell: fish v: 3.3.1 default: Bash v: 5.1.8 running-in: gnome-terminal inxi: 3.3.06 

I guess these are the latest available ISO's.
Have you tried with the official ISO's offered in the download web page (I think those from 210816)?

It's already fixed. Try latest iso.

https://iso.builds.garudalinux.org/iso/garuda/qtile/210918/

5 Likes

I tested the latest ISO in virtualbox, yes it works but, things like terminal, logout, and many other things were not working,same thing was with i3, so I'm pretty sure this problem is in virtualbox (will test on real hardware later)
What about sway, it doesn't work.
Also I wasn't able to find i3 cheatsheet, or we are intended to see that conky only which displays them.

Small thing for team members

In wiki : Qtile Cheatsheet | Garuda Linux wiki, you need to add "jgmenu" in Garuda Qtile uses " " which makes it easy

Alacrity don't work in virtualbox.

2 Likes

Nothing good happens unless you do it.

If it bothers you, create one and post it in the forum.
We will then put it in the wiki. :slight_smile:

2 Likes

I was also gonna post about this problem...
I couldn't go past the login manager...
I went to tty2 and found out the following error...


Thank you'll for fixing the issue...

Please open a new topic for this.
This one is solved and your problem looks different (unless you meant to say that it is already solved in the new ISO).
Take the chance to provide also additional information possibly: new installation? ISO used? Issue after update?

3 Likes

Make sure you are using latest iso, it's already fixed.

3 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.