Problems with sound on garuda

I have big problems with sound on garuda since I installed it.
The sound sometimes almost randomly doesnt work, firedragon also doesnt work correctly when that happens, when playing a video on youtube it loads for some time and then the whole browser freezes. Sound tests work but everything else doesnt. I tried stuff from the arch wiki and also stuff from forums but I couldnt resolve it. Would be nice if someone could help me on here :slight_smile:

Kernel: 5.19.13-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=7b132aa0-c8bb-43f6-bf92-5df4993fce8a rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=fa8276ff-217f-44da-98a2-4c66bad9a1e4 loglevel=3
Desktop: KDE Plasma v: 5.25.5 tk: Qt v: 5.15.6 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Desktop System: HP product: HP Pavilion Gaming Desktop 790-08xx
v: N/A serial: <superuser required> Chassis: type: 3
serial: <superuser required>
Mobo: HP model: 844C v: 00 serial: <superuser required> UEFI: AMI v: F.43
date: 11/25/2020
Info: model: Intel Core i7-8700 bits: 64 type: MT MCP arch: Coffee Lake
gen: core 8 level: v3 built: 2018 process: Intel 14nm family: 6
model-id: 0x9E (158) stepping: 0xA (10) microcode: 0xF0
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB
L3: 12 MiB desc: 1x12 MiB
Speed (MHz): avg: 2006 high: 3200 min/max: 800/4600 scaling:
driver: intel_pstate governor: powersave cores: 1: 1800 2: 1800 3: 2100
4: 1801 5: 1861 6: 1800 7: 2269 8: 3200 9: 1799 10: 2050 11: 1800
12: 1800 bogomips: 76799
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
Type: retbleed mitigation: IBRS
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
Type: spectre_v2 mitigation: IBRS, IBPB: conditional, RSB filling,
PBRSB-eIBRS: Not affected
Type: srbds mitigation: Microcode
Type: tsx_async_abort mitigation: TSX disabled
Device-1: NVIDIA GP106 [GeForce GTX 1060 3GB] vendor: Hewlett-Packard
driver: nvidia v: 515.76 alternate: nouveau,nvidia_drm non-free: 515.xx+
status: current (as of 2022-08) arch: Pascal code: GP10x
process: TSMC 16nm built: 2016-21 pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 01:00.0 chip-ID: 10de:1c02 class-ID: 0300
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
compositor: kwin_x11 driver: X: loaded: nvidia unloaded: modesetting
alternate: fbdev,nouveau,nv,vesa gpu: nvidia display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 90 s-size: 542x301mm (21.34x11.85")
s-diag: 620mm (24.41")
Monitor-1: HDMI-0 res: 1920x1080 hz: 60 dpi: 90
size: 543x302mm (21.38x11.89") diag: 621mm (24.46") modes: N/A
OpenGL: renderer: NVIDIA GeForce GTX 1060 3GB/PCIe/SSE2 v: 4.6.0 NVIDIA
515.76 direct render: Yes
Device-1: Intel Cannon Lake PCH cAVS vendor: Hewlett-Packard
driver: snd_hda_intel v: kernel
alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
chip-ID: 8086:a348 class-ID: 0403
Device-2: NVIDIA GP106 High Definition Audio vendor: Hewlett-Packard
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 01:00.1 chip-ID: 10de:10f1 class-ID: 0403
Sound Server-1: ALSA v: k5.19.13-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 16.1 running: no
Sound Server-3: PipeWire v: 0.3.58 running: yes
Device-1: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter
vendor: Hewlett-Packard driver: rtw_8821ce v: N/A modules: rtw88_8821ce
pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: 4000 bus-ID: 02:00.0
chip-ID: 10ec:c821 class-ID: 0280
IF: wlp2s0 state: down mac: <filter>
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Hewlett-Packard driver: r8169 v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 03:00.0 chip-ID: 10ec:8168
class-ID: 0200
IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Device-1: Realtek Bluetooth 4.2 Adapter type: USB driver: btusb v: 0.8
bus-ID: 1-14:5 chip-ID: 0bda:b00a class-ID: e001 serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter>
Local Storage: total: 1.14 TiB used: 577.73 GiB (49.4%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Toshiba model: N/A
size: 238.47 GiB block-size: physical: 512 B logical: 512 B
speed: 15.8 Gb/s lanes: 2 type: SSD serial: <filter> rev: ADHA0101
temp: 56.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000DM003-1SB102
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B
speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter> rev: HPH4
scheme: GPT
ID-1: / raw-size: 221.27 GiB size: 221.27 GiB (100.00%) used: 61.69 GiB
(27.9%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 608 KiB
(0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 221.27 GiB size: 221.27 GiB (100.00%) used: 61.69
GiB (27.9%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 221.27 GiB size: 221.27 GiB (100.00%) used: 61.69
GiB (27.9%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 221.27 GiB size: 221.27 GiB (100.00%) used: 61.69
GiB (27.9%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.37 GiB used: 142 MiB (0.9%)
priority: 100 dev: /dev/zram0
ID-2: swap-2 type: partition size: 16.9 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
System Temperatures: cpu: 52.0 C pch: 54.0 C mobo: N/A gpu: nvidia
temp: 46 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 40%
Processes: 315 Uptime: 31m wakeups: 0 Memory: 15.37 GiB used: 7.21 GiB
(46.9%) Init: systemd v: 251 default: graphical tool: systemctl
Compilers: gcc: 12.2.0 Packages: pm: pacman pkgs: 1499 libs: 444
tools: octopi,paru Shell: fish v: 3.5.1 default: Bash v: 5.1.16
running-in: konsole inxi: 3.3.21
Garuda (2.6.8-1):
System install date:     2022-09-18
Last full system update: 2022-10-05 ↻
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Snapper
Failed units:

Please, use this
Text from terminal
to make it more readable in the forum.

1 Like

Been having the same problem for about a month or so. The problem is intermittent, but firefox and my media players will occasionally freeze, or not play (e.g., youtube, pandora), until I adjust my volume from the keboard. Then everything is fine until the next song/video loads, but everything freezes again until I adjust the volume. Super annoying, and would love to find a solution. This is the only post I found on the internet that explains my exact same problem. Is this a Garuda or Arch issue? Doesn't happen in Pop_OS! or Windows. Thanks.

Seems not, otherwise the forum and the Internet would be full of it.

For a narrowing, there are just millions of hardware parts combinations :wink: how a PC/laptop can be assembled, you would need your garuda-inxi, but that could lead to illegibility or confusion in this post. So create a separate post if not already done.

Will do. Thanks.

1 Like

A post was merged into an existing topic: GNS3 from Chaotic no longer working

Could this possibly be an issue with JamesDSP again like in this thread: Videos not playing
It shouldn't autostart anymore, but maybe some people have it set to start still?

Try quitting out of JamesDSP if you have it running to see if that is the issue or not.
(I have not experienced issues like in the forum thread I linked since I removed JamesDSP )

Edit: not sure why my post was moved here...?
Edit2: thanks Bluish


I think that was an accident, I've moved it back. :slightly_smiling_face:


I'm not sure if I helped or not actually. Round and round they go...:face_with_spiral_eyes:

@Kayo I think your answer was good for either thread!

This seems very similar to what I encountered and for me it was because of JamesDSP. I realised that I dont use it that often, and I only load it when I need some bass boost.
Fixed by just removing it from autostart settings :smiley:

Hey looks like it is enabled, Ill remove it and check if it still happens after that, thanks for the help

1 Like

JamesDSP has been giving some trouble as of late... as someone already said you can disable it from startup and this will probably help. Also just by clicking the sound icon on top will unfreeze your video ( not a real solution but just what ppl and myself experienced couple of weeks ago) . I personally stopped it from auto-start and it fixed it then i put it back on and i have not encounter it again.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.