Problem with run CS:GO

I have problem with CS:GO. When I turn on CS: GO I get a black screen and turns off. When I turned on with the proton, the error launcher was showing up. I don't know what to do, please help. Btw sorry for my english

Hi there, welcome to the forum.
Please provide the output of your garuda-inxi as requested by the topic template.

1 Like

Can I do it tomorrow? I'm going to sleep soon

Try searching on proton.db for steam games problems.

Here is the thread for CS:GO
https://www.protondb.com/app/730

1 Like
System:
Kernel: 6.0.1-zen2-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=51911192-c46d-4ebb-8f27-151f928334dc rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3
Desktop: KDE Plasma v: 5.26.0 tk: Qt v: 5.15.6 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: HP product: HP 250 G4 Notebook PC
v: Type1ProductConfigId serial: <superuser required> Chassis: type: 10
serial: <superuser required>
Mobo: HP model: 80C2 v: 96.38 serial: <superuser required> UEFI: Insyde
v: F.19 date: 08/27/2015
Battery:
ID-1: BAT1 charge: 34.5 Wh (100.0%) condition: 34.5/41.6 Wh (83.0%)
volts: 16.6 min: 14.6 model: COMPAL PABAS0241231 type: Li-ion
serial: <filter> status: full
CPU:
Info: model: Intel Core i3-5005U bits: 64 type: MT MCP arch: Broadwell
gen: core 5 level: v3 note: check built: 2015-18 process: Intel 14nm
family: 6 model-id: 0x3D (61) stepping: 4 microcode: 0x2F
Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
L3: 3 MiB desc: 1x3 MiB
Speed (MHz): avg: 1885 high: 1900 min/max: 500/1900 scaling:
driver: intel_cpufreq governor: performance cores: 1: 1900 2: 1896 3: 1849
4: 1896 bogomips: 15963
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX unsupported
Type: l1tf mitigation: PTE Inversion
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: mmio_stale_data status: Unknown: No mitigations
Type: retbleed status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: conditional, RSB filling, PBRSB-eIBRS: Not affected
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel HD Graphics 5500 vendor: Hewlett-Packard driver: i915
v: kernel arch: Gen-8 process: Intel 14nm built: 2014-15 ports:
active: eDP-1 empty: DP-1,HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:1616
class-ID: 0300
Device-2: AMD Sun XT [Radeon HD 8670A/8670M/8690M / R5 M330 M430 Radeon
520 Mobile] vendor: Hewlett-Packard driver: radeon v: kernel
alternate: amdgpu arch: GCN-1 code: Southern Islands process: TSMC 28nm
built: 2011-20 pcie: gen: 2 speed: 5 GT/s lanes: 4 link-max: gen: 3
speed: 8 GT/s lanes: 8 bus-ID: 0d:00.0 chip-ID: 1002:6660 class-ID: 0380
temp: 40.0 C
Device-3: Cheng Uei Precision Industry (Foxlink) HP Webcam type: USB
driver: uvcvideo bus-ID: 1-5:4 chip-ID: 05c8:022a class-ID: 0e02
serial: <filter>
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
compositor: kwin_x11 driver: X: loaded: modesetting,radeon
alternate: fbdev,intel,vesa dri: iris,radeonsi gpu: i915 display-ID: :0
screens: 1
Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.21x7.99")
s-diag: 414mm (16.31")
Monitor-1: eDP-1 model: Samsung 0x4c51 built: 2014 res: 1366x768 hz: 60
dpi: 101 gamma: 1.2 size: 344x194mm (13.54x7.64") diag: 395mm (15.5")
ratio: 16:9 modes: 1366x768
OpenGL: renderer: Mesa Intel HD Graphics 5500 (BDW GT2) v: 4.6 Mesa
22.2.1 direct render: Yes
Audio:
Device-1: Intel Broadwell-U Audio vendor: Hewlett-Packard
driver: snd_hda_intel v: kernel bus-ID: 00:03.0 chip-ID: 8086:160c
class-ID: 0403
Device-2: Intel Wildcat Point-LP High Definition Audio
vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
chip-ID: 8086:9ca0 class-ID: 0403
Sound API: ALSA v: k6.0.1-zen2-1-zen running: yes
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.59 running: yes
Network:
Device-1: Realtek RTL810xE PCI Express Fast Ethernet
vendor: Hewlett-Packard driver: r8169 v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: 5000 bus-ID: 07:00.0 chip-ID: 10ec:8136
class-ID: 0200
IF: enp7s0 state: down mac: <filter>
Device-2: Realtek RTL8723BE PCIe Wireless Network Adapter
vendor: Hewlett-Packard driver: rtl8723be v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 13:00.0 chip-ID: 10ec:b723
class-ID: 0280
IF: wlp19s0 state: up mac: <filter>
Bluetooth:
Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8
bus-ID: 1-4:3 chip-ID: 0bda:b006 class-ID: e001 serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 0 state: down
bt-service: enabled,running rfk-block: hardware: no software: yes
address: <filter>
Drives:
Local Storage: total: 465.76 GiB used: 83.38 GiB (17.9%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST500LT012-1DG142
size: 465.76 GiB block-size: physical: 4096 B logical: 512 B
speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter> rev: YAM1
scheme: GPT
Partition:
ID-1: / raw-size: 465.46 GiB size: 465.46 GiB (100.00%) used: 83.38 GiB
(17.9%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 608 KiB
(0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 465.46 GiB size: 465.46 GiB (100.00%) used: 83.38
GiB (17.9%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 465.46 GiB size: 465.46 GiB (100.00%) used: 83.38
GiB (17.9%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 465.46 GiB size: 465.46 GiB (100.00%) used: 83.38
GiB (17.9%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 3.75 GiB used: 40 MiB (1.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 44.0 C pch: 40.5 C mobo: N/A gpu: radeon
temp: 40.0 C
Fan Speeds (RPM): N/A
Info:
Processes: 191 Uptime: 34m wakeups: 1 Memory: 3.75 GiB used: 1.98 GiB
(52.7%) Init: systemd v: 251 default: graphical tool: systemctl
Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: pm: pacman pkgs: 1834
libs: 514 tools: octopi,paru Shell: fish v: 3.5.1 default: Bash v: 5.1.16
running-in: konsole inxi: 3.3.22
Garuda (2.6.8-1):
System install date:     2022-10-15
Last full system update: 2022-10-16
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Snapper
Failed units:

I adjusted the inxi post to be more readable, according to the relevant tutorial.
As far as the issue is concerned, I cannot help much since I'm not a gamer.
Anyway, you could give a look at the topics below, containing "CS:GO" and solved.
https://forum.garudalinux.org/search?q=%22CS%3AGO%22%20status%3Asolved
The only suggestion I could think of is to try disabling the compositor (alt+shift+F12) before launching the game
(maybe this is already among the suggestions in the list above anyway).

Don't use Proton for CSGO.

thanks for your help

1 Like

Do you know how to solve my problem with csgo?

Change launch options to

prime-run %command%
1 Like

If csgo run in window I must launch -fullscreen?

You can enable fullscreen in game settings, IIRC the launch parameter for that is "-full".

1 Like

Now Csgo crashes fastly

I have problem with run CSGO. When I run CSGO in native it shows black screen.
Now I'm trying to turn csgo through a proton. But if I do this it shows "Fatal error, failed to connect with local Stean Client process". I don't know what to do.

System:
Kernel: 6.0.1-zen2-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=51911192-c46d-4ebb-8f27-151f928334dc rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3
Desktop: KDE Plasma v: 5.26.0 tk: Qt v: 5.15.6 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: HP product: HP 250 G4 Notebook PC
v: Type1ProductConfigId serial: <superuser required> Chassis: type: 10
serial: <superuser required>
Mobo: HP model: 80C2 v: 96.38 serial: <superuser required> UEFI: Insyde
v: F.19 date: 08/27/2015
Battery:
ID-1: BAT1 charge: 34.8 Wh (100.0%) condition: 34.8/41.6 Wh (83.5%)
volts: 16.6 min: 14.6 model: COMPAL PABAS0241231 type: Li-ion
serial: <filter> status: full
CPU:
Info: model: Intel Core i3-5005U bits: 64 type: MT MCP arch: Broadwell
gen: core 5 level: v3 note: check built: 2015-18 process: Intel 14nm
family: 6 model-id: 0x3D (61) stepping: 4 microcode: 0x2F
Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
L3: 3 MiB desc: 1x3 MiB
Speed (MHz): avg: 1897 high: 1900 min/max: 500/1900 scaling:
driver: intel_cpufreq governor: performance cores: 1: 1896 2: 1898 3: 1896
4: 1900 bogomips: 15962
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX unsupported
Type: l1tf mitigation: PTE Inversion
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: mmio_stale_data status: Unknown: No mitigations
Type: retbleed status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: conditional, RSB filling, PBRSB-eIBRS: Not affected
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel HD Graphics 5500 vendor: Hewlett-Packard driver: i915
v: kernel arch: Gen-8 process: Intel 14nm built: 2014-15 ports:
active: eDP-1 empty: DP-1,HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:1616
class-ID: 0300
Device-2: AMD Sun XT [Radeon HD 8670A/8670M/8690M / R5 M330 M430 Radeon
520 Mobile] vendor: Hewlett-Packard driver: radeon v: kernel
alternate: amdgpu arch: GCN-1 code: Southern Islands process: TSMC 28nm
built: 2011-20 pcie: gen: 2 speed: 5 GT/s lanes: 4 link-max: gen: 3
speed: 8 GT/s lanes: 8 bus-ID: 0d:00.0 chip-ID: 1002:6660 class-ID: 0380
temp: 49.0 C
Device-3: Cheng Uei Precision Industry (Foxlink) HP Webcam type: USB
driver: uvcvideo bus-ID: 1-5:4 chip-ID: 05c8:022a class-ID: 0e02
serial: <filter>
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
compositor: kwin_x11 driver: X: loaded: modesetting,radeon
alternate: fbdev,intel,vesa dri: iris,radeonsi gpu: i915 display-ID: :0
screens: 1
Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.21x7.99")
s-diag: 414mm (16.31")
Monitor-1: eDP-1 model: Samsung 0x4c51 built: 2014 res: 1366x768 hz: 60
dpi: 101 gamma: 1.2 size: 344x194mm (13.54x7.64") diag: 395mm (15.5")
ratio: 16:9 modes: 1366x768
OpenGL: renderer: Mesa Intel HD Graphics 5500 (BDW GT2) v: 4.6 Mesa
22.2.1 direct render: Yes
Audio:
Device-1: Intel Broadwell-U Audio vendor: Hewlett-Packard
driver: snd_hda_intel v: kernel bus-ID: 00:03.0 chip-ID: 8086:160c
class-ID: 0403
Device-2: Intel Wildcat Point-LP High Definition Audio
vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
chip-ID: 8086:9ca0 class-ID: 0403
Sound API: ALSA v: k6.0.1-zen2-1-zen running: yes
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.59 running: yes
Network:
Device-1: Realtek RTL810xE PCI Express Fast Ethernet
vendor: Hewlett-Packard driver: r8169 v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: 5000 bus-ID: 07:00.0 chip-ID: 10ec:8136
class-ID: 0200
IF: enp7s0 state: down mac: <filter>
Device-2: Realtek RTL8723BE PCIe Wireless Network Adapter
vendor: Hewlett-Packard driver: rtl8723be v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 13:00.0 chip-ID: 10ec:b723
class-ID: 0280
IF: wlp19s0 state: up mac: <filter>
Bluetooth:
Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8
bus-ID: 1-4:3 chip-ID: 0bda:b006 class-ID: e001 serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 0 state: down
bt-service: enabled,running rfk-block: hardware: no software: yes
address: <filter>
Drives:
Local Storage: total: 465.76 GiB used: 72.13 GiB (15.5%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST500LT012-1DG142
size: 465.76 GiB block-size: physical: 4096 B logical: 512 B
speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter> rev: YAM1
scheme: GPT
Partition:
ID-1: / raw-size: 465.46 GiB size: 465.46 GiB (100.00%) used: 72.13 GiB
(15.5%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 608 KiB
(0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 465.46 GiB size: 465.46 GiB (100.00%) used: 72.13
GiB (15.5%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 465.46 GiB size: 465.46 GiB (100.00%) used: 72.13
GiB (15.5%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 465.46 GiB size: 465.46 GiB (100.00%) used: 72.13
GiB (15.5%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 3.75 GiB used: 1.59 GiB (42.5%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 53.0 C pch: 49.5 C mobo: N/A gpu: radeon
temp: 49.0 C
Fan Speeds (RPM): N/A
Info:
Processes: 220 Uptime: 1h 47m wakeups: 1 Memory: 3.75 GiB used: 2.37 GiB
(63.2%) Init: systemd v: 251 default: graphical tool: systemctl
Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: pm: pacman pkgs: 1834
libs: 514 tools: octopi,paru Shell: fish v: 3.5.1 default: Bash v: 5.1.16
running-in: konsole inxi: 3.3.22
Garuda (2.6.8-1):
System install date:     2022-10-15
Last full system update: 2022-10-16
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Snapper
Failed units:

Do not open new help requests for the same problem, please, it is rude.

3 Likes

doesn't start in btrfs partition, only in case insensitive FSs

From ProtonDB.

You could try to break off some space for the game, format it with ext4 and try running the game then. A lot of work for a game, but if you really wanna play... doesn't seem to work on Btrfs.

Could also try launch-option -nojoy

1 Like

There seem to be a lot of hits and guides on the Internet for this error, although they don't seem to be a big deal at all...
Have you tried anything?
Even though they are always Windows-based, Steam is Steam, maybe you can try.
I just link one of them randomly:
https://thedroidguy.com/csgo-failed-to-connect-with-local-steam-client-process-error-1137680

3 Likes