Problem with garuda-update

Hey all and happy new year… :wink:

Can’t boot this morning, had to use a snapshot from yesterday morning.
No error message, just stuck when launching kde…

Here’s my inxi :

System:
Kernel: 6.6.8-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc available: acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=66082618-ab1d-4528-aec7-ddaef29e9b82 rw rootflags=subvol=@
quiet rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3 splash
pcie_aspm=off ibt=off
Desktop: KDE Plasma v: 5.27.10 tk: Qt v: 5.15.11 wm: kwin_x11 vt: 2
dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Convertible System: LENOVO product: 20FRS08U00
v: ThinkPad X1 Carbon 4th serial: <superuser required> Chassis: type: 31
serial: <superuser required>
Mobo: LENOVO model: 20FRS08U00 v: SDK0J40697 WIN
serial: <superuser required> UEFI: LENOVO v: N1FET81W (1.55 )
date: 10/11/2022
Battery:
ID-1: BAT0 charge: 47.4 Wh (100.0%) condition: 47.4/47.4 Wh (100.0%)
volts: 16.5 min: 14.8 model: LGC 00HW028 type: Li-ion serial: <filter>
status: full
CPU:
Info: model: Intel Core i7-6600U bits: 64 type: MT MCP arch: Skylake
gen: core 6 level: v3 note: check built: 2015 process: Intel 14nm family: 6
model-id: 0x4E (78) stepping: 3 microcode: 0xF0
Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
L3: 4 MiB desc: 1x4 MiB
Speed (MHz): avg: 475 high: 500 min/max: 400/3400 scaling:
driver: intel_pstate governor: powersave cores: 1: 500 2: 400 3: 500 4: 500
bogomips: 22399
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Graphics:
Device-1: Intel Skylake GT2 [HD Graphics 520] vendor: Lenovo driver: i915
v: kernel arch: Gen-9 process: Intel 14n built: 2015-16 ports: active: eDP-1
empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2 bus-ID: 00:02.0 chip-ID: 8086:1916
class-ID: 0300
Device-2: Lite-On HD Webcam (960×540) driver: uvcvideo type: USB rev: 2.0
speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-8:5 chip-ID: 04ca:705a
class-ID: 0e02
Display: x11 server: X.Org v: 21.1.10 with: Xwayland v: 23.2.3
compositor: kwin_x11 driver: X: loaded: intel unloaded: modesetting
alternate: fbdev,vesa dri: i965 gpu: i915 display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 mapped: eDP1 model: AU Optronics 0x183d built: 2014
res: 1920x1080 hz: 60 dpi: 157 gamma: 1.2 size: 310x170mm (12.2x6.69")
diag: 354mm (13.9") ratio: 16:9 modes: 1920x1080
API: EGL v: 1.5 hw: drv: intel iris platforms: device: 0 drv: iris
device: 1 drv: swrast surfaceless: drv: iris x11: drv: iris
inactive: gbm,wayland
API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 23.3.1-arch1.1
glx-v: 1.4 direct-render: yes renderer: Mesa Intel HD Graphics 520 (SKL GT2)
device-ID: 8086:1916 memory: 14.99 GiB unified: yes
API: Vulkan v: 1.3.274 layers: 3 device: 0 type: integrated-gpu name: Intel
HD Graphics 520 (SKL GT2) driver: mesa intel v: 23.3.1-arch1.1
device-ID: 8086:1916 surfaces: xcb,xlib device: 1 type: cpu name: llvmpipe
(LLVM 16.0.6 256 bits) driver: mesa llvmpipe v: 23.3.1-arch1.1 (LLVM
16.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
Audio:
Device-1: Intel Sunrise Point-LP HD Audio vendor: Lenovo
driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_soc_avs
bus-ID: 00:1f.3 chip-ID: 8086:9d70 class-ID: 0403
API: ALSA v: k6.6.8-zen1-1-zen status: kernel-api tools: N/A
Server-1: PipeWire v: 1.0.0 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pw-jack type: plugin
tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: Intel Ethernet I219-LM vendor: Lenovo driver: e1000e v: kernel
port: N/A bus-ID: 00:1f.6 chip-ID: 8086:156f class-ID: 0200
IF: enp0s31f6 state: down mac: <filter>
Device-2: Intel Wireless 8260 driver: iwlwifi v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 bus-ID: 04:00.0 chip-ID: 8086:24f3 class-ID: 0280
IF: wlp4s0 state: up mac: <filter>
Bluetooth:
Device-1: Intel Bluetooth wireless interface driver: btusb v: 0.8 type: USB
rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-7:4 chip-ID: 8087:0a2b
class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 3 state: up address: <filter> bt-v: 4.2
lmp-v: 8 status: discoverable: no pairing: no class-ID: 7c0000
Drives:
Local Storage: total: 1.4 TiB used: 177.64 GiB (12.4%)
ID-1: /dev/mmcblk0 maj-min: 179:0 model: SN01T size: 953.55 GiB
block-size: physical: 512 B logical: 512 B type: Removable tech: SSD
serial: <filter> scheme: MBR
SMART Message: Unknown smartctl error. Unable to generate data.
SMART Message: Unable to run smartctl. Root privileges required.
ID-2: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
model: MZVKV512HAJH-000L1 size: 476.94 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
fw-rev: 7L0QBXX7 temp: 38.9 C scheme: GPT
Partition:
ID-1: / raw-size: 194.8 GiB size: 194.8 GiB (100.00%)
used: 97.04 GiB (49.8%) fs: btrfs dev: /dev/nvme0n1p6 maj-min: 259:6
ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%)
used: 584 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p5 maj-min: 259:5
ID-3: /home raw-size: 194.8 GiB size: 194.8 GiB (100.00%)
used: 97.04 GiB (49.8%) fs: btrfs dev: /dev/nvme0n1p6 maj-min: 259:6
ID-4: /var/log raw-size: 194.8 GiB size: 194.8 GiB (100.00%)
used: 97.04 GiB (49.8%) fs: btrfs dev: /dev/nvme0n1p6 maj-min: 259:6
ID-5: /var/tmp raw-size: 194.8 GiB size: 194.8 GiB (100.00%)
used: 97.04 GiB (49.8%) fs: btrfs dev: /dev/nvme0n1p6 maj-min: 259:6
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 15.35 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 4 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 46.0 C pch: 44.0 C mobo: N/A
Fan Speeds (rpm): fan-1: 3211
Info:
Processes: 217 Uptime: 5m wakeups: 0 Memory: total: 16 GiB note: est.
available: 15.35 GiB used: 2.41 GiB (15.7%) Init: systemd v: 255
default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6
Packages: pm: dpkg pkgs: 0 pm: pacman pkgs: 1494 libs: 434
tools: octopi,paru,yay pm: rpm pkgs: 0 Shell: fish v: 3.6.4 default: Bash
v: 5.2.21 running-in: konsole inxi: 3.3.31
Garuda (2.6.22-1):
System install date:     2023-07-23
Last full system update: 2023-12-30
Is partially upgraded:   No
Relevant software:       snapper NetworkManager mkinitcpio
Windows dual boot:       Probably (Run as root to verify)
Failed units:

And that’s what i have when trying to do garuda-update :

extra/alacritty                    0.13.0-2         0.13.0-3           0.00 MiB
chaotic-aur/candy-icons-git        r1105.ada73e9-1  r1108.be75dd7-1    0.01 MiB
extra/fontconfig                   2:2.15.0-1       2:2.15.0-2         0.00 MiB
core/iputils                       20231222-1       20231222-2         0.00 MiB
multilib/lib32-libva-mesa-driver   1:23.3.1-1       1:23.3.2-1         0.00 MiB
multilib/lib32-mesa                1:23.3.1-1       1:23.3.2-1        -0.04 MiB
multilib/lib32-mesa-vdpau          1:23.3.1-1       1:23.3.2-1         0.00 MiB
multilib/lib32-opencl-clover-mesa  1:23.3.1-1       1:23.3.2-1         0.01 MiB
multilib/lib32-vulkan-intel        1:23.3.1-1       1:23.3.2-1        -0.03 MiB
multilib/lib32-vulkan-mesa-layers  1:23.3.1-1       1:23.3.2-1         0.00 MiB
multilib/lib32-vulkan-radeon       1:23.3.1-1       1:23.3.2-1         0.00 MiB
extra/libva-mesa-driver            1:23.3.1-1       1:23.3.2-1         0.04 MiB
chaotic-aur/linux-wifi-hotspot     4.6.0-1          4.7.0-1            0.00 MiB
extra/mesa                         1:23.3.1-1       1:23.3.2-1         0.05 MiB
extra/mesa-vdpau                   1:23.3.1-1       1:23.3.2-1         0.00 MiB
extra/opencl-clover-mesa           1:23.3.1-1       1:23.3.2-1         0.02 MiB
extra/opencl-rusticl-mesa          1:23.3.1-1       1:23.3.2-1         0.01 MiB
extra/thunar                       4.18.9-1         4.18.10-1          0.00 MiB
extra/vulkan-intel                 1:23.3.1-1       1:23.3.2-1         0.02 MiB
extra/vulkan-mesa-layers           1:23.3.1-1       1:23.3.2-1         0.00 MiB
extra/vulkan-radeon                1:23.3.1-1       1:23.3.2-1         0.00 MiB
extra/vulkan-swrast                1:23.3.1-1       1:23.3.2-1         0.00 MiB
chaotic-aur/zoom                   5.17.0-1         5.17.1-1           0.03 MiB

Have you tried garuda-update again?
Maybe it was just a bad update processing and/or bad mirrors.

2 Likes

No, hold on:

8 Likes

Yep, i tried garuda-update right now, but with the same issue…

You can rollback or downgrade those two Mesa packages and wait for a fix.
It looks like an important upstream regression bug.
But I guess people are recovering from parties :wink:

5 Likes

I think i’s better for me to wait for a fix…
But how can i be sure that the problem is fixed ?
Waiting for a new version ?

Yes, a version higher than the buggy one.
Or give a look every now and then to that bug report.

5 Likes

We will be adding the last working mesa package to the garuda repo shortly, causing the package to be frozen for all users. This will be reverted once the fix is available in the Arch repos.

9 Likes

Updated last night while everyone else was partying. :smiley:
https://archlinux.org/packages/extra/x86_64/mesa/

But perhaps I wrote too soon. :frowning:

Yup. A downgrade to the previous version is needed in Arch for some rigs. Mesa doesn’t typically do this. NetworkManager is the notorious one. :wink:

2 Likes

I see the two mesa packages have just been updated in Arch repo (let’s give them some time to synch :grinning:).
Anyway, it looks like the bug affected only some configurations.

5 Likes

I literally JUST added mesa to the garuda repo. Hahahaha.

6 Likes

Just did the update and this time evrything went well…

Thank you all for your job :smiling_face_with_three_hearts: :smiling_face_with_three_hearts: :smiling_face_with_three_hearts:

Seems like it’s not the first time that i have a problem with mesa…

Hey again,

Reading a lot of things on Gitlab, with the link you give above…

The problem seems to be that i dont need to have both xf86-video-intel and mesa installed, causing my problem…

They told to remove xf86-video-intel et to have only mesa…

My question is : is it safe to do that ?

xf86-video-intel has been known to cause horrible problems on anything above 2nd/3rd Gen Intel rigs since, I dunno, 2018? It’s been at least that long since I used it on a 4th Gen. rig in Arch.

I dunno what kinda thingee Garuda has concocted.

2 Likes

But is it risky to remove it ?

You’re running Skylake/6th Gen. No, you do not need it. But again, I don’t know what kind of framework @dr460nf1r3 has concocted.

Use pacman to see what else may be involved first. I’m not the best person to advise you since I’m in Windows and “btw, I run arch.”

1 Like
[root@jacques-20frs08t00 jacques]# pacman -Rcs xf86-video-intel
vérification des dépendances…

Paquets (2) libxvmc-1.0.13-2  xf86-video-intel-1:2.99.917+923+gb74b67f0-1

Taille totale supprimée :  2.27 MiB

:: Voulez-vous désinstaller ces paquets ? [O/n] n
[root@jacques-20frs08t00 jacques]#

libxvmc-1.0.13-2 seems to be the only dependencie…

That’s normal. Be sure you’re updated, remove it (them) reboot. Test it out.

2 Likes

It is risky to use -Rcs, yes. This is unnecessarily aggressive. You are recursively removing packages that depend on the target package, and that the target package depends on. I would suggest not using this command.

Here, take a look:

❯ pacman -Sii xf86-video-intel
Repository      : extra
Name            : xf86-video-intel
Version         : 1:2.99.917+923+gb74b67f0-1
Description     : X.org Intel i810/i830/i915/945G/G965+ video drivers
Architecture    : x86_64
URL             : https://01.org/linuxgraphics
Licenses        : custom
Groups          : xorg-drivers
Provides        : xf86-video-intel-uxa  xf86-video-intel-sna
Depends On      : mesa  libxvmc  pixman  xcb-util>=0.3.9  systemd-libs
Optional Deps   : libxrandr: for intel-virtual-output
                  libxinerama: for intel-virtual-output
                  libxcursor: for intel-virtual-output
                  libxtst: for intel-virtual-output
                  libxss: for intel-virtual-output
Required By     : None
Optional For    : optimus-manager  optimus-manager-git
Conflicts With  : xorg-server<21.1.1  X-ABI-VIDEODRV_VERSION<25  X-ABI-VIDEODRV_VERSION>=26  xf86-video-intel-sna
                  xf86-video-intel-uxa  xf86-video-i810  xf86-video-intel-legacy
Replaces        : xf86-video-intel-uxa  xf86-video-intel-sna
Download Size   : 726.51 KiB
Installed Size  : 2238.89 KiB
Packager        : Andreas Radke <[email protected]>
Build Date      : Thu 02 Feb 2023 01:35:27 AM EST
MD5 Sum         : 93ac2cac2732e61aec1cc86f2b50947d
SHA-256 Sum     : b8b2335918ba51e63d237bccfb2f5bd2392930cc2b102a543f5e608a3122f01f
Signatures      : 94657AB20F2A092B

libxvmc is a dependency of xf86-video-intel–not the other way around. I would leave that be.

This is right, only super old systems benefit from this driver. Anything newer than 3rd gen Intel should just use the modesetting driver.

It is safe to remove xf86-video-intel, but you should just remove it in a normal way like this:

pacman -R xf86-video-intel
6 Likes

Thanks for your advice… I remove it like you said with pacman -R…

I did a reboot without any problem.

Tomorrow i have to try this on 2 different laptops… Just hopin without any problem too…

1 Like