Problem installing the New Garuda Linux version

Hello everyone,

Today I tried to install Garuda Linux onto my computer. I have two drives: one is a NVMe SSD and one is a regular SSD with Windows on it. I downloaded the "Serpent Eagle" Dragonized gaming version from this thread:

Everything went all right and I was able to boot into the installer via USB. The install said it was successful and asked to reboot my PC. However, when I rebooted, it did not bring me to Grubmenu, it launched straight into my Windows 10 installation on my other SSD.

I didn't know what the issue was, since I checked the UEFI menu and Garuda was listed at the top priority. So I went into the boot menu manually and clicked on Garuda. When I did, I was faced with this black screen:

I have no idea why Grubmenu isn't launching or why I am unable to launch into my Garuda linux installation. I'm pretty sure I have Secure Boot disabled (I checked and the box that says "Secure Boot enable" was unchecked). So what's the problem here?

Possibly GRUB installed onto a partition rather than the drive. Go back through the installation steps and note down what you do at each stage.

4 Likes

I mean, I selected "Erase disk" and just clicked continue. Should I restart the Installer and do it again?

Yes - let's replicate the issue before trying to work out cause of the issue.

2 Likes

Alright, I will do that. I will also take pictures of each step and the UEFI menu afterwards and update here when I am done.

1 Like

Ah that was indeed the problem. It appears Grub was installed on a different partition. I just checked the boot menu and there was weird looking boot option with the name of my NVMe SSD on it. I originally had "Garuda" as the first boot priority, but when made that other boot option the first priority, it launched into Grub and showed both my Windows installation and Garuda together and worked perfectly. I am currently setting up Garuda now. Thank you for your help!

3 Likes

BTW

:slight_smile:

seems I miss your first post :slight_smile:

ooppppsss, X-mas, I miss a lot :wink:

2 Likes