Problem during "Audacity" installation

Hello, I am a newbie to the Linux operating system.
Currently, I am using Garuda Linux. I use the "yay" helper for AUR.
When I run the command "yay -S audacity" I want to install Audacity.

The error that I am retrieving:

warning: failed to retrieve some files
error: failed to commit transaction (failed to retrieve some files)
Errors occurred, and no packages were upgraded.
error: could not set install reason for package audacity (could not find or read the package)
-> error installing repo packages

Note It is same for using "sudo pacman -S audacity"

Hi, welcome to the forums! :wave:

This sounds like you haven't updated your system since first install. Run
garuda-update -a
and try to install Audacity after that with
sudo pacman -S audacity
There is no need to use an AUR helper for this since Audacity is in the community Arch repos, but it will still work even if you choose to ^^

For future posts, please make sure you read the issues and assistance template. A large number of issues are easily solved with information that is visible in your garuda-inxi output, even when it seems irrelevant. The output of this command does not contain any sensitive information as long as you don't run it as root.

I also highly recommend reading this topic, as it makes your posts more accessible to those who are reading these forums on their phone: How to write a nicely formatted post in Discourse/Forum
The most important part is putting terminal output between 3 tildes top and bottom, as shown in the template and the topic:

Nice, it looks like this solved your problem. A small tip, it is recommended for Arch and Arch-based systems to update at least once a week. Happy Garuda'ing! :_garuda_:


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.