Personal thank you to creator linux-cacule developer (ptr1337)

@ptr1337 I want to say thank you to this guy, I have never faster laptop! Your work is incredible, linux-cacule is really great kernel! But this isn't main thing what's valuable for me... there is a lot of developers around the linux kernel, but you are special!

Why?

  1. You learned me how to use modules, kernel parametrs, GRUB, systemd-boot, nvidia-all and just everything around nvidia GPU on linux. I have never undestand this from Arch Wiki, but I learned this things form you! I think it's very nice.
  2. You are helpful, really nice person, who knows what to do when something went wrong.
  3. I can read Arch Wiki much easier now, I created two guides from my knowledge.
  4. He's my soulmate... we have similar life.

Currently I testing everything what @ptr1337 add into the linux-cacule and trying give him feedback soon as possible.

Advice for beginners:
Testing bring more knowledge, experience for you... top way how to expolere Arch Linux and Arch-based systems and generally get more about linux world.

Short stroy:
Some days ago, I meet new linux version on Gradua, I stared testing that... and we started communication on Telegram, now on Discord :slightly_smiling_face:

14 Likes

Peter deserves the appreciation. He is very knowledgeable and very kind for helping and supporting. I would like to also thank you @Soong for your tests and feedback, and everyone who helped.

8 Likes

That's my impression as well :slight_smile:
Welcome to the Garuda forum, nice to see you here @Hamadmarri :grin:

8 Likes

Thanks for your feedback and that great thank you!

I'm very glad that you learned these things, i just try to help as much as possible, thats my person (sometimes not if i get really mad at dumb questions :smiley: )

but it is really fun to work with you, youre giving me a exact feedback where the performance is lagging around or getting better.

but for clearifcation: @Hamadmarri is the developer of cacule, not me. Im providing only for arch a build with some other patches and test things around.

Thank you for our gread feedback and much love :heart:

8 Likes

Hehe i know... sometimes my questions is... you know... :smiley: But i trying learn everything soon as possible.
I know, thank you for CacULE @Hamadmarri. You and @ptr1337 created something incredible.

I'm trying to be the best QA - tester (Quality assurance) person for you guys. I going to write guide how to follow and determine performance - just everything why I can give valuable feedback. :slight_smile:

6 Likes

RIP Privacy.

4 Likes

I just installed it and booted in and it seems the kernel isn't compatible with optimus-manager.

I tried my laptop with GTX 1050-Ti and second laptop with GT740M and PRIME works, optimus manager works. You should check your configuration. Tell me more details about your issue.

I'm not entirely sure whats wrong yet. I know I had to download an aur package to get it compatible with linux-zen. I will post inxi -Fxxxza output here later.


System:    Kernel: 5.12.3-2-cacule x86_64 bits: 64 compiler: gcc v: 10.2.0 
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-cacule root=UUID=6bffdc79-d9cf-4de9-a3aa-58bbfb0e7a9c rw 
rootflags=subvol=@ quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 
systemd.unified_cgroup_hierarchy=1 loglevel=3 intel_iommu=on i915.enable_gvt=1 kvm.ignore_msrs=1 i915.enable_guc=0 
Console: tty pts/1 wm: kwin_x11 DM: SDDM Distro: Garuda Linux base: Arch Linux 
Machine:   Type: Laptop System: Dell product: G3 3590 v: N/A serial: <filter> Chassis: type: 10 serial: <filter> 
Mobo: Dell model: 0DKM3T v: A00 serial: <filter> UEFI: Dell v: 1.8.0 date: 11/11/2019 
Battery:   ID-1: BAT0 charge: 33.6 Wh (79.6%) condition: 42.2/51.0 Wh (82.8%) volts: 11.1 min: 11.4 model: BYD DELL M4GWP98 
type: Li-poly serial: <filter> status: Discharging 
CPU:       Info: 6-Core model: Intel Core i7-9750H socket: BGA1440 (U3E1) note: check bits: 64 type: MT MCP arch: Kaby Lake 
note: check family: 6 model-id: 9E (158) stepping: A (10) microcode: DE cache: L1: 384 KiB L2: 12 MiB L3: 12 MiB 
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 62399 
Speed: 2597 MHz min/max: 800/2600 MHz base/boost: 2600/2600 volts: 0.9 V ext-clock: 100 MHz Core speeds (MHz): 
1: 2597 2: 2599 3: 2600 4: 2600 5: 2561 6: 2599 7: 2014 8: 2592 9: 2215 10: 2600 11: 2601 12: 2600 
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
Type: meltdown mitigation: PTI 
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
Type: srbds mitigation: Microcode 
Type: tsx_async_abort status: Not affected
Graphics:  Device-1: Intel UHD Graphics 630 vendor: Dell driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:3e9b
class-ID: 0300
Device-2: NVIDIA TU116M [GeForce GTX 1660 Ti Mobile] vendor: Dell driver: N/A alternate: nouveau bus-ID: 01:00.0
chip-ID: 10de:2191 class-ID: 0300
Device-3: Realtek Integrated_Webcam_HD type: USB driver: uvcvideo bus-ID: 1-5:2 chip-ID: 0bda:5521 class-ID: 0e02
serial: <filter>
Display: server: X.Org 1.20.11 compositor: kwin_x11 driver: loaded: intel unloaded: modesetting
alternate: fbdev,vesa display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9")
Monitor-1: eDP1 res: 1920x1080 hz: 60 dpi: 143 size: 340x190mm (13.4x7.5") diag: 389mm (15.3")
OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 21.1.0 direct render: Yes
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: Dell driver: sof-audio-pci-intel-cnl
alternate: snd_hda_intel,snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3 chip-ID: 8086:a348 class-ID: 0401
Device-2: NVIDIA TU116 High Definition Audio vendor: Dell driver: snd_hda_intel v: kernel bus-ID: 01:00.1
chip-ID: 10de:1aeb class-ID: 0403
Sound Server-1: ALSA v: k5.12.3-2-cacule running: yes
Sound Server-2: JACK v: 0.125.0 running: no
Sound Server-3: PulseAudio v: 14.2 running: yes
Sound Server-4: PipeWire v: 0.3.27 running: no
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Dell driver: r8169 v: kernel port: 3000
bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp3s0 state: down mac: <filter>
Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter vendor: Dell driver: ath10k_pci v: kernel
port: 3000 bus-ID: 04:00.0 chip-ID: 168c:0042 class-ID: 0280
IF: wlp4s0 state: up mac: <filter>
IF-ID-1: virbr0 state: down mac: <filter>
Bluetooth: Device-1: Qualcomm Atheros type: USB driver: btusb v: 0.8 bus-ID: 1-14:3 chip-ID: 0cf3:e009 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:    Local Storage: total: 1.38 TiB used: 1.15 TiB (83.5%)
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital model: PC SN520 NVMe WDC 512GB size: 476.94 GiB
block-size: physical: 512 B logical: 512 B speed: 15.8 Gb/s lanes: 2 rotation: SSD serial: <filter> rev: 20220012
temp: 60 Celsius C scheme: MBR
SMART: yes health: PASSED on: 159d 4h cycles: 1,286 read-units: 50,155,053 [25.6 TB]
written-units: 74,219,738 [38.0 TB]
ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000LM035-1RK172 family: Mobile HDD size: 931.51 GiB
block-size: physical: 4096 B logical: 512 B sata: 3.1 speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter> rev: ACM1
temp: 35 C scheme: GPT
SMART: yes state: enabled health: PASSED on: 2y 51d 17h cycles: 3338 read: 52.36 TiB written: 38.5 TiB Old-Age:
g-sense error rate: 330 Pre-Fail: attribute: Spin_Retry_Count value: 100 worst: 100 threshold: 97
Partition: ID-1: / raw-size: 476.64 GiB size: 476.64 GiB (100.00%) used: 428.11 GiB (89.8%) fs: btrfs block-size: 4096 B
dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 568 KiB (0.2%) fs: vfat block-size: 512 B
dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 476.64 GiB size: 476.64 GiB (100.00%) used: 428.11 GiB (89.8%) fs: btrfs block-size: 4096 B
dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 476.64 GiB size: 476.64 GiB (100.00%) used: 428.11 GiB (89.8%) fs: btrfs
block-size: 4096 B dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 476.64 GiB size: 476.64 GiB (100.00%) used: 428.11 GiB (89.8%) fs: btrfs
block-size: 4096 B dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:      Alert: No swap data was found.
Sensors:   System Temperatures: cpu: 58.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info:      Processes: 294 Uptime: 9m wakeups: 83 Memory: 15.43 GiB used: 3.43 GiB (22.3%) Init: systemd v: 248 tool: systemctl
Compilers: gcc: 10.2.0 clang: 11.1.0 Packages: pacman: 1760 lib: 546 Shell: fish (sudo) v: 3.2.2 default: Bash
v: 5.1.8 running-in: konsole inxi: 3.3.04

I checked optimus-manager logs and apparently it can't detect the nvidia drivers. Perhaps its not compatible with Nvidia vulkan drivers. I will have to check that. I installed nvidia drivers using nvidia-all package so that might be a problem.

Seems to be again a user configuration error.

It seems that I did not install the api-headers for cacule. Works fine now.

This kernel isn't meant for vfio is it? Because I tried to run my vfio setup on it was so slow.

We discussed about that with Ptr, but not so much user use that... we can open discuss again, what do you think @ptr1337 ?

personally i hve never used vfio, but i can watch for it to improve it.

regards.

1 Like

The only reason I chose vfio over wine/proton is because it has less of a hassle. As long as you setup your vm config its only a matter of booting into it and playing your games. Whereas wine/proton both need fiddling to get any complex game working.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.