Performance-tweaks and auto-cpufreq-git are in conflict

I have installed fresh Garuda on my system. After installing I went for a upgrade using pacman -Syu command. I am unable to upgrade or install any application because of this upgrade error. Screenshot below for your reference.

Please let me know if needed any further details on my system.



Not today but read

please and send

no pictures from terminal output.

IDK why there are in conflict but you can solve if you remove one of them like

sudo pacman -Rns performance-tweaks



Thank you, for the prompt reply. But just one query, what would be reason of conflict, is it my system or is it server, coz if it is server then we may have received bugs on this package, right?

Its because i conflicted them

Either install performance tweaks or auto-cpufreq
As both of them do one thing ie set cpu governor


In that that case what do you suggest to remove? performance-tweaks or auto-cpufreq-git? Asking as I am a Newbie. :slight_smile:

^ this :slight_smile:

1 Like

I got following error when removing that package...
removing auto-cpufreq-git breaks dependency 'auto-cpufreq-git' required by performance-tweaks

and Removing Performance-tweaks gives following error

removing performance-tweaks breaks dependency 'performance-tweaks' required by garuda-common-settings

Looks like your system is way too much outdated

So just do this

sudo pacman -Rdd auto-cpufreq-git
sudo pacman -Syu performance-tweaks

Hey. I'm having the same issue (along many others) after just installing Garuda. I've removed auto-cpufreq-git, but now there is another conflicting package: thermald.

Should I repeat the steps, removing thermald and running -Syu performance-tweaks?

Yeah remove the conflicting packages
If you have installed any of following remove them



sudo pacman -Syu performance-tweaks

Thanks for the fast reply. I removed thermald and ran - Syu. It's still going, so I think it's working.

I had many things installed on EndeavourOS. I installed Garuda and kept the Home partition in hopes of not losing my settings and apps. Maybe that's my issue? I don't have any apps or settings intact though, which sucks. All my data is still there, so it's not the end of the world. Just gotta set up everything again, including my qemu, plex, lidarr, sonarr...etc.:sweat_smile:

So far I'm liking Garuda. Feels good to start fresh.


Hi. I think you and me have the same problems. Maybe because we updating from very older .iso (for me is from "Imperial Eagle")

My problems is solved with :

sudo pacman -Rdd auto-cpufreq-git and sudo pacman -Rdd thermald

After that I full update to "Hawk Eagle" and all is run well without problem. Good luck :smiley:


Yes, I think! SO even I have downloaded the fresh iso and reinstalled the distro. It's running fine now. Though I have network issues for which I have opened a new topic.

Thanks All!


Yeah, my issues solved by removing the conflicting packages. So far the experience has been relatively pain-free.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.