Partition manager not loading from Garuda Welcome (No Icon either)

Where should we report possible issues?
BOP KDE.
Partition manager not loading from Garuda Welcome (No Icon either)

KDE Partition Manger loads just fine from Start menu.

System:
  Kernel: 6.8.9-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1 clocksource: tsc
    avail: acpi_pm parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=0eb11c94-d361-4490-9a56-8399da90c616 rw rootflags=subvol=@ quiet loglevel=3 ibt=off
  Desktop: KDE Plasma v: 6.0.4 tk: Qt v: N/A info: frameworks v: 6.1.0 wm: kwin_wayland vt: 1
    dm: SDDM Distro: Garuda base: Arch Linux
Machine:
  Type: Convertible System: SAMSUNG product: 950QDB v: P11AKG serial: <superuser required> Chassis:
    type: 31 serial: <superuser required>
  Mobo: SAMSUNG model: NP950QDB-KB3US v: SGLB153A0D-C01-G001-S0001+10.0.22000
    serial: <superuser required> part-nu: SCAI-A5A5-A5A5-TGL3-PAKG uuid: <superuser required>
    UEFI: American Megatrends LLC. v: P11AKG.027.231017.MK date: 10/17/2023
Battery:
  ID-1: BAT1 charge: 63.1 Wh (100.0%) condition: 63.1/66.8 Wh (94.5%) volts: 17.2 min: 15.4
    model: SAMSUNG Electronics SR Real Battery type: Li-ion serial: <filter> status: full cycles: 164
CPU:
  Info: model: 11th Gen Intel Core i7-1165G7 bits: 64 type: MT MCP arch: Tiger Lake gen: core 11
    level: v4 note: check built: 2020 process: Intel 10nm family: 6 model-id: 0x8C (140) stepping: 1
    microcode: 0xB6
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache: L1: 320 KiB
    desc: d-4x48 KiB; i-4x32 KiB L2: 5 MiB desc: 4x1.2 MiB L3: 12 MiB desc: 1x12 MiB
  Speed (MHz): avg: 551 high: 1612 min/max: 400/4700 scaling: driver: intel_pstate
    governor: performance cores: 1: 1612 2: 400 3: 400 4: 400 5: 400 6: 400 7: 400 8: 400
    bogomips: 44851
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities: <filter>
Graphics:
  Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] vendor: Samsung Co driver: i915 v: kernel
    alternate: xe arch: Gen-12.1 process: Intel 10nm built: 2020-21 ports: active: eDP-1 empty: DP-1,
    DP-2, DP-3, DP-4, DP-5 bus-ID: 00:02.0 chip-ID: 8086:9a49 class-ID: 0300
  Device-2: Generic 720p HD Camera driver: uvcvideo type: USB rev: 2.0 speed: 480 Mb/s lanes: 1
    mode: 2.0 bus-ID: 3-6:6 chip-ID: 2b7e:0171 class-ID: fe01 serial: <filter>
  Display: wayland server: X.org v: 1.21.1.13 with: Xwayland v: 23.2.6 compositor: kwin_wayland
    driver: X: loaded: modesetting alternate: fbdev,intel,vesa dri: iris gpu: i915 display-ID: 0
  Monitor-1: eDP-1 res: 1536x864 size: N/A modes: N/A
  API: EGL v: 1.5 hw: drv: intel iris platforms: device: 0 drv: iris device: 1 drv: swrast
    surfaceless: drv: iris wayland: drv: iris x11: drv: iris inactive: gbm
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 24.0.6-arch1.2 glx-v: 1.4
    direct-render: yes renderer: Mesa Intel Xe Graphics (TGL GT2) device-ID: 8086:9a49
    memory: 14.94 GiB unified: yes display-ID: :1.0
  API: Vulkan v: 1.3.279 layers: 9 device: 0 type: integrated-gpu name: Intel Xe Graphics (TGL
    GT2) driver: mesa intel v: 24.0.6-arch1.2 device-ID: 8086:9a49 surfaces: xcb,xlib,wayland
    device: 1 type: cpu name: llvmpipe (LLVM 17.0.6 256 bits) driver: mesa llvmpipe
    v: 24.0.6-arch1.2 (LLVM 17.0.6) device-ID: 10005:0000 surfaces: xcb,xlib,wayland
Audio:
  Device-1: Intel Tiger Lake-LP Smart Sound Audio vendor: Samsung Co
    driver: sof-audio-pci-intel-tgl alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 00:1f.3
    chip-ID: 8086:a0c8 class-ID: 0401
  API: ALSA v: k6.8.9-zen1-1-zen status: kernel-api with: aoss type: oss-emulator tools: N/A
  Server-1: PipeWire v: 1.0.5 status: active with: 1: pipewire-pulse status: active
    2: wireplumber status: active 3: pipewire-alsa type: plugin 4: pw-jack type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
Network:
  Device-1: Intel Wi-Fi 6E AX210/AX1675 2x2 [Typhoon Peak] driver: iwlwifi v: kernel pcie: gen: 2
    speed: 5 GT/s lanes: 1 bus-ID: 2d:00.0 chip-ID: 8086:2725 class-ID: 0280
  IF: wlp45s0 state: up mac: <filter>
  Info: services: NetworkManager, smbd, systemd-timesyncd, wpa_supplicant
Bluetooth:
  Device-1: Intel AX210 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0 speed: 12 Mb/s lanes: 1
    mode: 1.1 bus-ID: 3-10:8 chip-ID: 80
87:0032 class-ID: e001
  Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 5.3 lmp-v: 12 status:
    discoverable: no pairing: no class-ID: 6c0000
Drives:
  Local Storage: total: 3.44 TiB used: 15.3 GiB (0.4%)
  ID-1: /dev/mmcblk0 maj-min: 179:0 model: SN512 size: 476.71 GiB block-size: physical: 512 B
    logical: 512 B type: USB tech: SSD serial: <filter> scheme: MBR
  SMART Message: Unknown smartctl error. Unable to generate data.
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-2: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 970 EVO Plus 2TB size: 1.82 TiB
    block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
    fw-rev: 2B2QEXM7 temp: 41.9 C scheme: GPT
  ID-3: /dev/nvme1n1 maj-min: 259:2 vendor: Samsung model: MZVLQ1T0HBLB-00B size: 953.87 GiB
    block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
    fw-rev: FXM7AK1Q temp: 34.9 C scheme: GPT
  ID-4: /dev/sda maj-min: 8:0 vendor: SanDisk model: USB 3.2Gen1 size: 232.88 GiB block-size:
    physical: 512 B logical: 512 B type: USB rev: 3.2 spd: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1
    tech: N/A serial: <filter> fw-rev: 1.00 scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
  ID-1: / raw-size: 1.82 TiB size: 1.82 TiB (100.00%) used: 15.25 GiB (0.8%) fs: btrfs
    dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%) used: 46.9 MiB (18.3%) fs: vfat
    dev: /dev/nvme1n1p1 maj-min: 259:3
  ID-3: /home raw-size: 1.82 TiB size: 1.82 TiB (100.00%) used: 15.25 GiB (0.8%) fs: btrfs
    dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-4: /var/log raw-size: 1.82 TiB size: 1.82 TiB (100.00%) used: 15.25 GiB (0.8%) fs: btrfs
    dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-5: /var/tmp raw-size: 1.82 TiB size: 1.82 TiB (100.00%) used: 15.25 GiB (0.8%) fs: btrfs
    dev: /dev/nvme0n1p1 maj-min: 259:1
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: zram size: 15.3 GiB used: 0 KiB (0.0%) priority: 100 comp: zstd
    avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 8 dev: /dev/zram0
Sensors:
  Src: /sys System Temperatures: cpu: 48.0 C mobo: N/A
  Fan Speeds (rpm): N/A
  Power: 12v: N/A 5v: 5 3.3v: N/A vbat: N/A
Info:
  Memory: total: 16 GiB note: est. available: 15.3 GiB used: 4.39 GiB (28.7%)
  Processes: 334 Power: uptime: 11h 33m states: freeze,mem,disk suspend: s2idle avail: deep
    wakeups: 1 hibernate: platform avail: shutdown, reboot, suspend, test_resume image: 6.11 GiB
    services: org_kde_powerdevil, power-profiles-daemon, upowerd Init: systemd v: 255
    default: graphical tool: systemctl
  Packages: pm: pacman pkgs: 1956 libs: 577 tools: octopi,paru Compilers: clang: 17.0.6
    gcc: 13.2.1 Client: shell wrapper v: 5.2.26-release inxi: 3.3.34
Garuda (2.6.26-1):
  System install date:     2024-05-06
  Last full system update: 2024-05-07 ↻
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut
  Windows dual boot:       Probably (Run as root to verify)
  Failed units:            

The picture show not the standard color and icons from KDE Plasma dragonized :slight_smile: , but it works fine for me on i3wm, I test later KDE.

1 Like

Is displayed correctly for me (garuda-dr460nized).

But I can confirm that partitionmanager does not start from the GUI.
Journalctl / manual starting from terminal:

/usr/lib/garuda/pkexec-gui partitionmanager
kf.dbusaddons: DBus session bus not found. To circumvent this problem try the following command (with bash):
export $(dbus-launch)
1 Like

and works here too. :slight_smile:

pacman -Qi gparted
Name                     : gparted
Version                  : 1.6.0-1
partitionmanager

works too

At least

/usr/lib/garuda/pkexec-gui partitionmanager
Error executing command as another user: Not authorized

This incident has been reported.

Seems it works only one time :thinking:

Maybe the developer has a solution for this? @TNE

2 Likes

I did not have gparted installed for some reason. Just installed BOP last night.

I installed via pacman, icon appeared, when I click on it it asks for password but does not load.

I can start gparted from menu, enter password, and starts. Will restart system to see if issue resolves and update later.

sudo pacman -Syu gparted

pacman -Qi gparted
Name            : gparted
Version         : 1.6.0-1

1 Like

Just for fun, try

partitionmanager

in terminal

2 Likes

Works fine from Terminal as it does from start window.

I reinstalled Garuda-welcome still asks for password then returns to Garuda-Windows.

I also re-installed partitionmanager.
Doesn’t start from welcome, as I said there is a password screen then returns to welcome

Is there an log file for garuda welcome

This isn’t a issue for me, Just pointing out something odd.

after reinstall with sudo pacman -S garuda-welcome the version is soaring. Is soaring that the correct version of Garuda Welcome to use with BOP

This is the image of the password screen I get with the details

I noticed the logs

May 07 12:03:13 CompName sudo[19517]: UserName : a password is required ; TTY=pts/3 ; PWD=/home/UserName ; USER=root ; COMMAND=/usr/bin/true
May 07 12:04:18 CompName partitionmanager[21718]: kf.dbusaddons: DBus session bus not found. To circumvent this problem try the following command (with bash):
                                                      export $(dbus-launch)

I tried bash export $(dbus-launch got no reply, Tried Garuda-welcome>Partition manger, same thing, password window then returns to Garuda-welcome. I changed the computer name and user name for privacy.

Not sure if that helps in anyway.

I guess if no one else has an issue you can close this because i don’t need that to work.

Correct, this is GF computer she changed the themes, I was just testing everything on the new version. Let me know if you want me to try anything else if not I will push this issue to null.

That’s fine :slight_smile:
Remember that our mods, developers, and maintainers do everything in their spare time.
The developer is informed. Please be patient.
Only rarely does a new installation repair the existing error, rather it helps to delete the configuration files in ~/ (save beforehand).

I was able to reproduce the problem under KDE.

2 Likes

If KDE Partition Manager is installed it will still try to run that. It only runs GParted if it does not find the partitionmanager binary due to the way they are ordered in this if statement:

Can you try like this:

  • Install gparted
  • Uninstall partitionmanager
  • Click the icon in Garuda Welcome and see if GParted launches.

That may tell us if the issue is specifically related to something which has changed in KDE Partition Manager, or something else.

3 Likes

I am very sorry if I came across impatient. I was just testing things and noticed it didn’t work. Just wanted to report it somewhere. I wanted to try to provide as much information as possible, I learn that way too.

Honestly I was more concerned that I would get busy and forget about this and might not check back for a while.

After install KDE partition was installed Gparted was not. I installed Gparted but never uninstalled KDE Partition. Both work fine from terminal and the app menu. I will try the suggestion later and try to report back

1 Like

I had previously installed gparted
Gparted loaded correctly from welcome menue after uninstalling KDE partionmanager

Since I prefer Gparted this seems like a win.

3 Likes

Nice one, thanks for testing that. It sounds like something changed with KDE Partition Manager and it needs something from the environment that it is not getting from the pkexec tool. :face_with_monocle:

4 Likes

The partition manager is not supposed to be visible in Garuda assistant once installed so you don’t accidentally install again. Its in the menu if required.

Seems logical. But when I test things if its there I click it. lol

1 Like

No, it is supposed to be there and it is supposed to work when you click on it. Perhaps he is thinking of the installer, which should only appear when booted to the live environment.

2 Likes

Its in the Garuda welcome app
Sorry i thought it was in the Garuda assistant app

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.