Pamac workaround - no fix?

And, oh Gawd! The parallel downloads is enough to make me cream my jeans! I'm about to give up streaming in 1080p on this desktop to install a vanilla Arch on it just for that factor alone. Gawd, I'm so easily amused! LOLOLOL! :smiley:

8 Likes

Believe me, the first time I launched an update with the parallel download I looked at the screen like a child at a candy counter :child:

7 Likes

I understand....I keep wanting more/bigger downloads so I can marvel at how fast it goes. :slight_smile: Updates always did make me happy anyway.

6 Likes

We should give powerpill a proper burial :sneezing_face:

2 Likes

i' may try this but syu from terms not that hard and then reboot:)
for now is ok:)
how hard would it be to make synaptic for archlinux?
cause i still love GUI clues for updates etc.

That is a really good thing. It will make life easier, because the job of powerpill is done by pacman itself. We are getting modern.

5 Likes

Recently I discovered that my processor was frucked and it led to random hard freezing with no indication of what is the problem, and system breaking during updates for example. (I discovered in mem testing, hard freeze, and it was showing 99 degrees).

So I started fresh, new processor, new system (17th time but this time to last), and..... Garuda Assistant thing not working. I can install anything I want with yay and system update with pacman -Syu but I don't like Garuda Welcome not working.

I don't care about the Software Manager, but I'd like the comfort of the Garuda Assistant thing with all it's features.

I hope this really is related and not some problem with my installation?

I just did an Arch + Plasma install via archfi and got goose pimples watching the progress bars :pause_button::pause_button: :pause_button:.

It was worth it. :wink:

4 Likes

Yes please do this !!!! :slight_smile:

Times where security-fixes become more and more important to have them as soon as possible.

Tested it is still not working because the link libalpm.so.12.0.2 to libalpm.so.12 is missing.

Well, it turned out that rebuilding Pamac with this as dependency is impossible (well, without hacks at least) right now as it wants to build against libalpm13. What you can do however is installing the package manually, its in our repo.

2 Likes

Yes this worked for me but only after some manual smoothing...

First I was told this:

error: failed to commit transaction (conflicting files)
libalpm12: /usr/lib/libalpm.so.12 exists in filesystem
Errors occurred, no packages were upgraded.

So I had to

$ sudo mv /usr/lib/libalpm.so.12 /usr/lib/libalpm.so.12.orig

And then

$ sudo pacman -S chaotic-aur/libalpm12

And after that everything worked again.

Is that because you put that file in place manually?

Just in case, I've added a conflicts=(pacman<6.0) to avoid people installing this when the have pacman 5.2.2 installed.

2 Likes

The best PAMAC workaround is patience.

8 Likes

Day after day I believe that I get a little dumber with age, what are you taking to make yourself smarter and smarter day after day?
Second thought, don't answer that. :face_with_hand_over_mouth:

1 Like

Now it would really be the time for a "Keep calm and ..." meme customized for this case... :slight_smile:

3 Likes

I also got an idea!

Isn't such cases that unified packaging was invented for? :wink:

Snap, flatpak, appimage

Where are they when you need them? :laughing:

2 Likes

Pamac as a Snap would be pretty amusing... :rofl:

5 Likes

Wouldn't it work anyway?

1 Like