Paleofetch error on terminal start, only with AMD znver2 kernel

I try some different kernels .. on ever kernel i open terminal (zsh) paleofetch shows on Top . what i really like . But only on AMD znver2 kernel when i start terminal i got error msg : paleofetch: unable to retrieve login name
after that if i type paleofetch i starts without error

> โฏ paleofetch
>                      .%;888:8898898:              [email protected]
>                    x;XxXB%89b8:b8%b88:            -----------------------
>                 .8Xxd                8X:.         OS: Garuda Linux x86_64
>               .8Xx;                    8x:.       Kernel: 5.10.11-AMD-znver2
>             .tt8x          .d            x88;     Uptime: 1 min
>          [email protected];          .db:              [email protected];   
>        ,tSXXยฐ          [email protected];  Packages: 2315 (pacman)
>      .SXxx            bBBBBBBBBBBBBBBBBBBBbSBX8;  Shell: zsh
>    ,888S                                     pd!  Resolution: 3840x2160
>   8X88/                                       q   Terminal: konsole
>   GBB.                                            
>    x%88        [email protected]@[email protected]@[email protected]@[email protected]@[email protected]@X.        CPU: AMD Ryzen 9 3900X 12- Processor (24) @ 4.0GHz
>      dxXd    dB8b8b8B8B08bB88b998888b88x.         Memory: 5715MiB / 64231MiB (8%)
>       dxx8o                      [email protected]@;.            
>         dx88                   [email protected]                                      
>           d:[email protected]                                        
>             .d988999889889899dd.                  
> 
> 
> ๏…ผ ๏€• ~ ยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยท at ๏€— 21:36:27
> โฏ~~~

So you must post to znver2 kernel dev's or use another kernel.

i use xanmod Kernel there evrything is fine so not a problem for me :wink: .. i Have only think maybe its a bug from paleofetch bec manualy start is no problem .. only not show direct when open terminal

1 Like

Ah, seems paleofetch is not as quick as everybody think :wink:

Maybe place

## Run paleofetch if session is interactive
if status --is-interactive
   paleofetch
end

at the start from config.fish ?

1 Like

i still have zsh ... i try to add on .zshrc for test but it gives me error .
/home/smoky/.zshrc:7: parse error near end'`

# Enable Powerlevel10k instant prompt. Should stay close to the top of ~/.zshrc.
# Initialization code that may require console input (password prompts, [y/n]
# confirmations, etc.) must go above this block; everything else may go below.
## Run paleofetch if session is interactive
if status --is-interactive
   paleofetch
end
if [[ -r "${XDG_CACHE_HOME:-$HOME/.cache}/p10k-instant-prompt-${(%):-%n}.zsh" ]]; then
  source "${XDG_CACHE_HOME:-$HOME/.cache}/p10k-instant-prompt-${(%):-%n}.zsh"
fi

# If you come from bash you might have to change your $PATH.
# export PATH=$HOME/bin:/usr/local/bin:$PATH

Maybe there is a BOM(B) @SGS :laughing:

3 Likes

There was one indeed but this has been fixed yesterday. Try taking the zshrc from /etc/skel after updating

2 Likes

i update it ..
i try copy from skel . still same
then i try from garuda assistant -- Apply new configs
Still same ..
and if i add the line from SGS same error as b4
maybee its a kernel problem bec on 4 different kernels no problem only on this amd znver2

2 Likes

Post the exact error from terminal, please.

2 Likes

paleofetch: unable to retrieve login name

paleofetch: unable to retrieve login name
~ ยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยท at 12:38:52
โฏ 
1 Like

Try this

paleofetch --recache

and check again.
Idea from paleofetch open issue.

1 Like

Actually there is a desktop item which does this on logon, not sure if @smoky has it already though

1 Like

Which means...? :exploding_head:

1 Like
[Desktop Entry]
Categories=System;Monitor;
Comment=Recaches static paleofetch values
Exec=paleofetch --recache
Icon=system-upgrade
Name=Paleofetch recache
StartupNotify=false
Terminal=false
Type=Application

That was unclear, a .desktop autostart :smiley:

2 Likes

yes i have that autostart aktiv ?
if i type

paleofetch --recache

it Starts . but on next start its same paleofetch: unable to retrieve login name

What start? Terminal, session, reboot?

Terminal start .

now i have get a new update on pamac for zsh config .. i copyed from skel .. now when i start terminal

/home/smoky/.zshrc:189: parse error near `end'

~ 
โฏ 

in config this the last part line 189 is end

Run paleofetch if session is interactive

if status --is-interactive
paleofetch
end

1 Like

Is away but

/home/sgs/.zshrc:282: parse error near `end'

is up. I try since yesterday to find why, if without fi, maybe end is ok but not in zsh?
I'm not a programmer :smiley:

3 Likes

I am not sure, but try this and see what it finds

grep -c  '[^[:print:]]' /home/sgs/.zshrc
โฏ grep -c  '[^[:print:]]' /home/sgs/.zshrc
1