Pacman & alternatives wants to update to git versions

pacman, pamac, pamac-manager, yay :
wants to upgrade to git versions of packages

me :
I don't want git updates, I just want normal updates.
Maybe this is a normal behavior ?

# inxi -Faz
[https://termbin.com/d4jg]

System:    Kernel: 5.15.5-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=58e0aa23-7e3b-4062-99c3-df4495cea5e1 rw
           [email protected] loglevel=3 quiet libahci.ignore_sss=1 systemd.unified_cgroup_hierarchy=1 iommu=pt
           pcie_aspm=force delayacct
           Desktop: KDE Plasma 5.23.3 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux
           base: Arch Linux
Machine:   Type: Desktop System: Gigabyte product: N/A v: N/A serial: <superuser required> Chassis: type: 3
           serial: <superuser required>
           Mobo: Gigabyte model: GA-990X-Gaming SLI-CF v: x.x serial: <superuser required> UEFI: American Megatrends v: F1
           date: 01/28/2016
CPU:       Info: 8-Core model: AMD FX-8370E bits: 64 type: MCP arch: Bulldozer family: 15 (21) model-id: 2 stepping: 0
           microcode: 6000852 cache: L1: 640 KiB L2: 16 MiB L3: 8 MiB
           flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 61273
           Speed: 3076 MHz min/max: 1400/3700 MHz boost: enabled Core speeds (MHz): 1: 3076 2: 3870 3: 3122 4: 3647 5: 3228
           6: 3483 7: 3743 8: 3998
           Vulnerabilities: Type: itlb_multihit status: Not affected
           Type: l1tf status: Not affected
           Type: mds status: Not affected
           Type: meltdown status: Not affected
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
           Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: disabled, RSB filling
           Type: srbds status: Not affected
           Type: tsx_async_abort status: Not affected
Graphics:  Device-1: NVIDIA GP104 [GeForce GTX 1070 Ti] vendor: Micro-Star MSI driver: nvidia v: 495.44
           alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:1b82 class-ID: 0300
           Display: x11 server: X.Org 1.21.1.1 compositor: kwin_x11 driver: loaded: nvidia display-ID: :0 screens: 1
           Screen-1: 0 s-res: 1920x2100 s-dpi: 75 s-size: 650x711mm (25.6x28.0") s-diag: 963mm (37.9")
           Monitor-1: DVI-D-0 res: 1440x900 hz: 60 dpi: 64 size: 575x323mm (22.6x12.7") diag: 660mm (26")
           Monitor-2: HDMI-0 res: 1920x1200 hz: 60 dpi: 89 size: 550x344mm (21.7x13.5") diag: 649mm (25.5")
           OpenGL: renderer: NVIDIA GeForce GTX 1070 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 495.44 direct render: Yes
Audio:     Device-1: NVIDIA GP104 High Definition Audio vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus-ID: 01:00.1
           chip-ID: 10de:10f0 class-ID: 0403
           Device-2: Creative Labs EMU10k2/CA0100/CA0102/CA10200 [Sound Blaster Audigy Series] driver: snd_emu10k1 v: kernel
           bus-ID: 04:07.0 chip-ID: 1102:0004 class-ID: 0401
           Sound Server-1: ALSA v: k5.15.5-zen1-1-zen running: yes
           Sound Server-2: JACK v: 1.9.19 running: no
           Sound Server-3: PulseAudio v: 15.0 running: no
           Sound Server-4: PipeWire v: 0.3.40 running: yes
Network:   Device-1: Ralink RT2561/RT61 802.11g PCI vendor: Hercules driver: rt61pci v: 2.3.0 bus-ID: 04:06.0
           chip-ID: 1814:0301 class-ID: 0280
           IF: wlan0 state: down mac: <filter>
           Device-2: Intel I211 Gigabit Network vendor: Gigabyte driver: igb v: kernel port: b000 bus-ID: 07:00.0
           chip-ID: 8086:1539 class-ID: 0200
           IF: enp7s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Bluetooth: Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) type: USB driver: btusb v: 0.8 bus-ID: 5-1:2
           chip-ID: 0a12:0001 class-ID: e001
           Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: N/A
Drives:    Local Storage: total: 6.5 TiB used: 5.48 TiB (84.4%)
           SMART Message: Unable to run smartctl. Root privileges required.
           ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: PNY model: CS3030 1TB SSD size: 931.51 GiB block-size: physical: 512 B
           logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: CS303123 temp: 35.9 C scheme: GPT
           ID-2: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 850 EVO 250GB size: 232.89 GiB block-size: physical: 512 B
           logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 1B6Q scheme: GPT
           ID-3: /dev/sdb maj-min: 8:16 vendor: Samsung model: SSD 860 EVO 250GB size: 232.89 GiB block-size: physical: 512 B
           logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 1B6Q scheme: GPT
           ID-4: /dev/sdc maj-min: 8:32 vendor: Western Digital model: WD7500AAVS-00D7B1 size: 698.64 GiB block-size:
           physical: 512 B logical: 512 B speed: 3.0 Gb/s type: N/A serial: <filter> rev: 1A01 scheme: MBR
           ID-5: /dev/sdd maj-min: 8:48 vendor: Seagate model: ST1000DM003-1ER162 size: 931.51 GiB block-size:
           physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter> rev: CC45 scheme: GPT
           ID-6: /dev/sde maj-min: 8:64 vendor: Seagate model: ST2000DM001-1ER164 size: 1.82 TiB block-size: physical: 4096 B
           logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter> rev: CC25 scheme: GPT
           ID-7: /dev/sdf maj-min: 8:80 vendor: Western Digital model: WD2500JS-55NCB1 size: 232.89 GiB block-size:
           physical: 512 B logical: 512 B speed: 6.0 Gb/s type: N/A serial: <filter> rev: 2E01 scheme: MBR
           ID-8: /dev/sdg maj-min: 8:96 vendor: Western Digital model: WD6402AAEX-00Z3A0 size: 596.17 GiB block-size:
           physical: 512 B logical: 512 B speed: 6.0 Gb/s type: N/A serial: <filter> rev: 1D05 scheme: MBR
           ID-9: /dev/sdh maj-min: 8:112 type: USB vendor: Toshiba model: MQ04UBF100 size: 931.51 GiB block-size:
           physical: 512 B logical: 512 B type: HDD rpm: 5400 serial: <filter> scheme: MBR
Partition: ID-1: / raw-size: 232.59 GiB size: 232.59 GiB (100.00%) used: 175.91 GiB (75.6%) fs: btrfs dev: /dev/sda2
           maj-min: 8:2
           ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 564 KiB (0.2%) fs: vfat dev: /dev/sda1
           maj-min: 8:1
           ID-3: /home raw-size: 232.59 GiB size: 232.59 GiB (100.00%) used: 175.91 GiB (75.6%) fs: btrfs dev: /dev/sda2
           maj-min: 8:2
           ID-4: /var/log raw-size: 232.59 GiB size: 232.59 GiB (100.00%) used: 175.91 GiB (75.6%) fs: btrfs dev: /dev/sda2
           maj-min: 8:2
           ID-5: /var/tmp raw-size: 232.59 GiB size: 232.59 GiB (100.00%) used: 175.91 GiB (75.6%) fs: btrfs dev: /dev/sda2
           maj-min: 8:2
Swap:      Kernel: swappiness: 10 (default 60) cache-pressure: 100 (default)
           ID-1: swap-1 type: partition size: 100.47 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/nvme0n1p4 maj-min: 259:4
           ID-2: swap-2 type: zram size: 23.44 GiB used: 10.4 MiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 47.0 C mobo: 36.0 C gpu: nvidia temp: 59 C
           Fan Speeds (RPM): cpu: 870 fan-2: 0 fan-3: 722 fan-4: 494 fan-5: 0 gpu: nvidia fan: 0%
           Power: 12v: N/A 5v: N/A 3.3v: N/A vbat: 3.05
Info:      Processes: 387 Uptime: 22h 23m wakeups: 2 Memory: 23.44 GiB used: 7.54 GiB (32.2%) Init: systemd v: 249
           tool: systemctl Compilers: gcc: 11.1.0 clang: 13.0.0 Packages: note: see --pkg pacman: 2106 lib: 428 Shell: fish
           v: 3.3.1 running-in: konsole inxi: 3.3.09
***# sudo pamac update --no-aur***
Warning: removing 'syndication' from target list because it conflicts with 'syndication-git'
Warning: removing 'knewstuff' from target list because it conflicts with 'knewstuff-git'
Warning: removing 'kio' from target list because it conflicts with 'kio-git'
Warning: removing 'solid' from target list because it conflicts with 'solid-git'
Warning: removing 'kjobwidgets' from target list because it conflicts with 'kjobwidgets-git'
Warning: removing 'kcoreaddons' from target list because it conflicts with 'kcoreaddons-git'
Warning: removing 'kwidgetsaddons' from target list because it conflicts with 'kwidgetsaddons-git'
Warning: removing 'kbookmarks' from target list because it conflicts with 'kbookmarks-git'
Warning: removing 'kxmlgui' from target list because it conflicts with 'kxmlgui-git'
Warning: removing 'kglobalaccel' from target list because it conflicts with 'kglobalaccel-git'
Warning: removing 'kdbusaddons' from target list because it conflicts with 'kdbusaddons-git'
Warning: removing 'kconfig' from target list because it conflicts with 'kconfig-git'
Warning: removing 'kcrash' from target list because it conflicts with 'kcrash-git'
Warning: removing 'kwindowsystem' from target list because it conflicts with 'kwindowsystem-git'
Warning: removing 'kiconthemes' from target list because it conflicts with 'kiconthemes-git'
Warning: removing 'kconfigwidgets' from target list because it conflicts with 'kconfigwidgets-git'
Warning: removing 'kauth' from target list because it conflicts with 'kauth-git'
Warning: removing 'kcodecs' from target list because it conflicts with 'kcodecs-git'
Warning: removing 'kguiaddons' from target list because it conflicts with 'kguiaddons-git'
Warning: removing 'ki18n' from target list because it conflicts with 'ki18n-git'
Warning: removing 'kitemviews' from target list because it conflicts with 'kitemviews-git'
Warning: removing 'karchive' from target list because it conflicts with 'karchive-git'
Warning: removing 'attica' from target list because it conflicts with 'attica-git'
Warning: removing 'kwallet' from target list because it conflicts with 'kwallet-git'
Warning: removing 'knotifications' from target list because it conflicts with 'knotifications-git'
Warning: removing 'kservice' from target list because it conflicts with 'kservice-git'
Warning: removing 'ktextwidgets' from target list because it conflicts with 'ktextwidgets-git'
Warning: removing 'kcompletion' from target list because it conflicts with 'kcompletion-git'
Warning: removing 'sonnet' from target list because it conflicts with 'sonnet-git'
Warning: removing 'kded' from target list because it conflicts with 'kded-git'
Warning: removing 'kpackage' from target list because it conflicts with 'kpackage-git'
Warning: removing 'kio-extras' from target list because it conflicts with 'kio-extras-git'
Warning: removing 'kdnssd' from target list because it conflicts with 'kdnssd-git'
Warning: removing 'syntax-highlighting' from target list because it conflicts with 'syntax-highlighting-git'
Warning: removing 'kcmutils' from target list because it conflicts with 'kcmutils-git'
Warning: removing 'kdeclarative' from target list because it conflicts with 'kdeclarative-git'
Warning: removing 'kparts' from target list because it conflicts with 'kparts-git'
Warning: removing 'kactivities' from target list because it conflicts with 'kactivities-git'

Please read

Then install Arch or something where you can hand-pick everything that goes into making it so.

It is for Garuda. This isn't your grandad's distro. :wink:

EDIT: Thanks for reading and applying the posting rules. And welcome back. :slight_smile:

3 Likes

That was me, formatted it, with the request to devote to the link.
In all the work I forgot to put my name under it. :frowning:

:slight_smile:

3 Likes

If you have git versions installed then it will update to those versions.

Provide the full output of

sudo pacman -Syu

(as text)

5 Likes

Hmmm, I wonder if this may have originated from one of the earlier Garuda installations where -git packages were more prevalent. This would be prior to the Garuda developers decision to go with a minimal amount of -git?

Unless they were explicitly replaced with non-git pkgs by Nico or whomever? And the kernel AFAIK (not in Garuda at the moment) seems a bit out of date (current is linux-zen 5.15.11.zen1-1).

???

1 Like

These days no git versions of Plasma/KDE are used. It might be possible that OP has either dolphin-git, kate-git, konsole-git or kdenlive-git installed? These were switched to -git dependencies lately for consistency in order of our efforts to get the KDE-git edition rolling :eyes:

4 Likes

I had a case recently where I tried to install kdeconnect-git recently and it wanted to bring in a bunch of other git packages. I believe this happened because it was a version that had been modified for use in the Chaotic AUR (with extra git dependencies). So this issue can crop up occasionally.

4 Likes

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.