Packages corrupt and unknown trust

This is a common problem and has been asked allot. I have this error when I do a garuda-update

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
 chaotic-keyring-20220803-1-any downloading...
checking keyring...
checking package integrity...
error: chaotic-keyring: signature from "Nico Jensch (Chaotic-AUR) <[email protected]>" is unknown trust
:: File /var/cache/pacman/pkg/chaotic-keyring-20220803-1-any.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] error: failed to commit transaction (invalid or corrupted package (PGP signature))

Errors occurred, no packages were upgraded.

What I have tried to do is

sudo pacman -Sy archlinux-keyring chaotic-keyring
garuda-update remote keyring
sudo pacman-key --refresh-keys
sudo pacman -U '' ''

Aditionaly I used the garuda assistant to refresh keyrings and I am unable to update my system. This seemed to have happened in the past few days as previously I was only using the pamac utility to upgrade my system and it was successful for the past week or so. Its only in the past day or so that I started having failures. Only other system changes was installing steam games. Not sure how to solve this keyring problem. Any guidance would be appreciated. See my garuda-inxi here:

  Kernel: 6.3.5-zen2-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.1.1
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=dcbd50b9-1e83-4eb3-9da5-43e6e7fb35bb rw rootflags=subvol=@
    quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    resume=UUID=ec4cbef9-6a00-4c35-be6f-587f055fd4dd loglevel=3 ibt=off
  Desktop: GNOME v: 44.2 tk: GTK v: 3.24.38 wm: gnome-shell dm: GDM v: 44.1
    Distro: Garuda Linux base: Arch Linux
  Type: Desktop System: Gigabyte product: Z690 UD AX DDR4 v: N/A
    serial: <superuser required>
  Mobo: Gigabyte model: Z690 UD AX DDR4 v: x.x serial: <superuser required>
    UEFI: American Megatrends LLC. v: F7 date: 08/08/2022
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse MWireless M
    serial: N/A charge: 100% (should be ignored) rechargeable: yes
    status: discharging
  Info: model: 13th Gen Intel Core i5-13600K bits: 64 type: MST AMCP
    arch: Raptor Lake gen: core 13 level: v3 note: check built: 2022+
    process: Intel 7 (10nm) family: 6 model-id: 0xB7 (183) stepping: 1
    microcode: 0x113
  Topology: cpus: 1x cores: 14 mt: 6 tpc: 2 st: 8 threads: 20 smt: enabled
    cache: L1: 1.7 MiB desc: d-8x32 KiB, 12x48 KiB; i-12x32 KiB, 8x64 KiB
    L2: 56 MiB desc: 12x2 MiB, 8x4 MiB L3: 480 MiB desc: 20x24 MiB
  Speed (MHz): avg: 3304 high: 5111 min/max: 800/5100:3900 scaling:
    driver: intel_pstate governor: powersave cores: 1: 4908 2: 3401 3: 5111
    4: 3500 5: 800 6: 3500 7: 4823 8: 3500 9: 2003 10: 3500 11: 5100 12: 3500
    13: 798 14: 3345 15: 3500 16: 805 17: 3500 18: 3500 19: 3500 20: 3500
    bogomips: 139776
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities: <filter>
  Device-1: Intel Raptor Lake-S GT1 [UHD Graphics 770] vendor: Gigabyte
    driver: i915 v: kernel arch: Gen-13 process: Intel 7 (10nm) built: 2022+
    ports: active: none empty: DP-1,HDMI-A-1,HDMI-A-2 bus-ID: 00:02.0
    chip-ID: 8086:a780 class-ID: 0300
  Device-2: AMD Navi 23 [Radeon RX 6600/6600 XT/6600M] vendor: ASUSTeK
    driver: amdgpu v: kernel arch: RDNA-2 code: Navi-2x process: TSMC n7 (7nm)
    built: 2020-22 pcie: gen: 4 speed: 16 GT/s lanes: 16 ports:
    active: HDMI-A-3 empty: DP-2,DP-3,DP-4 bus-ID: 03:00.0 chip-ID: 1002:73ff
    class-ID: 0300
  Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.2
    compositor: gnome-shell driver: X: loaded: amdgpu,modesetting
    unloaded: radeon alternate: fbdev,intel,vesa dri: radeonsi,iris
    gpu: amdgpu display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3840x2160 s-dpi: 96 s-size: 1016x571mm (40.00x22.48")
    s-diag: 1165mm (45.88")
  Monitor-1: HDMI-A-3 mapped: HDMI-A-2 model: Samsung LS32R75
    serial: <filter> built: 2019 res: 3840x2160 hz: 60 dpi: 140 gamma: 1.2
    size: 697x392mm (27.44x15.43") diag: 800mm (31.5") ratio: 16:9 modes:
    max: 3840x2160 min: 720x400
  API: OpenGL v: 4.6 Mesa 23.1.1 renderer: AMD Radeon RX 6600 XT (navi23
    LLVM 15.0.7 DRM 3.52 6.3.5-zen2-1-zen) direct-render: Yes
  Device-1: Intel Alder Lake-S HD Audio vendor: Gigabyte driver: snd_hda_intel
    v: kernel alternate: snd_sof_pci_intel_tgl bus-ID: 00:1f.3
    chip-ID: 8086:7ad0 class-ID: 0403
  Device-2: AMD Navi 21/23 HDMI/DP Audio driver: snd_hda_intel v: kernel
    pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 03:00.1 chip-ID: 1002:ab28
    class-ID: 0403
  API: ALSA v: k6.3.5-zen2-1-zen status: kernel-api tools: N/A
  Server-1: PipeWire v: 0.3.71 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Intel Alder Lake-S PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:7af0 class-ID: 0280
  IF: wlo1 state: down mac: <filter>
  Device-2: Realtek RTL8125 2.5GbE vendor: Gigabyte driver: r8169 v: kernel
    pcie: gen: 2 speed: 5 GT/s lanes: 1 port: 3000 bus-ID: 05:00.0
    chip-ID: 10ec:8125 class-ID: 0200
  IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IF-ID-1: vmnet1 state: unknown speed: N/A duplex: N/A mac: <filter>
  IF-ID-2: vmnet8 state: unknown speed: N/A duplex: N/A mac: <filter>
  Device-1: Intel driver: btusb v: 0.8 type: USB rev: 2.0 speed: 12 Mb/s
    lanes: 1 mode: 1.1 bus-ID: 1-14:9 chip-ID: 8087:0033 class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 5 state: up address: <filter>
  Local Storage: total: 3.98 TiB used: 419.52 GiB (10.3%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: BarraCuda 120 SSD
    ZA1000CM10003 size: 931.51 GiB block-size: physical: 512 B logical: 512 B
    speed: 6.0 Gb/s tech: SSD serial: <filter> fw-rev: E014 scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Kingston model: SV300S37A120G
    size: 111.79 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: BBF0 scheme: GPT
  ID-3: /dev/sdc maj-min: 8:32 vendor: Seagate model: ST3000DM008-2DM166
    size: 2.73 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    tech: HDD rpm: 7200 serial: <filter> fw-rev: CC26 scheme: GPT
  ID-4: /dev/sdd maj-min: 8:48 vendor: Samsung model: SSD 850 PRO 256GB
    size: 238.47 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: 3B6Q scheme: GPT
  ID-1: / raw-size: 896.98 GiB size: 896.98 GiB (100.00%)
    used: 419.52 GiB (46.8%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 580 KiB (0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
  ID-3: /home raw-size: 896.98 GiB size: 896.98 GiB (100.00%)
    used: 419.52 GiB (46.8%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-4: /var/log raw-size: 896.98 GiB size: 896.98 GiB (100.00%)
    used: 419.52 GiB (46.8%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-5: /var/tmp raw-size: 896.98 GiB size: 896.98 GiB (100.00%)
    used: 419.52 GiB (46.8%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 31.12 GiB used: 794.9 MiB (2.5%)
    priority: 100 dev: /dev/zram0
  ID-2: swap-2 type: partition size: 34.24 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/sda3 maj-min: 8:3
  System Temperatures: cpu: 31.0 C mobo: N/A gpu: amdgpu temp: 40.0 C
    mem: 38.0 C
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 0
  Processes: 484 Uptime: 8d 6h 34m wakeups: 78 Memory: available: 31.12 GiB
  used: 9.58 GiB (30.8%) Init: systemd v: 253 default: graphical
  tool: systemctl Compilers: gcc: 13.1.1 alt: 12 clang: 15.0.7 Packages:
  pm: dpkg pkgs: 0 pm: pacman pkgs: 1704 libs: 511
  tools: gnome-software,pamac,paru Shell: fish v: 3.6.1 default: Bash
  v: 5.1.16 running-in: gnome-terminal inxi: 3.3.27
Garuda (2.6.16-1):
  System install date:     2023-03-16
  Last full system update: 2023-06-07 ↻
  Is partially upgraded:   Yes
  Relevant software:       snapper NetworkManager mkinitcpio
  Windows dual boot:       Probably (Run as root to verify)
  Failed units:          

System details :

OS: Garuda Linux x86_64
Host: Z690 UD AX DDR4
Kernel: 6.3.5-zen2-1-zen
Uptime: 8 days, 6 hours, 28 mins
Packages: 1704 (pacman)[stable]
Shell: fish 3.6.1
Display: 3840x2160
DE: Gnome 44.2
WM: Mutter (X11)
WM Theme: Adwaita
Theme:  [Plasma], {?}Adwaita [GTK2/3/4]
Icons: Adwaita [GTK2/3/4]
Terminal: gnome-terminal-server 3.48.1
Terminal Font: FiraCode Nerd Font Mono 12
CPU: 13th Gen Intel(R) Core(TM) i5-13600K (20) @ 5.1 GHz
GPU: Intel UHD Graphics 770
GPU: AMD Radeon RX 6600 XT
Memory: 7.74 GiB / 31.12 GiB


Thank you

I came here having the same problem.

error: chaotic-keyring: signature from "Nico Jensch (Chaotic-AUR) [email protected]" is unknown tru
:: File /var/cache/pacman/pkg/chaotic-keyring-20220803-1-any.pkg.tar.zst is corrupted (invalid or corrupted pa
ckage (PGP signature)).

Guess it isn't on my end

1 Like

No good sir , all is well on the land of end-user...just have to wait ever so painfully and patiently for maintainer "Nico" to fix deh "Repo"

Oye, I have nearly thrown my PC out the window today because of this.

I ended up corrupting my efi partition for Win11 and ...well, yeah. I thought there for awhile I was going to just explode.

I don't usually use forums but I was just about to ask the same question. Just a bit more pissed off sounding. It's weird how relieved I was when I first glanced at these post, I knew then I'd have to make an account just to go on this pointless half happy, half mad miniature rant.

1 Like

You can use the search function without creating an account.

The error message has been posted often enough because no one searches for the solution themselves first, as recommended in the template.

Unfortunately, many users only register in the forum when there are problems, not to leave a thank-you for everything that is made available to them free of charge.

We do all this on a voluntary basis in our spare time and thanks to our supporters, who finance this through donations, we can also offer Chaotic-AUR.

As always, ingratitude is the world's reward. :grin:


I see it's still down. What is going on between Garuda and Manjaro? I've never been one for coincidence.

What should Garuda have to do with Manjaro?
Do they also use chaotic-aur in unstable/stable/something?

So far 5 updates have worked for me, now it's time for the next laptop :slight_smile:

Thanks to @dr460nf1r3 :slight_smile:


You learned an important Linux-lesson today on a problem of this type. First:


You’re probably not the only one.
There’s probably a ‘fix’ or will be soon.
If you post your problem, somebody usually wanders by who’s willing to help.


I did search, multiple times hence where I got the commands to try.

I have always appreciated your contribution in actively maintaining the forum and helping people out even though they have been nothing but rude to you. I am in awe of your patience for the users here and admire your dedication in helping people out with your vast experience and knowledge.

You aren’t the only one I admire there are countless people here on forum that I respect and aspire to learn more from. I have always appreciated the work the moderators have put in maintaining this distro and forum. Infact garuda is the only OS on my only system. I hope project garuda never stops flying and also I hope you know that there is a bigger community of people who admire your work and dedication to this project than people who show ingratitude. :smile:


I think you have me confused with someone else. :grin:

But surely I have learned something in the last few years.

I’m still the bad cop here. :wink: go ahead and ask the other moderators.

Omg If @SGS says jump well you jump :smiley: :smiley: :smiley: :smiley:
A really good/bad cop :smiley: :smiley: :smiley:


I am pretty sure I have seen quite a few posts where you asked a newbie to maintain the decorum and follow the template to receive assistance and they have outright started going ballistic on you and started cursing you, yet you have replied to them down the line if you could have helped them.

Well someone has to take that role. But being a bad cop doesn’t mean you are a bad guy. :smile:


I wouldn’t bet on that.


when i see people talk down on garuda on youtube comments for the 'unfriendly community' i always cringe.... what a load of crap.. you guys are helpful just know your realistic limits for the support and amount of time you can assist.

I didn't even see this package signing issue... must have been fixed too quick :slight_smile: thanks for your effort and to the other mods


I love the pissy ones that don't do any work on their own to find answers. Are they expecting to be helped by....


I most totally agree! One thing that needs t o be a considered is the international-nature of the owners, developer/maintainers and–very importantly–the users. Not everyone speaks multiple languages (I don’t), nor can use and understand online translators.

So sometimes replies might be terse (i.e. short, abrupt) which, to me, might indicate the replier is trying to find the right words. Or they’re just assholes.

I prefer the former, although I have never really been sure which category my friend, @SGS, our “bad cop” fell into.

:smiley: :rofl:

Oh, he’s gonna kill me! :slight_smile: