Overwrite OK?

Obligatory inxi - however little relevance it has in this case :grin:

┌06:12:17 WD= [~]
└───freebird@nest ─▶$ inxi -Faz
  Kernel: 6.3.8-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.1.1
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=d7e2905f-a721-4129-8b88-6010754d074d rw rootflags=subvol=@
    splash loglevel=3 nowatchdog ibt=off
  Desktop: Xfce v: 4.18.1 tk: Gtk v: 3.24.36 info: xfce4-panel, plank
    wm: xfwm v: 4.18.0 vt: 7 dm: LightDM v: 1.32.0 Distro: Garuda Linux
    base: Arch Linux
  Type: Desktop Mobo: ASUSTeK model: TUF GAMING X570-PLUS v: Rev X.0x
    serial: <superuser required> UEFI: American Megatrends v: 1407
    date: 04/01/2020
  Info: model: AMD Ryzen 7 3700X bits: 64 type: MT MCP arch: Zen 2 gen: 3
    level: v3 note: check built: 2020-22 process: TSMC n7 (7nm)
    family: 0x17 (23) model-id: 0x71 (113) stepping: 0 microcode: 0x8701013
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
    L3: 32 MiB desc: 2x16 MiB
  Speed (MHz): avg: 3709 high: 4391 min/max: 2200/4426 boost: enabled
    scaling: driver: acpi-cpufreq governor: performance cores: 1: 3630 2: 3731
    3: 4265 4: 4391 5: 3600 6: 3589 7: 3592 8: 3586 9: 3600 10: 3665 11: 3744
    12: 3593 13: 3600 14: 3586 15: 3588 16: 3589 bogomips: 114985
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed mitigation: untrained return thunk; SMT enabled with STIBP
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
    always-on, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
    vendor: Micro-Star MSI driver: amdgpu v: kernel arch: GCN-4
    code: Arctic Islands process: GF 14nm built: 2016-20 pcie: gen: 3
    speed: 8 GT/s lanes: 16 ports: active: DVI-D-1,HDMI-A-2
    empty: DP-1,DP-2,HDMI-A-1 bus-ID: 08:00.0 chip-ID: 1002:67df
    class-ID: 0300 temp: 55.0 C
  Display: x11 server: X.Org v: 21.1.8 compositor: xfwm v: 4.18.0 driver: X:
    loaded: amdgpu unloaded: modesetting alternate: fbdev,vesa dri: radeonsi
    gpu: amdgpu display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 5640x2400 s-dpi: 96 s-size: 1492x635mm (58.74x25.00")
    s-diag: 1622mm (63.84")
  Monitor-1: DVI-D-1 mapped: DVI-D-0 pos: right model: NEC LCD2090UXi
    serial: <filter> built: 2006 res: 1800x2400 hz: 60 dpi: 149 gamma: 1.2
    size: 306x408mm (12.05x16.06") diag: 510mm (20.1") ratio: 4:3 modes:
    max: 1600x1200 min: 720x400
  Monitor-2: HDMI-A-2 mapped: HDMI-A-1 pos: primary,left model: BenQ EL2870U
    serial: <filter> built: 2018 res: 3840x2160 hz: 60 dpi: 157 gamma: 1.2
    size: 621x341mm (24.45x13.43") diag: 708mm (27.9") ratio: 16:9 modes:
    max: 3840x2160 min: 720x400
  API: OpenGL Message: Unable to show GL data. Required tool glxinfo
  Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
    vendor: Micro-Star MSI driver: snd_hda_intel v: kernel pcie: gen: 3
    speed: 8 GT/s lanes: 16 bus-ID: 08:00.1 chip-ID: 1002:aaf0 class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 0a:00.4 chip-ID: 1022:1487 class-ID: 0403
  API: ALSA v: k6.3.8-zen1-1-zen status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off with: a2jmidid status: off
    tools: qjackctl
  Server-2: PipeWire v: 0.3.71 status: off tools: pw-cli
  Server-3: PulseAudio v: 16.1 status: off with: 1: pulseaudio-alsa
    type: plugin 2: pulseaudio-jack type: module tools: pacat,pactl,pavucontrol
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASUSTeK driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: f000 bus-ID: 04:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IF-ID-1: wgpia0 state: unknown speed: N/A duplex: N/A mac: N/A
  Device-1: zdata type: zfs status: ONLINE level: linear raw: size: 2.72 TiB
    free: 1.17 TiB allocated: 1.55 TiB zfs-fs: size: 2.63 TiB free: 1.08 TiB
  Components: Online:
  Local Storage: total: raw: 3.64 TiB usable: 6.27 TiB used: 1.58 TiB (25.2%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Corsair model: Force MP600
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: EGFM11.3 temp: 46.9 C
    scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST3000DM001-1CH166
    size: 2.73 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    tech: HDD rpm: 7200 serial: <filter> fw-rev: CC27 scheme: GPT
  ID-1: / raw-size: 92.07 GiB size: 92.07 GiB (100.00%)
    used: 30.89 GiB (33.6%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
  ID-2: /boot/efi raw-size: 1000 MiB size: 998 MiB (99.80%)
    used: 235.2 MiB (23.6%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 92.07 GiB size: 92.07 GiB (100.00%)
    used: 30.89 GiB (33.6%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
  ID-4: /var/log raw-size: 92.07 GiB size: 92.07 GiB (100.00%)
    used: 30.89 GiB (33.6%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
  ID-5: /var/tmp raw-size: 92.07 GiB size: 92.07 GiB (100.00%)
    used: 30.89 GiB (33.6%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 31.25 GiB used: 1.2 MiB (0.0%) priority: 100
    dev: /dev/zram0
  ID-2: swap-2 type: partition size: 32.81 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/nvme0n1p7 maj-min: 259:7
  System Temperatures: cpu: 62.4 C mobo: N/A gpu: amdgpu temp: 55.0 C
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 1164
  Processes: 493 Uptime: 10m wakeups: 0 Memory: available: 31.25 GiB
  used: 9.6 GiB (30.7%) Init: systemd v: 253 default: graphical
  tool: systemctl Compilers: gcc: 13.1.1 clang: 15.0.7 Packages: pm: pacman
  pkgs: 1694 libs: 433 tools: pamac,yay Shell: Bash v: 5.1.16
  running-in: xfce4-terminal inxi: 3.3.27

Cannot currently update because of this error:

error: failed to commit transaction (conflicting files)
nss-hg: /usr/lib/p11-kit-trust.so exists in filesystem
Errors occurred, no packages were upgraded.

Having no familiarity with this item, or its affiliation, not sure how to proceed. Do I run with an overwrite? Just delete it? Other response? Thanks for any feedback…

1 Like

The tutorial explains what happened probably and gives some insights.
If you prefer, the fastest way is now

garuda-update -- --overwrite '*'

I have never used garuda-update, but I’ll assume it uses the same as a pacman call. Thanks - overwrite it is…


Of course it does, along with a lot of other stuff:

1 Like

Well, mostly I have survived without it so far - I run pacman updates, and separately run AUR updates and hat seems to have covered it as yet. Of course, I am not a gamer, nor am I on Plasma :grin: I guess I should try it sometime to see what else it does - but I suspect there would quite a lot I don’t need in there! Mirror updates etc I take care of on my own, cache cleanups likewise. Basically I run it much the same way I run my chaotic-AUR (and EnOS) mirror setup. Is t
there something else I need to know about in that app?

Are hotfixes likely to be Garuda specific - or Arch "normal’ for the most part?

I’ve been running Garuda since long before this script existed :grin:


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.