OS not booting after update

Been weeks trying to solve this issue and about ready to switch to another distro.
Using Garuda for about over a year and now cant get it to boot.

I update the OS then it hangs loading initial ramdisk on boot
I tried been reading the forums, tried so many possible solutions, nothing working
Reinstalled the OS, run the first update, reboot and same issue
Tried removing splash, changing to plymouth, switching kernals… Now it goes to emergency mode and getting dependency failed for boot/efi and local file systems and file system check

The Os has been working great for me on acer laptop dual booting with windows now its been a complete hassle just to boot and update. Been trouble shooting for weeks, ready to give up

Please advise

First use snapshot but now It’s too late after reinstalling.
We need garuda-inxi and the log from update too.


I actually tried that…Then I get efi wrap 1 not found, i was able to fix that issue, but then updated and back to the same issue as before



Can you still roll back a snapshot? If it’s the kernel parameters that are stopping you from booting you can change them from your grub menu temporarily (look here → /@/boot/vmlinuz-linuz-zen not found - #10 by filo on how to do it), i.e. they won’t be persisted across reboots but if it lets you boot into your system you can make it permanent.

Or if none of this works you can use a live usb and chroot into your system and from within chroot provide us with the update logs and the inxi to help us better understand what might be happening. To chroot you can use the command

garuda-chroot -a

from the live usb if this command fails (happens when you are using ventoy) you can follow this link to manually chroot into the system. → How to chroot Garuda Linux

Then can you provide us with the update logs? it is in /var/log/pacman.log along with the garuda-inxi. We need some idea of what might be happening in your system.

You can filter the logs to provide us with today’s logs

grep '^\[2023-10-15' /var/log/pacman.log

You can change the date accordingly.


I used a snapshot again after update but now it boots into emergency mode… I will post logs and ixni… stand by

Go into your BIOS and change this to AHCI mode.


I just came back to mention i just found the solution for this in another post here and yes you’re correct that seems to have been the issue. Very frustrating, a lot of trial and error, learned a lot at least lol. Thanks all

1 Like

Very good example, if garuda-inxi had been in the very first post, as the template requires,
we could have saved ourselves a lot of time as well.
Means we have to lock more posts directly where it is missing.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.