OS Crashes After Minecraft Goes Fullscreen

I've had a similar issue in the past and there's an old post about it here, at first it was solved by installing the LTS Kernel but that doesn't seem to be the case now...
I've tried disabling the compositor and didn't work either, i had to reinstall Garuda because i changed my HDD for an SSD recently, hardware is still the same (8GB DDR3 RAM x2 1066MHz, I5 3470 and the integrated graphics card which is an Intel HD 2,500) for some reason this issue is only affecting that one game, all the others appear to work fine. The issue is just the same as in the previous post (See System logs out when i put games on fullscreen - #5 by IronRose for more information).


╰─λ inxi -Faz
System:
Kernel: 5.15.33-1-lts arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-lts
root=UUID=13cb63b1-f18c-4a17-b803-8b3479656813 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3
Desktop: KDE Plasma v: 5.24.4 tk: Qt v: 5.15.3 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: Intel model: DH61CR v: AAG14064-210
serial: <superuser required> BIOS: Intel
v: BEH6110H.86A.0109.2012.1221.1455 date: 12/21/2012
CPU:
Info: model: Intel Core i5-3470 bits: 64 type: MCP arch: Ivy Bridge
family: 6 model-id: 0x3A (58) stepping: 9 microcode: 0x21
Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 256 KiB
desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB L3: 6 MiB
desc: 1x6 MiB
Speed (MHz): avg: 1718 high: 1850 min/max: 1600/3600 scaling:
driver: intel_cpufreq governor: performance cores: 1: 1850 2: 1638 3: 1728
4: 1658 bogomips: 25541
Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf
mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled
Type: mds mitigation: Clear CPU buffers; SMT disabled
Type: meltdown mitigation: PTI
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: disabled, RSB filling
Type: srbds status: Vulnerable: No microcode
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel Xeon E3-1200 v2/3rd Gen Core processor Graphics
driver: i915 v: kernel ports: active: VGA-1 empty: DP-1,HDMI-A-1
bus-ID: 00:02.0 chip-ID: 8086:0152 class-ID: 0300
Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.1
compositor: kwin_x11 driver: X: loaded: intel unloaded: modesetting
alternate: fbdev,vesa gpu: i915 display-ID: :0 screens: 1
Screen-1: 0 s-res: 1280x1024 s-dpi: 96 s-size: 338x270mm (13.31x10.63")
s-diag: 433mm (17.03")
Monitor-1: VGA-1 mapped: VGA1 model: HP L1740 serial: <filter>
built: 2006 res: 1280x1024 hz: 60 dpi: 99 gamma: 1.2
size: 330x270mm (12.99x10.63") diag: 426mm (16.8") ratio: 5:4 modes:
max: 1280x1024 min: 720x400
OpenGL: renderer: Mesa Intel HD Graphics 2500 (IVB GT1)
v: 4.2 Mesa 22.0.1 compat-v: 3.1 direct render: Yes
Audio:
Device-1: Intel 6 Series/C200 Series Family High Definition Audio
driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1c20
class-ID: 0403
Sound Server-1: ALSA v: k5.15.33-1-lts running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.49 running: yes
Network:
Device-1: Intel 82579V Gigabit Network driver: e1000e v: kernel port: f080
bus-ID: 00:19.0 chip-ID: 8086:1503 class-ID: 0200
IF: enp0s25 state: down mac: <filter>
Device-2: Ralink MT7601U Wireless Adapter type: USB driver: mt7601u
bus-ID: 2-1.4.4:12 chip-ID: 148f:7601 class-ID: 0000 serial: <filter>
IF: wlp0s29u1u4u4 state: up mac: <filter>
Drives:
Local Storage: total: 689.32 GiB used: 88.82 GiB (12.9%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital
model: WD1600BEKT-75A25T0 size: 149.05 GiB block-size: physical: 512 B
logical: 512 B speed: 3.0 Gb/s type: HDD rpm: 7200 serial: <filter>
rev: 1A01 scheme: MBR
ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST500DM002-1BD142
size: 465.76 GiB block-size: physical: 4096 B logical: 512 B
speed: 3.0 Gb/s type: HDD rpm: 7200 serial: <filter> rev: KC45
scheme: GPT
ID-3: /dev/sdc maj-min: 8:32 vendor: Western Digital
model: WD800JD-75MSA2 size: 74.51 GiB block-size: physical: 512 B
logical: 512 B speed: 3.0 Gb/s type: N/A serial: <filter> rev: 1E03
scheme: MBR
Partition:
ID-1: / raw-size: 149.05 GiB size: 149.05 GiB (100.00%)
used: 84.66 GiB (56.8%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-2: /home raw-size: 149.05 GiB size: 149.05 GiB (100.00%)
used: 84.66 GiB (56.8%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-3: /var/log raw-size: 149.05 GiB size: 149.05 GiB (100.00%)
used: 84.66 GiB (56.8%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-4: /var/tmp raw-size: 149.05 GiB size: 149.05 GiB (100.00%)
used: 84.66 GiB (56.8%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.24 GiB used: 14.5 MiB (0.2%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 29.8 C mobo: 27.8 C
Fan Speeds (RPM): N/A
Info:
Processes: 215 Uptime: 20h 35m wakeups: 0 Memory: 7.24 GiB
used: 2.27 GiB (31.4%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.2.0 Packages: pacman: 1732 lib: 522 Shell: fish v: 3.4.1
default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.15

It's weird that it seems the same issue but is now only affecting this one game. But that, plus the same steps not working this time, it could be something else.

What are you using to launch Minecraft? Might not be relevant, but I remember messing with atlauncher for a bit and there being an option to use the built-in glfw or the system glfw, could be worth looking into what your launcher tells java to expect to happen?

Also, do you have any crash logs? Not sure where they'd be for Java/Miinecraft, but might shed some light. (edit - probably SDDM or KDE logs also relevant/present, but I don't use KDE and wouldn't know what to look for)

Have you tried different window modes for minecraft? ( and @SonarMonkey )
Like

  • boderless fullscreen
  • fullscreen
  • windowed

Does it crash on all?

I never had it properly crashing, so I was just tweaking my way through the launcher, not really troubleshooting. The only thing I newly discovered in that is there's a patched version of GLFW for Wayland and a further-patched Wayland-Minecraft to make it play nice if I wanted to use the system version.

That said, Minecraft and Java-based apps in general have an absurd number of flags you can pass to change the behavior, so it could be whatever's launching Minecraft has something configured that no longer works?

There are also some Java-related environment variables, but again I only found the Wayland-related ones in my own fiddling. Might check printenv to see if any are currently set? This could be way off base though.

It also occurs to me - are you using optifine or any other adjacent mods?

1 Like

I have to point out that when i ran the game first time it was version 1.18 and it didn't do this, it was after i installed the 1.16.5 to make a pretty simple modpack... And now that you mention that, let me try and run 1.18 again. I'm using a LauncherFenix (it's made by a guy named YoFenix and that's the i've been using for more than 8 years at this point). I'll be right back to see if i'm able to run 1.18

Edit: After trying the game won't even let me run 1.18 anymore, and i don't know if i can set up this one to be windowed, because when the launcher loads the current version this one pops up in fullscreen already.

2 Likes

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.