System logs out when i put games on fullscreen

This is the first time i've experienced something like this; i'm not "new" to linux but this is something new to me... And i don't know how can i get some output from this. Because whenever i try to put a game on fullscreen (E.G: Left 4 Dead 2 or Wizard of Legend from my steam library) the system literally just freezes and then just get me to the SDDM login screen.

I know this may look like a vague post but i don't know how to explain this any better

Post your terminal/konsole in- and output as text (no pictures) from:

inxi -Faz

If it goes "BOOM" (meaning a delay then, bam and you are at SDDM) when you do it, it's likely a driver issue.

(Waiting for "Whiff! and "Holy Cow, Batman! to materialize in 10, 9, 8...)

1 Like

I will do my best to provide information. Thanks

Heres my output from inxi -Faz:

╰─λ inxi -Faz
System:    Kernel: 5.15.4-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=5006289a-929b-4012-a6f6-87b423fd6192 rw
[email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 resume=UUID=87e2c90b-d220-49e7-831a-cf0f4b7bf5f3 loglevel=3
Desktop: KDE Plasma 5.23.3 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux
base: Arch Linux
Machine:   Type: Desktop Mobo: Intel model: DH61CR v: AAG14064-210 serial: <filter> BIOS: Intel
v: BEH6110H.86A.0109.2012.1221.1455 date: 12/21/2012
CPU:       Info: Quad Core model: Intel Core i5-3470 bits: 64 type: MCP arch: Ivy Bridge family: 6 model-id: 3A (58)
stepping: 9 microcode: 21 cache: L2: 6 MiB
flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 25541
Speed: 2011 MHz min/max: 1600/3600 MHz Core speeds (MHz): 1: 2011 2: 2896 3: 3583 4: 3150
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled
Type: mds mitigation: Clear CPU buffers; SMT disabled
Type: meltdown mitigation: PTI
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: disabled, RSB filling
Type: srbds status: Vulnerable: No microcode
Type: tsx_async_abort status: Not affected
Graphics:  Device-1: Intel Xeon E3-1200 v2/3rd Gen Core processor Graphics driver: i915 v: kernel bus-ID: 00:02.0
chip-ID: 8086:0152 class-ID: 0300
Display: x11 server: X.Org compositor: kwin_x11 driver: loaded: intel unloaded: modesetting
alternate: fbdev,vesa display-ID: :0 screens: 1
Screen-1: 0 s-res: 1280x1024 s-dpi: 96 s-size: 338x270mm (13.3x10.6") s-diag: 433mm (17")
Monitor-1: VGA1 res: 1280x1024 hz: 60 dpi: 99 size: 330x270mm (13.0x10.6") diag: 426mm (16.8")
OpenGL: renderer: Mesa DRI Intel HD Graphics 2500 (IVB GT1) v: 4.2 Mesa 21.2.5 compat-v: 3.0 direct render: Yes
Audio:     Device-1: Intel 6 Series/C200 Series Family High Definition Audio driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
chip-ID: 8086:1c20 class-ID: 0403
Device-2: C-Media Audio Adapter (Unitek Y-247A) type: USB driver: cmedia_hs100b,snd-usb-audio,usbhid
bus-ID: 1-1.3.4:6 chip-ID: 0d8c:0014 class-ID: 0300
Sound Server-1: ALSA v: k5.15.4-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.40 running: yes
Network:   Device-1: Intel 82579V Gigabit Network driver: e1000e v: kernel port: f080 bus-ID: 00:19.0 chip-ID: 8086:1503
class-ID: 0200
IF: enp0s25 state: down mac: <filter>
Device-2: D-Link System DWA-125 Wireless N 150 Adapter(rev.A2) [Ralink RT3070] type: USB driver: rt2800usb
bus-ID: 2-1.1:5 chip-ID: 07d1:3c16 class-ID: 0000 serial: <filter>
IF: wlp0s29u1u1 state: down mac: <filter>
IF-ID-1: enp0s29u1u2 state: unknown speed: -1 duplex: half mac: <filter>
Bluetooth: Device-1: T & A Mobile Phones 6062W type: USB driver: rndis_host v: kernel bus-ID: 2-1.2:7 chip-ID: 1bbb:0174
class-ID: 0a00 serial: <filter>
Report: bt-service: enabled,stopped note: tool can't run
Drives:    Local Storage: total: 614.81 GiB used: 52.98 GiB (8.6%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD1600BEKT-75A25T0 size: 149.05 GiB block-size:
physical: 512 B logical: 512 B speed: 3.0 Gb/s type: HDD rpm: 7200 serial: <filter> rev: 1A01 scheme: MBR
ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST500DM002-1BD142 size: 465.76 GiB block-size: physical: 4096 B
logical: 512 B speed: 3.0 Gb/s type: HDD rpm: 7200 serial: <filter> rev: KC45 scheme: MBR
Partition: ID-1: / raw-size: 456.96 GiB size: 456.96 GiB (100.00%) used: 52.98 GiB (11.6%) fs: btrfs dev: /dev/sdb1
maj-min: 8:17
ID-2: /home raw-size: 456.96 GiB size: 456.96 GiB (100.00%) used: 52.98 GiB (11.6%) fs: btrfs dev: /dev/sdb1
maj-min: 8:17
ID-3: /var/log raw-size: 456.96 GiB size: 456.96 GiB (100.00%) used: 52.98 GiB (11.6%) fs: btrfs dev: /dev/sdb1
maj-min: 8:17
ID-4: /var/tmp raw-size: 456.96 GiB size: 456.96 GiB (100.00%) used: 52.98 GiB (11.6%) fs: btrfs dev: /dev/sdb1
maj-min: 8:17
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.24 GiB used: 1.2 MiB (0.0%) priority: 100 dev: /dev/zram0
ID-2: swap-2 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sdb2 maj-min: 8:18
Sensors:   System Temperatures: cpu: 51.0 C mobo: 27.8 C
Fan Speeds (RPM): N/A
Info:      Processes: 209 Uptime: 9m wakeups: 0 Memory: 7.24 GiB used: 2.75 GiB (38.0%) Init: systemd v: 249 tool: systemctl
Compilers: gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1700 lib: 504 Shell: fish v: 3.3.1 default: Bash v: 5.1.8

Was it working fine before a driver update? Perhaps there's a regression for the old iGPU as they bring in the new.
Could try rollback to an older snapshot or downgrade the appropriate packages?

1 Like

The issue was there before upgrading the system, i tried to update to see if this will correct that. But still the same.
I'll try to downgrade to see if it works.

When did you have these games work?

1 Like

They work just fine, only issue is when i try to put them on fullscreen. Literally the entire system goes on a black screen and sends me to SDDM login screen.

Has that always been the case, or has there been a time when it did work?

I was on Manjaro Linux for a while and this issue wasn't present at all, but for some odd reason games weren't running so stable in there, so i decided to make a change after 5 years (no matter what i tried, games were always unstable) here on Garuda they run fine, only issue is this one.

Return journalctl -p 3 -xb

It sounds like you are trying to switch to fullscreen with an unsupported resolution...

1 Like

So they've never run full-screen on Garuda since installing (and initial update)?
How long ago did you install Garuda?

I'm just trying to establish whether an update has broken this functionality, or it's a configuration change/problem.

1 Like

I know that I am like a guy whose only tool is a hammer: for me everything seems a nail, but, not being anything harmful and being even a good practice to have the LTS kernel installed (also because your issue is related to graphics, and you are using one of the latest kernels and the i915 driver), you maybe can try this:

1 Like

Have you tried to check if this issue occurs if you disable the compositor (alt+shift+F12) before going fullscreen?

1 Like

Ok, i will try this and the help above, thanks for your support!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.