Optimus-manager

Hello.

$ inxi -Faz
System:    Kernel: 5.15.7-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=147a9eef-7570-42d7-b8b8-ccb00a45ad5e rw
           [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
           systemd.unified_cgroup_hierarchy=1 loglevel=3
           Desktop: GNOME 41.1 tk: GTK 3.24.30 wm: gnome-shell dm: GDM 41.0 Distro: Garuda Linux base: Arch Linux
Machine:   Type: Laptop System: Dell product: XPS 15 9510 v: N/A serial: <superuser required> Chassis: type: 10
           serial: <superuser required>
           Mobo: Dell model: 01V4T3 v: A01 serial: <superuser required> UEFI: Dell v: 1.6.2 date: 11/13/2021
Battery:   ID-1: BAT0 charge: 13.8 Wh (16.4%) condition: 84.3/84.3 Wh (100.0%) volts: 11.5 min: 11.4 model: SMP DELL 70N2F95
           type: Li-poly serial: <filter> status: Charging
CPU:       Info: 8-Core model: 11th Gen Intel Core i7-11800H bits: 64 type: MT MCP arch: Tiger Lake family: 6
           model-id: 8D (141) stepping: 1 microcode: 34 cache: L1: 640 KiB L2: 10 MiB L3: 24 MiB
           flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 73728
           Speed: 1413 MHz min/max: 800/4600 MHz Core speeds (MHz): 1: 1413 2: 1464 3: 2127 4: 3143 5: 4005 6: 1558 7: 2382
           8: 1011 9: 907 10: 1326 11: 4380 12: 947 13: 832 14: 1102 15: 929 16: 1376
           Vulnerabilities: Type: itlb_multihit status: Not affected
           Type: l1tf status: Not affected
           Type: mds status: Not affected
           Type: meltdown status: Not affected
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
           Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
           Type: srbds status: Not affected
           Type: tsx_async_abort status: Not affected
Graphics:  Device-1: Intel TigerLake-H GT1 [UHD Graphics] vendor: Dell driver: i915 v: kernel bus-ID: 0000:00:02.0
           chip-ID: 8086:9a60 class-ID: 0300
           Device-2: NVIDIA GA107M [GeForce RTX 3050 Ti Mobile] vendor: Dell driver: N/A alternate: nouveau
           bus-ID: 0000:01:00.0 chip-ID: 10de:25a0 class-ID: 0302
           Device-3: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo bus-ID: 3-11:3 chip-ID: 0c45:672e class-ID: 0e02
           Display: x11 server: X.Org 1.21.1.1 compositor: gnome-shell driver: loaded: intel unloaded: modesetting
           alternate: fbdev,vesa display-ID: :1 screens: 1
           Screen-1: 0 s-res: 1920x1200 s-dpi: 96 s-size: 508x317mm (20.0x12.5") s-diag: 599mm (23.6")
           Monitor-1: eDP1 res: 1920x1200 hz: 60 dpi: 143 size: 340x210mm (13.4x8.3") diag: 400mm (15.7")
           Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:     Device-1: Intel Tiger Lake-H HD Audio vendor: Dell driver: snd_hda_intel v: kernel alternate: snd_sof_pci_intel_tgl
           bus-ID: 0000:00:1f.3 chip-ID: 8086:43c8 class-ID: 0403
           Sound Server-1: ALSA v: k5.15.7-zen1-1-zen running: yes
           Sound Server-2: JACK v: 1.9.19 running: no
           Sound Server-3: PulseAudio v: 15.0 running: no
           Sound Server-4: PipeWire v: 0.3.40 running: yes
Network:   Device-1: Intel Tiger Lake PCH CNVi WiFi vendor: Rivet Networks driver: iwlwifi v: kernel bus-ID: 0000:00:14.3
           chip-ID: 8086:43f0 class-ID: 0280
           IF: wlp0s20f3 state: up mac: <filter>
Bluetooth: Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 3-14:4 chip-ID: 8087:0026 class-ID: e001
           Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
RAID:      Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd v: 0.6 port: N/A bus-ID: 0000:00:0e.0
           chip-ID: 8086:9a0b rev: class-ID: 0104
Drives:    Local Storage: total: 953.87 GiB used: 14.33 GiB (1.5%)
           SMART Message: Required tool smartctl not installed. Check --recommends
           ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SK Hynix model: PC711 NVMe 1TB size: 953.87 GiB block-size:
           physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 41001131 temp: 53.9 C
           scheme: GPT
Partition: ID-1: / raw-size: 48.83 GiB size: 48.83 GiB (100.00%) used: 11.46 GiB (23.5%) fs: btrfs dev: /dev/nvme0n1p4
           maj-min: 259:4
           ID-2: /boot/efi raw-size: 240 MiB size: 236 MiB (98.33%) used: 118.4 MiB (50.2%) fs: vfat dev: /dev/nvme0n1p1
           maj-min: 259:1
           ID-3: /home raw-size: 758.2 GiB size: 745.23 GiB (98.29%) used: 2.76 GiB (0.4%) fs: ext4 dev: /dev/nvme0n1p5
           maj-min: 259:5
           ID-4: /var/log raw-size: 48.83 GiB size: 48.83 GiB (100.00%) used: 11.46 GiB (23.5%) fs: btrfs dev: /dev/nvme0n1p4
           maj-min: 259:4
           ID-5: /var/tmp raw-size: 48.83 GiB size: 48.83 GiB (100.00%) used: 11.46 GiB (23.5%) fs: btrfs dev: /dev/nvme0n1p4
           maj-min: 259:4
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
           ID-1: swap-1 type: zram size: 62.53 GiB used: 1024 KiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 58.0 C mobo: N/A
           Fan Speeds (RPM): N/A
Info:      Processes: 375 Uptime: 1h 58m wakeups: 4770 Memory: 62.53 GiB used: 3.71 GiB (5.9%) Init: systemd v: 249
           tool: systemctl Compilers: gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1183 lib: 321 Shell: fish v: 3.3.1
           running-in: gnome-terminal inxi: 3.3.09

I installed sudo pacman -S gcc make autoconf automake packages.

And I tried to install proprietary drivers via Garuda Settings Manager but I have errors:

$ cat /var/lib/dkms/nvidia/495.44/build/make.log
...
==> dkms install --no-depmod nvidia/495.44 -k 5.15.7-zen1-1-zen
Error! Bad return status for module build on kernel: 5.15.7-zen1-1-zen (x86_64)
...

I try to run manually with root and it works:

$ dkms install --no-depmod nvidia/495.44 -k 5.15.7-zen1-1-zen
$ modinfo /usr/lib/modules/5.15.7-zen1-1-zen/updates/dkms/nvidia.ko.zst
filename:       /usr/lib/modules/5.15.7-zen1-1-zen/updates/dkms/nvidia.ko.zst
firmware:       nvidia/495.44/gsp.bin
alias:          char-major-195-*
version:        495.44
supported:      external
license:        NVIDIA
srcversion:     517AEB70F81499E7A75AA0D
alias:          pci:v000010DEd*sv*sd*bc03sc02i00*
alias:          pci:v000010DEd*sv*sd*bc03sc00i00*
depends:        
retpoline:      Y
name:           nvidia
vermagic:       5.15.7-zen1-1-zen SMP preempt mod_unload 
parm:           NvSwitchRegDwords:NvSwitch regkey (charp)
parm:           NvSwitchBlacklist:NvSwitchBlacklist=uuid[,uuid...] (charp)
parm:           NVreg_ResmanDebugLevel:int
parm:           NVreg_RmLogonRC:int
parm:           NVreg_ModifyDeviceFiles:int
parm:           NVreg_DeviceFileUID:int
parm:           NVreg_DeviceFileGID:int
parm:           NVreg_DeviceFileMode:int
parm:           NVreg_InitializeSystemMemoryAllocations:int
parm:           NVreg_UsePageAttributeTable:int
parm:           NVreg_RegisterForACPIEvents:int
parm:           NVreg_EnablePCIeGen3:int
parm:           NVreg_EnableMSI:int
parm:           NVreg_TCEBypassMode:int
parm:           NVreg_EnableStreamMemOPs:int
parm:           NVreg_RestrictProfilingToAdminUsers:int
parm:           NVreg_PreserveVideoMemoryAllocations:int
parm:           NVreg_EnableS0ixPowerManagement:int
parm:           NVreg_S0ixPowerManagementVideoMemoryThreshold:int
parm:           NVreg_DynamicPowerManagement:int
parm:           NVreg_DynamicPowerManagementVideoMemoryThreshold:int
parm:           NVreg_EnableGpuFirmware:int
parm:           NVreg_EnableUserNUMAManagement:int
parm:           NVreg_MemoryPoolSize:int
parm:           NVreg_KMallocHeapMaxSize:int
parm:           NVreg_VMallocHeapMaxSize:int
parm:           NVreg_IgnoreMMIOCheck:int
parm:           NVreg_NvLinkDisable:int
parm:           NVreg_EnablePCIERelaxedOrderingMode:int
parm:           NVreg_RegisterPCIDriver:int
parm:           NVreg_RegistryDwords:charp
parm:           NVreg_RegistryDwordsPerDevice:charp
parm:           NVreg_RmMsg:charp
parm:           NVreg_GpuBlacklist:charp
parm:           NVreg_TemporaryFilePath:charp
parm:           NVreg_ExcludedGpus:charp
parm:           rm_firmware_active:charp
$ sudo insmod /usr/lib/modules/5.15.7-zen1-1-zen/updates/dkms/nvidia.ko.zst

I tried to run optimus-manager:

$ optimus-manager
ERROR: the latest GPU setup attempt failed at Xorg pre-start hook.
Log at /var/log/optimus-manager/switch/switch-20211212T165717.log
Cannot execute command because of previous errors.
$ cat /var/log/optimus-manager/switch/switch-20211212T165717.log
File: /var/log/optimus-manager/switch/switch-20211212T165717.log
[15] INFO: # Xorg pre-start hook
[16] INFO: Previous state was: {'type': 'pending_pre_xorg_start', 'requested_mode': 'hybrid', 'current_mode': None}
[16] INFO: Requested mode is: hybrid
[79] INFO: Available modules: ['nouveau']
[79] INFO: Unloading modules ['nouveau'] (if loaded)
[84] INFO: switching=none, nothing to do
[861] INFO: Nvidia card not visible in PCI bus, rescanning
[861] INFO: Rescanning PCI bus
[1507] ERROR: Nvidia card not showing up in PCI bus after rescan. Continuing anyways.
[1507] INFO: Setting Nvidia PCI power state to auto
[2158] ERROR: Cannot set PCI power management state. Continuing anyways. Error is: Unexpected PCI ID format: 0000:01:00.0
[2175] INFO: Loading module nvidia
[2176] ERROR: Xorg pre-start setup error
Traceback (most recent call last):
  File "/usr/lib/python3.9/site-packages/optimus_manager/hooks/pre_xorg_start.py", line 51, in main
    setup_kernel_state(config, prev_state, requested_mode)
  File "/usr/lib/python3.9/site-packages/optimus_manager/kernel.py", line 22, in setup_kernel_state
    _nvidia_up(config, hybrid=(requested_mode == "hybrid"))
  File "/usr/lib/python3.9/site-packages/optimus_manager/kernel.py", line 95, in _nvidia_up
    _load_nvidia_modules(config, available_modules)
  File "/usr/lib/python3.9/site-packages/optimus_manager/kernel.py", line 164, in _load_nvidia_modules
    _load_module(available_modules, "nvidia", options=nvidia_options)
  File "/usr/lib/python3.9/site-packages/optimus_manager/kernel.py", line 241, in _load_module
    raise KernelSetupError(
optimus_manager.kernel.KernelSetupError: module nvidia is not available for current kernel. Is the corresponding package installed ?
[2176] INFO: Removing /etc/X11/xorg.conf.d/10-optimus-manager.conf (if present)
[2177] INFO: Writing state {'type': 'pre_xorg_start_failed', 'switch_id': '20211212T165717', 'requested_mode': 'hybrid'}

Any idea ? :slight_smile:

Check you do not have fastboot and secure boot enabled then try again

1 Like

I have disabled fastboot but same thing, I have also this strange error:

$ cat /var/lib/dkms/nvidia/495.44/build/make.log
File: /var/lib/dkms/nvidia/495.44/build/make.log
DKMS make.log for nvidia-495.44 for kernel 5.15.7-zen1-1-zen (x86_64)
Sun Dec 12 19:47:41 CET 2021
make[1]: Entering directory '/usr/lib/modules/5.15.7-zen1-1-zen/build'
make[1]: cc: No such file or directory
warning: the compiler differs from the one used to build the kernel
  The kernel was built by: gcc (GCC) 11.1.0
  You are using:           cc (GCC) 11.1.0
make[1]: make: No such file or directory
make[1]: *** [Makefile:1863: /var/lib/dkms/nvidia/495.44/build] Error 127
make[1]: Leaving directory '/usr/lib/modules/5.15.7-zen1-1-zen/build'
make: *** [Makefile:80: modules] Error 2
ll (which gcc cc)
lrwxrwxrwx    3 root 13 mai   16:02  /usr/bin/cc -> gcc
.rwxr-xr-x 1,2M root 13 mai   16:02  /usr/bin/gcc

check you have gcc and gcc-libs installed

1 Like
$ sudo pacman -Qi gcc-libs gcc
Nom                      : gcc-libs
Version                  : 11.1.0-1
Description              : Runtime libraries shipped by GCC
Architecture             : x86_64
URL                      : https://gcc.gnu.org
Licences                 : GPL  LGPL  FDL  custom
Groupes                  : --
Fournit                  : gcc-libs-multilib  libgo.so=19-64  libgfortran.so=5-64  libgphobos.so=2-64  libubsan.so=1-64  libasan.so=6-64  libtsan.so=0-64  liblsan.so=0-64
DĂ©pend de                : glibc>=2.27
DĂ©pendances opt.         : --
Requis par               : aom  blas  brotli  chromaprint  compiler-rt  db  double-conversion  elfutils  exempi  exiv2  fftw  fish  flac  fmt  gc  gcc  gettext  glslang  gmp  gnustep-base  gnutls  gptfdisk  graphite  groff  icu  imath
                           intel-compute-runtime  intel-gmmlib  intel-media-driver  jack2  js78  libbs2b  libcdio  libde265  libebml  libelf  libgme  libimagequant  libinih  libmfx  libmodplug  libplacebo  libproxy  libsidplay  libsigc++
                           libsmbios  libsoxr  libvdpau-va-gl  libvpx  libwpe  libyuv  llvm-libs  lzip  mhwd-db-garuda-git  mjpegtools  ncurses  openal  p7zip  pcre  pcre2  poppler  portaudio  powertop  protobuf  rav1e  rubberband
                           shaderc  soundtouch  spirv-tools  starship  thin-provisioning-tools  uchardet  unarchiver  unrar  v4l-utils  vdpauinfo  vid.stab  visual-studio-code-bin  vmaf  webrtc-audio-processing  x265  zeromq  zimg
                           zita-alsa-pcmi  zita-resampler  zstd  zxing-cpp
Optionnel pour           : --
Est en conflit avec      : --
Remplace                 : gcc-libs-multilib  libgphobos
Taille installée         : 122,34 MiB
Paqueteur                : Giancarlo Razzolini <[email protected]>
Compilé le               : jeu. 13 mai 2021 16:02:30
Installé le              : jeu. 28 oct. 2021 15:39:06
Motif d’installation     : Explicitement installé
Script d’installation    : Non
Validé par               : Signature

Nom                      : gcc
Version                  : 11.1.0-1
Description              : The GNU Compiler Collection - C and C++ frontends
Architecture             : x86_64
URL                      : https://gcc.gnu.org
Licences                 : GPL  LGPL  FDL  custom
Groupes                  : base-devel
Fournit                  : gcc-multilib
DĂ©pend de                : gcc-libs=11.1.0-1  binutils>=2.28  libmpc
Dépendances opt.         : lib32-gcc-libs: for generating code for 32-bit ABI [installé]
Requis par               : clang  dkms  lib32-clang
Optionnel pour           : xorg-xrdb
Est en conflit avec      : --
Remplace                 : gcc-multilib
Taille installée         : 151,27 MiB
Paqueteur                : Giancarlo Razzolini <[email protected]>
Compilé le               : jeu. 13 mai 2021 16:02:30
Installé le              : dim. 12 déc. 2021 00:27:46
Motif d’installation     : Explicitement installé
Script d’installation    : Non
Validé par               : Signature

How to completely remove the nvidia card ?
I think it's the better solution, my laptop is new and my battery is empty 2h after the full charge :frowning:

I think it is because the nvidia card drain all energy

I hear the fan is running and the computer heats up during use (I use only chrome) all CPU is low and load < 1

$ sensors
ucsi_source_psy_USBC000:002-isa-0000
Adapter: ISA adapter
in0:           5.00 V  (min =  +5.00 V, max =  +5.00 V)
curr1:         0.00 A  (max =  +0.00 A)

coretemp-isa-0000
Adapter: ISA adapter
Package id 0:  +60.0°C  (high = +100.0°C, crit = +100.0°C)
Core 0:        +58.0°C  (high = +100.0°C, crit = +100.0°C)
Core 1:        +57.0°C  (high = +100.0°C, crit = +100.0°C)
Core 2:        +56.0°C  (high = +100.0°C, crit = +100.0°C)
Core 3:        +57.0°C  (high = +100.0°C, crit = +100.0°C)
Core 4:        +55.0°C  (high = +100.0°C, crit = +100.0°C)
Core 5:        +55.0°C  (high = +100.0°C, crit = +100.0°C)
Core 6:        +58.0°C  (high = +100.0°C, crit = +100.0°C)
Core 7:        +56.0°C  (high = +100.0°C, crit = +100.0°C)

nvme-pci-e100
Adapter: PCI adapter
Composite:    +53.9°C  (low  =  -0.1°C, high = +82.8°C)
                       (crit = +84.8°C)
Sensor 1:     +46.9°C  (low  = -273.1°C, high = +65261.8°C)
Sensor 2:     +51.9°C  (low  = -273.1°C, high = +65261.8°C)

ucsi_source_psy_USBC000:003-isa-0000
Adapter: ISA adapter
in0:           5.00 V  (min =  +5.00 V, max =  +5.00 V)
curr1:         0.00 A  (max =  +0.00 A)

ucsi_source_psy_USBC000:001-isa-0000
Adapter: ISA adapter
in0:           5.00 V  (min =  +5.00 V, max =  +5.00 V)
curr1:         0.00 A  (max =  +0.00 A)

iwlwifi_1-virtual-0
Adapter: Virtual device
temp1:        +41.0°C  

BAT0-acpi-0
Adapter: ACPI interface
in0:          11.46 V  
curr1:         2.81 A  
 $ glxinfo | grep "OpenGL renderer"
OpenGL renderer string: Mesa Intel(R) UHD Graphics (TGL GT1)

 $ lshw -c video
ATTENTION: ce programme devrait être lancé en tant que super-utilisateur.
  *-display NON-RÉCLAMÉ     
       description: 3D controller
       produit: GA107M [GeForce RTX 3050 Ti Mobile]
       fabriquant: NVIDIA Corporation
       identifiant matériel: 0
       information bus: [email protected]:01:00.0
       version: a1
       bits: 64 bits
       horloge: 33MHz
       fonctionnalités: bus_master cap_list
       configuration: latency=0
       ressources: mémoireE/S:600-5ff mémoireE/S:610-60f mémoire:a0000000-a0ffffff mémoire:6000000000-60ffffffff mémoire:6100000000-6101ffffff portE/S:3000(taille=128)
  *-display
       description: VGA compatible controller
       produit: TigerLake-H GT1 [UHD Graphics]
       fabriquant: Intel Corporation
       identifiant matériel: 2
       information bus: [email protected]:00:02.0
       version: 01
       bits: 64 bits
       horloge: 33MHz
       fonctionnalités: vga_controller bus_master cap_list
       configuration: driver=i915 latency=0
       ressources: mémoireE/S:610-60f mémoireE/S:400-3ff irq:128 mémoire:6164000000-6164ffffff mémoire:4000000000-400fffffff portE/S:4000(taille=64) mémoire:c0000-dffff mémoire:4010000000-4016ffffff mémoire:4020000000-40ffffffff
ATTENTION: les informations sont potentiellement incomplètes ou erronées, vous devriez lancer ce programme en tant que super-utilisateur.
$ upower -i /org/freedesktop/UPower/devices/battery_BAT0
  native-path:          BAT0
  vendor:               SMP
  model:                DELL 70N2F95
  serial:               3975
  power supply:         yes
  updated:              lun. 13 déc. 2021 13:44:32 (22 seconds ago)
  has history:          yes
  has statistics:       yes
  battery
    present:             yes
    rechargeable:        yes
    state:               discharging
    warning-level:       none
    energy:              43,3314 Wh
    energy-empty:        0 Wh
    energy-full:         84,2916 Wh
    energy-full-design:  84,2916 Wh
    energy-rate:         29,469 W
    voltage:             11,293 V
    time to empty:       1,5 hours
    percentage:          51%
    capacity:            100%
    technology:          lithium-polymer
    icon-name:          'battery-good-symbolic'
  History (charge):
    1639399472	51,000	discharging
  History (rate):
    1639399472	29,469	discharging

I would like really use garuda (I use fedora for the last 5 years as my primary OS)

Python was recently updated to 3.10 - looks like optimus-manager needs to be rebuilt.

This is why you shouldn't be using optimus-manager and instead be using prime :stuck_out_tongue:

1 Like

5th time I'm reinstalling garuda cinnamon after update broke X server and I finally decide to take a look at the forum...

Well at least now I know why it all went awry, I just have to wait for optimus to be updated to finalize my setup :slight_smile:

1 Like

This is odd to me as this worked flawlessly from a fresh install of Garuda. I was able to switch between Nvidia and Intel on my MSI laptop.
Has rtx 2070 and onboard Intel graphics.

When in doubt, reinstall.

fresh installing today on a Dell with gtx 3050 : the install works perfectly, reboot OK, but after system full update and reboot, nothing works anymore, with the same error messages than OP.

I'll try to block python 3.9 for the time being...

On Fedora (live USB key), it seems better (with AC plugged), no fan is running:

$ sensors
coretemp-isa-0000
Adapter: ISA adapter
Package id 0:  +44.0°C  (high = +100.0°C, crit = +100.0°C)
Core 0:        +40.0°C  (high = +100.0°C, crit = +100.0°C)
Core 1:        +40.0°C  (high = +100.0°C, crit = +100.0°C)
Core 2:        +40.0°C  (high = +100.0°C, crit = +100.0°C)
Core 3:        +42.0°C  (high = +100.0°C, crit = +100.0°C)
Core 4:        +38.0°C  (high = +100.0°C, crit = +100.0°C)
Core 5:        +38.0°C  (high = +100.0°C, crit = +100.0°C)
Core 6:        +44.0°C  (high = +100.0°C, crit = +100.0°C)
Core 7:        +41.0°C  (high = +100.0°C, crit = +100.0°C)

nvme-pci-e100
Adapter: PCI adapter
Composite:    +46.9°C  (low  =  -0.1°C, high = +82.8°C)
                       (crit = +84.8°C)
Sensor 1:     +39.9°C  (low  = -273.1°C, high = +65261.8°C)
Sensor 2:     +43.9°C  (low  = -273.1°C, high = +65261.8°C)

iwlwifi_1-virtual-0
Adapter: Virtual device
temp1:        +36.0°C  

BAT0-acpi-0
Adapter: ACPI interface
in0:          11.33 V  
curr1:         1.10 A

$ glxinfo | grep "OpenGL renderer"
OpenGL renderer string: Mesa Intel(R) UHD Graphics (TGL GT1)

$  lshw -c video
WARNING: you should run this program as super-user.
  *-display                 
       description: 3D controller
       product: GA107M [GeForce RTX 3050 Ti Mobile]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: [email protected]:01:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: bus_master cap_list rom
       configuration: driver=nouveau latency=0
       resources: iomemory:600-5ff iomemory:610-60f irq:204 memory:a0000000-a0ffffff memory:6000000000-60ffffffff memory:6100000000-6101ffffff ioport:3000(size=128)
  *-display
       description: VGA compatible controller
       product: TigerLake-H GT1 [UHD Graphics]
       vendor: Intel Corporation
       physical id: 2
       bus info: [email protected]:00:02.0
       version: 01
       width: 64 bits
       clock: 33MHz
       capabilities: vga_controller bus_master cap_list
       configuration: driver=i915 latency=0
       resources: iomemory:610-60f iomemory:400-3ff irq:203 memory:6164000000-6164ffffff memory:4000000000-400fffffff ioport:4000(size=64) memory:c0000-dffff memory:4010000000-4016ffffff memory:4020000000-40ffffffff
WARNING: output may be incomplete or inaccurate, you should run this program as super-user.

Another difference with XDG_SESSION_TYPE:

  • X11 for garuda
  • wayland for Fedora

i am not having this exact issue but i cant seem to change any of the settings in OM. I am using Dragonized Gaming Edition and OM is installed as default. How would I switch to Prime? If it is better why and why is it not default?

And to be honest what is Prime? I'm New. lol

Edit:
I uninstalled and reinstalled packages for OM and all is well. and I know what prime is now. :slight_smile:

I installed manually without the garuda assistant:

$ pacman -S nvidia-dkms nvidia-prime nvidia-settings nvtop

It's better, all works fine:

$ glxinfo | grep "OpenGL renderer"
OpenGL renderer string: Mesa Intel(R) UHD Graphics (TGL GT1)

$ prime-run glxinfo | grep "OpenGL renderer"
OpenGL renderer string: NVIDIA GeForce RTX 3050 Ti Laptop GPU/PCIe/SSE2

But the power consumption is too high.

I installed powerstat:

$ yay -S powerstat

I consume average 11/12w in Garuda. I try with Gnome usb live and I recompile powerstat and I consume only 6.5w.

The difference is too huge.

I try to install optimus-manager to switch only on Intel only (with optimus-manager --switch integrated) without success:

$ pacman -S optimus-manager

After installing optimus-manager gdm failed and I see a black sreen.

I also try to install gdm-prime but I have always a black screen:

$ pacman -S gdm-prime

I hope to fix this issue, I work on that for 1 week to use Garuda. But now I have no idea to solve this problem.
If I failed to solve this issue in the following days I will reluctantly switch to Ubuntu :frowning:

What's different between the two?

There's also a "power saving tweaks" package in Garuda - by default it is set for performance so power usage will be higher.

The difference is that is the driver nouveau.

I just install ubuntu with the nvidia-dkms-495 driver and I consume less that 4w on demand profile (same as garuda)

$ ./powerstat 
Running for 300.0 seconds (30 samples at 10.0 second intervals).
Power measurements will start in 180 seconds time.

  Time    User  Nice   Sys  Idle    IO  Run Ctxt/s  IRQ/s  Watts               
23:57:55   0.0   0.0   0.1  99.9   0.0    1    246    157   4.27 
23:58:05   0.0   0.0   0.0  99.9   0.0    1    132     97   3.39 
23:58:15   0.0   0.0   0.1  99.9   0.0    1    270    173   3.99 
23:58:25   0.0   0.0   0.0 100.0   0.0    1    116     86   3.40 
23:58:35   0.0   0.0   0.1  99.9   0.0    1    243    154   4.11 

That means the driver is not the difference.

As I said, there are some default performance-related tweaks in Garuda that will make the laptop use more power. If you disable those then it will use less power.

The Ubuntu kernel is also different, as well as most of the underlying software. I'd be interested to find out which things Ubuntu includes (or does not include) in whichever version you're testing that halves power use.

2 Likes

How to disable these tweaks or where are they referenced ?

They are in garuda assistant

1 Like

There is no change (I consume 12w) and I can't uncheck the other options (nothing happens and the options are still checked)