/oldroot preventing shutting down

related: Failed to unmount /oldroot: Device or resource busy [at shutdown]

systemctl --failed
UNIT                                 LOAD   ACTIVE SUB    DESCRIPTION
● systemd-networkd-wait-online.service loaded failed failed Wait for Network to be Configured

LOAD   = Reflects whether the unit definition was properly loaded.
ACTIVE = The high-level unit activation state, i.e. generalization of SUB.
SUB    = The low-level unit activation state, values depend on unit type.
1 loaded units listed.```
journalctl -p 3 -b
Apr 21 06:06:18 Mikado systemd[324]: /usr/lib/systemd/system-generators/systemd-fstab-generator failed with exit sta>
Apr 21 06:06:17 Mikado systemd-modules-load[354]: Failed to find module 'ashmem_linux'
Apr 21 06:06:17 Mikado systemd-modules-load[354]: Failed to find module 'binder_linux'
Apr 21 06:06:18 Mikado systemd-modules-load[354]: Failed to find module 'nvidia-uvm'
Apr 21 06:06:18 Mikado systemd-udevd[388]: /usr/lib/udev/rules.d/55-Argyll.rules:157 Unknown group 'colord', ignoring
Apr 21 06:06:18 Mikado kernel: Bluetooth: hci0: unexpected cc 0x0c25 length: 2 < 3
Apr 21 06:06:18 Mikado kernel: Bluetooth: hci0: Opcode 0x c25 failed: -38
Apr 21 06:08:20 Mikado systemd-networkd-wait-online[761]: Timeout occurred while waiting for network connectivity.
Apr 21 06:08:20 Mikado systemd[1]: Failed to start Wait for Network to be Configured.
Apr 21 06:19:34 Mikado sddm-helper[134886]: gkr-pam: unable to locate daemon control file```

From another /oldroot related post: You are not authorized to mount this device [External HDD] - #9 by SGS
i am also using a HDD to backup my files without changing it's filesystem.

TLDR:
while shutting down i see a long text screen some of the lines are like:
failed to unmount /oldroot/dev: device busy or ...
ignoring....
and the last line is "shutting down"
previously made a topic: Can't shutdown hibernate sleep
i thought it has something to do with my kernel, but now i think it has to do something with oldroot. and i didn't find any article on oldroot in archiwiki.

garuda-inxi
System:
Kernel: 5.17.3-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=9defb73e-3680-499e-89ec-10d7b12843a5 rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 amdgpu.ppfeaturemask=0xffffffff
resume=UUID=922b6371-e6a5-4c9a-beae-5a05f7ce4b41 loglevel=3
Console: pty pts/0 wm: kwin_x11 DM: SDDM Distro: Garuda Linux
base: Arch Linux
Machine:
Type: Desktop Mobo: Gigabyte model: B450M S2H v: x.x serial: N/A
UEFI: American Megatrends v: F50 date: 11/27/2019
CPU:
Info: model: AMD Ryzen 3 3100 socket: AM4 bits: 64 type: MT MCP arch: Zen 2
family: 0x17 (23) model-id: 0x71 (113) stepping: 0 microcode: 0x8701013
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 2 MiB desc: 4x512 KiB
L3: 16 MiB desc: 2x8 MiB
Speed (MHz): avg: 2200 min/max: 2200/3906 boost: enabled
base/boost: 3600/3900 scaling: driver: acpi-cpufreq governor: ondemand
volts: 1.1 V ext-clock: 100 MHz cores: 1: 2200 2: 2200 3: 2200 4: 2200
5: 2200 6: 2200 7: 2200 8: 2200 bogomips: 57490
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Retpolines, IBPB: conditional, STIBP: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
vendor: Sapphire driver: amdgpu v: kernel pcie: gen: 3 speed: 8 GT/s
lanes: 16 ports: active: HDMI-A-2 empty: DP-1, DP-2, DVI-D-1, HDMI-A-1
bus-ID: 0a:00.0 chip-ID: 1002:67df class-ID: 0300
Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.1
compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting
alternate: fbdev,vesa gpu: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: HDMI-A-2 mapped: HDMI-A-1 model: LG (GoldStar) FULL HD
serial: <filter> built: 2020 res: 1920x1080 hz: 60 dpi: 102 gamma: 1.2
size: 480x270mm (18.9x10.63") diag: 551mm (21.7") ratio: 16:9 modes:
max: 1920x1080 min: 720x400
OpenGL: renderer: AMD Radeon RX 570 Series (polaris10 LLVM 13.0.1 DRM
3.44 5.17.3-zen1-1-zen)
v: 4.6 Mesa 22.0.1 direct render: Yes
Audio:
Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
vendor: Sapphire driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s
lanes: 16 bus-ID: 0a:00.1 chip-ID: 1002:aaf0 class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: Gigabyte
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 0c:00.4 chip-ID: 1022:1487 class-ID: 0403
Device-3: JMTek LLC. FANTECH CAPTAIN 7.1 type: USB
driver: hid-generic,snd-usb-audio,usbhid bus-ID: 3-1:2 chip-ID: 0c76:16cb
class-ID: 0300
Sound Server-1: ALSA v: k5.17.3-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.50 running: yes
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Gigabyte driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: f000 bus-ID: 09:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp9s0 state: up speed: 100 Mbps duplex: full mac: <filter>
IF-ID-1: docker0 state: up speed: 10000 Mbps duplex: unknown
mac: <filter>
IF-ID-2: veth76eac49 state: up speed: 10000 Mbps duplex: full
mac: <filter>
Bluetooth:
Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) type: USB
driver: btusb v: 0.8 bus-ID: 1-4.1:3 chip-ID: 0a12:0001 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: N/A
Drives:
Local Storage: total: 1.14 TiB used: 720.71 GiB (61.6%)
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: A-Data model: SX6000PNP
size: 238.47 GiB block-size: physical: 512 B logical: 512 B
speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: V9002s34
temp: 37.9 C scheme: GPT
SMART: yes health: PASSED on: 101d 1h cycles: 1,519
read-units: 48,225,882 [24.6 TB] written-units: 67,612,866 [34.6 TB]
ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000DM010-2EP102
family: BarraCuda 3.5 (CMR) size: 931.51 GiB block-size: physical: 4096 B
logical: 512 B sata: 3.0 speed: 6.0 Gb/s type: HDD rpm: 7200
serial: <filter> rev: CC43 temp: 43 C scheme: GPT
SMART: yes state: enabled health: PASSED on: 1y 35d 14h cycles: 1483
read: 5.1 TiB written: 4.14 TiB Pre-Fail: attribute: Spin_Retry_Count
value: 100 worst: 100 threshold: 97
Partition:
ID-1: / raw-size: 221.05 GiB size: 221.05 GiB (100.00%)
used: 202.27 GiB (91.5%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat block-size: 512 B dev: /dev/nvme0n1p1
maj-min: 259:1
ID-3: /home raw-size: 221.05 GiB size: 221.05 GiB (100.00%)
used: 202.27 GiB (91.5%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
maj-min: 259:2
ID-4: /var/log raw-size: 221.05 GiB size: 221.05 GiB (100.00%)
used: 202.27 GiB (91.5%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
maj-min: 259:2
ID-5: /var/tmp raw-size: 221.05 GiB size: 221.05 GiB (100.00%)
used: 202.27 GiB (91.5%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 17.13 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
ID-2: swap-2 type: zram size: 15.63 GiB used: 256 KiB (0.0%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 16.8 C mobo: N/A gpu: amdgpu temp: 46.0 C
Fan Speeds (RPM): N/A gpu: amdgpu fan: 799
Info:
Processes: 320 Uptime: 37m wakeups: 0 Memory: 15.63 GiB
used: 4.1 GiB (26.2%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.2.0 clang: 13.0.1 Packages: pacman: 2016 lib: 576
Shell: garuda-inxi (sudo) default: Bash v: 5.1.16 running-in: konsole
inxi: 3.3.15
Garuda (2.6.1-3):
System install date:     2021-11-10
Last full system update: 2022-04-19
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Snapper
Failed units:            systemd-networkd-wait-online.service
1 Like

Fix these.
Remove any unknown/old module/options files in /etc/modules-load.d/ and /etc/modprobe.d/ folders. You don't even have nvidia... :exploding_head:
Check the udev rule file owner and see what is wrong and correct it.
The other messages are not uncommon and not seem fatal.

6 Likes

removed ashem and binder file (was in anbox.conf)
but didn't find any file containing nvidia. i found that "3" package naming with 'nvidia' is installed as dependency of 'mhwd-db-garuda-git'
and another package named nvidia-utils as a dependency of steam-native-runtime

They are irellevant.

How is this package named?

However, you can find which package owns a file with:

pacman -Qo <file-path>

Give actual package and file names. We can't use not accurate info.
Do your work. We can't connect to your system :person_shrugging:

1 Like