Off Topic Chit Chat - (Silliness factor 5)

This is called bureaucracy…or rather bureaucrazy :smile:

2 Likes

Reminds me of… :wink:

5 Likes

Some things don’t work, like the cosmic store. Also the battery applet doesn’t read battery % and stays at 0% :sweat_smile:

Also apparenty cosmic-epoch-git is outdated and the cosmic-session-git is more up-to-date and stable (but takes too much time to build). I am not saying this but the pinned comment here:
https://youtu.be/bCwD7JIB-r4?si=uh4U9LlEILbXZT0n
If you read the comment thread from above video, you’ll see the OP mentioning that this package is not stable like the ones on fedora or pop.

Tiling’s great and so is themeing!

Also I don’t find essential settings pages like battery and stuff anywhere in Settings.

Can’t set keybinds for apps and the page for it is broken:

3 Likes

How is it in terms of usability? For every day use.

1 Like

Considering they aren’t even at an alpha release, that’s impressive that there are so few things not working! I’ve talked with the CEO on X a few times about implementing some more features to Cosmic as well (moving buttons to left side of window, global appmenu) since they are so strongly wanting this to be completely customizable for users. I think it’ll be a great release. Once again, would love to see a Garuda Cosmic release :sweat_smile: would have to learn a lot otherwise I’d maintain it myself.

2 Likes

This is just a rant about how bad I am in English :melting_face:

I have heard a lot about Competitive programming , so wanted to try out whatever it is ,
I logged into leetcodes , and then I choosed a problem , as I just wanted to get a little bit of taste of it , so I just choosed a problem which was labelled as easy .
And I started doing it

Problem

I thought that input would be as it is, as show in examples
and output would exactly same as that in the example

And after an hour of struggle I completed my first leetcode problem .

Code
#include <bits/stdc++.h>
using namespace std;
int main() {
    string a, b, lis , c , d , num ;
    cin >> a>> b>> lis >> c >> d >> num ;
    vector <int> vec;
    a = "";
    for ( int i= 1 ; i< lis.length()-2 ; i++ ) {
        if ( lis[i] != ',' ) {
            a += lis[i] ;
        } else if(lis[i] == ',')  {
            int  x = stoi(a) ;
            vec.push_back(x);
            a = "";
        }
    }
    int nu = stoi(num) ;
    int  x = stoi(a) ;
    vec.push_back(x);
    vector<int>::iterator it;
    vector<int>::iterator it2;
    vector<int> vec1;
    int i = 0;
    for (it = vec.begin() ; it != vec.end() ;  ++it){
        bool cond = 0 ;
        ++i ;
        int j = 0 ;
        for ( it2 = vec.begin() ; it2 != vec.end() ; ++it2 ) {
            ++j;
            if ( nu == *it + *it2 & i != j) {
                vec1.push_back(i-1);
                vec1.push_back(j-1);
                cond = true ;
                break;
            }
        }
        if ( cond == true ) {
            break;
        }
    }
    cout << '[' << *vec1.begin() << ',' << *(vec1.end()-1) << ']';
}

And a picture too, because I want to show off the beauty of neovim :grin:

And I tested the code I was thinking like yes it is perfect .

Summary

And I was fully assured that yes it is the code that was needed . But when I submitted it
It was… False!!

Errors

And I was like, WTF ?? why is not working ?
And then I realized that it just wanted a constructure which just return those indices , and after all this stupidity I literally wanted to smash my head on the wall :moyai:

I feel like I need to first get better at understanding English instead of learning to code :joy: :face_holding_back_tears:

1 Like

TL;DR
Basically people were not updating BIOS and complaining about instability under high load using Intel CPU + Nvidia GPU. Crashing in nvgpucomp64.dll when the CPU was using most of its power.

What really gets me is this quote from the thread:

Updating the BIOS is usually a simple process but it’s not something we would normally encourage people to do – usually the advice is “if it ain’t broke don’t fix it”

:man_facepalming:
Security updates… getting support for Resizable BAR… better support for processors & RAM. There are a ton of reasons to update BIOS, and a lot of drivers/kernels expect things to be in certain working order. Long as you aren’t updating to an alpha/beta version you should be fine updating (although sometimes even a beta version is even needed for important timely fixes).
Updating BIOS is a thing that is overlooked time and time again for not only system instability but also graphical related problems and performance issues.

6 Likes

The hint that you can brick your motherboard stops many people.

Always update the BIOS via the BIOS or the BIOS flashback button on certain motherboards + USB stick. Your board is most likely bricked.

:smiley:

2 Likes

Yes. It is usable if you ignore small bugs and stuff.
Currently I am in process of building the cosmic-session package and it’s dependencies. Let’s see how it goes!

1 Like

More support/updates are usually had with boards that usually have some kind of fallback option (like the flashback button).
Long as people aren’t using shoddy USB sticks or ports with bad connectivity, things usually go well. Though with people without some kind of fallback option should really update BIOS while connected to a UPS (Uninterrupted Power Supply)… or at least think about putting a few extra dollars into the next motherboard with better support and flashback button :laughing:

3 Likes

Keep us updated! Pretty excited to see it get finished!

1 Like

Tried building but fails at building cosmic-applets-git, cosmic-settings-git. Also the build time is kinda crazy as my system is not the best…
Gonna try again though :grin:

EDIT:
The ArchWiki cosmic page has just been updated today and says about cosmic-session-git

1 Like

Nope cosmic-applets-git just refuses to build!
Guess we should just… wait?

1 Like

I can give it a go here in a while and see what happens. I’ll update here when I have the results

2 Likes

Oddly enough I was able to get cosmic-applets-git to build!
==> Finished making: cosmic-applets-git r1007.4ceac0c-1 (Thu 11 Jul 2024 02:31:41 PM CDT)

Now it’s building cosmic-comp-git. Hopefully it builds successfully. I will say cosmic-applets-git took the longest to build so far.


:frowning:

@IUSELINUX so after it failed I tried to build it again and it finished like it was successful. So I logged out, logged into cosmic session and immediately ran into issues. Keyboard shortcuts didn’t work at all, and attempting to open the application menu would show the app menu for a fraction of a second before disappearing again. I couldn’t right click the desktop, so I wasn’t able to open anything outside of what was already pinned to the dock. It was unusable unfortunately. I think we’ll have to wait a while to see if fixes are implemented

1 Like

Anyways, me building cosmic-applets-git always fails so I got no option.

This didn’t happen to me in cosmic-epoch-git version…

1 Like

Yeah I have no clue tbh. I’m following the development blog pretty close and sounds like they’re down to 20 must-fix bugs before alpha can be released.

1 Like

Well, it looks like this is more to do with those Intel CPUs being extremely bad… BIOS updates don’t help the issue completely. More information here:

3 Likes

There are as well videos from Steve & Steve and level1 tech digging into it deeper. Looks like last two generations of i9 are pretty F**********

3 Likes