Nvidia stuff is installed, but I have a Radeon card

This is the only distro where this has happens to me- some games, notably Star Wars Battlefront 2 from Steam, give me an error trying to launch saying something like "You are using an outdated Nvidia driver version please upgrade to 390.xx". The strange thing is, I don't use any Nvidia hardware, I have a Radeon RX580 w/ Ryzen 5.
So I looked in the software center and found that I have two nvidia-related packages installed, mhwd-nvidia and mhwd-nvidia-390xx. When I try to remove these, it also tries to uninstall a bunch of important seeming things, like garuda-settings-manager and a bunch of non-nvidia dependencies.
Any idea what's going on? My display controller under hardware config says "Ellesmere" and seems to recognize my GPU correctly. Should I keep those nvidia packages, or are those not related to the BF2 issue?

Oops :-)
garuda-settings-manager

Hardware config

Read

please
and post

inxi -Fza

as text! Even if you personally think it is unnecessary.

and
:slight_smile:

2 Likes

These are used by Garuda settings manager which depends on them. So uninstalling is not possible. That aint the real driver used by the system though, so dont worry.

3 Likes
System:    Kernel: 5.12.8-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0  
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=0eefd4a1-310e-4c03-aebb-ea9c87f1a440 rw  
[email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 resume=UUID=dd99f611-be54-471b-9d1f-3f1c159a46ff loglevel=3
Desktop: KDE Plasma 5.21.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux  
base: Arch Linux  
Machine:   Type: Desktop Mobo: ASRock model: B450M Pro4-CB serial: <filter> UEFI: American Megatrends v: P1.30  
date: 03/04/2019  
Battery:   ID-1: hidpp_battery_0 charge: N/A condition: N/A volts: 3.7 min: N/A model: Logitech G Pro Wireless Gaming Mouse  
type: N/A serial: <filter> status: Discharging  
CPU:       Info: 6-Core model: AMD Ryzen 5 2600 bits: 64 type: MT MCP arch: Zen+ family: 17 (23) model-id: 8 stepping: 2  
microcode: 800820D cache: L2: 3 MiB  
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 81435  
Speed: 2431 MHz min/max: 1550/3400 MHz boost: enabled Core speeds (MHz): 1: 2431 2: 3892 3: 2231 4: 3796 5: 3774  
6: 3507 7: 3782 8: 3748 9: 3741 10: 3781 11: 3763 12: 3832  
Vulnerabilities: Type: itlb_multihit status: Not affected  
Type: l1tf status: Not affected  
Type: mds status: Not affected  
Type: meltdown status: Not affected  
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp  
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization  
Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: disabled, RSB filling  
Type: srbds status: Not affected  
Type: tsx_async_abort status: Not affected  
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]  
vendor: Micro-Star MSI driver: amdgpu v: kernel bus-ID: 1c:00.0 chip-ID: 1002:67df class-ID: 0300  
Display: x11 server: X.Org 1.20.11 compositor: kwin_x11 driver: loaded: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9")
Monitor-1: HDMI-A-0 res: 1920x1080 hz: 144 dpi: 92 size: 531x298mm (20.9x11.7") diag: 609mm (24")
OpenGL: renderer: Radeon RX 580 Series (POLARIS10 DRM 3.40.0 5.12.8-zen1-1-zen LLVM 11.1.0) v: 4.6 Mesa 21.1.1
direct render: Yes
Audio:     Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590] vendor: Micro-Star MSI driver: snd_hda_intel
v: kernel bus-ID: 1c:00.1 chip-ID: 1002:aaf0 class-ID: 0403
Device-2: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: ASRock driver: snd_hda_intel v: kernel
bus-ID: 1e:00.3 chip-ID: 1022:1457 class-ID: 0403
Device-3: Texas Instruments PCM2902 Audio Codec type: USB driver: hid-generic,snd-usb-audio,usbhid bus-ID: 3-3:3
chip-ID: 08bb:2902 class-ID: 0300
Sound Server-1: ALSA v: k5.12.8-zen1-1-zen running: yes
Sound Server-2: JACK v: 0.125.0 running: no
Sound Server-3: PulseAudio v: 14.2 running: yes
Sound Server-4: PipeWire v: 0.3.28 running: yes
Network:   Device-1: Intel Dual Band Wireless-AC 3168NGW [Stone Peak] driver: iwlwifi v: kernel bus-ID: 17:00.0
chip-ID: 8086:24fb class-ID: 0280
IF: wlp23s0 state: down mac: <filter>
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASRock driver: r8169 v: kernel port: f000
bus-ID: 18:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp24s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Bluetooth: Device-1: Intel Wireless-AC 3168 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-10:2 chip-ID: 8087:0aa7
class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:    Local Storage: total: 2.04 TiB used: 284.42 GiB (13.6%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD20EZAZ-00GGJB0 size: 1.82 TiB block-size:
physical: 4096 B logical: 512 B speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter> rev: 0A80 scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: A-Data model: SU630 size: 223.57 GiB block-size: physical: 512 B
logical: 512 B speed: 6.0 Gb/s rotation: SSD serial: <filter> rev: 0A0 scheme: GPT
Partition: ID-1: / raw-size: 206.14 GiB size: 206.14 GiB (100.00%) used: 27.74 GiB (13.5%) fs: btrfs dev: /dev/sdb2
maj-min: 8:18
ID-2: /boot/efi raw-size: 256 MiB size: 252 MiB (98.46%) used: 546 KiB (0.2%) fs: vfat dev: /dev/sdb1 maj-min: 8:17
ID-3: /home raw-size: 206.14 GiB size: 206.14 GiB (100.00%) used: 27.74 GiB (13.5%) fs: btrfs dev: /dev/sdb2
maj-min: 8:18
ID-4: /var/log raw-size: 206.14 GiB size: 206.14 GiB (100.00%) used: 27.74 GiB (13.5%) fs: btrfs dev: /dev/sdb2
maj-min: 8:18
ID-5: /var/tmp raw-size: 206.14 GiB size: 206.14 GiB (100.00%) used: 27.74 GiB (13.5%) fs: btrfs dev: /dev/sdb2
maj-min: 8:18
Swap:      Kernel: swappiness: 10 (default 60) cache-pressure: 75 (default 100)
ID-1: swap-1 type: partition size: 17.18 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sdb3 maj-min: 8:19
ID-2: swap-2 type: zram size: 1.3 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram0
ID-3: swap-3 type: zram size: 1.3 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram1
ID-4: swap-4 type: zram size: 1.3 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram2
ID-5: swap-5 type: zram size: 1.3 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram3
ID-6: swap-6 type: zram size: 1.3 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram4
ID-7: swap-7 type: zram size: 1.3 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram5
ID-8: swap-8 type: zram size: 1.3 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram6
ID-9: swap-9 type: zram size: 1.3 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram7
ID-10: swap-10 type: zram size: 1.3 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram8
ID-11: swap-11 type: zram size: 1.3 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram9
ID-12: swap-12 type: zram size: 1.3 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram10
ID-13: swap-13 type: zram size: 1.3 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram11
Sensors:   System Temperatures: cpu: 44.4 C mobo: 0 C gpu: amdgpu temp: 54.0 C
Fan Speeds (RPM): N/A gpu: amdgpu fan: 957
Info:      Processes: 351 Uptime: 35m wakeups: 3 Memory: 15.62 GiB used: 3.43 GiB (22.0%) Init: systemd v: 248 tool: systemctl
Compilers: gcc: 11.1.0 clang: 11.1.0 Packages: pacman: 1763 lib: 553 Shell: fish v: 3.2.2 default: Zsh v: 5.8
running-in: konsole inxi: 3.3.04

That's the info I needed, thank you! But could these packages be the reason some games recognize my card as Nvidia? Never had this issue anywhere else and I can't play a big chunk of games because of it. I have a feeling I might have gone overboard installing unneeded packages during that startup wizard..

1 Like

No I dont think thats the issue here. You can verify this by removing garuda-settings-manager (should get rid of those packages in question as well) with

sudo pacman -Rns garuda-settings-manager

Then try gaming, Im sure though that doesnt change the fact that it wont work. Im not gaming myself & dont own AMD either, might be worth to do some research how to get the specific card running on Arch maybe.

1 Like

I can't seem to find anyone else with the issue, I've been looking for days. Everywhere I look it up, it's people having trouble with their own respective Nvidia cards. I can't find anything else on Nvidia driver issues showing up for AMD cards. I don't think it's a game specific thing because native games run fine but the ones configured with Proton/Wine etc (that work out the box on other distros) give me issues 90% of the time. Strange considering the only distro I tried tailored for gaming is the only one that gave me problems running games. But when they DO run, they run super smoothly.
I think I'm going to do a clean install again and only install the required bare minimum, I guess trying to go for maximum compatibility broke something during installation. At least I know it isn't those 2 packages I was concerned about, thank you

It is. Look in the game's (or whatever controls the game) settings.
Your driver configuration is fine, you don't need to re-install.

If you enjoy reinstalling, though, go ahead. Anything pleases anyone... :wink:

1 Like

I hardly think it's a coincidence that the game very recently ran perfectly on numerous other distros but borked on Garuda only, but thanks for trying to help.

Just wild guessing here:

Garuda uses the following, a change might help?

export AMD_VULKAN_ICD=RADV
3 Likes

I apologize for the naivety & wasting everyone's time, I'm not sure what exactly that last command did but I ran that and rebooted and everything single game that wasn't starting before works beautifully now. What a relief. Thank you both so much for your time and patience

Whatever that command did, it was lost after reboot.
So, you may safely conclude your computer has some hidden ghosts inside.
Don't laugh, there are several others with the same issue!!! :ghost: :ghost:

2 Likes

I'm going back to Solus, I don't need the devs bullying me when all I need is tech support. How about fix your shitty buggy unstable OS so it doesn't have these probs out the box so I wouldn't have to waste your time?
Please delete my account and this post if possible, thanks.

Sorry, what???
Are you joking?? :man_facepalming:

3 Likes

Insults don't help anyone, but only bring out the character of users who, when they get stuck, stomp their feet like toddlers.
Garuda, like many other Arch OS, works for thousands of users.
Only a few have problems because of missing hardware drivers that do not support Linux from the manufacturer's side.

But it's so nice and easy to anonymously get worked up about the gifts without ever having set up anything of your own.

But even with snide remarks you can't cover up your own incompetence.

Have a good trip.

2 Likes

By doing NOTHING different from what I do on other distros (even Arch based), either my computer has coincidentally died/broke physically during the last 13 hours, or your operating system has literally broke my computer. I've only stopped for 30 mins to eat. It's 4:28 am and I'm still looking at a bootloop. Garuda has destroyed my hard drive in ways that no other OS ever has, and I'm giving up. I know there's no point asking for assistance when google results leave me stranded and the creators really seem to hate helping beginners. Before Garuda, I would distrohop frequently. I'm not sure what this OS did to my hardware but ever since I installed it no OS that I install on my PC will boot. I even attempted to go back to Windows that is how desperate I got :frowning: I get an filesystem dev/sda corrupt error or something when trying to boot the installer. My cyberpowerPC splash screen is also now all green for some reason and makes a loud beaping noise before it rapidly shuts off. Linux Live CDs don't even boot. I'm typing this from my brother's PC as mine can no longer seem to reach any sort GUI. I'm lying, I installed the non-gaming version instead and I now have no problems.
Did you know you actually can obtain the triforce in Ocarina of Time? Immediately after getting Zelda's ocarina from the ditch and seeing the dying soldier easter egg in the market, go talk to Saria.

If you read the topic title that you have created, it says nothing about system problems.

If you have any issues with your Garuda system, start a new topic.
This topic is answered and solved.

3 Likes