Nvidia problem Optimus

I click on Optimus and try to switch to Nvidia i get the error message .Now I'm not sure if Ive even installed my drivers correct;y ,as i have AMD as well .Thoughts please.

╰─λ paleofetch
                     .%;888:8898898:              [email protected]
                   x;XxXB%89b8:b8%b88:            -------------------------------
                .8Xxd                8X:.         OS: Garuda Linux x86_64
              .8Xx;                    8x:.       Kernel: 5.13.0-173-tkg-bmq
            .tt8x          .d            x88;     Uptime: 34 mins
         [email protected];          .db:              [email protected];
       ,tSXX°          [email protected];  Packages: 1802 (pacman)
     .SXxx            bBBBBBBBBBBBBBBBBBBBbSBX8;  Shell: bash
   ,888S                                     pd!  Resolution: 1920x1080
  8X88/                                       q   Terminal: Alacritty
  GBB.
   x%88        [email protected]@[email protected]@[email protected]@[email protected]@[email protected]@X.        CPU: AMD Ryzen 7 4800H with Radeon Graphics (16) @ 2.9GHz
     dxXd    dB8b8b8B8B08bB88b998888b88x.         Memory: 3197MiB / 15419MiB (20%)
      dxx8o                      [email protected]@;.
        dx88                   [email protected]
          d:[email protected]
            .d988999889889899dd.

╭─rob at rob-tufgamingfa506iifx506ii in ⌁
╰─λ```
1 Like

Stuffed up forgot how to post a screenshot in private bin omg i feel so stupid i can not for the life of me remember .I have googled help and the Private bin help .I still cant find this basic step.

1 Like

Can you post your

inxi -Fza

2 Likes

Thank you for your help PrivateBin

1 Like

i need the password
or post on here with ~~~ at the begining and ~~~ at the end

2 Likes
                .8Xxd                8X:.         OS: Garuda Linux x86_64
              .8Xx;                    8x:.       Kernel: 5.13.0-173-tkg-bmq
            .tt8x          .d            x88;     Uptime: 2 hours, 55 mins
         [email protected];          .db:              [email protected];
       ,tSXX°          [email protected];  Packages: 1802 (pacman)
     .SXxx            bBBBBBBBBBBBBBBBBBBBbSBX8;  Shell: bash
   ,888S                                     pd!  Resolution: 1920x1080
  8X88/                                       q   Terminal: Alacritty
  GBB.
   x%88        [email protected]@[email protected]@[email protected]@[email protected]@[email protected]@X.        CPU: AMD Ryzen 7 4800H with Radeon Graphics (16) @ 2.9GHz
     dxXd    dB8b8b8B8B08bB88b998888b88x.         Memory: 4327MiB / 15419MiB (28%)
      dxx8o                      [email protected]@;.
        dx88                   [email protected]
          d:[email protected]
            .d988999889889899dd.

╭─rob at rob-tufgamingfa506iifx506ii in ⌁
╰─λ inxi -Fza
System:
  Kernel: 5.13.2-180-tkg-bmq x86_64 bits: 64 compiler: gcc v: 11.1.0
  parameters: intel_pstate=passive BOOT_IMAGE=/@/boot/vmlinuz-linux-tkg-bmq
  root=UUID=eae5dbb5-1074-40c2-951c-63719da574c4 rw [email protected] quiet splash
  rd.udev.log_priority=3 vt.global_cursor_default=0
  systemd.unified_cgroup_hierarchy=1 loglevel=3
  Desktop: KDE Plasma 5.22.3 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1
  dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: ASUSTeK product: TUF Gaming FA506II_FX506II v: 1.0
  serial: <filter>
  Mobo: ASUSTeK model: FA506II v: 1.0 serial: <filter> UEFI: American Megatrends
  v: FA506II.309 date: 07/02/2020
Battery:
  ID-1: BAT1 charge: 36.6 Wh (98.1%) condition: 37.3/48.2 Wh (77.3%) volts: 3.9
  min: 11.9 model: ASUS A32-K55 type: Li-ion serial: N/A status: Unknown
CPU:
  Info: 8-Core model: AMD Ryzen 7 4800H with Radeon Graphics bits: 64 type: MT MCP
  arch: Zen 2 family: 17 (23) model-id: 60 (96) stepping: 1 microcode: 8600104
  cache: L2: 4 MiB
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  bogomips: 92710
  Speed: 1397 MHz min/max: 1400/2900 MHz boost: enabled Core speeds (MHz): 1: 1397
  2: 1397 3: 1397 4: 1396 5: 1397 6: 1397 7: 1397 8: 1397 9: 1397 10: 1397 11: 1397
  12: 1397 13: 1397 14: 1396 15: 1397 16: 1397
  Vulnerabilities: Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
  mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
  mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, IBRS_FW,
  STIBP: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: NVIDIA TU117M [GeForce GTX 1650 Ti Mobile] vendor: ASUSTeK driver: N/A
  alternate: nouveau bus-ID: 01:00.0 chip-ID: 10de:1f95 class-ID: 0300
  Device-2: AMD Renoir vendor: ASUSTeK driver: amdgpu v: kernel bus-ID: 05:00.0
  chip-ID: 1002:1636 class-ID: 0300
  Device-3: IMC Networks USB2.0 HD UVC WebCam type: USB driver: uvcvideo
  bus-ID: 1-4:3 chip-ID: 13d3:56a2 class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org 1.20.12 compositor: kwin_x11 driver: loaded: amdgpu
  unloaded: modesetting alternate: ati,fbdev,vesa display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
  s-diag: 582mm (22.9")
  Monitor-1: eDP res: 1920x1080 hz: 144 dpi: 142 size: 344x194mm (13.5x7.6")
  diag: 395mm (15.5")
  OpenGL: renderer: AMD RENOIR (DRM 3.41.0 5.13.2-180-tkg-bmq LLVM 12.0.0)
  v: 4.6 Mesa 21.1.4 direct render: Yes
Audio:
  Device-1: AMD vendor: ASUSTeK driver: snd_hda_intel v: kernel bus-ID: 05:00.1
  chip-ID: 1002:1637 class-ID: 0403
  Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor driver: N/A
  alternate: snd_pci_acp3x, snd_rn_pci_acp3x bus-ID: 05:00.5 chip-ID: 1022:15e2
  class-ID: 0480
  Device-3: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel
  bus-ID: 05:00.6 chip-ID: 1022:15e3 class-ID: 0403
  Sound Server-1: ALSA v: k5.13.2-180-tkg-bmq running: yes
  Sound Server-2: JACK v: 0.125.0 running: no
  Sound Server-3: PulseAudio v: 14.2 running: yes
  Sound Server-4: PipeWire v: 0.3.31 running: yes
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK
  driver: r8169 v: kernel port: e000 bus-ID: 02:00.0 chip-ID: 10ec:8168
  class-ID: 0200
  IF: enp2s0 state: down mac: <filter>
  Device-2: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter
  vendor: AzureWave driver: rtw_8822ce v: N/A modules: rtw88_8822ce port: d000
  bus-ID: 03:00.0 chip-ID: 10ec:c822 class-ID: 0280
  IF: wlp3s0 state: up mac: <filter>
Bluetooth:
  Device-1: IMC Networks Bluetooth Radio type: USB driver: btusb v: 0.8
  bus-ID: 3-1:2 chip-ID: 13d3:3548 class-ID: e001 serial: <filter>
  Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
  Local Storage: total: 476.94 GiB used: 275.2 GiB (57.7%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Kingston model: OM8PCP3512F-AB
  size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
  lanes: 4 rotation: SSD serial: <filter> rev: ECFK52.3 scheme: GPT
Partition:
  ID-1: / raw-size: 476.64 GiB size: 476.64 GiB (100.00%) used: 275.2 GiB (57.7%)
  fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 560 KiB (0.2%)
  fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
  used: 275.2 GiB (57.7%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-4: /var/log raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
  used: 275.2 GiB (57.7%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-5: /var/tmp raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
  used: 275.2 GiB (57.7%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 50 (default 100)
  ID-1: swap-1 type: zram size: 15.06 GiB used: 0 KiB (0.0%) priority: 100
  dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 50.1 C mobo: 50.0 C gpu: amdgpu temp: 49.0 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 345 Uptime: 2h 55m wakeups: 1 Memory: 15.06 GiB used: 5.88 GiB (39.1%)
  Init: systemd v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1
  Packages: pacman: 1802 lib: 533 Shell: fish v: 3.3.1 default: Bash v: 5.1.8
  running-in: alacritty inxi: 3.3.05
╭─rob at rob-tufgamingfa506iifx506ii in ⌁
╰─λ```
1 Like

Thanks for that :grinning:
Did you install nvidia drivers using system setting / hardware configuration / auto install propriety drivers

2 Likes

I think i did at the first install you mean . Is there a way to check.Thanks for your help

1 Like

you should see in hardware configuration video optimus enablled and video-nvidia-prime-render-offload enabled.

2 Likes

hmm ok i checked and i none of those are checked nothing of nvidia is checked

1 Like

in that case auto install propriety drivers
Screenshot_5

2 Likes

Ok done this dosnt look good Starting


> Using config 'video-optimus-manager' for device: 0000:05:00.0 (0300:1002:1636) Display controller ATI Technologies Inc Renoir

Error: config 'video-optimus-manager' conflicts with config(s): video-chaotic-nvidia-tkg-prime-render-offload

Done ...```   B.R.B mate Tea time
1 Like

When you tried the live usb did you try it with nvidia drivers the default live usb settings before you installed and was it working.
The reason i am asking it looks like you have fast boot enabled and secure boot enabled in your bios

2 Likes

Sorry i have no idea what i did .i made the use able usb i then installed it and i clicked on install,remove other o.s I then followed the 15 things to do after installing Garuda .so im not sure if i followed all the steps correctly at the time i was very new to linux Distros .What can you suggest please.

1 Like

Ok i would check in your bios to see fast boot and secure boot are enabled and if they are disable them.

2 Likes

OMG your awesome i think ive been having issues since day one of my first install BRB.Ok i found Fast boot it is disabled ,cant find secure boot I just found this .
On many models, there is no way to directly disable Secure Boot mode. For this reason, we will have to erase the keys that activate it from the BIOS. Don’t worry, you can always reverse this process and enable Secure Boot without any issues. You will also not void the warranty by disabling or enabling Secure Boot.

2 Likes

Yes its ok to do that.
Then double check they are still disabled.
When done just reinstall and you should be good to go

2 Likes

In the boot menu i see Garuda kingston and uefi its on the Garuda kingston as boot first is that right .Like i said i cant see the secure boot option

1 Like

sorry check bios and set to uefi boot only
Then reinstall garuda

2 Likes

reinstall farout really .from the usb .I will lose all my documents ?its boot option 1 UEFI

1 Like