NVIDIA-DKMS-performance 470.57.02-1 problem

Hello all. Im using Garuda KDE. I have issue with this driver as tittle says. Issues are: Horizon Zero Dawn crash on Linux-tkg-pds kernel and on Linux-xanmod-git its start but after loading save on half it start to use high amount of RAM almost all 16GBs and after some time it crash or freeze my comp and I need to restart it its same on ZEN kernel and now I cant play HZD, on Nvidia driver 465 my RAM usage was nearly half of 16GB. PLS help. THX
And with Mass Effect Legendary Edition when I start the game on launcher only shows this:

Here is my inxi:

System: Kernel: 5.13.4-xanmod1-1-git+ x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-xanmod-git root=UUID=7fc014f4-e4fb-4efc-af71-263c81b35d51 rw
[email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3 nvidia-drm.modeset=1
Desktop: KDE Plasma 5.22.3 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine: Type: Desktop Mobo: ASUSTeK model: PRIME A320M-K v: Rev X.0x serial: UEFI: American Megatrends v: 5602
date: 07/14/2020
CPU: Info: 8-Core model: AMD Ryzen 7 2700X bits: 64 type: MT MCP arch: Zen+ family: 17 (23) model-id: 8 stepping: 2
microcode: 800820D cache: L2: 4 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 118164
Speed: 2598 MHz min/max: 2200/3700 MHz boost: disabled Core speeds (MHz): 1: 2598 2: 3177 3: 2468 4: 2433 5: 2903
6: 2493 7: 2468 8: 3693 9: 2438 10: 2449 11: 2687 12: 2631 13: 2537 14: 3687 15: 3530 16: 3026
Vulnerabilities: Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: disabled, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics: Device-1: NVIDIA GP104 [GeForce GTX 1080] vendor: Micro-Star MSI driver: nvidia v: 470.57.02
alternate: nvidiafb,nouveau,nvidia_drm bus-ID: 07:00.0 chip-ID: 10de:1b80 class-ID: 0300
Display: x11 server: X.Org 1.20.12 compositor: kwin_x11 driver: loaded: nvidia display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 42 s-size: 1161x653mm (45.7x25.7") s-diag: 1332mm (52.4")
Monitor-1: HDMI-0 res: 1920x1080 hz: 60 dpi: 69 size: 708x398mm (27.9x15.7") diag: 812mm (32")
OpenGL: renderer: NVIDIA GeForce GTX 1080/PCIe/SSE2 v: 4.6.0 NVIDIA 470.57.02 direct render: Yes
Audio: Device-1: NVIDIA GP104 High Definition Audio vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus-ID: 07:00.1
chip-ID: 10de:10f0 class-ID: 0403
Device-2: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel
bus-ID: 09:00.3 chip-ID: 1022:1457 class-ID: 0403
Sound Server-1: ALSA v: k5.13.4-xanmod1-1-git+ running: yes
Sound Server-2: JACK v: 0.125.0 running: no
Sound Server-3: PulseAudio v: 14.2 running: yes
Sound Server-4: PipeWire v: 0.3.32 running: yes
Network: Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK PRIME B450M-A driver: r8169
v: kernel port: f000 bus-ID: 05:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac:
Drives: Local Storage: total: 4.77 TiB used: 3.07 TiB (64.3%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Biostar model: S100-240GB size: 223.57 GiB block-size: physical: 512 B
logical: 512 B speed: 6.0 Gb/s rotation: SSD serial: rev: V4.9 scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: Western Digital model: WD10EZEX-75M2NA0 size: 931.51 GiB block-size:
physical: 4096 B logical: 512 B speed: 6.0 Gb/s rotation: 7200 rpm serial: rev: 1A01 scheme: MBR
ID-3: /dev/sdc maj-min: 8:32 vendor: Toshiba model: HDWE140 size: 3.64 TiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s rotation: 7200 rpm serial: rev: FP1R scheme: GPT
Partition: ID-1: / raw-size: 116.3 GiB size: 116.3 GiB (100.00%) used: 45.59 GiB (39.2%) fs: btrfs dev: /dev/sda5 maj-min: 8:5
ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%) used: 576 KiB (0.1%) fs: vfat dev: /dev/sda4 maj-min: 8:4
ID-3: /home raw-size: 465.76 GiB size: 457.38 GiB (98.20%) used: 344.47 GiB (75.3%) fs: ext4 dev: /dev/sdb2
maj-min: 8:18
ID-4: /var/log raw-size: 116.3 GiB size: 116.3 GiB (100.00%) used: 45.59 GiB (39.2%) fs: btrfs dev: /dev/sda5
maj-min: 8:5
ID-5: /var/tmp raw-size: 116.3 GiB size: 116.3 GiB (100.00%) used: 45.59 GiB (39.2%) fs: btrfs dev: /dev/sda5
maj-min: 8:5
Swap: Kernel: swappiness: 133 (default 60) cache-pressure: 50 (default 100)
ID-1: swap-1 type: zram size: 15.56 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0
Sensors: System Temperatures: cpu: 37.8 C mobo: N/A gpu: nvidia temp: 37 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 64%
Info: Processes: 398 Uptime: 18m wakeups: 0 Memory: 15.57 GiB used: 3.61 GiB (23.2%) Init: systemd v: 249 tool: systemctl
Compilers: gcc: 11.1.0 Packages: 1511 pacman: 1466 lib: 416 flatpak: 30 snap: 15 Shell: Zsh v: 5.8
running-in: konsole inxi: 3.3.05

Try as many kernels as you can.

I tried, and result is same. On some is RAM usage like i described in my post and on some HZD crash on startup...

Please edit your thread title as begging for help in all caps is frowned upon on the Garuda forum. If you have created a thread in the "Issues & Assistance" sub-forum it is already understood that you are asking for help. Posting "PLEASE HELP" in your thread title is not only redundant, but comes off as begging for help. It is also degrading to other users and their help requests, as it intimates your request is "MORE IMPORTANT".

Please do not use all caps on the forum as a method to beg for help.

5 Likes

As far as I know games like these generate shaders after every drivers update on first run. And HZD specifically eats all the ram when it generates shaders so I think the solution is to first delete existing shaders.
There was a update in hzd which allowed tweaking of how shaders were generated pls change stuff there specially generate shaders during game so this will not fill the ram with all shaders
And finally if it doesn't work and u know how to limit ram do it so it doesn't crash ur system and it will manage the rest own its own

That is intended(In most cases ) because of a method garuda uses to speed up your PC as unused ram is wasted ram. Have you tried using the Nvidia-all drivers

1 Like

Ill try that.

I didnt had RAM usage problem with nvidia driver version 465, that problem arise when nvidia-dkms got updated to version 470... And yeah I tried nvidia-all version 470 and problem was the same. So I installed nvidia-all 465 driver coz I can only find version 465 in nvidia-all. I can see that its not only me that having the same problem with v470 drivers, I saw someone with Kubuntu reported on github exactly the same problem... Ill try to delete my prefix and fresh start HZD like TikZSZ one post above suggested... But I think its not gonna fix it.

Edit: Btw its not main problem RAM its that HZD crash on some kernels and on some it start but it crash coz of high of RAM usage which I didnt had with nvidia driver v465

Edit2: So I tried what TikZSZ suggested, and even reinstalled the game, Its same result with Nvidia v470 driver...

Try my guide for nvidia-all

1 Like

Thx for reply. I already tried that yesterday. I installed nvidia-all 470 series: 470.57.02 without success, result is the same with that driver. I think its or Driver or Kernels which need to be patched for that driver version... Thats my guess.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.