Nvidia DKMS failed to build

Hello Garuda users.

When I am updating the system this error is presented to me at the bottom of update konsole output:

--> A problem with the NVIDIA drivers has been detected

---> Building NVIDIA DKMS module for kernel 6.1.12-arch1-1
Module nvidia 525.89.02 is not installed for kernel 6.1.12-arch1-1 (x86_64). Skipping...
Module nvidia 525.89.02 is not built for kernel 6.1.12-arch1-1 (x86_64). Skipping...
Sign command: /usr/lib/modules/6.1.12-arch1-1/build/scripts/sign-file
Binary /usr/lib/modules/6.1.12-arch1-1/build/scripts/sign-file not found, modules won't be signed
Error! Your kernel headers for kernel 6.1.12-arch1-1 cannot be found at /usr/lib/modules/6.1.12-arch1-1/build or /usr/lib/modules/6.1.12-arch1-1/source.
Please install the linux-headers-6.1.12-arch1-1 package or use the --kernelsourcedir option to tell DKMS whereit's located.
---> Failed to build NVIDIA DKMS module for kernel 6.1.12-arch1-1

System updated! 🐧

It is suggesting me that I should install linux some linux headers but I don't know if that is the right approach as I am using zen-linux kernel and I have headers for it installed. Also I tried to forse reinstall the drivers with mhwd but it fails as there are packages dependent on this driver. So I tried to install another nvidia driver (video-nvidia-470xx-dkms) but it also fails because config 'video-nvidia-470xx-dkms' conflicts with config(s): video-nvidia-dkms. Please hyelp me how should I handle this error? Also I am a little bit scared to turn off the computer now.

My garuda-inxi:

Kernel: 6.1.6-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=67ff22b8-b895-4fc8-8a44-b341923d92c8 rw [email protected]
amd_iommu=on iommu=pt iommu=1 quiet splash rd.udev.log_priority=3
vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1 loglevel=3
nouveau.modeset=0 ibt=off
Desktop: KDE Plasma v: 5.27.1 tk: Qt v: 5.15.8 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Desktop Mobo: ASRock model: B450 Gaming K4
serial: <superuser required> BIOS: American Megatrends v: P5.00
date: 05/10/2021
Info: model: AMD Ryzen 5 3600 bits: 64 type: MT MCP arch: Zen 2 gen: 3
level: v3 note: check built: 2020-22 process: TSMC n7 (7nm)
family: 0x17 (23) model-id: 0x71 (113) stepping: 0 microcode: 0x8701021
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
L3: 32 MiB desc: 2x16 MiB
Speed (MHz): avg: 3627 high: 3935 min/max: 2200/4208 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 3935 2: 3600
3: 3600 4: 3600 5: 3600 6: 3600 7: 3600 8: 3600 9: 3600 10: 3600 11: 3600
12: 3600 bogomips: 86397
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Device-1: NVIDIA GP104 [GeForce GTX 1070] vendor: ASUSTeK driver: nvidia
v: 525.78.01 alternate: nouveau,nvidia_drm non-free: 525.xx+
status: current (as of 2023-02) arch: Pascal code: GP10x
process: TSMC 16nm built: 2016-21 pcie: gen: 1 speed: 2.5 GT/s lanes: 16
link-max: gen: 3 speed: 8 GT/s bus-ID: 0a:00.0 chip-ID: 10de:1b81
class-ID: 0300
Display: x11 server: X.Org v: 21.1.6 with: Xwayland v: 22.1.8
compositor: kwin_x11 driver: X: loaded: nvidia gpu: nvidia display-ID: :0
screens: 1
Screen-1: 0 s-res: 3840x1080 s-dpi: 81 s-size: 1204x343mm (47.40x13.50")
s-diag: 1252mm (49.29")
Monitor-1: DP-0 pos: primary,left res: 1920x1080 dpi: 82
size: 598x336mm (23.54x13.23") diag: 686mm (27.01") modes: N/A
Monitor-2: HDMI-0 pos: right res: 1920x1080 hz: 60 dpi: 96
size: 509x286mm (20.04x11.26") diag: 584mm (22.99") modes: N/A
API: OpenGL v: N/A renderer: N/A direct-render: N/A
Device-1: NVIDIA GP104 High Definition Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 16
link-max: gen: 3 speed: 8 GT/s bus-ID: 0a:00.1 chip-ID: 10de:10f0
class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: ASRock
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 0c:00.4 chip-ID: 1022:1487 class-ID: 0403
Sound API: ALSA v: k6.1.6-zen1-1-zen running: yes
Sound Interface: sndio v: N/A running: no
Sound Server-1: JACK v: 1.9.22 running: no
Sound Server-2: PulseAudio v: 16.1 running: yes
Sound Server-3: PipeWire v: 0.3.66 running: yes
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: ASRock driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
port: f000 bus-ID: 09:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp9s0 state: up speed: 100 Mbps duplex: full mac: <filter>
IF-ID-1: docker0 state: down mac: <filter>
IF-ID-2: virbr0 state: down mac: <filter>
Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) type: USB
driver: btusb v: 0.8 bus-ID: 1-6:3 chip-ID: 0a12:0001 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Local Storage: total: 2.73 TiB used: 769.95 GiB (27.6%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
model: WDS100T2B0C-00PXH0 size: 931.51 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 211070WD temp: 45.9 C scheme: MBR
ID-2: /dev/sda maj-min: 8:0 vendor: Western Digital
model: WD20EZRZ-00Z5HB0 size: 1.82 TiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter>
rev: 0A80 scheme: MBR
ID-1: / raw-size: 869.14 GiB size: 869.14 GiB (100.00%)
used: 769.95 GiB (88.6%) fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:1
ID-2: /home raw-size: 869.14 GiB size: 869.14 GiB (100.00%)
used: 769.95 GiB (88.6%) fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /var/log raw-size: 869.14 GiB size: 869.14 GiB (100.00%)
used: 769.95 GiB (88.6%) fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:1
ID-4: /var/tmp raw-size: 869.14 GiB size: 869.14 GiB (100.00%)
used: 769.95 GiB (88.6%) fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:1
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 31.27 GiB used: 963.2 MiB (3.0%)
priority: 100 dev: /dev/zram0
System Temperatures: cpu: 39.5 C mobo: 36.0 C gpu: nvidia temp: 53 C
Fan Speeds (RPM): fan-1: 0 fan-2: 0 fan-3: 420 fan-4: 428 fan-5: 0
gpu: nvidia fan: 0%
Power: 12v: N/A 5v: N/A 3.3v: 3.33 vbat: 3.26
Processes: 388 Uptime: 2h 38m wakeups: 0 Memory: 31.27 GiB
used: 9.38 GiB (30.0%) Init: systemd v: 253 default: graphical
tool: systemctl Compilers: gcc: 12.2.1 alt: 11 clang: 15.0.7 Packages:
pm: pacman pkgs: 2272 libs: 578 tools: pamac,paru,yay Shell: fish v: 3.6.0
default: Zsh v: 5.9 running-in: konsole inxi: 3.3.25
Garuda (2.6.15-1):
System install date:     2021-06-12
Last full system update: 2023-02-25 ↻
Is partially upgraded:   No
Relevant software:       timeshift NetworkManager mkinitcpio nvidia-dkms
Windows dual boot:       <superuser required>
Failed units:            bluetooth-autoconnect.service systemd-guest-user.service
1 Like

The log is very very clear... Your kernel headers for kernel 6.1.12-arch1-1 cannot be found... it's talking about the linux package, no linux-zen. Just install linux-headers and that's all.


Thanks for the quick response. I installed the headers and error disappeared. Unfortunately My terminal has a white background now :smiley:

Is there some fancy trick how to reset terminal appearance settings back to the default garuda drakonized look? I know I can change it in the settings of terminal but I am not sure how is it set by default anymore.

that is because the theme is missing.

Again, you are better off restoring a snapshot or reinstalling. Apparently 99% of your garuda configuration is wiped. It's a bad idea to even continue trying to install stuff

I restored it. I mentioned it in previous thread (Different issue as this one). After the restoration everything looked all right. Just after the update (and removing of completly unrelated package pocketsphinx to be able to update the system) I saw the nvidia error for the first time. So the restoration isn't helping as I would have to keep my system unupdated to bypass this issue. Could it be removed in the process of updating as result of conflict? Also I think it is worth mentioning that because of timeout errors I have to update the system a few times before it is able to go through all the packages without errors.

regarding the timeouts: I think you disabled mirror refreshing in garuda-update. Refresh the mirrors via the garuda assistant.

The solution to the nvidia issue should be the one stated above.

Your theme disappearing indicates that something got removed while upgrading your system. While garuda-update deals with these kind of issues automatically, I fear that something was done wrong here.

Could you show us the log from your update that caused this issue? (I hope garuda-update does not just hide the replace-prompts) You can find the logs in /var/log/garuda/.

This is what I was able to find in /var/log/garuda/ from today. There was also a 3 attempts to update before this one. This one is the first that went through without errors. Others failed on timeout.

This happened to someone else too, you can just change it back in the Konsole settings.

1 Like

Yes I know how to edit the appearance color schemes. The thing is that I don't know is what is the default garuda setting. None of my color schemes is transparent. I know that it is transparent in default garuda.

If no one knows the exact setting and there is no option to revert it to the default. Maybe someone could share content of his ~/.local/share/konsole?

The default color scheme is called "Sweet".

It has a pre-set background color transparency value of 35%.


Thanks, I must have missed this one. I switched to sweet color scheme and everything is back to normal. Thanks for the help :slight_smile: and have a great day

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.