Not able to install Garuda Linux

After extraction using Rufus in usb. When boot to my usb it's says welcome to grub. Then i click boot garuda it's boot to black screen and nothing happens after that. I waited for more than 30 mins. No result. I tried nomodeset but it's take me to three dots with grey BG and again nothing.

Use free driver, click on driver=nofree to choose.

and

:slight_smile:

Click ESC mhwd needs sometime 2:46 min.

It again gives me nothing. Black screen only I am using AMD RADEON R5 GRAPHICS, AMD A9 PROCESSOR, 4GB RAM, 1 TB HDD. UEFI GPT MODE

Read

Very new Hardware?
Dual boot?
BIOS secure and fast boot off?

1 Like

No I think it's old but not much u can medium.
Yes dual boot.
Yes both off

Ok I got it. With nomodeset using free driver

Okay, sorry it's still not solved. Garuda booting was started but it's stuck while it was loading for a long time then just pressed Alt+Ctrl+Dlt. It's started again. And again followed my previous steps but it got back to it's previous error. Three dots with grey background. And nothing after that.

Read Reporting bugs,

Which ISO you use? full name, please.

Did you check sha sum?

Use balena etcher!!!

1 Like

I am using garuda-dr460nized-gaming linux-tkg-bmq-210102.iso

I have used balena etcher already. It's fine me the same error

Try last one, seems it was fixed.

https://builds.garudalinux.org/iso/garuda/dr460nized-gaming/210107/

1 Like

I am trying last one method but now to this is happening.

I call @dr460nf1r3 :slight_smile: I am out of knowledge.

2 Likes

Well we have almost 0 logs here so thats really hard to debug..
Can you switch TTY when this screen happens? (ctrl + alt + f3) If yes, login with garuda/garuda and type startx afterwards. I read some reports on SDDM not being able to startup while having a quick search

3 Likes

I would suggest using balena Etcher, a free Windows utility you can download from here, and re-write the ISO to USB.

"Do not use Rufus to flash the ISO."

regards

2 Likes

I have already tried balena etcher it gives me the same result.
No I am not able to switch TTY.
Any other solutions?

I have tried unnetbootin but it is having me the same black screen.


Now it is getting freezed here. Using nomodeset with free driver.

Unnetbootin is not recommended for use with Garuda.

You could try using the dd command to create you boot disk.

You could also try one of the barebones editions just to see if the LTS kernel used on those editions works for you. Unfortunately, those editions really aren't intended for new users that aren't very familiar with installing their own system from a very sparse Arch base.

This method will at least tell you if the kernel is your primary problem.

1 Like

Actually this isnt the case anymore, forgot to build it with a non-standart kernel :sweat_smile:
But ill start a build with LTS kernel now, just to see if it helps in this case.

I wasn't 100% sure if the LTS was still being used on the barebones editions, but I hadn't heard anything about it being dropped either.

That would be great if you'd rebuild the barebones editions with the LTS kernel again. With the issues some people are having with the recent kernel change it would be a good alternative to have again even if just for troubleshooting.

Thanks for all your efforts.

Its ready in a few minutes, hopefully it helps :slight_smile:

1 Like

ok so now I m here after using Alt+Ctrl+f4
I logged in what next.