Not able to change the color profile

The colors looked a bit more saturated than usual, i had the same issue in manjaro(gnome) too but i was able to fix it by unticking the checkbox in the screenshot below but here it says that gnome color management is required but i tried installing the gnome-color-manager and it was still the same even after rebooting. I even tried installing colord-kde but still nothing. Can anyone tell me the fix?

Whats bad with a bit more saturated colors than usual?

As always, read

please
and post

inxi -Fxxxza

as text! Even if you personally think it is unnecessary.

and
:slight_smile:

Maybe you need to calibrate you monitor (if possible). I have many settings in my ASUS monitor.

4 Likes
inxi -Fxxxza

the output:

System:  Kernel: 5.11.12-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 10.2.0 
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=2b3f5a85-c7ce-4004-883e-1b3dac3e28b6 
rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 
systemd.unified_cgroup_hierarchy=1 loglevel=3 
Desktop: KDE Plasma 5.21.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM 
Distro: Garuda Linux base: Arch Linux 

Machine:  Type: Laptop System: LENOVO product: 80XH v: Lenovo ideapad 320-15ISK serial: <filter> Chassis: 
type: 10 v: Lenovo ideapad 320-15ISK serial: <filter> 
Mobo: LENOVO model: LNVNB161216 v: SDK0J40688 WIN serial: <filter> UEFI: LENOVO v: 4WCN29WW 
date: 09/30/2017 

Battery:   ID-1: BAT0 charge: 15.0 Wh (100.0%) condition: 15.0/35.0 Wh (42.9%) volts: 8.4 min: 7.6 
model: LGC L16L2PB3 type: Li-poly serial: <filter> status: Full 

CPU: Info: Dual Core model: Intel Core i3-6006U bits: 64 type: MT MCP arch: Skylake family: 6 
model-id: 4E (78) stepping: 3 microcode: E2 cache: L2: 3 MiB 
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 15999 
Speed: 2000 MHz min/max: 400/2000 MHz Core speeds (MHz): 1: 2000 2: 2000 3: 2000 4: 1809 
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
Type: meltdown mitigation: PTI 
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
Type: spectre_v2 
mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
Type: srbds mitigation: Microcode 
Type: tsx_async_abort status: Not affected 

Graphics:  Device-1: Intel HD Graphics 520 vendor: Lenovo driver: i915 v: kernel bus-ID: 00:02.0 
chip-ID: 8086:1921 class-ID: 0300 
Device-2: NVIDIA GM108M [GeForce 920MX] vendor: Lenovo driver: nouveau v: kernel 
bus-ID: 01:00.0 chip-ID: 10de:134f class-ID: 0302 
Device-3: Acer EasyCamera type: USB driver: uvcvideo bus-ID: 1-8:4 chip-ID: 5986:210f 
class-ID: 0e02 
Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: loaded: intel,nouveau 
unloaded: modesetting alternate: fbdev,nv,vesa display-ID: :0 screens: 1 
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9") 
Monitor-1: eDP1 res: 1920x1080 hz: 60 dpi: 143 size: 340x190mm (13.4x7.5") diag: 389mm (15.3") 
OpenGL: renderer: Mesa Intel HD Graphics 520 (SKL GT2) v: 4.6 Mesa 21.0.2 direct render: Yes 

Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: Lenovo driver: snd_hda_intel v: kernel 
alternate: snd_soc_skl bus-ID: 00:1f.3 chip-ID: 8086:9d70 class-ID: 0403 
Sound Server-1: ALSA v: k5.11.12-zen1-1-zen running: yes 
Sound Server-2: JACK v: 0.125.0 running: no 
Sound Server-3: PulseAudio v: 14.2 running: yes 
Sound Server-4: PipeWire v: 0.3.25 running: yes 

Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Lenovo driver: r8169 
v: kernel port: 3000 bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200 
IF: enp2s0 state: down mac: <filter> 
Device-2: Intel Dual Band Wireless-AC 3165 Plus Bluetooth driver: iwlwifi v: kernel port: 3000 
bus-ID: 03:00.0 chip-ID: 8086:3166 class-ID: 0280 
IF: wlp3s0 state: up mac: <filter> 

Bluetooth: Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8 bus-ID: 1-7:3 
chip-ID: 8087:0a2a class-ID: e001 
Report: ID: hci0 state: down bt-service: enabled, running address: <filter> 

RAID:      Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci v: 3.0 port: 5060 
bus-ID: 00:17.0 chip-ID: 8086.282a rev: 21 class-ID: 0104 

Drives:    Local Storage: total: 931.51 GiB used: 14.63 GiB (1.6%) 
SMART Message: Unable to run smartctl. Root privileges required. 
ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000LM035-1RK172 size: 931.51 GiB
block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter>
rev: LCM2 scheme: GPT

Partition: ID-1: / raw-size: 93.2 GiB size: 93.2 GiB (100.00%) used: 14.63 GiB (15.7%) fs: btrfs
dev: /dev/sda10 maj-min: 8:10
ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%) used: 560 KiB (0.1%) fs: vfat
dev: /dev/sda8 maj-min: 8:8
ID-3: /home raw-size: 93.2 GiB size: 93.2 GiB (100.00%) used: 14.63 GiB (15.7%) fs: btrfs
dev: /dev/sda10 maj-min: 8:10
ID-4: /var/log raw-size: 93.2 GiB size: 93.2 GiB (100.00%) used: 14.63 GiB (15.7%) fs: btrfs
dev: /dev/sda10 maj-min: 8:10
ID-5: /var/tmp raw-size: 93.2 GiB size: 93.2 GiB (100.00%) used: 14.63 GiB (15.7%) fs: btrfs
dev: /dev/sda10 maj-min: 8:10

Swap:      Kernel: swappiness: 10 (default 60) cache-pressure: 75 (default 100)
ID-1: swap-1 type: partition size: 3.95 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sda9
maj-min: 8:9
ID-2: swap-2 type: zram size: 1.89 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram0
ID-3: swap-3 type: zram size: 1.89 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram1
ID-4: swap-4 type: zram size: 1.89 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram2
ID-5: swap-5 type: zram size: 1.89 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram3

Sensors:   System Temperatures: cpu: 51.5 C mobo: N/A
Fan Speeds (RPM): N/A

Info: Processes: 240 Uptime: 1h 49m wakeups: 1 Memory: 7.55 GiB used: 3.65 GiB (48.3%) Init: systemd
v: 248 tool: systemctl Compilers: gcc: 10.2.0 clang: 11.1.0 Packages: pacman: 1339 lib: 340
Shell: fish v: 3.2.1 running-in: konsole inxi: 3.3.03

There is no Nvidia driver installed, but I am not an expert for Notebooks with two GPU.

Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: loaded: intel,nouveau 
unloaded: modesetting alternate: fbdev,nv,vesa display-ID: :0 screens: 1 
3 Likes

It is supposed to be used to calibrate or create a custom profile. Have you used it? (I guess it may need Gnome, but maybe not...

You may get a proper profile from other OSes, if you multiboot.
Check the linked article for your options.

If your issue is not application specific, I think it might be because of GPU drivers configuration.
Look up in Intel and Nouveau archwiki topics for possible troubleshooting.

Since ICC is used from specific apps (not all), try starting relevant apps that use them and also try starting them with DRI_PRIME=1 (to use nouveau) comparing appearance.

3 Likes

Yeah i did install them later but nothing the NVIDIA drivers for notebooks doesn't provide this feature.

You may get a proper profile from other OSes 2, if you multiboot.
Check the linked article for your options.

Thanx for the help, I tried importing them but it said that it was already imported, but that's not the issue, i have the other ones too but i cannot install them just like it is in the screenshot above. Anyways you could get a trick to untick that checkbox please share.

Read the rest of my post.
Don't stick on what you think you need.
Find what you actually need.

2 Likes

That BIOS is dated 2017. Is there a more recent one available?

3 Likes