Not able to boot after update

Hi all,
I updated the system after approx 3 weeks (as usual) using the command: garuda-update. Usually, once it's done I reboot the system.
This time it stuck at "loading ramdisk".
Note: I am using Zen kernel.

After some searching, I tried the following options :

  1. I guess Garuda migrations removed splash but 2 quiet words were not removed from Grub, so removed them and tried.
  2. Boot using LTS kernel.

Both did not work.
When booting using the LTS kernel after the update I get the following error.

Some forums were saying that it was a bug in Plymouth but I do not see Plymouth in the list of packages getting updated.

Here is the list of packages being updated using garuda-update:

Packages (177) abseil-cpp-20230125.3-2  alsa-card-profiles-1:0.3.76-2  beautyline-1:20230729-1
bind-9.18.17-1  binutils-2.41-3  bluedevil-1:5.27.7-1  brave-bin-1:1.56.14-1  breeze-5.27.7-1
btrfs-progs-6.3.3-1  ca-certificates-mozilla-3.92-1  candy-icons-git-r1033.f78e4e7-1
curl-8.2.1-1  device-mapper-2.03.22-1  docker-1:24.0.5-1  electron25-25.3.2-1  exa-0.10.1-8
fmt-10.0.0-1  garuda-dr460nized-3.0.6-1  gcc-13.2.1-3  gcc-libs-13.2.1-3  git-2.41.0-2
glibc-2.38-2  glslang-12.3.1-2  gmp-6.3.0-1  go-2:1.20.7-1  gspell-1.12.2-1
gst-plugin-pipewire-1:0.3.76-2  gupnp-1:1.6.5-1  harfbuzz-8.1.1-1  harfbuzz-icu-8.1.1-1
highway-1.0.5-1  hyprland-nvidia-git-0.27.2.r65.g5c50fac9-1  icaclient-
imagemagick-  kactivitymanagerd-5.27.7-1  kde-cli-tools-5.27.7-1
kde-gtk-config-5.27.7-1  kdecoration-5.27.7-1  kdeplasma-addons-5.27.7-1  khotkeys-5.27.7-1
kinfocenter-5.27.7-1  kirigami-addons-0.10.0-1  kmenuedit-5.27.7-1  kpipewire-5.27.7-1
kscreen-5.27.7-1  kscreenlocker-5.27.7-1  ksystemstats-5.27.7-1  kwallet-5.108.0-2
kwallet-pam-5.27.7-1  kwayland-integration-5.27.7-1  kwin-5.27.7-1  layer-shell-qt-5.27.7-1
lib32-curl-8.2.1-1  lib32-gcc-libs-13.2.1-3  lib32-glibc-2.38-2  lib32-harfbuzz-8.1.1-1
lib32-libcurl-compat-8.2.1-1  lib32-libcurl-gnutls-8.2.1-1  lib32-libpipewire-1:0.3.76-1
lib32-libva-2.19.0-1  lib32-libva-mesa-driver-1:23.1.5-1  lib32-llvm-libs-15.0.7-3
lib32-mesa-1:23.1.5-1  lib32-mesa-vdpau-1:23.1.5-1  lib32-nss-3.92-1  lib32-openssl-1:3.1.2-1
lib32-openssl-1.1-1.1.1.v-1  lib32-pipewire-1:0.3.76-1  lib32-pipewire-jack-1:0.3.76-1
lib32-systemd-254-1  lib32-vulkan-intel-1:23.1.5-1  lib32-vulkan-mesa-layers-1:23.1.5-1
lib32-vulkan-radeon-1:23.1.5-1  lib32-xz-5.4.4-1  libarchive-3.7.1-1  libcamera-0.1.0-1
libcamera-ipa-0.1.0-1  libcurl-compat-8.2.1-1  libcurl-gnutls-8.2.1-1  libelf-0.189-3
libgit2-1:1.7.0-3  libimagequant-4.2.0-1  libkscreen-5.27.7-1  libksysguard-5.27.7-1
libmfx-23.2.2-2  libpipewire-1:0.3.76-2  libplacebo-5.264.1-2  libsysprof-capture-3.48.0-4
libtool-2.4.7+4+g1ec8fa28-6  libva-mesa-driver-1:23.1.5-1  libva-utils-2.19.0-1
licenses-20230729-1  linux-api-headers-6.4-1  linux-firmware-20230625.ee91452d-5
linux-firmware-whence-20230625.ee91452d-5  linux-lts-6.1.39-3  linux-lts-headers-6.1.39-3
linux-zen-6.4.8.zen1-1  linux-zen-headers-6.4.8.zen1-1  lsb-release-2.0.r53.a86f885-1
luajit-2.1.0.beta3.r493.g8635cbab-1  lvm2-2.03.22-1  mesa-1:23.1.5-1  mesa-vdpau-1:23.1.5-1
milou-5.27.7-1  mpfr-4.2.0.p12-3  mpv-1:0.36.0-1  neovim-0.9.1-3  noto-fonts-1:23.8.1-1
noto-fonts-cjk-20220126-2  nss-3.92-1  obsidian-1.3.7-1  openexr-3.1.10-1  openssl-3.1.2-1
oxygen-sounds-5.27.7-1  perl-file-listing-6.16-1  pipewire-1:0.3.76-2
pipewire-alsa-1:0.3.76-2  pipewire-audio-1:0.3.76-2  pipewire-jack-1:0.3.76-2
pipewire-pulse-1:0.3.76-2  pipewire-v4l2-1:0.3.76-2  pipewire-x11-bell-1:0.3.76-2
pipewire-zeroconf-1:0.3.76-2  plasma-browser-integration-5.27.7-1  plasma-desktop-5.27.7-1
plasma-firewall-5.27.7-1  plasma-integration-5.27.7-1  plasma-nm-5.27.7-1  plasma-pa-5.27.7-1
plasma-systemmonitor-5.27.7-1  plasma-thunderbolt-5.27.7-1  plasma-wayland-session-5.27.7-1
plasma-workspace-5.27.7-1  polkit-123-1  polkit-kde-agent-5.27.7-1  powerdevil-5.27.7-1
pyenv-2.3.23-1  python-cairo-1.24.0-1  python-chardet-5.2.0-1  python-markdown-3.4.4-1
python-pyqt5-sip-12.12.2-1  qca-qt5-2.3.7-1  qt5-base-5.15.10+kde+r145-1
rate-mirrors-0.16.4-1  rubberband-3.3.0-1  sddm-kcm-5.27.7-1  seatd-0.8.0-1  shaderc-2023.4-1
smartmontools-7.4-1  spdlog-1.11.0-3  starship-1.16.0-1  strongswan-5.9.11-1  sudo-1.9.14.p3-1
systemd-254-1  systemd-libs-254-1  systemd-sysvcompat-254-1  systemsettings-5.27.7-1
tar-1.35-1  telegram-desktop-4.8.10-1  thin-provisioning-tools-1.0.5-1  unrar-1:6.2.10-1
visual-studio-code-bin-1.80.2-1  vulkan-intel-1:23.1.5-1  vulkan-mesa-layers-1:23.1.5-1
vulkan-radeon-1:23.1.5-1  vulkan-swrast-1:23.1.5-1  waybar-hyprland-git-0.9.20.r61.g94c34a29-1
webkit2gtk-2.40.5-1  whois-5.5.18-1  xdg-desktop-portal-hyprland-git-1:r288.af539f4-1
xdg-desktop-portal-kde-5.27.7-1  xfsprogs-6.4.0-1  xxhash-0.8.2-1  xz-5.4.4-1  yay-12.1.2-1

Total Download Size:    277.97 MiB
Total Installed Size:  5098.04 MiB
Net Upgrade Size:        -1.57 MiB
Kernel: 6.4.4-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.1.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=4416ced6-42d0-4882-8f60-32cb1db5f37f rw rootflags=subvol=@
quiet quiet rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
nvidia-drm.modeset=1 ibt=off
Desktop: KDE Plasma v: 5.27.6 tk: Qt v: 5.15.10 wm: kwin_wayland vt: 1
dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Laptop System: Acer product: Nitro AN515-52 v: V1.28
serial: <superuser required>
Mobo: CFL model: Freed_CFS v: V1.28 serial: <superuser required>
UEFI: Insyde v: 1.28 date: 08/05/2019
ID-1: BAT1 charge: 30.9 Wh (100.0%) condition: 30.9/48.9 Wh (63.1%)
volts: 16.3 min: 15.2 model: LG PABAS0241231 type: Li-ion serial: <filter>
status: full
Info: model: Intel Core i7-8750H bits: 64 type: MT MCP arch: Coffee Lake
gen: core 8 level: v3 note: check built: 2018 process: Intel 14nm family: 6
model-id: 0x9E (158) stepping: 0xA (10) microcode: 0xF2
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB
L3: 9 MiB desc: 1x9 MiB
Speed (MHz): avg: 3834 high: 4005 min/max: 800/4100 scaling:
driver: intel_pstate governor: powersave cores: 1: 4000 2: 3998 3: 2200
4: 4005 5: 4000 6: 4004 7: 4001 8: 3922 9: 3989 10: 3900 11: 3999 12: 4001
bogomips: 52799
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630]
vendor: Acer Incorporated ALI driver: i915 v: kernel arch: Gen-9.5
process: Intel 14nm built: 2016-20 ports: active: eDP-1 empty: none
bus-ID: 0000:00:02.0 chip-ID: 8086:3e9b class-ID: 0300
Device-2: NVIDIA GP107M [GeForce GTX 1050 Ti Mobile]
vendor: Acer Incorporated ALI driver: nvidia v: 535.86.05
alternate: nouveau,nvidia_drm non-free: 535.xx+
status: current (as of 2023-07) arch: Pascal code: GP10x
process: TSMC 16nm built: 2016-21 ports: active: none off: HDMI-A-1
empty: none bus-ID: 0000:01:00.0 chip-ID: 10de:1c8c class-ID: 0300
Device-3: Quanta HD Webcam driver: uvcvideo type: USB rev: 2.0
speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-5:3 chip-ID: 0408:a060
class-ID: 0e02 serial: <filter>
Display: wayland server: v: with: Xwayland v: 23.1.2
compositor: kwin_wayland driver: X: loaded: modesetting,nvidia
unloaded: nouveau alternate: fbdev,intel,nv,vesa dri: iris
gpu: i915,nvidia d-rect: 3840x1080 display-ID: 0
Monitor-1: HDMI-A-1 pos: right res: 1920x1080 size: N/A modes: N/A
Monitor-2: eDP-1 pos: primary,left res: 1920x1080 size: N/A modes: N/A
API: OpenGL v: 4.6 Mesa 23.1.4 renderer: Mesa Intel UHD Graphics 630 (CFL
GT2) direct-render: Yes
Device-1: Intel Cannon Lake PCH cAVS vendor: Acer Incorporated ALI
driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl
bus-ID: 0000:00:1f.3 chip-ID: 8086:a348 class-ID: 0403
Device-2: NVIDIA GP107GL High Definition Audio
vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel
bus-ID: 0000:01:00.1 chip-ID: 10de:0fb9 class-ID: 0403
Device-3: C-Media USB Audio Device
driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 1.1 speed: 12 Mb/s
lanes: 1 mode: 1.1 bus-ID: 1-4.1:4 chip-ID: 0d8c:0012 class-ID: 0300
API: ALSA v: k6.4.4-zen1-1-zen status: kernel-api tools: N/A
Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
Server-2: PipeWire v: 0.3.75 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Intel Cannon Lake PCH CNVi WiFi driver: iwlwifi v: kernel
bus-ID: 0000:00:14.3 chip-ID: 8086:a370 class-ID: 0280
IF: wlp0s20f3 state: up mac: <filter>
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Acer Incorporated ALI driver: r8169 v: kernel port: 3000
bus-ID: 0000:06:00.1 chip-ID: 10ec:8168 class-ID: 0200
IF: enp6s0f1 state: down mac: <filter>
Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) driver: btusb
v: 0.8 type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-14:5
chip-ID: 8087:0aaa class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 2 state: down
bt-service: enabled,running rfk-block: hardware: no software: no
address: <filter>
Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode]
driver: intel_nvme_remap v: N/A port: 5060 bus-ID: 0000:00:17.0
chip-ID: 8086:282a rev: N/A class-ID: 0104
Local Storage: total: 1.84 TiB used: 101.53 GiB (5.4%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SanDisk model: 1TB NVME EVM
size: 953.87 GiB block-size: physical: 512 B logical: 512 B tech: SSD
serial: <filter> fw-rev: T0918A0L temp: 36.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: HGST (Hitachi) model: HTS721010A9E630
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
tech: HDD rpm: 7200 serial: <filter> fw-rev: A3J0 scheme: GPT
ID-1: / raw-size: 250.26 GiB size: 250.26 GiB (100.00%)
used: 101.49 GiB (40.6%) fs: btrfs dev: /dev/sda4 maj-min: 8:4
ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%)
used: 46.6 MiB (48.5%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 250.26 GiB size: 250.26 GiB (100.00%)
used: 101.49 GiB (40.6%) fs: btrfs dev: /dev/sda4 maj-min: 8:4
ID-4: /var/log raw-size: 250.26 GiB size: 250.26 GiB (100.00%)
used: 101.49 GiB (40.6%) fs: btrfs dev: /dev/sda4 maj-min: 8:4
ID-5: /var/tmp raw-size: 250.26 GiB size: 250.26 GiB (100.00%)
used: 101.49 GiB (40.6%) fs: btrfs dev: /dev/sda4 maj-min: 8:4
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.46 GiB used: 60.5 MiB (0.4%)
priority: 100 dev: /dev/zram0
System Temperatures: cpu: 64.0 C pch: 52.0 C mobo: N/A
Fan Speeds (RPM): N/A
Processes: 330 Uptime: 34m wakeups: 1 Memory: total: 16 GiB
available: 15.46 GiB used: 5.61 GiB (36.3%) Init: systemd v: 253
default: graphical tool: systemctl Compilers: gcc: 13.1.1 clang: 15.0.7
Packages: pm: pacman pkgs: 1431 libs: 438 tools: octopi,pamac,paru,yay
Shell: fish v: 3.6.1 default: Bash v: 5.1.16 running-in: konsole
inxi: 3.3.28
Garuda (2.6.16-1):
System install date:     2022-12-13
Last full system update: 2023-07-23
Is partially upgraded:   No
Relevant software:       snapper NetworkManager mkinitcpio nvidia-dkms
Windows dual boot:       Probably (Run as root to verify)
Failed units:

For now, I just restored the latest snapshot before the update but is there any permanent solution to this or any package I should exclude while updating to circumvent this issue till it's fixed in the upstream?

Hmm, that is curious. Did you check lsblk -f and compare with /etc/fstab?

When you tried the LTS kernel, did you update first? (Update > install LTS kernel> reboot into new kernel.)


Im right there with you, I did a total reinstall just test. After the intial install it will boot just fine. Once the automated update runs, it will no longer completely boot. I will check the whole plymouth issue once I figure out how to get back in as of now I may need to just reinstall again and stop the update process. I have post up here as well with almost the same thing. I have tried the LTS kernel, it get's a little further but still no glory. I miss my Garauda ;-). Its been great for 6 months..

Same here. Used Garuda great for 1 year, then had problem after updating today. Update as usual, then reboot. Network would not work. Tried to use Garuda settings to load snapshot in boot settings, and reboot just gets stuck at Lenovo flash screen and does not load the linux.

This happened once about 1.5 years ago, and then I took a break from Garuda. This is strike 2. It is a pity, as I was really fond of it. But a couple of weeks ago I also lost stereo audio output and it was after Garuda loaded Haskell pkgs into the update. I also noticed the ati-spi-bus-launcher and ati-spi2-registryd getting installed. It would be better for Garuda to ask the user if they want more bloat ware before loading it into routine kernel updates.

Not sure what the trouble is but am on the road travelling so not convenient to try to reinstall. But after last year at least I did not encrypt my hdd so maybe can recover files.

It looks like Garuda is getting hacked or bribed by 3rd parties (competitors, insec people, whatever). Pity to lose it again. Let's see if I find the time to try it again.

Please, which DE you use?
Maybe it’s better to open a separate thread with your garuda-inxi.

1 Like

Thanks. It was Garuda Dragonized (on Hardened LTS) with the KDE Plasma. I can't boot to it presently and don't have my pen drive with me to try to do the temp boot.

Is there a temp. install boot that is not for fresh installs but can be used to repair installs? I didn't do anything except change boot in Garuda settings to select snapshots. But now not loading that so stuck.

If there are any hot keys to try from Lenovo splash screen to get to Garuda (vs bios) please do tell.

Thanks for your response. I will try to power on again and wait to see if I am giving it enought time it takes to load.

Update: Since I was using Windows the last 2 days (dual booted)
I booted into Linux updated and I see it's still stuck in "loading initial ramdisk"
To answer your questions :

I had both Zen and LTS kernels before. The update in fact updated both.
Before update :

╭─vishnu@vishnu in ~ took 670ms
╰─λ lsblk -f                                                                                          (base)
NAME        FSTYPE FSVER LABEL           UUID                                 FSAVAIL FSUSE% MOUNTPOINTS
├─sda1      ntfs         Data            3C7444127443CD78
├─sda2      vfat   FAT32                 402A-FD12
├─sda3      ext4   1.0                   0c8dfade-5069-4efe-8b3f-f2ee547b8ea4
└─sda4      btrfs                        4416ced6-42d0-4882-8f60-32cb1db5f37f                /root
zram0                                                                                        [SWAP]
├─nvme0n1p1 vfat   FAT32                 527B-726C                              49.4M    48% /boot/efi
├─nvme0n1p3 ntfs         WINDOWS 11 NVME 6C767DC8767D9394
└─nvme0n1p4 ntfs                         6E34D74E34D71843

╭─vishnu@vishnu in ~ took 54ms
╰─λ cat /etc/fstab                                                                                    (base)
File: /etc/fstab
# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=527B-726C                            /boot/efi      vfat    umask=0077 0 2
UUID=4416ced6-42d0-4882-8f60-32cb1db5f37f /              btrfs   subvol=/@,defaults,noatime,compress=zstd 0 0
UUID=4416ced6-42d0-4882-8f60-32cb1db5f37f /home          btrfs   subvol=/@home,defaults,noatime,compress=zstd
0 0
UUID=4416ced6-42d0-4882-8f60-32cb1db5f37f /root          btrfs   subvol=/@root,defaults,noatime,compress=zstd
0 0
UUID=4416ced6-42d0-4882-8f60-32cb1db5f37f /srv           btrfs   subvol=/@srv,defaults,noatime,compress=zstd 0
UUID=4416ced6-42d0-4882-8f60-32cb1db5f37f /var/cache     btrfs   subvol=/@cache,defaults,noatime,compress=zstd
0 0
UUID=4416ced6-42d0-4882-8f60-32cb1db5f37f /var/log       btrfs   subvol=/@log,defaults,noatime,compress=zstd 0
UUID=4416ced6-42d0-4882-8f60-32cb1db5f37f /var/tmp       btrfs   subvol=/@tmp,defaults,noatime,compress=zstd 0

Post update I tried to boot into LTS kernel I got the same error as before but lemme show the lsblk -f command

Is it because of the Nvidia driver update?

Here is the whole update log using garuda-update :

Using Pastebin since the post has a char limit.

( 99/226) upgrading hyprland-nvidia-git


Oh about this, around a month back I wanted to try Hyperland on Dragonized so I installed those and played around a bit, but after then I log in using KDE plasma Wayland session only.
I don't think that would cause an issue because it was booting fine before though if you want I can remove the hyper land-related stuff and try it.

I managed to get a Garuda splash screen by just typing some gibberish and Control Alt Delete from the frozen Lenovo screen (old thinkpad but with new SSD) so am trying to roll back to the oldest snapshot i have (27july pre pipewire although I would have gone back futher to try to recapture my stereo audio output.)

It is reloading now and I got back in. VPN (proton) won't load but otherwise can do backups. I will try to remove all unused packages. Is there a way to remove unnecessary Linux kernel loadings? (During fresh install I had opted in for Kali and others but don't use them so maybe better to get them off).

Your fstab indicates your Garuda system is set to use the EFI partition on the NVMe drive (shared EFI partition with Windows). Nothing wrong with that, except the NVMe drive is not detected while booting--perhaps the Windows "fast startup" feature is holding it down.

You need to get that feature disabled.

It looks like you installed a second EFI partition on the SATA drive. If you are trying to use that for Garuda, you need to edit your fstab to point to the new UUID and make sure you have a bootloader installed on it. You may also need to amend your EFI boot variables.


I will check into that.
My fast startup is disabled for a long time.

what I did not get is how it was working till now and one update is breaking (my guess is some package) everything.

Hmm, well something is preventing the NVMe drive from being recognized at boot time, which is an issue since that is where your EFI partition is.

Check in your BIOS settings to confirm your device's SATA controller is set to AHCI mode (not RAID, or any other configuration).


Wow, I changed the bios settings for SATA to AHCI (I forgot what it was before sorry).
Now it booted after the update. Thanks a lot :slight_smile:

Can u suggest a relevant page where I can learn a bit more about this (mainly how EFI and Sata config are related for booting)?

Also just to confirm now after boot I don't see a splash screen but a black screen for like 5 to 10 secs before the login screen comes up. This is intended behavior, right? because as part of the removal of splash from grub


The Wikipedia article is interesting, and not too lengthy.

On systems that come with Windows pre-installed, often the firmware RAID mode is enabled by default (firmware RAID is interesting as well, check it out) instead of AHCI mode. Even though most people do not set up a RAID configuration on their laptop, there is really no downside to this choice for systems running Windows because it is supposed to also enable AHCI. However, as we know, for some reason this does not always work on Linux, and it is instead best to explicitly set AHCI mode.

Plymouth (the software that provides the animated boot splash) started causing a lot of issues after an update not too long ago–including many systems that could not successfully boot. As a damage control effort, Plymouth was removed from all systems.

Some folks are able to keep using it just fine. If your system doesn’t have any problems with it and you would like to restore the boot splash animation, you can go ahead and set it up again on your own by following the guidance here: Plymouth - ArchWiki. There is really not much to it, just make sure the package is installed, re-add the kernel parameter, and rebuild your initramfs (sudo dracut-rebuild) and you’re pretty much up and running.

Alternately, if you remove the quiet kernel parameter (both of them, in your case) you will see the systemd terminal output when booting instead of a black screen. Some people don’t like to see the journal output, but I think it’s more interesting than just staring at a blank monitor waiting for something to happen. Also, if something is holding up your boot you can see what it is right there on the monitor.


Thanks a lot for the info. :slight_smile:

Just for completeness what I observed yesterday was once I changed the SATA conf from RST/RAID to AHCI. The Windows 11 boot failed (good old blue screen with minimal info)(if you using a dual boot that is ).
Upon searching I got to know that ACHI drivers are sometimes not present in Windows and hence need to boot into Windows safe mode so that it downloads the appropriate drivers.

Here is the detailed description:'t-restore-windows-11-after-changing-bios-raid-to-ahci/647fa33bf4ccf8a8de90bf48

I will test this tonight and confirm if working or not. Thanks.


I believe that if you change your Dell's settings to AHCI mode prior to creating a system image, then that system image will be restorable because you had changed it prior to making that system image. It's worth noting that any Windows restoration from that system image will probably destroy GRUB.

Please be sure to read all of that discussrion you linked, especially about "bcdedit."

I run Dells in AHCI mode with or without Windows or any Linux distributions and never a problem iin that category. AHCI mode would not be the problem that you may or may not face, anyway. You're projecting a bit. :slight_smile:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.