No sound is coming through bluetooth device

I am facing an issue with my bluetooth my bluetooth was working fine but now no sound is comming through my bluetooth device on connection with laptop, at first they were getting connected and sometimes the sound was comming for 5 minutes or so but now no voice is comming thorugh them please help my entire workflow is stopped and I am facing a lot of inconvience please help me out resolving the issues with my bluetooth, the bluetooth device is the only audio out put I have my speakers are broken already , my bluetooth devices are working perfectly fine on other devices
Here is my guruda-inxi

Kernel: 6.4.2-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.1.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=f6c17212-3382-420b-9c2d-8476e08ec308 rw single
Desktop: KDE Plasma v: 5.27.6 tk: Qt v: 5.15.10 wm: kwin_x11 vt: 2
dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Laptop System: Acer product: Aspire A515-51G v: V2.02
serial: <superuser required>
Mobo: KBL model: Charmander_KL v: V2.02 serial: <superuser required>
UEFI: Insyde v: 2.02 date: 01/03/2019
ID-1: BAT1 charge: 34.9 Wh (100.0%) condition: 34.9/48.9 Wh (71.2%)
volts: 16.6 min: 15.2 model: LG 004B384234314341 type: Li-ion
serial: <filter> status: not charging
Info: model: Intel Core i5-8250U bits: 64 type: MT MCP arch: Coffee Lake
gen: core 8 level: v3 note: check built: 2017 process: Intel 14nm family: 6
model-id: 0x8E (142) stepping: 0xA (10) microcode: 0xF2
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
L3: 6 MiB desc: 1x6 MiB
Speed (MHz): avg: 799 high: 800 min/max: 400/3400 scaling:
driver: intel_pstate governor: powersave cores: 1: 800 2: 800 3: 800 4: 800
5: 799 6: 800 7: 800 8: 800 bogomips: 28800
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel UHD Graphics 620 vendor: Acer Incorporated ALI driver: i915
v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20 ports:
active: eDP-1 empty: HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:5917
class-ID: 0300
Device-2: NVIDIA GP108M [GeForce MX150] vendor: Acer Incorporated ALI
driver: nvidia v: 535.54.03 alternate: nouveau,nvidia_drm non-free: 530.xx+
status: current (as of 2023-05) arch: Maxwell code: GMxxx
process: TSMC 28nm built: 2014-19 pcie: gen: 1 speed: 2.5 GT/s lanes: 4
link-max: gen: 3 speed: 8 GT/s bus-ID: 01:00.0 chip-ID: 10de:1d10
class-ID: 0302
Device-3: Quanta HD Webcam driver: uvcvideo type: USB rev: 2.0
speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-7:4 chip-ID: 0408:a060
class-ID: 0e02 serial: <filter>
Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.2
compositor: kwin_x11 driver: X: loaded: modesetting,nvidia unloaded: nouveau
alternate: fbdev,intel,nv,vesa dri: iris gpu: i915 display-ID: :0
screens: 1
Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.21x7.99")
s-diag: 414mm (16.31")
Monitor-1: eDP-1 model: BOE Display 0x0959 built: 2020 res: 1366x768
hz: 60 dpi: 101 gamma: 1.2 size: 344x194mm (13.54x7.64") diag: 395mm (15.5")
ratio: 16:9 modes: 1366x768
API: OpenGL v: 4.6 Mesa 23.1.3 renderer: Mesa Intel UHD Graphics 620 (KBL
GT2) direct-render: Yes
Device-1: Intel Sunrise Point-LP HD Audio vendor: Acer Incorporated ALI
driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_soc_avs
bus-ID: 00:1f.3 chip-ID: 8086:9d71 class-ID: 0403
API: ALSA v: k6.4.2-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: alsactl,alsamixer,amixer
Server-1: PipeWire v: 0.3.73 status: active with: 1: wireplumber
status: active 2: pw-jack type: plugin tools: pw-cat,pw-cli,wpctl
Server-2: PulseAudio v: 16.1 status: off with: 1: pulseaudio-alsa
type: plugin 2: pulseaudio-jack type: module tools: pacat,pactl,pavucontrol
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Acer Incorporated ALI driver: r8169 v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 02:00.1 chip-ID: 10ec:8168
class-ID: 0200
IF: enp2s0f1 state: down mac: <filter>
Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter
vendor: Lite-On driver: ath10k_pci v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 bus-ID: 03:00.0 chip-ID: 168c:0042 class-ID: 0280
IF: wlp3s0 state: up mac: <filter>
IF-ID-1: vmnet1 state: unknown speed: N/A duplex: N/A mac: <filter>
IF-ID-2: vmnet8 state: unknown speed: N/A duplex: N/A mac: <filter>
Device-1: Lite-On Qualcomm Atheros QCA9377 Bluetooth driver: btusb v: 0.8
type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-5:3
chip-ID: 04ca:3015 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 2 state: up address: <filter>
Local Storage: total: 931.51 GiB used: 879.17 GiB (94.4%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital
model: WD10SPZX-21Z10T0 size: 931.51 GiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s tech: HDD rpm: 5400 serial: <filter>
fw-rev: 1A02 scheme: GPT
ID-1: / raw-size: 922.42 GiB size: 922.42 GiB (100.00%)
used: 879.17 GiB (95.3%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 922.42 GiB size: 922.42 GiB (100.00%)
used: 879.17 GiB (95.3%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 922.42 GiB size: 922.42 GiB (100.00%)
used: 879.17 GiB (95.3%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 922.42 GiB size: 922.42 GiB (100.00%)
used: 879.17 GiB (95.3%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.63 GiB used: 2.81 GiB (36.8%)
priority: 100 dev: /dev/zram0
ID-2: swap-2 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2
dev: /dev/sda3 maj-min: 8:3
System Temperatures: cpu: 86.0 C mobo: N/A
Fan Speeds (RPM): N/A
Processes: 299 Uptime: 17h 58m wakeups: 1 Memory: available: 7.64 GiB
used: 4.9 GiB (64.1%) Init: systemd v: 253 default: graphical
tool: systemctl Compilers: gcc: 13.1.1 Packages: pm: pacman pkgs: 1455
libs: 381 tools: octopi,paru,yay Shell: fish v: 3.6.1 running-in: konsole
inxi: 3.3.27
Garuda (2.6.16-1):
System install date:     2023-03-07
Last full system update: 2023-07-11 ↻
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut nvidia-dkms
Windows dual boot:       No/Undetected
Failed units:

This means a reboot is pending after the latest update.
Most likely this is not related to your issue but you never can say.
Make sure to test a few other kernels, e.g. for the LTS one:

sudo pacman -S linux-lts linux-lts-headers

Then you'll have to select the LTS kernel from the Advanced Options sub-menu in the GRUB.


I have installed the lts linux kernel , but when I am selecting from the garuda boot menu's advance options the screen stucks on loading linux-lts loading initramfs, the i boot into the non lts kernel after the restart the sound comming through my earphones but I can't play videos on any website in any browser , my connection is 50 mbps giving a speed of 30 mbps currently can stream videos on other devices but on my laptop whenever I try to watch any video it says if play back don't start try restarting your device, I reinstalled chrome but still the same, all other things like browsing some downloads through konsole are working fine please help

For the video issue try disabling hardware acceleration in your browser (there should be a similar setting in any browser).

Have you checked for any newer BIOS updates?

1 Like

I've turned off the hardware acceleration but it's still the same not playing

╭─starboy@starboy in ~ via  v20.4.0 ╰─λ sudo dmidecode -s bios-version [sudo] password for starboy: V2.02

how to check bios update @Bro

[🔴] × sudo dmidecode -t bios -q
[sudo] password for starboy:
BIOS Information
Vendor: Insyde Corp.
Version: V2.02
Release Date: 01/03/2019
Address: 0xE0000
Runtime Size: 128 kB
ROM Size: 8 MB
PCI is supported
BIOS is upgradeable
BIOS shadowing is allowed
Boot from CD is supported
Selectable boot is supported
EDD is supported
Japanese floppy for NEC 9800 1.2 MB is supported (int 13h)
Japanese floppy for Toshiba 1.2 MB is supported (int 13h)
5.25"/360 kB floppy services are supported (int 13h)
5.25"/1.2 MB floppy services are supported (int 13h)
3.5"/720 kB floppy services are supported (int 13h)
3.5"/2.88 MB floppy services are supported (int 13h)
8042 keyboard services are supported (int 9h)
CGA/mono video services are supported (int 10h)
ACPI is supported
USB legacy is supported
BIOS boot specification is supported
Targeted content distribution is supported
UEFI is supported
BIOS Revision: 2.2
Firmware Revision: 1.17

may I expect any help ?

You have an Acer:

With an Insyde BIOS:

That is where to go and what to update if possible. :smiley:

Have fun!

1 Like

In the past this had been solved by someone reinstalling pipewire. I didn't expext this to happen again, but you could try:

sudo pacman -Syu pipewire pipewire-alsa pipewire-jack pipewire-pulse
[🔴] × sudo pacman -Syu pipewire pipewire-alsa pipewire-jack pipewire-pulse
:: Synchronizing package databases...
garuda is up to date
core is up to date
extra is up to date
multilib is up to date
chaotic-aur is up to date
blackarch is up to date
warning: pipewire-1:0.3.73-1 is up to date -- reinstalling
warning: pipewire-jack-1:0.3.73-1 is up to date -- reinstalling
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
:: pipewire-alsa and pulseaudio-alsa are in conflict. Remove pulseaudio-alsa? [y/N] y
:: pipewire-pulse and pulseaudio are in conflict. Remove pulseaudio? [y/N] y
:: pipewire-pulse and pulseaudio-bluetooth are in conflict. Remove pulseaudio-bluetooth? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: removing pulseaudio breaks dependency 'pulseaudio=16.1-6' required by pulseaudio-equalizer
:: removing pulseaudio breaks dependency 'pulseaudio=16.1-6' required by pulseaudio-jack
:: removing pulseaudio breaks dependency 'pulseaudio=16.1-6' required by pulseaudio-lirc
:: removing pulseaudio breaks dependency 'pulseaudio=16.1-6' required by pulseaudio-rtp
:: removing pulseaudio breaks dependency 'pulseaudio=16.1-6' required by pulseaudio-zeroconf

i've installed it using gurda assistant now after installing it , pulseaudio got removed and no sound is comming though my earphones, the bluetooth device is connected in the bluetooth section topright , but no device other than speaker is detect though pavucontrol

Device 00:00:AB:CE:12:FD (public)
Name: Airdopes 441
Alias: Airdopes 441
Class: 0x00240404 (2360324)
Icon: audio-headset
Paired: yes
Bonded: yes
Trusted: yes
Blocked: no
Connected: yes
LegacyPairing: no
UUID: Vendor specific           (00000000-0000-0000-0099-aabbccddeeff)
UUID: Headset                   (00001108-0000-1000-8000-00805f9b34fb)
UUID: Audio Sink                (0000110b-0000-1000-8000-00805f9b34fb)
UUID: A/V Remote Control Target (0000110c-0000-1000-8000-00805f9b34fb)
UUID: Advanced Audio Distribu.. (0000110d-0000-1000-8000-00805f9b34fb)
UUID: A/V Remote Control        (0000110e-0000-1000-8000-00805f9b34fb)
UUID: Handsfree                 (0000111e-0000-1000-8000-00805f9b34fb)
UUID: PnP Information           (00001200-0000-1000-8000-00805f9b34fb)
UUID: Vendor specific           (df21fe2c-2515-4fdb-8886-f12c4d67927c)
Modalias: bluetooth:v0094p0123d1000```

You can run Pipewire or Pulseaudio w/ALSA, your choice. But you can't do both. This is probably the heart of your problem.

Pipewire is the latest and usually the one used nowadays. If you need effects like Pulseaudio can provide then you can use either JamesDSP or EasyEffects packages with Pipewire.

P.S. I also like to install Pavucontrol-qt. It is written for pulseaudio but works with pipewire.


I REMOVED THE PULSEAUDIO COMPLETELY AND INSTALLED PIPEWIRE, i removed THE LINUX-LTS kernel and installed it again, now after booting into linux-lts kernel my problem seems to be gone! Thank @filo , @Bro for helping me out, Garuda community is awsome, will update the thread in case things go wrong again .


It happened again bro in LTS also , it was connected properly for half hour or so , then sound disappeared all of a sudden when I was taking a lacutre