No Sound Ellesmere Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590] Digital Stereo (HDMI)

Hi Everyone,

I've been using Garuda for a few months now and loving it (was my first try with switching to Linux, and it's definitely my favorite so far :wink:). I'm running it on a mid-2017 27" iMac, and everything works great except there is no sound for HDMI or Analog.

Here are my outputs:

inxi -Faz:

System:    Kernel: 5.15.5-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=43de5839-f81f-4f30-ad38-9d6ed368c7d6
rw [email protected] quiet
cryptdevice=UUID=599d5358-ffa5-4019-9de5-8951a3e735af:luks-599d5358-ffa5-4019-9de5-8951a3e735af
root=/dev/mapper/luks-599d5358-ffa5-4019-9de5-8951a3e735af splash rd.udev.log_priority=3
vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.23.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Machine:   Type: Laptop System: Apple product: iMac18,3 v: 1.0 serial: <superuser required> Chassis:
type: 9 v: Mac-BE088AF8C5EB4FA2 serial: <superuser required>
Mobo: Apple model: Mac-BE088AF8C5EB4FA2 v: iMac18,3 serial: <superuser required> UEFI: Apple
v: 428.0.0.0.0 date: 06/16/2020
CPU:       Info: Quad Core model: Intel Core i5-7500 bits: 64 type: MCP arch: Kaby Lake family: 6
model-id: 9E (158) stepping: 9 microcode: EA cache: L1: 256 KiB L2: 1024 KiB L3: 6 MiB
flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 27199
Speed: 3771 MHz min/max: 800/3800 MHz Core speeds (MHz): 1: 3771 2: 3774 3: 3761 4: 3789
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled
Type: mds mitigation: Clear CPU buffers; SMT disabled
Type: meltdown mitigation: PTI
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: disabled, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort mitigation: TSX disabled
Graphics:  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] vendor: Apple driver: amdgpu
v: kernel bus-ID: 01:00.0 chip-ID: 1002:67df class-ID: 0300
Device-2: Apple FaceTime HD Camera (Built-in) type: USB driver: uvcvideo bus-ID: 1-5:4
chip-ID: 05ac:8511 class-ID: 0e02 serial: <filter>
Display: x11 server: X.Org 1.21.1.1 compositor: kwin_x11 driver: loaded: amdgpu,ati
unloaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1
Screen-1: 0 s-res: 2560x1440 s-dpi: 96 s-size: 676x380mm (26.6x15.0") s-diag: 775mm (30.5")
Monitor-1: eDP res: 2560x1440 hz: 60 dpi: 109 size: 597x336mm (23.5x13.2") diag: 685mm (27")
OpenGL:
renderer: AMD Radeon RX 470 Graphics (POLARIS10 DRM 3.42.0 5.15.5-zen1-1-zen LLVM 13.0.0)
v: 4.6 Mesa 21.2.5 direct render: Yes
Audio:     Device-1: Intel 100 Series/C230 Series Family HD Audio driver: snd_hda_intel v: kernel
bus-ID: 00:1f.3 chip-ID: 8086:a170 class-ID: 0403
Device-2: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590] driver: snd_hda_intel
v: kernel bus-ID: 01:00.1 chip-ID: 1002:aaf0 class-ID: 0403
Sound Server-1: ALSA v: k5.15.5-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.40 running: yes
Network:   Device-1: Broadcom BCM43602 802.11ac Wireless LAN SoC vendor: Apple driver: brcmfmac v: kernel
bus-ID: 03:00.0 chip-ID: 14e4:43ba class-ID: 0280
IF: wlp3s0 state: up mac: <filter>
Device-2: Broadcom NetXtreme BCM57766 Gigabit Ethernet PCIe driver: tg3 v: kernel port: N/A
bus-ID: 04:00.0 chip-ID: 14e4:1686 class-ID: 0200
IF: enp4s0f0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Bluetooth: Device-1: Apple Bluetooth USB Host Controller type: USB driver: btusb,hid-generic,usbhid
bus-ID: 1-6:5 chip-ID: 05ac:8296 class-ID: fe01
Report: bt-adapter note: tool can't run ID: hci0 rfk-id: 0 state: down bt-service: disabled
rfk-block: hardware: no software: no address: N/A
Drives:    Local Storage: total: 957.59 GiB used: 13.92 GiB (1.5%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Apple model: SSD SM0032L size: 26.08 GiB block-size:
physical: 4096 B logical: 4096 B speed: 15.8 Gb/s lanes: 2 type: SSD serial: <filter>
rev: DXZ77A0Q temp: 33.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Apple model: HDD ST1000DM003 size: 931.51 GiB block-size:
physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter> rev: AQ04
scheme: GPT
Partition: ID-1: / raw-size: 25.79 GiB size: 25.79 GiB (100.00%) used: 13.91 GiB (54.0%) fs: btrfs
dev: /dev/dm-0 maj-min: 254:0 mapped: luks-599d5358-ffa5-4019-9de5-8951a3e735af
ID-2: /boot/efi raw-size: 260 MiB size: 259.4 MiB (99.76%) used: 720 KiB (0.3%) fs: vfat
dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 25.79 GiB size: 25.79 GiB (100.00%) used: 13.91 GiB (54.0%) fs: btrfs
dev: /dev/dm-0 maj-min: 254:0 mapped: luks-599d5358-ffa5-4019-9de5-8951a3e735af
ID-4: /var/log raw-size: 25.79 GiB size: 25.79 GiB (100.00%) used: 13.91 GiB (54.0%) fs: btrfs
dev: /dev/dm-0 maj-min: 254:0 mapped: luks-599d5358-ffa5-4019-9de5-8951a3e735af
ID-5: /var/tmp raw-size: 25.79 GiB size: 25.79 GiB (100.00%) used: 13.91 GiB (54.0%) fs: btrfs
dev: /dev/dm-0 maj-min: 254:0 mapped: luks-599d5358-ffa5-4019-9de5-8951a3e735af
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.66 GiB used: 2 MiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 51.0 C mobo: N/A gpu: amdgpu temp: 51.0 C
Fan Speeds (RPM): N/A
Info:      Processes: 235 Uptime: 3h 22m wakeups: 0 Memory: 7.66 GiB used: 3.08 GiB (40.2%) Init: systemd
v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1227 lib: 314
Shell: fish v: 3.3.1 default: Bash v: 5.1.12 running-in: konsole inxi: 3.3.09

aplay -IL:

null
Discard all samples (playback) or generate zero samples (capture)
samplerate
Rate Converter Plugin Using Samplerate Library
speexrate
Rate Converter Plugin Using Speex Resampler
jack
JACK Audio Connection Kit
oss
Open Sound System
pipewire
PipeWire Sound Server
pulse
PulseAudio Sound Server
speex
Plugin using Speex DSP (resample, agc, denoise, echo, dereverb)
upmix
Plugin for channel upmix (4,6,8)
vdownmix
Plugin for channel downmix (stereo) with a simple spacialization
default
Default ALSA Output (currently PulseAudio Sound Server)
front:CARD=PCH
Front output / input
surround21:CARD=PCH
2.1 Surround output to Front and Subwoofer speakers
surround40:CARD=PCH
4.0 Surround output to Front and Rear speakers
surround41:CARD=PCH
4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=PCH
5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=PCH
5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=PCH
7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
usbstream:CARD=PCH
HDA Intel PCH
USB Stream Output
hdmi:CARD=HDMI,DEV=0
HDA ATI HDMI, HDMI 0
HDMI Audio Output
hdmi:CARD=HDMI,DEV=1
HDA ATI HDMI, HDMI 1
HDMI Audio Output
hdmi:CARD=HDMI,DEV=2
HDA ATI HDMI, HDMI 2
HDMI Audio Output
hdmi:CARD=HDMI,DEV=3
HDA ATI HDMI, HDMI 3
HDMI Audio Output
hdmi:CARD=HDMI,DEV=4
HDA ATI HDMI, HDMI 4
HDMI Audio Output
hdmi:CARD=HDMI,DEV=5
HDA ATI HDMI, HDMI 5
HDMI Audio Output
hdmi:CARD=HDMI,DEV=6
HDA ATI HDMI, HDMI 6
HDMI Audio Output
usbstream:CARD=HDMI
HDA ATI HDMI
USB Stream Output

sudo fuser -v /dev/snd/*:

USER        PID ACCESS COMMAND
/dev/snd/controlC1:  strcat    239168 F.... pulseaudio
strcat    243490 F.... pipewire-media-
/dev/snd/seq:        strcat    243489 F.... pipewire

pacmd list-cards:

1 card(s) available.
index: 0
name: <alsa_card.pci-0000_01_00.1>
driver: <module-alsa-card.c>
owner module: 6
properties:
alsa.card = "1"
alsa.card_name = "HDA ATI HDMI"
alsa.long_card_name = "HDA ATI HDMI at 0x92660000 irq 60"
alsa.driver_name = "snd_hda_intel"
device.bus_path = "pci-0000:01:00.1"
sysfs.path = "/devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1"
device.bus = "pci"
device.vendor.id = "1002"
device.vendor.name = "Advanced Micro Devices, Inc. [AMD/ATI]"
device.product.id = "aaf0"
device.product.name = "Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]"
device.string = "1"
device.description = "Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]"
module-udev-detect.discovered = "1"
device.icon_name = "audio-card-pci"
profiles:
output:hdmi-stereo: Digital Stereo (HDMI) Output (priority 5900, available: no)
output:hdmi-surround: Digital Surround 5.1 (HDMI) Output (priority 800, available: no)
output:hdmi-surround71: Digital Surround 7.1 (HDMI) Output (priority 800, available: no)
output:hdmi-stereo-extra1: Digital Stereo (HDMI 2) Output (priority 5700, available: no)
output:hdmi-surround-extra1: Digital Surround 5.1 (HDMI 2) Output (priority 600, available: no
)
output:hdmi-surround71-extra1: Digital Surround 7.1 (HDMI 2) Output (priority 600, available:
no)
output:hdmi-stereo-extra2: Digital Stereo (HDMI 3) Output (priority 5700, available: no)
output:hdmi-surround-extra2: Digital Surround 5.1 (HDMI 3) Output (priority 600, available: no
)
output:hdmi-surround71-extra2: Digital Surround 7.1 (HDMI 3) Output (priority 600, available:
no)
output:hdmi-stereo-extra3: Digital Stereo (HDMI 4) Output (priority 5700, available: no)
output:hdmi-surround-extra3: Digital Surround 5.1 (HDMI 4) Output (priority 600, available: no
)
output:hdmi-surround71-extra3: Digital Surround 7.1 (HDMI 4) Output (priority 600, available:
no)
output:hdmi-stereo-extra4: Digital Stereo (HDMI 5) Output (priority 5700, available: no)
output:hdmi-surround-extra4: Digital Surround 5.1 (HDMI 5) Output (priority 600, available: no
)
output:hdmi-surround71-extra4: Digital Surround 7.1 (HDMI 5) Output (priority 600, available:
no)
output:hdmi-stereo-extra5: Digital Stereo (HDMI 6) Output (priority 5700, available: no)
output:hdmi-surround-extra5: Digital Surround 5.1 (HDMI 6) Output (priority 600, available: no
)
output:hdmi-surround71-extra5: Digital Surround 7.1 (HDMI 6) Output (priority 600, available:
no)
output:hdmi-stereo-extra6: Digital Stereo (HDMI 7) Output (priority 5700, available: no)
output:hdmi-surround-extra6: Digital Surround 5.1 (HDMI 7) Output (priority 600, available: no
)
output:hdmi-surround71-extra6: Digital Surround 7.1 (HDMI 7) Output (priority 600, available:
no)
off: Off (priority 0, available: unknown)
active profile: <output:hdmi-stereo>
sinks:
alsa_output.pci-0000_01_00.1.hdmi-stereo/#0: Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580
/590] Digital Stereo (HDMI)
sources:
alsa_output.pci-0000_01_00.1.hdmi-stereo.monitor/#0: Monitor of Ellesmere HDMI Audio [Radeon R
X 470/480 / 570/580/590] Digital Stereo (HDMI)
ports:
hdmi-output-0: HDMI / DisplayPort (priority 5900, latency offset 0 usec, available: no)
properties:
device.icon_name = "video-display"
hdmi-output-1: HDMI / DisplayPort 2 (priority 5800, latency offset 0 usec, available: no)
properties:
device.icon_name = "video-display"
hdmi-output-2: HDMI / DisplayPort 3 (priority 5700, latency offset 0 usec, available: no)
properties:
device.icon_name = "video-display"
hdmi-output-3: HDMI / DisplayPort 4 (priority 5600, latency offset 0 usec, available: no)
properties:
device.icon_name = "video-display"
hdmi-output-4: HDMI / DisplayPort 5 (priority 5500, latency offset 0 usec, available: no)
properties:
device.icon_name = "video-display"
hdmi-output-5: HDMI / DisplayPort 6 (priority 5400, latency offset 0 usec, available: no)
properties:
device.icon_name = "video-display"
hdmi-output-6: HDMI / DisplayPort 7 (priority 5300, latency offset 0 usec, available: no)
properties:
device.icon_name = "video-display"

pacmd list-sinks:

1 sink(s) available.
* index: 0
name: <alsa_output.pci-0000_01_00.1.hdmi-stereo>
driver: <module-alsa-card.c>
flags: HARDWARE DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
state: SUSPENDED
suspend cause: IDLE
priority: 9030
volume: front-left: 65536 / 100% / 0.00 dB,   front-right: 65536 / 100% / 0.00 dB
balance 0.00
base volume: 65536 / 100% / 0.00 dB
volume steps: 65537
muted: no
current latency: 0.00 ms
max request: 0 KiB
max rewind: 0 KiB
monitor source: 0
sample spec: s16le 2ch 44100Hz
channel map: front-left,front-right
Stereo
used by: 0
linked by: 0
configured latency: 0.00 ms; range is 0.50 .. 1999.82 ms
card: 0 <alsa_card.pci-0000_01_00.1>
module: 6
properties:
alsa.resolution_bits = "16"
device.api = "alsa"
device.class = "sound"
alsa.class = "generic"
alsa.subclass = "generic-mix"
alsa.name = "HDMI 0"
alsa.id = "HDMI 0"
alsa.subdevice = "0"
alsa.subdevice_name = "subdevice #0"
alsa.device = "3"
alsa.card = "1"
alsa.card_name = "HDA ATI HDMI"
alsa.long_card_name = "HDA ATI HDMI at 0x92660000 irq 60"
alsa.driver_name = "snd_hda_intel"
device.bus_path = "pci-0000:01:00.1"
sysfs.path = "/devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1"
device.bus = "pci"
device.vendor.id = "1002"
device.vendor.name = "Advanced Micro Devices, Inc. [AMD/ATI]"
device.product.id = "aaf0"
device.product.name = "Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]"
device.string = "hdmi:1"
device.buffering.buffer_size = "352768"
device.buffering.fragment_size = "176384"
device.access_mode = "mmap+timer"
device.profile.name = "hdmi-stereo"
device.profile.description = "Digital Stereo (HDMI)"
device.description = "Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590] Digital Stereo (H
DMI)"
module-udev-detect.discovered = "1"
device.icon_name = "audio-card-pci"
ports:
hdmi-output-0: HDMI / DisplayPort (priority 5900, latency offset 0 usec, available: no)
properties:
device.icon_name = "video-display"
active port: <hdmi-output-0>

pacman -Qs Sound Firmware:

local/sof-firmware 1.9.2-1
Sound Open Firmware

pacman -Qi sof-firmware:

Name            : sof-firmware
Version         : 1.9.2-1
Description     : Sound Open Firmware
Architecture    : x86_64
URL             : https://www.sofproject.org/
Licenses        : custom:BSD  custom:ISC
Groups          : None
Provides        : None
Depends On      : None
Optional Deps   : None
Required By     : pulseaudio-support
Optional For    : None
Conflicts With  : None
Replaces        : None
Installed Size  : 12.08 MiB
Packager        : Jan Alexander Steffens (heftig) <[email protected]>
Build Date      : Wed 24 Nov 2021 02:07:02 PM EST
Install Date    : Wed 01 Dec 2021 09:29:24 PM EST
Install Reason  : Explicitly installed
Install Script  : No
Validated By    : Signature

ls -1 /usr/lib/firmware/intel | grep sof

 sof -> sof-v1.9.2
 sof-tplg -> sof-tplg-v1.9.2
 sof-tplg-v1.9.2
 sof-v1.9.2

I added options snd-hda-intel model=imac27 to both files with reboot:

/etc/modprobe.d/sound.conf
/etc/modprobe.d/alsa-base.conf

but that unfortunately didn't work. All of the output profiles for Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590] in Pavucontrol are listed as (unplugged) & (unavailable). And there is no Analog output option. There seem to be quite a few others with similar problems, but despite weeks of searching for solutions and trying different things, I still can't figure out what might be causing it. Still being very new to Linux, I figured I would reach out to see if there's anything obvious I might be overlooking. Would so very much appreciate any possible help or input! :pray: :slight_smile:

Heh have you tried removing pipeTrouble...I mean wire...ehem yes PipeWire?

Also have you made sure that the interfaces it sees in alsamixer have their volume up? Pulse can say they are disconnected till the cows come home but alsamixer is still the gatekeeper.

/me changes name to Pipewire_scortched_earth_campaign

I swear, for all the trouble sound systems seem to be having nowadays (and for the past several years), it's a shame alsamixer doesn't come installed on all of the ISOs by default.

@dr460nf1r3, are you listening? :slight_smile:

1 Like

Yeah it's kinda ridiculous. However it's just as retarded that pulse doesn't have the same functionality or can/doesn't sync correctly with alsa. Another reason why I already hate pipewire. Another top end that does 5% of what you need for no reason other than to just be more crap that doesn't do anything. Then it reuses things from the older audio systems its supposed to replace...things that themselves STILL aren't complete!

Wait 'til you try easyeffects. :slight_smile:

Alsamixer. OP, have you installed/tried it yet.

Never heard of it, I have pulseeffects on the TV machine to help with normalization/maximize TV/Movie audio. I don't use those things because I do pro audio stuff.

Yes OP if you try alsamixer in your term and get ye olde command not found do
sudo pacman -S alsa-utils

easyeffects is the pipewire equivalent. And, like pipewire, needs a bit of work.

1 Like

Ah, well given how many audio issues I've been helping trouble shoot I'd say it ALL needs some work. Also why I'm so adamant about things. I've spent a lot of time trouble shooting and figuring out what works where and how because it's such a hodge podge.

Sadly @CatWaves hasn't been back but with all the info he dumped he seems like he has a decent grasp of most things with the audio system. I would really like to hear if it worked after just removing pipewire.

1 Like

Im listening. Personally I never had to use it, does it really provide a big advantage? :eyes:

1 Like

Hey there!

I'm here, just not at my desk right now. But thanks everyone for all the replies :slight_smile:

Yes, you are not kidding about pipewire. I would not say I'm particularly experienced/knowledgeable about audio issues, lol. Only first touched Linux about 6 mos ago, but trying to learn as I go and become more comfortable with CLI.

I did try to completely remove pipewire, but it seems to have a lot of little straggling dependencies. I also found others running into that problem, but I don't really have a good understanding of how PW/pulse/Wayland/jack/alsa all work together. What would be the proper way to completely remove pipewire & have the other components functioning correctly? I did originally try to go through the Garuda assistant way and uncheck the PW boxes. I also tried what user @Neeto did in changing the kernel parameter to snd_hda_intel.dmic_detect=0
and updating grub, but that had no effect either.

Yes, I know I installed alsamixer & alsa-utils somewhere along the way. And yes, verified that nothing was muted. @c00ter , what would be the proper way to go about configuring easyeffects? It sounds like I obviously need to completely remove PW. Just to make sure everything has a chance to work as it should, I guess what would be the right order try this?

Based on the above info, does anything else look odd/out of place? Do I have things pointed to the right sinks? Still really no idea what that means & just trying to learn. But wasn't getting anywhere at all after several weeks​:joy_cat:

Was/is sound working on any version/distro from a live boot disk. If you can find one that things are working properly try to replicate that setup.

1 Like

It can be very helpful when there are cases where audio is active but no sound will issue. I've observed this time and time again, over a long period of time, over a wide range of distributions, Arch-based or not. The problem can seem unsolvable--a real "head scratcher." It turns out in these cases, that sound was simply muted, and alsamixer can quicky determine and usually 'fix' that problem. I do not know why this happens but it does, willy nilly. And alsamixer is just a small ncurses application that's been around a long, long time (relative to Linux).

It's oftentimes the last utility tried, but can be the only one needed. With alsamixer a user or helper can quickly verify if sound is just muted or not. It's led to a lot of "duh" moments, and I can remember one of mine. :slight_smile:

That's about all I know about alsamixer.

2 Likes

It's a pipewire utility, found in the community repo and there is nothing easy about it, not for me, anyway. Experts--you bet. You get the interface, that's all. The sound drivers, sound effects, equalization, everything--has to be installed by the user, and it looks like they're mostly from .git packages. I installed it; saw all the work involved, said eff it, got rid of pipewire and went back to pulseaudio so I could use pulseaudio-equalizer-ladspa. I need a decent EQ, not an unfinished kitchen sink.

I'm not an audiophile of any sort and don't know much about it, but I want the lows to be low and the highs to be high. :slight_smile:

You've really got to stop with "NUKE PIPEWIRE" as your first response to every audio-related problem - it's not helpful. PipeWire is the Garuda default for a reason, and none of your opened topics show what problem you had with it in a Garuda installation (or what removing it solved).

Might be worth another go now - while the interface might take a little getting used to (e.g. plugins is hidden away at the bottom), EasyEffects does work well:

Or, it works well for me. :grin:

3 Likes

Why would I have an open topic about something I know how to solve sudo pacman -R pipewire ;p

While I've seen it work on twos machine I've also seen it be the cause of no sound on several more. Given it's a useless addition removing it is best. Yes it's useless you still need alsa, still need pulse and in many cases jack...pipewire has not replaced them, it's just more crap. When you have ONLY pipewire then I'll stop with the scorched earth ;p

I'm not sure on your system what dependencies pipewire is holding on to. I know OBS is now built with it as a requirement but outside that Wayland is a different topic and not linked to any of this.

The core things would be do you have alsamixer installed, have you opened it and selected your correct output. From there is the main or PCM channels muted? If not good, now move the faders for the main and PCM. It seems stupid but I've seen on some devices the audio will behave as muted until you change the faders. Lots of fun irrational behaviors.

If Alsa sees your card and the outputs are unmuted and set to unity then what does the pulseaudio control say? pavucontrol Under the last / right most tab "configuration" does your audio interface show there? If yes then what does the output tab show?

If all this checks out play some audio from an application not running previously (as they can grab a sink that wasn't there before you made changes and keep sending to the black hole that is that non-working sink.

1 Like

I'll give it another go. It's been awhile. Thanks, @jonathon

2 Likes

Those effects things are also subjective to your hardware. For one guy it works great, someone else crashes and just garbage because either the machine is too slow or no dsp on the SC. That said my crappy TV machine runs pulse effects OK. Thankfully the latency can be adjusted for because it's one of those machines with el crapo/no dsp heh.

1 Like

Okay, I'm not really sure how to even answer that, as I don't even understand how all these things work together, lol. But I guess with the aplay -IL command, it says PipeWire Sound Server under pipewire. And the sudo fuser -v /dev/snd/* output had

USER        PID ACCESS COMMAND
/dev/snd/controlC1:  strcat    239168 F.... pulseaudio
strcat    243490 F.... pipewire-media-
/dev/snd/seq:        strcat    243489 F.... pipewire

(Again, admitted ignorance as to what that means. I have read about it, but I still don't understand what it means.)

Yes, I do have alsamixer installed. There are three options for Sound Card if I press F6:

This is what shows in pavucontrol:

I feel like I'm probably missing something obvious, so just trying to narrow down possibilities. I have not tried other distros on this machine as of yet, only on an older 17" MBP (which Garuda runs fine on, save for random freezes on the desktop when I do things like running Firedragon or adjusting window sizes---that behavior goes away if I run other distros in KVM with Garuda as the host, but still have no issues with audio). But it has Intel & NVIDIA cards, so somewhat different.

Well it sees it but definitely doesn't see the connection. Fearing sounding like 1990's Dell Support but have you tried a different HDMI cable?