No keyboard / mouse input on installation iso

Garuda started acting up, so I decided a fresh install was called for. System was freezing on start intermittently, I could live with it but it's still annoying.

I attempted to install using Garuda KDE Dr460nized, Xfce, GNOME, and Qtile. Each of these failed to detect keyboard or mouse input, this includes two different keyboards and two different mice. G413 Carbon keyboard, Reddragon mouse, and a cheap-o keyboard and mouse as well. I've looked in my BIOS, but I'm not seeing anything obvious blocking a USB, it's not in fast boot nor secure boot. Updated my motherboard BIOS. No joy.

Note that this issue has been happening for me for about a month. I have installed KDE Dragonized before, and tried to reinstall earlier. But ended up installing barebones.

That being said, Garuda barebones does detect keyboard and mouse. I just got sick of attempting to resolve various issues with it. I resolved the package conflicts, and the out of date keys / mirror issues, but that apprently wasn't enough for this most recent attempt. But I'm not here for that issue, I'd rather install KDE Dragonized. Or at least Xfce.

Arch installer, Sparkylinux stable, and Linux Mint Cinnamon (I'm currently using this) detect mouse and keyboard on the installer without issue.

My setup:

Installing on M.2 nvme drive (nvme1n0).
EFI on SATA ssd (sda1)
Swap on sda2

Mobo: ASUS ROG Strix B550-E Gaming AMD AM4
Processor: AMD Ryzen 9 3900XT

Apologies if there's something dumb I'm looking over. If you need more info let me know.

Are you trying this in a VM? Also for experts to help you more easily, please run inxi -Fza in a linux terminal.

1 Like

Are you trying this in a VM?

Negative. Installing on a nvme. Details under “My setup”.

inxi results:

  Kernel: 5.4.0-74-generic x86_64 bits: 64 compiler: gcc v: 9.3.0 
  parameters: BOOT_IMAGE=/@/boot/vmlinuz-5.4.0-74-generic 
  root=UUID=e6b85000-551f-4a49-b928-b3301f51e0bf ro rootflags=subvol=@ quiet 
  Desktop: Cinnamon 4.8.6 wm: muffin 4.8.1 dm: LightDM 1.30.0 
  Distro: Linux Mint 20.1 Ulyssa base: Ubuntu 20.04 focal 
  Type: Desktop System: ASUS product: N/A v: N/A serial: <filter> 
  Mobo: ASUSTeK model: ROG STRIX B550-E GAMING v: Rev X.0x serial: <filter> 
  UEFI: American Megatrends v: 2401 date: 05/25/2021 
  Topology: 12-Core model: AMD Ryzen 9 3900XT bits: 64 type: MT MCP 
  arch: Zen family: 17 (23) model-id: 71 (113) stepping: N/A 
  microcode: 8701021 L2 cache: 6144 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 182051 
  Speed: 2196 MHz min/max: 2200/3800 MHz boost: enabled Core speeds (MHz): 
  1: 2195 2: 2195 3: 2195 4: 2198 5: 2194 6: 2189 7: 2188 8: 2195 9: 2196 
  10: 2195 11: 2195 12: 2193 13: 2194 14: 2191 15: 2196 16: 2195 17: 2196 
  18: 2196 19: 2196 20: 2196 21: 2201 22: 2195 23: 2196 24: 2196 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: 
  conditional, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: AMD Vega 10 XL/XT [Radeon RX Vega 56/64] 
  vendor: Sapphire Limited driver: amdgpu v: kernel bus ID: 09:00.0 
  chip ID: 1002:687f 
  Display: x11 server: X.Org 1.20.9 driver: amdgpu,ati 
  unloaded: fbdev,modesetting,vesa resolution: 2560x1080~60Hz 
  renderer: Radeon RX Vega (VEGA10 DRM 3.35.0 5.4.0-74-generic LLVM 11.0.0) 
  v: 4.6 Mesa 20.2.6 direct render: Yes 
  Device-1: AMD Vega 10 HDMI Audio [Radeon Vega 56/64] driver: snd_hda_intel 
  v: kernel bus ID: 09:00.1 chip ID: 1002:aaf8 
  Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK 
  driver: snd_hda_intel v: kernel bus ID: 0b:00.4 chip ID: 1022:1487 
  Device-3: Corsair type: USB driver: hid-generic,snd-usb-audio,usbhid 
  bus ID: 1-9.1:6 chip ID: 1b1c:0a3e serial: <filter> 
  Sound Server: ALSA v: k5.4.0-74-generic 
  Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel bus ID: 05:00.0 
  chip ID: 8086:2723 
  IF: wlp5s0 state: up mac: <filter> 
  Device-2: Intel vendor: ASUSTeK driver: igc v: 0.0.1-k port: N/A 
  bus ID: 06:00.0 chip ID: 8086:15f3 
  IF: enp6s0 state: down mac: <filter> 
  Local Storage: total: 1.60 TiB used: 16.74 GiB (1.0%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/nvme0n1 vendor: Western Digital model: WDS100T2B0C-00PXH0 
  size: 931.51 GiB block size: physical: 512 B logical: 512 B 
  speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: 211070WD 
  ID-2: /dev/sda vendor: Team model: T253X2128G size: 119.24 GiB block size: 
  physical: 512 B logical: 512 B speed: 6.0 Gb/s serial: <filter> rev: 117D 
  scheme: GPT 
  ID-3: /dev/sdb vendor: Team model: T253X2128G size: 119.24 GiB block size: 
  physical: 512 B logical: 512 B speed: 6.0 Gb/s serial: <filter> rev: 0A0 
  scheme: MBR 
  ID-4: /dev/sdc vendor: Team model: T253X2128G size: 119.24 GiB block size: 
  physical: 512 B logical: 512 B speed: 6.0 Gb/s serial: <filter> rev: 0A0 
  ID-5: /dev/sdd vendor: Team model: T253X2128G size: 119.24 GiB block size: 
  physical: 512 B logical: 512 B speed: 6.0 Gb/s serial: <filter> rev: 117D 
  scheme: MBR 
  ID-6: /dev/sde vendor: Team model: T253X2128G size: 119.24 GiB block size: 
  physical: 512 B logical: 512 B speed: 6.0 Gb/s serial: <filter> rev: 117D 
  scheme: GPT 
  ID-7: /dev/sdf type: USB vendor: PNY model: USB 2.0 FD size: 115.46 GiB 
  block size: physical: 512 B logical: 512 B serial: <filter> rev: PMAP 
  scheme: MBR 
  ID-1: / raw size: 931.51 GiB size: 931.51 GiB (100.00%) 
  used: 16.73 GiB (1.8%) fs: btrfs dev: /dev/nvme0n1 
  ID-2: /home raw size: 931.51 GiB size: 931.51 GiB (100.00%) 
  used: 16.73 GiB (1.8%) fs: btrfs dev: /dev/nvme0n1 
  ID-3: swap-1 size: 118.24 GiB used: 0 KiB (0.0%) fs: swap 
  swappiness: 60 (default) cache pressure: 100 (default) dev: /dev/sda2 
  System Temperatures: cpu: 37.4 C mobo: N/A gpu: amdgpu temp: 49 C 
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 1183 
  Processes: 503 Uptime: 1h 41m Memory: 62.79 GiB used: 3.87 GiB (6.2%) 
  Init: systemd v: 245 runlevel: 5 Compilers: gcc: 9.3.0 alt: 9 Shell: bash 
  v: 5.0.17 running in: gnome-terminal inxi: 3.0.38

Hrm. Found this, it sounds similar to my issue. I do the steps, or think I do the steps, and get something along the lines of “atkbd.reset not found”, before booting into the iso and getting the same no keyboard, no mouse results.

It looks like this is a problem related to the used kernel in combination to the specific BIOS (ACPI) implementation.
There are certain kernel parameters (search page for kbd) that might help override it. You can know, only if you try them, since it is a system specific issue, not general to all HW.
From the posted links, you may try for example adding at garuda grub extra parameters

atkbd.reset=1 i8042.nomux=1 i8042.reset=1 i8042.nopnp=1 i8042.dumbkbd=1

or i8042.kbdreset or other (just guessing).

Maybe try more?

As for the problems that made you want to re-install, this might also answer to the current issue. Do you have a link to your support requests on those?


I didn't post any thread for my other issues.

No resolution yet.

So far I've:
Checked for more options in BIOS. Found out I could disable the keyboard/mouse from BIOS! I had to pull the CMOS battery to reset it after that one...

Used all of the suggested extra parameters, plus a few more I thought were worth a try. This includes mce=no_cmci mce=bios_cmci_threshold aipc noaipc
...and others.

In addition, as a threat I added
echo "If you don't work I'm going to reinstall windows 10!"
I think it knew it was an empty threat. Also, I'm pretty sure my changes are going through because my threat appeared on the screen. I'm no longer getting the "atkbd.reset not found" error message. Apparently I was putting my parameters in the wrong location previously.

Huston, we have a problem!.. :rocket:
What do you think (now) is the right place?..

It might help whoever is watching the topic, if you confirmed there is no typo mistake in parameters and also where did you find them and in what combination and order you have tried them.

I never would have imagined you can run echo commands through kernel parameters :thinking:

1 Like

I put the echo below the parameters. I put the parameters in what is the second to last line after hitting "e" on the driver options (either open or proprietary). Previously I was putting the parameters on their own line, by themselves, at the end. I also didn't include "=1".

Maybe step back a bit:

  • ISO checksum?
  • Freshly formatted USB key?
  • Burn the ISO with a Garuda-approved method?

ISO checksum checks out.
Formatted USB
Balena Etcher to write ISO

While I'm at it, this is my code.

setparams 'Boot with open source drivers' 'x86_64 lang=en_us keytable=us tz=UTC misobasedir=garuda misolabel=GARUDA_DR460NIZED_SOARING_ quiet systemd.show_status=1 systemd.unified_cgroup_hierarchy=1'
# set arguments above with the editor
        linux /boot/vmlinuz-$2 driver=free nouveau.modest=1 i915.modeset=1 radeon.modeset=1 atkbd.reset=1
        initrd /boot/amd_ucode.img /boot/intel_ucode.img /boot/initramfs-x86_64.img

echo "Things put here show up next screen for a tiny moment"

Italics / emphasized text was added. This is a free driver start, and I would add whatever other parameter where I put atkbd.reset=1

edit: removed emphasization because all it seemed to do, on my setup anyway, was put *'s around the added text, potentially confusing the issue.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.