Newbie has issue with dependencies updating

just installed garuda linux, not for the first time and had an issue when updating.
The error said that two pipewire dependencies were in conflict:

:: Starting full system upgrade...
:: Replace kwayland-server with extra/kwin? [Y/n] y
:: Replace lib32-sdl with multilib/lib32-sdl12-compat? [Y/n] y
:: Replace qemu with extra/qemu-desktop? [Y/n] y
:: Replace qemu-arch-extra with extra/qemu-emulators-full? [Y/n] y
:: Replace sdl with community/sdl12-compat? [Y/n] y
:: Replace wxgtk-common with extra/wxwidgets-common? [Y/n] y
:: Replace wxgtk3 with extra/wxwidgets-gtk3? [Y/n] y
resolving dependencies...
looking for conflicting packages...
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: wireplumber and pipewire-media-session are in conflict

What should i do to resove this.
garuda-inixi command output here:

Kernel: 5.17.4-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=15156c4f-3e3e-41d3-958e-6a41e5b966d5 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3
Desktop: KDE Plasma v: 5.24.4 tk: Qt v: 5.15.3 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: HP product: OMEN by HP Laptop 15-ce0xx v: N/A
serial: <superuser required> Chassis: type: 10 serial: <superuser required>
Mobo: HP model: 838F v: 40.28 serial: <superuser required>
UEFI: American Megatrends v: F.24 date: 07/05/2021
Battery:
ID-1: BAT0 charge: 61.1 Wh (100.0%) condition: 61.1/61.1 Wh (100.0%)
volts: 17.4 min: 15.4 model: HP Primary type: Li-ion serial: N/A
status: full
Device-1: hidpp_battery_0 model: Logitech Wireless Mouse serial: <filter>
charge: 55% (should be ignored) rechargeable: yes status: discharging
CPU:
Info: model: Intel Core i5-7300HQ bits: 64 type: MCP arch: Kaby Lake
family: 6 model-id: 0x9E (158) stepping: 9 microcode: 0xEC
Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 256 KiB
desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB L3: 6 MiB
desc: 1x6 MiB
Speed (MHz): avg: 3263 high: 3482 min/max: 800/3500 scaling:
driver: intel_pstate governor: performance cores: 1: 3124 2: 3210 3: 3238
4: 3482 bogomips: 19999
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf
mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled
Type: mds mitigation: Clear CPU buffers; SMT disabled
Type: meltdown mitigation: PTI
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: disabled, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel HD Graphics 630 vendor: Hewlett-Packard driver: i915
v: kernel ports: active: eDP-1 empty: DP-1,HDMI-A-1 bus-ID: 00:02.0
chip-ID: 8086:591b class-ID: 0300
Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] vendor: Hewlett-Packard
driver: nvidia v: 510.60.02 alternate: nouveau,nvidia_drm pcie: gen: 2
speed: 5 GT/s lanes: 8 link-max: gen: 3 speed: 8 GT/s lanes: 16 ports:
active: none off: HDMI-A-2 empty: DP-2 bus-ID: 01:00.0 chip-ID: 10de:1c8d
class-ID: 0300
Device-3: Chicony HP Wide Vision FHD Camera type: USB driver: uvcvideo
bus-ID: 1-6:3 chip-ID: 04f2:b593 class-ID: 0e02 serial: <filter>
Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.1
compositor: kwin_x11 driver: X: loaded: modesetting,nvidia
gpu: i915,nvidia,nvidia-nvswitch display-ID: :0 screens: 1
Screen-1: 0 s-res: 4480x1440 s-dpi: 96 s-size: 1182x380mm (46.54x14.96")
s-diag: 1242mm (48.88")
Monitor-1: not-matched mapped: HDMI-1-0 pos: primary,top-left
res: 2560x1440 dpi: 109 size: 597x336mm (23.5x13.23") diag: 685mm (26.97")
modes: N/A
Monitor-2: eDP-1 pos: bottom-r model: LG Display 0x0532 built: 2016
res: 1920x1080 hz: 60 dpi: 142 gamma: 1.2 size: 344x194mm (13.54x7.64")
diag: 395mm (15.5") ratio: 16:9 modes: 1920x1080
OpenGL: renderer: Mesa Intel HD Graphics 630 (KBL GT2) v: 4.6 Mesa 22.0.2
direct render: Yes
Audio:
Device-1: Intel CM238 HD Audio vendor: Hewlett-Packard
driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 chip-ID: 8086:a171
class-ID: 0403
Device-2: NVIDIA GP107GL High Definition Audio driver: snd_hda_intel
v: kernel pcie: speed: Unknown lanes: 63 link-max: gen: 6 speed: 64 GT/s
bus-ID: 01:00.1 chip-ID: 10de:0fb9 class-ID: 0403
Sound Server-1: ALSA v: k5.17.4-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.50 running: yes
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Hewlett-Packard driver: r8169 v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 3b:00.0 chip-ID: 10ec:8168
class-ID: 0200
IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
Device-2: Intel Wireless 7265 driver: iwlwifi v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 bus-ID: 3c:00.0 chip-ID: 8086:095a class-ID: 0280
IF: wlo1 state: down mac: <filter>
Bluetooth:
Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8
bus-ID: 1-7:5 chip-ID: 8087:0a2a class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter>
Drives:
Local Storage: total: 1.03 TiB used: 14.4 GiB (1.4%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: LITE-ON model: CA1-8D128-HP
size: 119.24 GiB block-size: physical: 512 B logical: 512 B
speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: A182
temp: 37.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000LM049-2GH172
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B
speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter> rev: RXM3
scheme: GPT
Partition:
ID-1: / raw-size: 118.95 GiB size: 118.95 GiB (100.00%)
used: 14.4 GiB (12.1%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 118.95 GiB size: 118.95 GiB (100.00%)
used: 14.4 GiB (12.1%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 118.95 GiB size: 118.95 GiB (100.00%)
used: 14.4 GiB (12.1%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 118.95 GiB size: 118.95 GiB (100.00%)
used: 14.4 GiB (12.1%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.38 GiB used: 1.5 MiB (0.0%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 58.0 C pch: 60.5 C mobo: N/A
Fan Speeds (RPM): cpu: 7680 fan-2: 0
Info:
Processes: 254 Uptime: 24m wakeups: 3 Memory: 15.38 GiB
used: 3.62 GiB (23.6%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.2.0 Packages: pacman: 1704 lib: 511 Shell: fish v: 3.4.1
default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.15
Garuda (2.6.2-1):
System install date:     2022-07-29
Last full system update: 2022-07-29
Is partially upgraded:   Yes
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Snapper
Failed units:

many thanks

Hi there, welcome to the forum.
Please try:

sudo pacman -Rdd pipewire-media-session && garuda-update

PS: I edited your post to format it according to:

3 Likes

Thankyou very much for your help, however when the update command occurs there is an error


error: optimus-manager-qt: signature from "Nico Jensch (Chaotic-AUR) <[email protected]>" is invalid
:: File /var/cache/pacman/pkg/optimus-manager-qt-1.6.9-1-x86_64.pkg.tar.zst is corrupted (invalid or corruptedpackage (PGP signature)).
Do you want to delete it? [Y/n] y
error: failed to commit transaction (invalid or corrupted package)
Errors occurred, no packages were upgraded.

Maybe try:

garuda-update remote keyring
2 Likes

same result

error: optimus-manager-qt: signature from "Nico Jensch (Chaotic-AUR) <[email protected]>" is invalid
:: File /var/cache/pacman/pkg/optimus-manager-qt-1.6.9-1-x86_64.pkg.tar.zst is corrupted (invalid or corruptedpackage (PGP signature)).
Do you want to delete it? [Y/n] y
error: failed to commit transaction (invalid or corrupted package)
Errors occurred, no packages were upgraded.

Try

sudo rm /var/cache/pacman/pkg/optimus-manager-qt-1.6.9-1-x86_64.pkg.tar.zst

If that doesn't work, try

sudo find /var/cache/pacman/pkg/ -iname "*.part" -delete

(This is what I would do in Arch, I hope it's also applicable here)

Thankyou so much, the first otpion didnt recognise the file, said that the file didnt exist , and the second caused a new error to occur

[🔴] × sudo pacman -Syu
:: Synchronising package databases...
garuda is up to date
core is up to date
extra is up to date
community is up to date
multilib is up to date
chaotic-aur                          1970.2 KiB  4.22 MiB/s 00:00 [------------------------------------] 100%
:: Starting full system upgrade...
:: Replace kwayland-server with extra/kwin? [Y/n] y
:: Replace lib32-sdl with multilib/lib32-sdl12-compat? [Y/n] y
:: Replace qemu with extra/qemu-desktop? [Y/n] y
:: Replace qemu-arch-extra with extra/qemu-emulators-full? [Y/n] y
:: Replace sdl with community/sdl12-compat? [Y/n] y
:: Replace wxgtk-common with extra/wxwidgets-common? [Y/n] y
:: Replace wxgtk3 with extra/wxwidgets-gtk3? [Y/n] y
resolving dependencies...
looking for conflicting packages...
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: sweet-theme-full-git and kvantum-theme-sweet-git are in conflict

If you use garuda-update many of the conflict issues etc. will be taken care of automatically.

2 Likes

First I think you could try garuda-update again.
If you get the same error, you could temporarily try this workaround (the -git version)

and then garuda-update

1 Like

not sure how to do this without triggering the error

] × sudo pacman -S optimus-manager-qt-git
[sudo] password for sebastian:
resolving dependencies...
looking for conflicting packages...
:: optimus-manager-qt-git and optimus-manager-qt are in conflict. Remove optimus-manager-qt? [y/N] y

Packages (2) optimus-manager-qt-1.6.5-1 [removal]  optimus-manager-qt-git-1.6.9.r1.g4c35f53-1

Total Download Size:   0.20 MiB
Total Installed Size:  0.86 MiB
Net Upgrade Size:      0.02 MiB

:: Proceed with installation? [Y/n] y
:: Retrieving packages...
optimus-manager-qt-git-1.6.9.r1....   205.8 KiB   497 KiB/s 00:00 [-------------------------------------] 100%
(1/1) checking keys in keyring                                     [-------------------------------------] 100%
(1/1) checking package integrity                                   [-------------------------------------] 100%
error: optimus-manager-qt-git: signature from "Nico Jensch (Chaotic-AUR) <[email protected]>" is invalid
:: File /var/cache/pacman/pkg/optimus-manager-qt-git-1.6.9.r1.g4c35f53-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] n
error: failed to commit transaction (invalid or corrupted package (PGP signature))
Errors occurred, no packages were upgraded.


this triggers the same conflict error

:: Proceed with installation? [Y/n] y
:: Retrieving packages...
optimus-manager-qt-1.6.9-1-x86_64     205.8 KiB   420 KiB/s 00:00 [-------------------------------------] 100%
dxvk-mingw-git-1.10.1.r364.gea76...     7.4 MiB  7.38 MiB/s 00:01 [-------------------------------------] 100%
Total (2/2)                             7.6 MiB  7.33 MiB/s 00:01 [-------------------------------------] 100%
(1000/1000) checking keys in keyring                               [-------------------------------------] 100%
(1000/1000) checking package integrity                             [-------------------------------------] 100%
error: sweet-kde-theme-git: signature from "Nico Jensch (Chaotic-AUR) <[email protected]>" is invalid
:: File /var/cache/pacman/pkg/sweet-kde-theme-git-r24.9e36d3a-4-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: sweet-folders-icons-git: signature from "Nico Jensch (Chaotic-AUR) <[email protected]>" is invalid
:: File /var/cache/pacman/pkg/sweet-folders-icons-git-r12.d50fbe3-1-any.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: sweet-theme-full-git: signature from "Nico Jensch (Chaotic-AUR) <[email protected]>" is invalid
:: File /var/cache/pacman/pkg/sweet-theme-full-git-r277.7190f77-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: ananicy-cpp: signature from "Nico Jensch (Chaotic-AUR) <[email protected]>" is invalid
:: File /var/cache/pacman/pkg/ananicy-cpp-1.0.0.rc6-1.1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: ananicy-rules-git: signature from "Nico Jensch (Chaotic-AUR) <[email protected]>" is invalid
:: File /var/cache/pacman/pkg/ananicy-rules-git-2.2.1.r297.g8e78562-1-any.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: bluetooth-autoconnect: signature from "Nico Jensch (Chaotic-AUR) <[email protected]>" is invalid
:: File /var/cache/pacman/pkg/bluetooth-autoconnect-1.3-1.1-any.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: find-the-command-git: signature from "Nico Jensch (Chaotic-AUR) <[email protected]>" is invalid
:: File /var/cache/pacman/pkg/find-the-command-git-2.0.r1.g608d240-1-any.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: optimus-manager-qt: signature from "Nico Jensch (Chaotic-AUR) <[email protected]>" is invalid
:: File /var/cache/pacman/pkg/optimus-manager-qt-1.6.9-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: failed to commit transaction (invalid or corrupted package)
Errors occurred, no packages were upgraded.
sudo pacman -Sy archlinux-keyring chaotic-keyring

Then update again.

1 Like

the named command finished without error, however then the upgrade errored out with the same previous conflicts

:: Starting full system upgrade...
:: Replace kwayland-server with extra/kwin? [Y/n] y
:: Replace lib32-sdl with multilib/lib32-sdl12-compat? [Y/n] y
:: Replace qemu with extra/qemu-desktop? [Y/n] y
:: Replace qemu-arch-extra with extra/qemu-emulators-full? [Y/n] y
:: Replace sdl with community/sdl12-compat? [Y/n] y
:: Replace wxgtk-common with extra/wxwidgets-common? [Y/n] y
:: Replace wxgtk3 with extra/wxwidgets-gtk3? [Y/n] y
resolving dependencies...
looking for conflicting packages...
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: sweet-theme-full-git and kvantum-theme-sweet-git are in conflict

No, that's a different error. Apparantly those two packages - sweet-theme-full-git and kvantum-theme-sweet-git - are in conflict now. Try to delete one before trying updating once more.

This is a fresh installation? Maybe next time use a fresh installation medium too.

1 Like

Did you update via garuda-update?
If yes, try to remove the package via sudo pacman -Rdd <package> (<package> being either sweet-theme-full-git or kvantum-theme-sweet-git, whatever you have installed) and then update again

The kvantum deleted, however when i tried to update afterward i got another error

error: ananicy-cpp: signature from "Nico Jensch (Chaotic-AUR) <[email protected]>" is invalid
:: File /var/cache/pacman/pkg/ananicy-cpp-1.0.0.rc6-1.1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: ananicy-rules-git: signature from "Nico Jensch (Chaotic-AUR) <[email protected]>" is invalid
:: File /var/cache/pacman/pkg/ananicy-rules-git-2.2.1.r297.g8e78562-1-any.pkg.tar.zst is corrupted (invalid orcorrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: bluetooth-autoconnect: signature from "Nico Jensch (Chaotic-AUR) <[email protected]>" is invalid
:: File /var/cache/pacman/pkg/bluetooth-autoconnect-1.3-1.1-any.pkg.tar.zst is corrupted (invalid or corruptedpackage (PGP signature)).
Do you want to delete it? [Y/n] y
error: find-the-command-git: signature from "Nico Jensch (Chaotic-AUR) <[email protected]>" is invalid
:: File /var/cache/pacman/pkg/find-the-command-git-2.0.r1.g608d240-1-any.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: optimus-manager-qt: signature from "Nico Jensch (Chaotic-AUR) <[email protected]>" is invalid
:: File /var/cache/pacman/pkg/optimus-manager-qt-1.6.9-1-x86_64.pkg.tar.zst is corrupted (invalid or corruptedpackage (PGP signature)).
Do you want to delete it? [Y/n] y
error: plymouth-git: signature from "Nico Jensch (Chaotic-AUR) <[email protected]>" is invalid
:: File /var/cache/pacman/pkg/plymouth-git-22.02.122.r50.g0d30fe59-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: failed to commit transaction (invalid or corrupted package)
Errors occurred, no packages were upgraded.

try

sudo pacman -Sy archlinux-keyring chaotic-keyring && garuda-update
2 Likes

I also faced this issue , I think one of the chaotic mirror is the root of all these pgp failures

BTW remove optimus-manager-qt and install optimus-manager-qt-git
Do this for all conflicting packages if garuda-update does not helps

Which one?

Maybe India one According to https://status.chaotic.cx/geo