New user issue with JellyFin Media server

HI
just installed Garuda, 95% of it working flawlessly, but one big problem right now is Jellyfin server
it's a media server solution similar to Emby or Plex

I used it before on other Linux distro's and normal, you install, start the servers, browse to the localhost web address, and are presented with a configuration wizard, which guides you through setting up an initial username and password, and libraries etc.

However after installing Jellyfin through Chaotic-Aur I then started the service, browsed to the web address, and instead of the configuration wizard i'm asked for a username & password to log in (which I never set up)

Please help?

Hi, first try
User : jellyfin; password :
(Blank password)

If it doesn't work, refer to

3 Likes

Tried Jellyfin
tried my system username, neither worked
looked that up before I came here.
I'm really stumped

I tried to uninstall and re-isntall using standard aur instead of Chaotic, and still get the same behaviour

Well, in this case, I would request you to ask on jellyfin forums.

I don't think it is Garuda specific problem.

Which one? Any Arch based?

yes endeavourOs, about 15 min ago....

1 Like

Do you have a firewall running?

1 Like

ok found a workaround on the Jellyfin forums

does not explain WHY it happened in the first place, but I was able to get into the account

No I didn't have a firewall running

now I have a further problem

Can not install any plugins
the default Official plugin repo is not listed/configured, and trying to add it results in a failure

Again this very much seems to be a problem with the Chaotic-aur installation having like premade/leftover config files, that I can not find or change.

If the AUR Jellyfin version was doing the same thing I'm not sure why you think the Chaotic AUR version is the problem?

Generally when you post a help request on the forum and you find a workaround or solution yourself the common courtesy/accepted practice is to inform other users what method you used.

The forum is not here simply for your own personal use, it is a permanent knowledge repository for the distro specifically, and Linux in general. When you find an answer you are expected to post it, so that other users may benefit from your discovery.

4 Likes

because I installed the Chaotic Aur version first, and unisntalling/.reinstalling would not have removed any configuration files

Adding this string
/web/index.html?start=wizard#!/wizardstart.html
to the end of the URL forces the configuration wizard and allows you to setup a new account

I didn't post it here originally, because it's a workaround, it doesn't explain why the problem happened in the first place.

I dont want to sound ungratefull, and I apologize if it comes across that way, it's jsut that I have you here telling me the problem has to be Jellyfin based,
I have the Jelly fin mods telling me it has to be an installation problem

and meanwhile during my distro hoping I've done this literally over 30 times, and Garuda is the first distro that's given me this issue, it's also the only distro I've used that uses Chaotic-Aur instead of regular Aur, so I'm just looking at the common denominator here

It would if you used the -Rns option.

Is this a trialware or paid/pro version of software?

1 Like

i didn't use -Rns I'm not familiar with those options I used Pamac

I'm still learning my way around the Terminal
I've been using Linux for about 2 years, but only been on arch based distros for about 6 months

Sorry if you think I'm rude, but then perhaps it was your lack of knowledge on how to use pacman that is at issue.

I generally start to get a little peeved when users evade answering my questions!!!

3 Likes

I never said you were rude? what gave you that impression
I'm sorry
I didn't mean to offend
no this is not trial ware or paid/pro software

please understand I'm trying to be helpful but I'm feeling very attacked right now
I'm juggling my time and responses between two different forums, who's developers are giving me conflicting information

2 Likes
1 Like

Checked the link

Couldn't find any mention of -Rns

is the whole community as much of an asshole as you?
I think I'll be going back to EndeavourOs

Thank you very much for your time, and what little effort you did put into helping me
I hope the next user to come here looking for help has more success than I did

pacman -R --help

Give a man a fish and you feed him for a day, teach a man to fish and he is fed forr a lifetime.

I have given you the answer already, all you need to do is apply it.

1 Like

While I understand your philosphy, and even agree with it
there's a difference between

"here friend ,let me show you how to fish, so that you may be fed"
and
throws pole at mans face "here use that to catch it yourself looser"

I'm sorry again that we couldn't come to some satisfactory solution here
understand please
it's not your lacka of knowledge, that is driving me away from this distro ,it's your attitude

If you want to be spoon fed every answer then yes, perhaps you should go back to EOS, Funny thing is though EOS is a terminal centric distro where they expect you to know how to use pacman.

And just FYI, sometimes when you come out pointing your finger at the distro for creating your issue you might not get a warm response in return.

Just sayin perhaps I'm not the only one coming off as being abrasive.

3 Likes
sudo turn down heat 
chill out bois. problems are temporary.
being rational is important
3 Likes